recentpopularlog in

ezequiel : 2016   240

« earlier  
linux mint - mount: No such file or directory with encrypted recovery - Unix & Linux Stack Exchange
Q: [...] Nothing I’ve tried seems to work and I don’t have the original mounting seed. I’ve also tried sudo ecryptfs-recover-private but my system then just says No such file or directory:

frankenmint@honeybadger /home $ sudo ecryptfs-recover-private
INFO: Searching for encrypted private directories (this might take a while)...
INFO: Found [/home/.ecryptfs/frankenmint/.Private].
Try to recover this directory? [Y/n]: y
INFO: Found your wrapped-passphrase
Do you know your LOGIN passphrase? [Y/n] y
INFO: Enter your LOGIN passphrase...
Passphrase:
Inserted auth tok with sig [979c6cdf80d2e44d] into the user session keyring
mount: No such file or directory
ERROR: Failed to mount private data at [/tmp/ecryptfs.Hy3BV96c].

[...]

A: I found that running sudo bash and then running ecryptfs-recover-private as root (rather than via sudo) worked. Not sure why it should be any different.

Edit:
TL;DR:

# ecryptfs-unwrap-passphrase /mnt/crypt/.ecryptfs/user/.ecryptfs/wrapped- passphrase - | ecryptfs-add-passphrase --fnek -
< Type your login password here >
Inserted auth tok with sig [aaaaaaaaaaaaaaaa] into the user session keyring
Inserted auth tok with sig [bbbbbbbbbbbbbbbb] into the user session keyring

You will not see a prompt and must type your login password, blind, into the above command. [...]
2016  forumthread  stackexchange  cli  sysadmin  encryption  filesystem  ubuntu  debian  mint  tips  issue  workaround  example  guide  linux  security  mount  ubuntu.xenial  ubuntu.trusty  ubuntu.bionic  ecryptfs 
21 days ago by ezequiel
[SOLVED] Hibernate, 15.10, 16.04, Unity, systemd, tlp, wifi module reload, tuxonice
I thought I should share this in case anyone else has the similar problem and wants to know how to solve it. With the new systemd configuration, the Unity menu's "hibernate" option does not call on pm-hibernate. It instead uses the hibernate and sleep service of logind / systemd. I'm using a tuxonice kernel, and the tlp power management setup on a thinkpad w520, running Ubuntu 16.04 (devel). I think this article is still relevant even if you don't have tlp or tuxonice, since it's systemd that changes how suspend and hibernate work.

When this laptop suspends or hibernates, sometimes the wifi stops working when it wakes back up. The solution is to unload the wifi device driver module prior to sleep, and then reload it upon resume, the way the "hibernate" script does, and "pm-hibernate" also did.
2016  forumthread  sysadmin  linux  powermanagement  script  scripts  example  kernelmodule  systemd  tips  cli  configuration  ubuntu  ubuntu.xenial  wifi 
26 days ago by ezequiel
How To Get A Global Menu In Xubuntu 16.04 Or Lubuntu 16.04 (Using TopMenu) ~ Web Upd8: Ubuntu / Linux blog
TopMenu (a global menu for MATE, Xfce and LXDE panels) is available in the official Ubuntu 16.04 repositories and it works great in Ubuntu MATE 16.04, but it doesn't work in Xubuntu 16.04 and Lubuntu 16.04 by simply installing the panel applet package.

Here's how to get TopMenu to work in Xubuntu 16.04 and Lubuntu 16.04, using the official packages, with a minor tweak.
screenshots  gtk  gtk2  gtk3  gui  ui  extension  xfce  mate  lxde  desktop  customize  configuration  installation  howto  guide  linux  x11  blogpost  2016  sysadmin  ppa  links  ubuntu  mint  xubuntu  lubuntu 
26 days ago by ezequiel
internet - Netgear N-300/ WNA3100 USB Adapter for Ubuntu 16.04 - Ask Ubuntu
Q: I am new to Linux and Ubuntu and I am having trouble connecting to the Internet.

I have a netgear WNA3100 USB Adapter and I don't have anything in my additional drivers.

A: You can add Support for the Netgear N-300/ WNA3100 USB Adapter by installing the ndiswrapper and loading the Windows network driver. [...]

(me: ndiswrapper fails to build when using kernel-headers >= 5.0 (on i686), then (even if patched) the 32-bit WinXP driver from NetGear does not work: ndiswrapper causes an "oops" because of the "nx" cpu protection bit; then, after disabling this (see another link saved today), ndiswrapper gives yet another error. Result (so far): failed).
ndiswrapper  issue  howto  guide  tips  example  cli  sysadmin  networking  wifi  2016  ubuntu  configuration  usb  driver  drivers  windows  links  linux  kernelmodule  forumthread  stackexchange 
28 days ago by ezequiel
linux - How to turn off Wireless power management permanently - Unix & Linux Stack Exchange
Q: In Linux Mint 17.3 / 18 iwconfig says the power management of my wireless card is turned on. I want to turn it off permanently or some workaround on this issue.

sudo iwconfig wlan0 power off works, until I reboot the laptop.

Also, if I randomly check iwconfig, sometimes it's on, despite I did run this command. [...]

A #1: Open this file with your favorite text editor, I use nano here:

sudo nano /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

By default there is:

[connection]
wifi.powersave = 3

Change the value to 2. Reboot for the change to take effect. [...]
2016  forumthread  stackexchange  linux  ubuntu  mint  debian  networking  software  configuration  sysadmin  powermanagement  usb  issue  workaround  cli  links  documentation  tips  example  wifi 
28 days ago by ezequiel
How to configure KODI to run in windowed mode from command line? - Ask Ubuntu
Q: I am running Kodi via XServer from 2-monitor remote conputer. When Kodi starts, it occupies entire 2 monitor are and absolutely useless.

It has a config to run in windowed mode, but how to activate it from command line? [...]
2016  forumthread  stackexchange  issue  configuration  cli  example  tips  gui  hardwaresupport  windows  linux  xorg  x11  xbmc 
4 weeks ago by ezequiel
Television via Acestream on Raspberry PI. Now in docker containers
On Habré, AceStream was repeatedly mentioned: a technology that provides the user access to video streams using the AceStream private P2P protocol, the so-called. torrent tv. AceStream provides access to a distributed content delivery network, i.e. watching the channel, the user transmits data to other users, which allows to drastically reduce the cost of services.
2016  blogpost  acestream  install  raspberrypi  osmc  raspbian  docker.container  sysadmin  howto  links  proxy  github  screenshots  xbmc  configuration 
5 weeks ago by ezequiel
Build your own Command Line with ANSI escape codes
Everyone is used to programs printing out output in a terminal that scrolls as new text appears, but that's not all your can do: your program can color your text, move the cursor up, down, left or right, or clear portions of the screen if you are going to re-print them later. This is what lets programs like Git implement its dynamic progress indicators, and Vim or Bash implement their editors that let you modify already-displayed text without scrolling the terminal.
2016  terminal  shell  cli  configuration  blogpost  tips  example  unix  linux  macosx  colour  screenshots 
6 weeks ago by ezequiel
How to access docker container from another machine on local network - Open Source Projects / Docker Toolbox - Docker Forums
If I read the docs right all you need to do is this:

$ docker run --network=host …

host network should piggy back on the host computers connection rather than just machine that the container is running on.
docker  sysadmin  configuration  networking  cli  howto  tips  example  forumthread  2016  linux  links 
6 weeks ago by ezequiel
Finally got 802.11r roaming working : openwrt
[edit] Since people still find this post for advice, I'll quickly add a few notes.

Configuration has been vastly simplified with a recent OpenWRT release. Basically all you need is the following:

option mobility_domain 'e612' #same for all APs
option ieee80211r '1'
option ft_psk_generate_local '1'
option nasid 'xxxxxxxx' # different for all APs, AFAIK it will automatically derived from the MAC Address if omitted.

All this is availably via LuCI, go to "Wireless Security", enable "802.11r Fast Transition", enable "Generate PMK locally", that should be it. Unfortunately I lack the time and hardware to really test this. [...]
openwrt  wifi  configuration  article  forumthread  reddit  security  example  tips  linux  router  networking  sysadmin  cli  links  2016 
7 weeks ago by ezequiel
download files from luci ( use LuCI as file share ) · Issue #846 · openwrt/luci
Q: I've uploaded some files in my OpenWrt root , /etc , /tmp directories.
I want user to be able to download uploaded files from from the above directories.
How can i give a download URL to user, to download that files?
github  openwrt  issue  workaround  tips  example  configuration  webserver  downloads  links  howto  guide  screenshots  router  serverapp  sysadmin  networking  forumthread  2016 
8 weeks ago by ezequiel
Thomson TG585 v7 [Old OpenWrt Wiki]
NOT supported. However Openwrt can be installed in this router, read this forum thread. You may need to replace your bootloader.
router  hardwaresupport  wikientry  openwrt  2016  links  firmware  spec  wifi 
8 weeks ago by ezequiel
systemd-nspawn and sh: can't access tty; job control turned off · Issue #1431 · systemd/systemd
Q: Trying to launch alpine container on CoreOS via toolbox and getting sh: can't access tty; job control turned off warning. I've read about it in BusyBox FAQ, which didn't work for me, and tried this, also without any luck.

This works without any issues nor tweaks with docker. Is there some parameter that should be passed to nspawn like --interactive with docker? Or is this something completely different?

A: [...] toolbox getty -nl /bin/sh 0 /dev/console [...]
2015  2016  forumthread  issue  workaround  cli  example  tips  sysadmin  coreos  tool  github  linux  systemd  links 
9 weeks ago by ezequiel
CoreOS: containers not restarting after reboot · Issue #3241 · docker/compose
A: This was indeed a configuration change within CoreOS. For the benefit of others, the solution was to enable the Docker service in systemd:

# systemctl enable docker.service
# systemctl start docker.service
coreos  docker  booting  issue  workaround  cli  example  tips  2016  forumthread  github 
9 weeks ago by ezequiel
memory usage - What do the changes in `free` output from 14.04 to 16.04 mean? - Ask Ubuntu
Q: I noticed that the free command reporting has changed somewhere between Trusty and Xenial. Here is what `free -m' shows on one of my Trusty computers: [...]
2016  2018  ubuntu  ubuntu.trusty  ubuntu.xenial  memory  cli  tool  sysadmin  linux  kernel  tips  links  reference  info  forumthread  stackexchange 
10 weeks ago by ezequiel
ssl certificate - SSL encryption with CNAME redirect - Server Fault
Q: Here is my current architecture: I have a simple site hosted in the cloud that needs to be served from my company. Thus, mysite.com has a CNAME redirect to 1234.cloud.com. I understand that the SSL certificate needs to be created for mysite.com.

Here are my questions:

a) how does the CNAME redirect work when fetching content? does DNS resolve the cloud IP address and allow just one HTTP connection to the cloud or is the HTTP connection sent to my server and then relayed to the cloud? which server presents the SSL cert for mysite.com? I believe that I need to configure a local server to offer the SSL certificate because DNS alone would not suffice, but I am not sure on the architecture. [...]
2016  forumthread  stackexchange  faq  info  links  dns  ssl  tls  security  internet  http  protocol  browser 
10 weeks ago by ezequiel
google cloud platform - GCP network usage monitoring - Stack Overflow
Q: Is there any network monitor for GCP VMs? I think that my apps is experiencing some network problem, keep on facing JSONP failed request [...]
2016  forumthread  stackexchange  google.cloud  cloudcomputing  remote  tool  tools  links  free  opensource 
11 weeks ago by ezequiel
linux - Keep SSH session alive - Stack Overflow
A: #1: The ssh daemon (sshd), which runs server-side, closes the connection from the server-side if the client goes silent (i.e., does not send information). To prevent connection loss, instruct the ssh client to send a sign-of-life signal to the server once in a while.

The configuration for this is in the file $HOME/.ssh/config, create it if the configuration file does not exist. To send the signal every four minutes (240 seconds) to the remote host, put the following that configuration file:

Host remotehost:
HostName remotehost.com
ServerAliveInterval 240

[...]

A: #2: [...] If you want to set the keep alive for the server, add this to /etc/ssh/sshd_config:

ClientAliveInterval 60
ClientAliveCountMax 2

[...]
2014  2016  forumthread  stackexchange  ssh  configuration  tips  example  networking  issue  workaround  linux  unix  windows  macosx  remote 
11 weeks ago by ezequiel
Can anyone explain docker.sock - Stack Overflow
Q: I am trying to understand the actual reason for mounting docker.sock in docker-compose.yml file. Is it for auto-discovery?

volumes:
- /var/run/docker.sock:/var/run/docker.sock

A: docker.sock is the UNIX socket that Docker daemon is listening to. It's the main entry point for Docker API. It also can be TCP socket but by default for security reasons Docker defaults to use UNIX socket.

Docker cli client uses this socket to execute docker commands by default. You can override these settings as well. [...]
2016  forumthread  stackexchange  docker  configuration  sockets  daemon  info  cli  example 
12 weeks ago by ezequiel
How to Restrict SFTP Users to Home Directories Using chroot Jail
In this tutorial, we will be discussing how to restrict SFTP users to their home directories or specific directories. It means the user can only access his/her respective home directory, not the entire file system.

Restricting users home directories is vital, especially in a shared server environment, so that an unauthorized user won’t sneak peek into the other user’s files and folders.
scripting  sysadmin  security  ssh  sftp  configuration  howto  tips  blogpost  2016  example  linux  unix  remote  tutorial 
january 2020 by ezequiel
power management - How can I hibernate a Google Compute Engine server? - Stack Overflow
A: Compute Engine has alpha support for suspending virtual machines. A quote from that documentation:

gcloud alpha compute instances suspend is used to suspend a Google Compute Engine virtual machine. Suspending a VM is the equivalent of sleep or standby mode: the guest receives an ACPI S3 suspend signal, after which all VM state is saved to temporary storage. An instance can only be suspended while it is in the RUNNING state. A suspended instance will be put in SUSPENDED state.

The command is not yet available in the Compute Engine web UI but can be invoked from the command line like:

gcloud alpha compute instances suspend my-vm
2013  2016  cli  example  sysadmin  virtualisation  cloudcomputing  google.cloud  configuration  tips  performance  links  moneysaving  powermanagement  forumthread  stackexchange 
december 2019 by ezequiel
Learning AWS — For the budget conscious - A Cloud Guru
So you want to get AWS certified, but you’re on a budget? Fear not, A Cloud Guru is on hand to show you how to get best value for little, or no cost at all.
2016  blogpost  amazon.aws  free  finances  price  cloudcomputing  links  tips  moneysaving 
december 2019 by ezequiel
linker - Where is __dso_handle defined? - Stack Overflow
Q: I have an unresolved symbol error when trying to compile my program which complains that it cannot find __dso_handle. Which library is this function usually defined in? [...]
2016  2018  gcc  linking  linux  gnu  cli  development  tool  compiler  compatibility  internals  sharedlibraries  c  c++  stackexchange  forumthread 
november 2019 by ezequiel
Android 2.2.1 · Issue #2125 · koreader/koreader · GitHub
Q: Is there anyway I can force KOReader to install on my old Sony PRS-T1 which runs on android 2.2.1. I know its supposed to run on android 2.3 and above but is there some hack that I can try ? It will make the device super cool. [...]
sony.prs.t2  koreader  compatibility  issue  github  2017  porting  android.app  forumthread  2016 
october 2019 by ezequiel
Why Go’s structs are superior to class-based inheritance
Go is unique from a lot of object-oriented languages in that it doesn’t have classes. Instead, Go has two awesome features that make its model of polymorphism way more powerful than classical inheritance: interfaces and struct embedding.
golang  ood  2016  example  tips  blogpost 
september 2019 by ezequiel
Tip: 24-bit True Color Terminal + tmux + vim
The version of vim in -current is 24-bit color ready, and the version of tmux (2.2) in -current/testing is also 24-bit color ready. I'm happily using them together. Want a 24-bit terminal emulator/tmux/vim combination? Read on.
2016  forumthread  tmux  vim  colour  tips  configuration  shell  scripting  example  linux  unix  ubuntu  debian  cli  terminal 
september 2019 by ezequiel
[TUTORIAL] [OPL DEBUG] OPL Yellow Debug Color Fix - PS2-HOME.com - PS2 Homebrew and Tools
NOTE: We found a method on how to fix the Yellow Debug Color for a game that gets stuck there. We discovered that sometimes a ISO rip may not be ripped correctly or by a different ripping tool that may not be compatible with OPL--thus this may cause the game to get stuck when loading at the Yellow Debug Color in OPL.
opl.ps2  vg.plat.ps2  howto  tips  example  gaming  issue  workaround  fix  forumthread  tutorial  2016  samba  configuration  links  faq  windows  cd  dvd  burning  info  freemcboot  backup  compatibility 
august 2019 by ezequiel
How To Route Web Traffic Securely Without a VPN Using a SOCKS Tunnel | DigitalOcean
Sometimes you're on a network that's insecure or has an overly restrictive firewall, and you need to access a website. You want to make sure no one in the middle is watching the traffic.

One solution is a VPN, but many VPNs require special client software on your machine, which you may not have rights to install.
proxy  ssh  vpn  howto  tips  blogpost  cli  unix  linux  windows  putty  terminal  configuration  security  2016 
july 2019 by ezequiel
[TUTORIAL] [OPL DEBUG] OPL White Screen Debug Color Fix - PS2-HOME.com - PS2 Homebrew and Tools
There are three possible reasons why you may trigger the White Debug Color in OPL (aka: OPL Whitescreen [white screen]) when you try to load a game.

So here are these separate incidents and a possible fixes. [...]
opl.ps2  vg.plat.ps2  howto  tips  example  gaming  issue  workaround  fix  forumthread  tutorial  2016  samba  configuration  links  faq  windows  cd  dvd  burning  info  freemcboot  backup  compatibility 
july 2019 by ezequiel
[TUTORIAL] [OPL DEBUG] OPL Compatibility MODES: An Explanation... - PS2-HOME.com - PS2 Homebrew and Tools
[...] UPDATE: These modes have been updated since OPL r813: Click Here to get the latest OPL version.
[...] NOTE: It's never a good idea to enable modes to games that show signs that it is not needed. So keep that in mind. Enabling modes should be applied to games that tend to require it -- consult with our OPL Compatibility Lists to see what games require a mode enabled--and if the game is not listed, then test it, but don't go enabling a bunch of modes on the first test. [...]
2016  forumthread  vg.plat.ps2  tips  info  links  opl.ps2  freemcboot  backup  configuration  reference 
july 2019 by ezequiel
[TUTORIAL] [BACKUPS] WinMD5Free (MD5 Hash Checksum Tool) and Tutorial - PS2-HOME.com - PS2 Homebrew and Tools
[...] A lot of times in this forum, we ask members to always check the MD5 checksum of their ISOs to see if it matches with the Checksum provided at redump.org. Here is the utility I frequently use, I've used many different ones in the past, but this one seems to be the fastest of them all. -- Plus OPL Manager has a built in Hash checker also -- in case you didn't know this. (see tutorial below). [...]
2016  forumthread  cd  dvd  burning  vg.plat.ps2  tips  info  links  faq  opl.ps2  freemcboot  backup  windows  linux  unix  tutorial 
july 2019 by ezequiel
#3749 (Segfault in VFSs not setting block size in stat upon overwriting existing file) – Midnight Commander
See #3406 for the details.
Reproducer:
1) Connect by SFTP
2) Copy local file to remote
3) Overwrite local file on remote
4) Observe segfault if unlucky
issue  mc  links  2016  crash  linux  unix  remote  workaround 
july 2019 by ezequiel
[TUTORIAL] [OPL DEBUG] How to Troubleshoot Games that won't play in OPL - PS2-HOME.com - PS2 Homebrew and Tools
NOTE: Keep in mind that if you have all your OPL settings set correct, then most of the times when a game doesn't load in OPL, its because your RIPS are not good--this guide will help you troubleshoot them.

KEEP IN MIND: There are a few games that won't load no matter what you do--and we have a list of such games. Some games actually play better with older OPL builds. List of games that are known to have problems with either certain OPL Versions or Devices. [...]

[...] My favorite versions to test against are usually the following: r726, r753, r785, r789, and r791. Here is a list of games that play better with those older versions of OPL: [...]
opl.ps2  vg.plat.ps2  howto  tips  example  gaming  issue  workaround  fix  forumthread  tutorial  2016  samba  configuration  links  faq  windows  cd  dvd  burning  info  freemcboot  backup 
july 2019 by ezequiel
An input lag investigation - libretro forums
So, having improved the test rig, I decided to re-run some of my previous tests (and perform some additional ones). The aim of this post is to:
* Look at what sort of input lag that can be expected from RetroPie and if it differs between the OpenGL and Dispmanx video drivers.
* Look at what sort of input lag that can be expected from RetroArch in Windows 10.
* Isolate the emulator/game part of the input lag from the rest of the system, in order to see how much lag they actually contribute with and if there are any meaningful differences between emulators.
2016  forumthread  archived.version  retro  library  performance  issue  statistics  emulator 
july 2019 by ezequiel
zsnes dual monitor full screen issue. : snes
Comment: Try another emulator. Using ZSNES today has no rational advantage. RetroArch (with bsnes Accuracy core), snes9x and no$sns are great choices. higan would be the best, but I don't think it has fullscreen support the way you want it. [...]
2016  forumthread  snes  issue  workaround  windows  retro  gaming  emulator  reddit 
july 2019 by ezequiel
Cannot restart samba, samba.service is masked - Ask Ubuntu
Q: When I try to restart Samba, I am receiving the following error message:

Failed to start samba.service: Unit samba.service is masked.

In addition, when I run systemctl, it shows smbd.service in red showing failed.

At the same time restart began to fail, I have lost the share ability in folders created and cannot access. [...]
forumthread  2016  stackexchange  issue  samba  sysadmin  howto  systemd  workaround  tips  example  linux 
july 2019 by ezequiel
keyboard shortcuts - In bash vi mode, map jk to exit insert mode - Unix & Linux Stack Exchange
Q: I'm using a fresh install of ubuntu 16.04, with the bash shell. There are two things that I want to do:

Set up vi mode so I can have vim-like movements from the terminal
exit insert mode by typing jk
I read in another post how this can be done with zsh, how can I do it with bash? [...]
2016  bash  vi  keyboard  configuration  howto  zsh  links  example  unix  linux  windows  macosx  scripting  stackexchange  forumthread 
june 2019 by ezequiel
Adding 24-bit TrueColor RGB escape sequences to tmux - The Terminal Programmer
[...] Enable the Tc terminal capability for the outer terminal (to which tmux is attached) by setting the terminal-overrides option in tmux and subsequently detach and reattach tmux, as the following example (wherein $TERM is st-256color and % is a shell prompt) illustrates: [...]
tmux  textui  colour  terminal  howto  tips  configuration  scripting  example  2016  blogpost  links  patches  linux  unix 
june 2019 by ezequiel
streaming - How to watch Acestream / Sopcast Ubuntu 16.04 LTS? - Ask Ubuntu
Q: Have you guys used Acestreams? The repository has not yet issued for 16.04 LTS, but besides, it might not be free anymore.
Is anyone watching Acestreams/Sopcast with any other software + where can I find such software? [...]
2016  forumthread  stackexchange  installation  install  howto  tips  example  linux  ubuntu  ubuntu.xenial  mint  snap  acestream  player 
june 2019 by ezequiel
Xfce4 Desktop getting stuck (not responding) / Desktop / Xfce Forums
The Xfce4 desktop is not responding all of a sudden. This is happening every day. The keyboard, mouse both are getting stuck. Neither does the mouse pointer moves nor does the keyboard work. [...]
xfce  xubuntu  mint  linux  desktop  issue  workaround  forumthread  2016  tips  cli  sysadmin  xorg 
june 2019 by ezequiel
Start a docker container on CentOS at boot time as a linux service | esalagea
Note: If docker daemon does not start at boot, you might want to enable the docker service
(me: very simple example that does not address errors well, integration with firewalls (ufw), reusability, etc.)
docker  blogpost  2016  example  tips  linux  systemd 
june 2019 by ezequiel
Life and death of a container – DevOpsion – Medium
Docker containers are prepared to die at any time: you can stop, kill and destroy them quickly. And when you do it, all data created during its existence is wiped out by default.
2016  blogpost  reference  faq  diagrams  docker  example  sysadmin  cli 
june 2019 by ezequiel
The Overhead of Docker Run | The Iron.io Blog
We use Docker a lot. Like a lot, lot. While we love it for a lot of things, it still has a lot of room for improvement. One of those areas that could use improvement is the startup/teardown time of running a container.
performance  docker  linux  macosx  comparison  test  blogpost  2016 
june 2019 by ezequiel
Run Chrome/Chromium with proxy settings on Linux - Internal Pointers
[...] Fair enough: Chrome and Chromium cannot read environment parameters I set up for my proxy, so the solution lies in the command line. What follows is the generic option flag for when you invoke Chrome/Chromium from the terminal: [...]
blogpost  2016  cli  chrome.browser  chromium  configuration  proxy  howto  example  tips 
may 2019 by ezequiel
Goodbye, Lua · RealMensch
[...] So why did I leave?
Five factors combined in a perfect storm to cause me to drop Lua as a game scripting language, as a server language, and as a language for my command line tools:
* LuaJIT is in permanent maintenance mode.
* Lua version fragmentation.
* JavaScript's ecosystem is awesome.
* Lua Coroutines are no longer a monopoly.
* Type annotations FTW
(me: good comments and links about performance, language design, etc.)
2016  blogpost  lua  comparison  links  forumthread  performance  compatibility  review  python  language 
april 2019 by ezequiel
x11 - How to get the real name of font? - Unix & Linux Stack Exchange
Q: In my .spacemacs I try to change my default font but it draws an error, how to find the name of fonts that you can write up in config files?
2016  forumthread  stackexchange  unix  linux  x11  emacs  configuration  fonts  cli  tool  tips  example  scripting 
april 2019 by ezequiel
Primer on Python Decorators – Real Python
In this tutorial on decorators, we’ll look at what they are and how to create and use them. Decorators provide a simple syntax for calling higher-order functions.

By definition, a decorator is a function that takes another function and extends the behavior of the latter function without explicitly modifying it.
python  tutorial  howto  tips  example  online  2018  programming  article  2016  2015 
april 2019 by ezequiel
Faster Grepping in Vim
However, we have a need for speed. How can we grep faster?
grep  vim  howto  tips  search  blogpost  2013  2016  example  tool  linux  unix  configuration 
april 2019 by ezequiel
amazon web services - Is there a way to export an AWS CLI Profile to Environment Variables? - Stack Overflow
Q: When working with certain third-party tools like Terraform, it's not easily possible to specify an AWS CLI profile, and I like working with the environment variables better than the profiles.

Is there a way for me to have the AWS CLI simply export the current profile as AWS_ACCESS_KEY_ID and AWS_SECRET_KEY environment variables to my session?
cli  environment  shell  unix  linux  example  tips  amazon.aws  forumthread  stackexchange  2016  2018  script  terraform 
april 2019 by ezequiel
makefile - make - define multiple variables in the same eval call - Stack Overflow
A: What separates each variable definition is the newline character, which you are escaping with the backslash. Since you cannot put it directly in the eval function, you have to define it and to use it into eval like this: [...]
[...] Note that if you want to use a variable in the definition of the second one you have to escape the $ character like this: [...]
2016  forumthread  stackexchange  make  gnu  tips  example  scripting 
march 2019 by ezequiel
Ensure Data Integrity of Objects in Amazon S3
Q: I want to upload an object to an Amazon Simple Storage Service (Amazon S3) bucket. Additionally, I want to verify the integrity of the uploaded object using the MD5 checksum value. How can I do that?
faq  howto  guide  amazon.aws  amazon.s3  cli  windows  linux  unix  macosx  example  2018  2016  info  links  tips 
february 2019 by ezequiel
HTTPD listening in IPv6, according netstat, but reacheable in IPv4 - Server Fault
Q: Using Openstack, I have a Web GUI (horizon) hosted on my server (HTTPS).

When I do a netstat -lt | grep https, I have:

tcp6 0 0 [::]:https [::]:* LISTEN
With lsof -i :443, I have:
[...]
However the server is reachable in IPv4. It's ok for me but I wonder why there is not an entry with netstat like this:

tcp 0 0 0.0.0.0:https 0.0.0.0:* LISTEN
ipv6  tcpip  networking  linux  forumthread  stackexchange  sysadmin  info  cli  2016 
february 2019 by ezequiel
With Lua how can I get the current date-time with milliseconds - Stack Overflow
A: You could take the current UNIX time with os.time() and then add the milliseconds from os.clock() [...]
2016  time  api  example  lua  forumthread  stackexchange 
january 2019 by ezequiel
python - Merging two dictionaries while keeping the original - Stack Overflow
Q: In Python, when I merge two dictionaries using the update() method, any existing keys will be overwritten.

Is there a way to merge the two dictionaries while keeping the original keys in the merged result? [...]
2016  forumthread  stackexchange  python  programming  example  tips 
december 2018 by ezequiel
How to Merge Two Python Dictionaries
In a previous tutorial we learned about Python Dictionaries, and saw that they are considered unordered sets with a key/value pair, where keys are used to access items as opposed to the position, as in lists for instance.

In this quick tip, I'm going to show you how to concatenate (merge) two dictionaries together. [...]
2016  blogpost  python  programming  tips  example 
december 2018 by ezequiel
What is the difference between the vim snippets plugins? - Vi and Vim Stack Exchange
Q: There is a great number of snippets plugins for vim: ultisnips, snipmate, xptemplate, neosnippet and a lot more.

They all have pros and cons and more or less dependencies. [...]

[...] There is a listing here which could be a good start but some complete, clear and precises answers as our community can write would be pretty useful.
2016  forumthread  stackexchange  vim  plugins  comparison  links  development  tool 
december 2018 by ezequiel
Using Vim as a JavaScript IDE - DotNetSurfers
I have been writing a lot of Javascript code (both server and client side) over the last few months. Having worked entirely with Visual Studio and R# for the last 10 years, I had a couple of options for my Javascript IDE. I could use Visual Studio Code, or JetBrains WebStorm or Vim, which I have been using for the last few years for text editing. I have been wanting to level up my Vim-Fu for a while, so I decided to start with that.

In this post, I’ll outline the plugins that have helped me get a good coding workflow going. I use Vundle to manage my Vim plugins, though any good plugin manager should suffice. I am using MacVim currently, but the same setup should work in Terminal Vim too.
development  javascript  ide  editor  tips  vim  configuration  plugins  links  blogpost  2016  screenshots  reviews 
december 2018 by ezequiel
linux - how to change python interpreter used by jedi-vim - Vi and Vim Stack Exchange
Q: I have Anaconda (including python3.5.2), VIM (7.4) and Jedi-VIM installed on my system. There was also a python installed on the linux system by default.
The autocompletion is working on base packages, at least. But for packages like numpy (which was included in Anaconda) the completion is not working.
[...]
How can I get jedi-vim to use also the path of anaconda python for getting package autocompletion?
2016  forumthread  stackexchange  python  vim  tool  configuration  howto  tips  links 
december 2018 by ezequiel
autocmd - Stop highlighting when entering Insert mode - Vi and Vim Stack Exchange
Q: I would like Vim to stop highlighting matches when entering Insert mode. And not to highlight them again until a new search is performed. [...]
2016  forumthread  stackexchange  configuration  scripting  example  tips  vim  ui 
december 2018 by ezequiel
Airline caused massive lag when editing ruby files · Issue #1026 · vim-airline/vim-airline
So I've seen most of the suggestions for speeding up Ruby and Vim specifically and I've implemented almost all of them. But what ended up having the most impact was actually removing this plugin. I profile about 5 seconds of editing a ruby file the results are below.
I'm not sure if this is specific to Ruby either. I know Ruby syntax and Vim have some problems so the lag might not be apparent for other languages.
Could there have been something wrong with my setup?
2016  github  issue  plugin  performance  vim  neovim  forumthread  profiling  tips  configuration 
november 2018 by ezequiel
vim get slower after installing vim-airline · Issue #421 · vim-airline/vim-airline
A: [...] Super late to this, but first time install airline and encountered a similar issue. Found a nice solution should anybody else stumble along this down the line. [...]
2014  2016  issue  github  vim  plugin  ui  keyboard  performance  configuration  example  tips  links  workaround 
september 2018 by ezequiel
tmux session in weird semi-zombie state · Issue #298 · tmux/tmux
Q: [...] I'll attach to a running tmux session and all of the windows/panes in it appear frozen. But they're not actually frozen; they're just not redrawing when they receive input. [...]
issue  tmux  github  terminal  textui  workaround  2016  unix  linux  keyboard 
september 2018 by ezequiel
Tmux Scripting | Peter Debelak
If you use tmux in your terminal you probably have a default set-up you use. For example, I always have the same windows open with the same names split up in the same way at work, so I decided I might as well make a script to avoid all that manual work each time.
tmux  scripting  example  blogpost  2016  unix  linux  tips 
september 2018 by ezequiel
How do I check the version of NeoVim in vimscript? - Vi and Vim Stack Exchange
Q: I can check vim's version by using v:version, and I can check if I am running in nvim by doing has('nvim'). Is there a variable like v:version in neovim to let me know the nvim version, like 0.1.4 or 0.1.6?
2016  forumthread  stackexchange  neovim  scripting  tips  example  compatibility  howto 
august 2018 by ezequiel
Using a different X11 window manager with XQuartz - Tony Finch's blog
[...] You can't just switch window managers by starting another one - X only allows one window manager at a time, and other window managers will refuse to start if one is already running. So you have to configure your X session if you want to use a different window manager. [...]
2016  xquartz  windowmanager  howto  tips  macosx  x11  configuration  blogpost 
august 2018 by ezequiel
Ubuntu virtual terminal cursor style resetting - Super User
Q: I am running Ubuntu 14.04 and using one of the virtual terminals (TTY[1-6], accessible via Ctrl-Alt-F[1-6]); I want to permanently change the appearance of my cursor from the apparent default, a blinking underline, to a blinking box. I can change it temporarily, but it is consistently resetting when certain applications are run. [...]
(me: good explanation in the "accepted answer"; quoted excerpt from tmux(1) man page provided the only command that worked to fix tmux after neovim left the terminal in a "garbage-writing" state: printf '\033[0 q')
2016  forumthread  stackexchange  textui  terminal  configuration  issue  workaround  links  unix  linux  xterm  tmux  neovim  tips  example  debian  ubuntu  mint 
august 2018 by ezequiel
Tim Urban: Inside the mind of a master procrastinator | TED Talk
Tim Urban knows that procrastination doesn't make sense, but he's never been able to shake his habit of waiting until the last minute to get things done. In this hilarious and insightful talk, Urban takes us on a journey through YouTube binges, Wikipedia rabbit holes and bouts of staring out the window -- and encourages us to think harder about what we're really procrastinating on, before we run out of time.
productivity  psychology  procrastination  2016  video 
july 2018 by ezequiel
pip install --user should check that the user's $PATH is correct · Issue #3813 · pypa/pip
On Unix, pip install --user ... drops scripts into ~/.local/bin. Historically, this directory has not been on the default Debian/Ubuntu $PATH. [...]
2016  issue  github  python.pip  configuration  bash  shell  unix  linux  forumthread 
july 2018 by ezequiel
Penn & Teller FOOL US Featuring Michael Vincent YouTube - YouTube
This is my first appearance on Penn & Teller FOOL US recorded in 2009 and aired in 2010. I was given full permission to make use of this footage for my PR by September Films and 1/17 Productions. I am sharing this footage on my Channel now for all to enjoy. I may not have fooled Penn & Teller, however, to go on television and perform a classic and classy piece of magic meant the world to me along with receiving the effusive praise of Penn & Teller. Thanks for watching.
magic  playingcards  video  youtube  english  2016 
july 2018 by ezequiel
Installing PDN under Wine in Linux. - Paint.NET Discussion and Questions - paint.net Forum
Has anyone had any success installing PDN under Wine in Linux? I've tried multiple times with version 4.0.9 and even 3.5.11, with no luck at all. I thought v 4.0.9 would succeed, but it crashed while trying to install Dot.NET 4.6.1.
winecompatible  howto  tips  installation  example  wine  ubuntu  mint  linux  guide  forumthread  2016  software  paint.net 
may 2018 by ezequiel
Which algorithms can predict stock price? - Quora
A1: First of all I agree that it’s nearly impossible to predict the exact value of the stock price. I think that the more sound approach is to try to consider stock price as a random variable and to try to estimate it’s distribution and how it could change. [...]
forumthread  2016  finances  english 
may 2018 by ezequiel
javascript - Browser: Identifier X has already been declared - Stack Overflow
Q: I am using ES6 with Babel in my project and I am getting an error when I declare one of my const [...]
2016  forumthread  stackexchange  javascript  browser  issue  workaround  tips  example  node.js 
may 2018 by ezequiel
Suddenly my MacBook Pro 13-inch is giving a low sound output when compared to the first time. What should I do? - Quora
A: I am also facing the same issue and for the same i have did little research on google finding the reasons.
And then i found that it is because of team viewer application.
Many users solved it by closing that app.
2016  forumthread  tips  issue  workaround  audio  mac  macosx  hardwaresupport 
may 2018 by ezequiel
16.04 - Installing and using universal-ctags instead of exuberant-ctags - Ask Ubuntu
Q: How could I switch from exuberant-ctags to universal-ctags. I am using Ubuntu 16.04 LTS and [...]
-
tags: ctags tool build howto example forumthread stackexchange 2016 tips
ctags  tool  build  howto  example  forumthread  stackexchange  2016  tips 
march 2018 by ezequiel
« earlier      
per page:    204080120160

Copy this bookmark:





to read