recentpopularlog in

ezequiel : 2017   185

« earlier  
xubuntu - Why does light-locker keep the screen black after unlock? - Ask Ubuntu
Q: A Xubuntu 16.04 fully patched machine with a freshly created user wont let me unlock after using light-locker to lock my screen (regardless if lock was activated manually or via timeout). The screen remains black (but powered) on correct password entry

Killing light-locker from tty1 will reveal the desktop then (and consequently prevents further locking). [...]

A: TL;DR: light-locker keeps the screen black if systemd cannot read /proc

* light-locker depends on dbus providing IPC.
* dbus depends on systemd-logind providing session information.
* systemd-logind depends on /proc providing process information. [...]
2017  forumthread  stackexchange  internals  desktop  xfce  xubuntu  issue  workaround  tips  example  cli  sysadmin  security  hardwaresupport  systemd  dbus  ui 
6 days ago by ezequiel
xorg - How is my Intel gpu running without its driver installed? - Ask Ubuntu
Q: When I boot my Xubuntu 17.04 PC with the integrated Intel gpu, it runs fine (with screen tearing) at full native resolution without the xserver-xorg-video-intel package installed. But, lshw -c video lists the driver in use as driver=i915. How is this possible?
xubuntu  ubuntu  intel  driver  xorg  kernelmodule  hardwaresupport  forumthread  stackexchange  2017  info  links  opengl  memory 
11 days ago by ezequiel
How to Migrate Your Google Account to a New One
Whether you’ve outgrown your college era email address and you want a professional one, or you want to change your firstname.maiden account to firstname.marriedname one, we’ve got you covered with a start-to-finish Google migration guide.
google  privacy  cloudcomputing  backup  remote  howto  guide  blogpost  2017 
16 days ago by ezequiel
#870126 - ecryptfs-mount-private: mount: No such file or directory - Debian Bug report logs
Q: I have setup the standard home ~/Private directory. It looks like it is confused about which key to use.

For the last few months or so, I get this (key IDs changed but consistent in report):

$ ecryptfs-mount-private

[...]

A: [...]

1. The problem is the user keyring not being linked
to the session keyring. keyctl link @u @s is a much easier workaround. [...]
2017  issue  workaround  ecryptfs  encryption  forumthread  cli  example  configuration  pam  filesystem  debian  ubuntu  security  tips 
17 days ago by ezequiel
How to Easily Softmod ANY Fat PS2! | FreeMCBoot & FreeHDBoot Install Tutorial - YouTube
This tutorial has been requested for quite a long time but I waited so long because I was not too keen on the many install methods shown out there. A few recommendations to softmod a PS2 with FreeMCBoot normally include: finding a pre-modded console, using a disc swap trip, using Swap Magic, all of which could be a bit costly or time consuming. With this method all we need is one console and a few tools at our disposal! No swap tricks or discs, no pre-loaded memory card, no reliance on any other system!

This involves installing FreeHDBoot to a hard drive, loading it into the PS2 and using that as our entry point to install FreeMCBoot. That's it! No additional games needed and no need to open up our console!
vg.plat.ps2  modding  hacking  freemcboot  harddisk  windows  windows7  windows8  windows10  configuration  booting  sysadmin  howto  guide  tutorial  video  youtube  gaming  hardwaresupport  hardware  links  2017  opl.ps2  usb  memory 
17 days ago by ezequiel
FS#714 : ARP/Broadcast does not reach other clients in the same WLAN
I have the default bridge with ethernet and WLAN in it. When i try to send data from a client to another, both connected to the same WLAN SSID, it doesn’t work (Destination unreachable).
Wireshark shows that it sends endless ARP requests to Broadcast, but the other clients in that WLAN never get it (and therefore can’t answer). The broadcast gets still delivery to every client connected through Ethernet. If i create a second WLAN SSID (even on the same adapter) and and add it to the bridge, it gets also all broadcast packets from the other WLAN...
So if i put the 2 clients in different WLAN SSIDs or ethernet they get the broadcast from each other, but not when both are connected to the same.
wifi  networking  openwrt  issue  workaround  forumthread  configuration  2017 
28 days ago by ezequiel
Hack Correlation: Non-genuine battery in Lenovo X230
[...] Second, the battery is suited for an X220 model, not X230.
Third - and most importantly - the battery is a fake, with less than the advertised capacity.

If you still decide to continue, then read on. Some nice people have managed to decrypt the EC firmware inside the Lenovo laptops and allow for a way to rewrite it:
https://github.com/hamishcoleman/thinkpad-ec [...]
2017  blogpost  laptop  battery  tips  howto  hacking  windows  windows10  ubuntu  linux  links  tool  screenshots  issue  workaround  bios  firmware  patches  hardwaresupport 
4 weeks ago by ezequiel
How to View Colored Man Pages in Linux
[...] By default, the man program normally uses a terminal pager program such as more or less to format its output, and the default view is normally in white color for every kind of text (bold, underlined etc..).

You can make some tweaks to your ~/.bashrc file to get nicely colored man pages by specifying a color scheme using various LESS_TERMCAP variables. [...]
tutorial  howto  configuration  terminal  colour  linux  unix  manpage  blogpost  2017  environment  example  tips 
5 weeks ago by ezequiel
How to configure ufw to forward port 80/443 to internal server hosted on LAN - nixCraft
I am using UFW to protect my network. How do I forward TCP HTTP port # 80 and 443 to an internal server hosted at 192.168.1.100:80 and 192.168.1.100:443 using UFW on Ubuntu Linux server?

UFW is an acronym for uncomplicated firewall. It is used for managing a Linux firewall and aims to provide an easy to use interface for the user. In this tutorial, you will learn how to forward incoming traffic to your server running ufw on port 80/443 to port 80/443 on another internal server hosted in your LAN/VLAN.
2017  iptables  ubuntu  firewall  networking  configuration  sysadmin  linux  cli  example  tips  blogpost 
5 weeks ago by ezequiel
Docker-compose.yml and custom script after entrypoint (before command) · Issue #205 · docker-library/wordpress
Q: I have fairly simple need, and have been struggling with this many hours now. I want to run some script after entrypoint, and before command. I've tried running it as a command but no luck. [...]
2017  configuration  docker  tool  tips  issue  workaround  github  example  howto 
5 weeks ago by ezequiel
Understand Linux Load Averages and Monitor Performance of Linux
In this article, we will explain one of the critical Linux system administration tasks – performance monitoring in regards to system/CPU load and load averages.
performance  tool  tools  linux  kernel  benchmark  tips  info  example  cli  software  tutorial  cpu  2017  article 
6 weeks ago by ezequiel
KODI 17 KRYPTON FORK FOR ANDROID 4.4.2 -
This is a Kodi 17 Krypton fork made specifically for older devices using Android 4.4.2 operating system, and is called MyGica Media Centre
Also works on Android 4.4.4
android.app  compatibility  oldversion  xbmc  download  links  mediaplayer  2017 
7 weeks ago by ezequiel
Low_On_Memory - linux-mm.org Wiki
It's a common dilemma: I just got a brand new Linux machine, loaded it up with lots of expensive RAM, and left it for a day. Now, it's out of memory, or it is swapping! It definitely has enough RAM, so there must be a bug in Linux!I assure you, in almost all cases, your system has plenty of RAM. However, where is all of that RAM going? For what does Linux use all of it? How can I actually tell that I'm out of RAM? Unfortunately, Linux can make these very hard questions to answer. This article will explain in detail many of the ways that Linux uses RAM for things other than user data and how you can tell when your system is _actually_ out of RAM.
2017  wikientry  article  memory  fileformats  linux  kernel  internals  tips  example  reference  documentation  cli 
9 weeks ago by ezequiel
Removed Container Still Attached to Network · Issue #33156 · moby/moby
Q: I've got a removed container tying up an endpoint name in the bridged network, and I can't remove the container from the network since the container no longer exists.

The issue could most likely be resolved by clearing everything out and starting it up again but due to #32613 that would result in data loss so I'm avoiding that. Using a different name for the container allows it to be started but this is not ideal.

A: [...] Have you tried the -f / --force option on docker network disconnect? docker network disconnect <network> <endpoint-id>, so in your case; [...]
issue  docker  networking  configuration  workaround  forumthread  2017  linux  sysadmin  tips  example  github 
9 weeks ago by ezequiel
Using HAProxy with the Proxy Protocol to Better Secure Your Database - HAProxy Technologies
The Proxy protocol is a widely used invention of our CTO at HAProxy Technologies, Willy Tarreau, to solve the problem of TCP connection parameters being lost when relaying TCP connections through proxies. Its primary purpose is to chain proxies and reverse-proxies without losing client information, and it’s used and supported by AWS ELB, Apache, NGINX, Varnish, Citrix, and many more (here’s a longer list of Proxy protocol supported technologies).
proxy  tcpip  2017  security  blogpost  haproxy  protocol  links  article  example 
11 weeks ago by ezequiel
some kind of screen corruption · Issue #1040 · tmux/tmux
Q: [...] I'm executing '/', then repeating that search few times with n and after that I'm using move commands. You can notice some kind of corruption on screen - it looks like some of the lines are duplicated until vim repaints them. For completness, here I'm trying to reproduce this with 2.3, where everything works correctly: [...]

A: [townba commented on 17 Aug 2017]
I suspect that the three emulators that show the problem don't implement everything correctly.
Can you try adding the line:

set -ags terminal-overrides ",xterm-*:csr@"

to your .tmux.conf and see if that helps?
2017  github  issue  terminal  screen  tmux  workaround  configuration  links  gui  textui  linux  unix 
december 2019 by ezequiel
arrays - TCL: How to convert a tcl data into json format? - Stack Overflow
Q: For an example tcl array:

% set arr {"key" {1 2 3}}

conversion into json format

-> {"key" : [1,2,3]}

I am looking for a solution for above example without using any library.
2017  forumthread  stackexchange  links  example  tips  tcl  library  json 
october 2019 by ezequiel
Why not rewrite LLVM in Rust? : rust
Q: I know this would take a long time to redo entire LLVM in Rust, but given that Rust is now faster and much safer than C++ makes me think "why not?"
[...]
A: There's a lot of reasons why not and this applies to any large project where people say, "Why not rewrite it in Rust?" [...]
llvm  c++  rust  comparison  forumthread  reddit  2017  performance  security  links 
october 2019 by ezequiel
Bug #1717995 “extra domains not removed from resolv.conf when VP...” : Bugs : systemd package : Ubuntu
I use a VPN (network manager "vpnc" config) to connect to my work network. The gateway is "webvpn.purestorage.com". When I connect, I get "purestorage.com" added to the "search" line in my /etc/resolv.conf (and /run/resolvconf/interface/systemd-resolved) - which makes perfect sense, the VPN passes this info to me and then I can connect to systems within the work network without having to use a FQDN.

The bug (which is a regression from older versions of Ubuntu) is that when I lose my connection to the VPN (either because I disconnect explicitly, or because the network goes down or I suspend my laptop), the "purestorage.com" domain is not removed from those "search" lines. And for some reason this prevents me from resolving webvpn.purestorage.com (which prevents me from reconnecting to the VPN). [...]
systemd  issue  ubuntu  linux  2017  forumthread  dns  sysadmin  networking  vpn 
october 2019 by ezequiel
What to do with 4 old sata drives? - Raspberry Pi Forums
Q: I have 4 old internal 80Gb sata drives, not much value in them, but they're all identical and good quality. So why not build a raid I hear you say! Well, I was thinking the same thing. [...]
raspberrypi  harddisk  hardwaresupport  usb  power  hardware  raid  forumthread  2017  tips  embedded 
october 2019 by ezequiel
Linux Distributions Optimized for Hosting Docker · Sweetcode.io
You can run Docker containers on any modern Linux distribution. But some specialized Linux-based operating systems are designed specifically for running Docker. If you want to host containers, these Linux platforms may be a better fit than an all-purpose Linux distribution.
2017  blogpost  distro  comparison  links  linux  docker  sysadmin  virtualisation  tips  performance 
october 2019 by ezequiel
Android 2.2.1 · Issue #2125 · koreader/koreader · GitHub
Q: Is there anyway I can force KOReader to install on my old Sony PRS-T1 which runs on android 2.2.1. I know its supposed to run on android 2.3 and above but is there some hack that I can try ? It will make the device super cool. [...]
sony.prs.t2  koreader  compatibility  issue  github  2017  porting  android.app  forumthread  2016 
october 2019 by ezequiel
dual boot - How can I repair grub? (How to get Ubuntu back after installing Windows?) - Ask Ubuntu
A: [...] I've seen various instructions for replacing GRUB by mucking around with GRUB commands or some such, but to me the easiest way is to simply chroot into your install and run update-grub. chroot is great because it allows you to work on your actual install, instead of trying to redirect things here and there. It is really clean.
2011  2017  grub  booting  issue  workaround  installation  howto  tips  sysadmin  ubuntu  debian  livecd  livedvd  example  harddisk  partition  configuration  linux  windows  forumthread  stackexchange 
september 2019 by ezequiel
Docker -- WARNING: No swap limit support - Unix & Linux Stack Exchange
Q: I'm running Docker(1.9.1) on Ubuntu 16.04. When I run docker info the last line of the output says:

WARNING: No swap limit support. [...]

A: [...] Swap limit support allows you to limit the swap the container uses, see https://docs.docker.com/engine/admin/resource_constraints

According to https://docs.docker.com/engine/installation/linux/linux-postinstall/#your-kernel-does-not-support-cgroup-swap-limit-capabilities : [...]
docker  2017  memory  configuration  kernel  booting  linux  performance  reference  links  sysadmin  virtualisation  workaround 
september 2019 by ezequiel
6 ideas de un esclavo que vivió hace casi 2000 años que podrían cambiarte la vida
Sufres porque quieres, nadie te puede dañar y eres tan infeliz como deseas. Al menos es lo que te diría Epicteto (50 - ¿120? dC), el filósofo estoico que vivió más de 40 años como esclavo en Roma durante el siglo I d.C. Hoy, algunos psicólogos cognitivos recuperan algunas de sus ideas para mejorar nuestra salud emocional. Después de 2.000 años, algunas de ellas todavía parecen novedosas y, sobre todo, eficaces.
2017  article  spanish  philosophy  lifehacks  health  psychology 
september 2019 by ezequiel
compression - How can I reduce the file size of a scanned PDF file? - Ask Ubuntu
Q: I have a 72.9MB PDF file that I need to shrink into under 500KB.
The file was a JPEG image that I had scanned, and then converted to pdf.

A: [...] Here are a couple of script and command-line solutions. Use as you see fit.
* reduce-pdf-file-size-linux
* shrinkpdf
* compress-a-pdf-with-pdftk
* pdfcompress
pdf  fileformats  tool  tools  cli  links  unix  linux  ubuntu  debian  forumthread  stackexchange  2012  2015  2017  compression 
september 2019 by ezequiel
linux - "Cannot allocate memory" despite free reporting "available" - Stack Overflow
Q: I got this error from qemu, trying to start a VM with 3GB memory:

ioctl(KVM_CREATE_VM) failed: 12 Cannot allocate memory
failed to initialize KVM: Cannot allocate memory
[...]

A: [...] echo 1 > /proc/sys/vm/compact_memory [...]
qemu  issue  memory  workaround  virtualisation  links  forumthread  stackexchange  2017  2018  kernel  example  cli  sysadmin  linux 
august 2019 by ezequiel
Which OpenGL implementation is my Qt Quick app using today? - Qt Blog
[...] It is not always obvious what is going on. Just starting a Qt Quick application and getting some output does not mean rendering is happening on the optimal path. When the application does not render at the expected speed, the very first thing to verify is if the graphics stack is the expected one. There can always be an unexpected environment variable or blacklist rule present, or the application may pick the wrong graphics stack when there are multiple ones present in the system. [...]
qt  blogpost  2017  configuration  cli  example  tips  windows  macosx  linux  opengl  library  performance 
august 2019 by ezequiel
Vmc not working - Forum: Official Open PS2 Loader Forum
A: [...] I rarely got this message only when my connection with the SMB server was cut by an unfortunate "Reset" when launching any game. The SMB server is a Windows-7, it has "kept" the active connection only with the VMC, it is a Win7 system error I have never met with a WinXP. This error corrects itself by stopping the console (total shutdown) for 1 to 2 minutes and then resuming the game everything happens alone. If that does not work, you have to restart your PC and everything will resume as before your problem. You can also stop your Ethernet connection and restart it. [...]
(me: running (on Debian/Ubuntu): 'sudo systemctl restart smbd nmbd' sorted it for me)
issue  2017  windows  windows7  windowsxp  samba  networking  opl.ps2  workaround  forumthread  configuration  vg.plat.ps2 
august 2019 by ezequiel
#866019 - mc: Crash On SFTP Upload - Debian Bug report logs
When I try to upload a file with SFTP then MC crashes with following error:

mc:7228 GLib-ERROR ** /build/.../glib/gmem.c:100 failed to allocate ... bytes

Trace/Breakpoint

Jun 26 18:33:54 - kernel: [10139.526827] do_trap: 93 callbacks suppressed
Jun 26 18:33:54 - kernel: [10139.526834] traps: mc[7228] trap int3
ip:7f96dfacd261 sp:7ffec9304350 error:0
Jun 26 18:33:54 - kernel: [10139.526842] in
libglib-2.0.so.0.5000.3[7f96dfa7d000+112000]

Download is fine.

And there are some SFTP Protocol Error -31
debian  issue  links  mc  linux  remote  2017  ssh 
july 2019 by ezequiel
#3406 (-31: SFTP Protocol Error when transferring file via SFTP Link) – Midnight Commander
Seems that after OpenSSH Server update after infamous Heartblead bug, Im allways getting these errors when copying / moving files within SFTP built in mc:
COPY/MOVE FILE TO REMOTE: "-31: SFTP Protocol Error"
REMOVE REMOTE FILE/DIR: "-31: Failed opening remote file"
[...]
(me: eventually fixed -- patches included, releases containing the patches are available)
mc  issue  patches  workaround  source  ssh  remote  links  forumthread  2015  2017 
july 2019 by ezequiel
LevelDB read failure: Corruption: block checksum mismatch · Issue #11355 · bitcoin/bitcoin
Build against commit f197a4c, a small change from master branch 09627b1 - bitcoin-qt had been running for 12 hours or so without a problem, was fully synced, then suddenly I saw an error frame pop up with no content. Here's a screenshot: [...]
bitcoin  software  linux  unix  qt  issue  forumthread  2017 
july 2019 by ezequiel
How to change Wi-Fi password? - Help and Support / Raspberry Pi - OSMC Forums
My OSMC setup was doing well and then yesterday I changed my Wi-Fi password for security reasons and wanted to change it on my Raspberry Pi using the GUI with My OSMC but the connexion times out when I try to enter the new password and I can not forgot my WiFi network within My OSMC …
2017  raspberrypi  networking  raspbian  configuration  wifi  security  sysadmin  howto  tips  forumthread 
june 2019 by ezequiel
How to force Docker not to bypass the UFW rules on Ubuntu 16.04
[...] So let’s just go a bit deeper and face one of the most commonly occurring problems I tried to solve a few months ago as well. If you have ever tried to make the Docker work with the UFW, then you probably know what’s the said struggle. Let’s examine it!
2017  blogpost  cli  sysadmin  ufw  firewall  configuration  howto  tips  example  linux  docker  iptables  ubuntu  ubuntu.xenial 
june 2019 by ezequiel
How to get a Docker container's IP address from the host? - Stack Overflow
Q: Is there a command I can run to get the container's IP address right from the host after a new container is created?

Basically, once Docker creates the container, I want to roll my own code deployment and container configuration scripts.
2013  2017  forumthread  stackexchange  cli  networking  tcpip  example  tips  links  docker  sysadmin 
june 2019 by ezequiel
linux - Systemd: Supervising process XXXX which is not our child. We'll most likely not notice when it exits - Server Fault
Q: [...] Everything looks ok, except for:

... systemd[1]: aaa.service: Supervising process 18285 which is not our child. We'll most likely not notice when it exits.

Wondering why this message is showing and if it is anything to be concerned about?
issue  forumthread  stackexchange  2017  linux  systemd  sysadmin  example 
june 2019 by ezequiel
group - Unable to get iptables owner module (gid-owner) to work - Unix & Linux Stack Exchange
A: [...] Only the primary/default group of the owner of the packet will be compared. Therefore, any username you added to your vpn group after the user was created will be in the vpn group as a secondary user, and they won't be branched even though they are a member of the group! [...]
iptables  issue  workaround  forumthread  stackexchange  sysadmin  linux  firewall  configuration  howto  links  tips  example  2017  security  networking 
may 2019 by ezequiel
iptables - Redirect port 80 to 8080 and make it work on local machine - Ask Ubuntu
Q: It works fine for all the world except my own machine. I am a developer and I need to redirect port 80 to 8080 for myself.

My IP is 192.168.0.111

My web server runs on port 8080

I wish to open website from http://192.168.0.111/ instead of http://192.168.0.111:8080/ from same machine where server runs. [...]
2014  2017  forumthread  stackexchange  iptables  firewall  linux  cli  example  tips  sysadmin  networking  security  proxy  webserver 
may 2019 by ezequiel
URLBlacklist.com [archive.org]
[...] You are reminded that this is a commercial service that works upon an honour system. If you use the service then you must buy a subscription. We do not password the blacklist download to keep scripts simple for all users. Please do not abuse the service. [...]
proxy  e2guardian  squid  security  downloads  links  daily  security.list  archived.version  2017 
may 2019 by ezequiel
Observer Design Pattern | Microsoft Docs
The observer design pattern enables a subscriber to register with and receive notifications from a provider. It is suitable for any scenario that requires push-based notification. The pattern defines a provider (also known as a subject or an observable) and zero, one, or more observers. Observers register with the provider, and whenever a predefined condition, event, or state change occurs, the provider automatically notifies all observers by calling one of their methods. In this method call, the provider can also provide current state information to observers. In the .NET Framework, the observer design pattern is applied by implementing the generic System.IObservable<T> and System.IObserver<T> interfaces. The generic type parameter represents the type that provides notification information.
dotnet  api  design  article  howto  tips  microsoft  2017 
april 2019 by ezequiel
python - Filter dict to contain only certain keys? - Stack Overflow
Q: I've got a dict that has a whole bunch of entries. I'm only interested in a select few of them. Is there an easy way to prune all the other ones out?
2010  2017  python  example  tips  programming  forumthread  stackexchange 
february 2019 by ezequiel
How to pass a tuple as arguments to a Lua function? - Stack Overflow
A: Lua does not have "tuples".
When a function returns multiple values, it returns multiple values. They aren't put together into some data structure; they're separate values. If you want to store multiple return values in a single data structure, you have to actually do that.
2017  lua  programming  language  example  tips  forumthread  stackexchange 
february 2019 by ezequiel
python - How do I install PyCrypto on Windows? - Stack Overflow
A: If you don't already have a C/C++ development environment installed that is compatible with the Visual Studio binaries distributed by Python.org, then you should stick to installing only pure Python packages or packages for which a Windows binary is available.

Fortunately, there are PyCrypto binaries available for Windows: http://www.voidspace.org.uk/python/modules.shtml#pycrypto
2012  2017  forumthread  stackexchange  python  cryptography  downloads  windows  x86  amd64  links  winecompatible  software  libraries 
february 2019 by ezequiel
Plato: A document reader for PDF, ePUB, DjVu, etc. - MobileRead Forums
Plato is a document reader for Kobo's e-readers.
It was tested on the following devices:
* Forma.
* Aura H₂O Edition 2.
* Aura Edition 2.
* Aura ONE (FW 4.10.11655).
* Glo HD (FW 4.12.12111).
* Aura H₂O.
* Aura (FW 4.12.12111).
* Glo.
* Touch C.
kobo.reader  kobo.reader.app  hardwaresupport  forumthread  2017  installation  howto  fileformats  pdf  epub  djvu  mobilereading 
february 2019 by ezequiel
amazon web services - how to copy s3 object from one bucket to another using python boto3 - Stack Overflow
Q: I want to copy a file from one s3 bucket to another. I get the following error:

s3.meta.client.copy(source,dest)
TypeError: copy() takes at least 4 arguments (3 given)

I'am unable to find a solution by reading the docs. Here is my code: [...]
2017  forumthread  stackexchange  amazon.boto  amazon.s3  tips  example  python  issue 
february 2019 by ezequiel
Shell Command Language [pubs.opengroup.org]
This chapter contains the definition of the Shell Command Language.
shell  scripting  spec  documentation  reference  online  2017  2018  posix  links 
december 2018 by ezequiel
vimscript - How can I get the character at the cursor position in a multibyte aware manner? - Vi and Vim Stack Exchange
Q: [...] Vim has several useful functions for dealing with strings in a multibyte-aware fashion, but getting the cursor position seems difficult: [...]
2017  forumthread  stackexchange  vim  scripting  example  tips  links  unicode 
december 2018 by ezequiel
Vim node.js completion? : node [reddit]
Q: Question for fellow Vim users out there. What do you use for completion (not necessarily auto-completion, CTRL-x CTRL-o is sufficient and preferable for making the completion window pop up)?

Doing some googling, nothing is jumping out at me and figured I'm not the first node.js developer that uses Vim.

EDIT: I should have explained this originally, but I used to use YouCompleteMe for this purpose (if I remember correctly it gave me node.js completion) but that's such a huge plugin that comes with much more than I need, and in an effort to slim down my vimrc I'm here asking.
node.js  development  tool  vim  links  tips  forumthread  reddit  2017  plugins  javascript  tern.js 
december 2018 by ezequiel
Changing lightline colorscheme on the fly · Issue #258 · itchyny/lightline.vim
Q: I was hoping to test out the different lightline colorschemes to see which I liked best, and in a wanton episode of yak-shaving ended up writing the following command to change colorscheme, including command-line completion for the colorscheme names.
2017  github  plugin  vim  issue  configuration  colour  links  example  scripting 
december 2018 by ezequiel
pyopenssl: object has no attribute 'SSL_ST_INIT' · Issue #13 · brocaar/loraserver-setup
A: [...] There is an issue with a dependency that changed lately, because of this 'module ' object has no attribute 'SSL_ST_INIT' error is returned. For now I recommend the following commands: [...]
forumthread  issue  workaround  ssl  python  python.pip  unix  linux  ubuntu  github  2017 
december 2018 by ezequiel
How to install Kodi 17.3 Krypton on Android 4.4 Fact kodi 17.3 available for Android 4.4.2
This post contains information on how to install kodi 17 on older Android operating systems. If you are running a newer version higher than Android 5.0 then you need this post: HOW-TO: Install Kodi 17.4 for Android.
xbmc  installation  howto  tips  links  2017  blogpost  android.app  streaming 
december 2018 by ezequiel
VIM recipes – Oleg Smetanin – Medium
This is my list of VIM recipes. It might be interesting for beginners that have basic knowledge about VIM and familiar with VIM cheat sheet. There are a lot of VIM plugins can be found at https://vimawesome.com and you can easily get lost in this universe, but I strongly recommends to precisely look at top 20 of them. My minimalistic config can be found at the end of this note.
vim  tips  plugins  links  example  howto  blogpost  2017  configuration  keyboard  development  tools 
september 2018 by ezequiel
Rendering Bug with the statusline and DirectX Renderer on Windows · Issue #1520 · vim/vim
[...] This is actually pretty disturbing and it took me a while to figure out, that this is caused by the directx rendering. In Vim-Airline, it makes the line numbering almost unusable, because there the actual line number is sometimes not even displayed at all, or only half of the number is displayed: [...]
vim  plugin  issue  links  github  directx  windows  gui  font  2017  unicode 
september 2018 by ezequiel
How to securely store API keys - DEV Community 👩‍💻👨‍💻
In the past, I’ve seen many people use git repositories to store sensitive information related to their projects. Lately, I’ve also been seeing some people even announce that they’re storing API keys on their private GitHub repositories. I’m writing this article because I believe that people should understand the risks of storing API keys with your code.
2017  blogpost  git  github  tips  software  security  api  bitbucket  development 
september 2018 by ezequiel
usb - Why doesn't this udev rule trigger upon removal of the device? - Unix & Linux Stack Exchange
Q: [...] The ADD action works fine, the REMOVE action doesn't. Executing either of the RUN commands manually in a terminal works fine. [...]
(me: proposed solution didn't quite worked for an usb-connected joystick)
2013  2017  udev  hardwaresupport  usb  linux  sysadmin  kernelmodule  configuration  tips  howto  issue  workaround 
august 2018 by ezequiel
Building Palm OS Emulator from sources
[...] Software building process will happen inside chroot environment created with Debootstrap. It is a tool which will install a Debian base system into a subdirectory of another, already installed system. [...]
debian  ubuntu  tips  howto  guide  blogpost  2017  palmos  emulator  build  chroot 
august 2018 by ezequiel
The elusive Palm OS 5.5 Garnet emulator for Windows/Linux
As some of you may undoubtedly know, I'm a bit of a sucker for Palm OS. These past few years, I've been busy collecting ROMs for the Palm OS emulator and simulator, making sure I have all the major Palm OS releases covered. There's really not much of a reason to do this - I have working devices which are a much better option than the emulators/simulators in most cases - other than to have a complete collection I can keep around forever.
palm  palmos  emulator  links  article  2017  screenshots  history  linux  windows 
august 2018 by ezequiel
terraform and vault: provider.aws: InvalidClientTokenId: The security token included in the request is invalid. · Issue #1086 · terraform-providers/terraform-provider-aws
[...] Actual Behavior:
Refreshing Terraform state in-memory prior to plan...
The refreshed state will be used to calculate this plan, but will not be
persisted to local or remote state storage.

data.vault_generic_secret.aws_iam_keys: Refreshing state...
Releasing state lock. This may take a few moments...
Error refreshing state: 1 error(s) occurred:

* provider.aws: InvalidClientTokenId: The security token included in the request is invalid.
status code: 403, request id: f477482f-6379-11e7-8ecb-85e000cae410
issue  tool  amazon.aws  security  workaround  links  github  2017  terraform 
august 2018 by ezequiel
opengl - Disable graphic accelleration on CentOS 7 - Mesa Libraries - Stack Overflow
Q: I have finally successfully compiled a Qt app (C++) using OpenGL on a CentOS 7 machine. The application was originally developed for Windows.
I have an OpenGL scene that is showing a black screen. It works if I compile the project with the Windows version of Qt in a Windows environment. [...]
2017  forumthread  stackexchange  compatibility  opengl  linux  unix  xorg  x11  issue  workaround  shell  tips  qt 
august 2018 by ezequiel
Sansa Fuze+ Firmware 02.38.06 - SanDisk Forums
[...] SanDisk has just released  firmware version 02.38.06 for the Sansa Fuze+. Download links and the release notes are available below. [...]
sansa  sansa.fuze+  firmware  downloads  links  forumthread  hardwaresupport  audio  2017 
august 2018 by ezequiel
What is your favorite colorscheme? : vim
[...] There is issue 1665 open at the vim/vim repository to include more and pretty colorschemes with vim. I have already went ahead and asked to submit a couple of popular colorschemes: [...]
colour  themes  vim  links  customize  configuration  textui  gui  reddit  forumthread  2017 
august 2018 by ezequiel
BEST SPEECH EVER - Simon Sinek on Millennials in the Workplace | SO INSPIRING! - YouTube
Simon Sinek speaking about Millennials in the workplace of today, and social media addiction.
video  youtube  psychology  2017  socialmedia  english  interview  usa 
august 2018 by ezequiel
GET READY: A NEW V8 IS COMING, NODE.JS PERFORMANCE IS CHANGING.
Since it’s inception Node.js has depended on the V8 JavaScript engine to provide code execution in the language we all know and love. The V8 JavaScript engine is a JavaScript VM written by Google for the Chrome browser. From the beginning, a primary goal of V8 was to make JavaScript fast, or at least — faster than the competition. For a highly dynamic, loosely typed language this is no easy feat. This piece is about the evolution of V8 and JS engines performance.
2017  javascript  performance  article  blogpost  node.js  internals  tech  example  links  comparison  oldversion 
august 2018 by ezequiel
Michael Vincent Live at The IKON Gallery - Classic Card Magic | Michael Vincent - YouTube
This video features some classic card magic that I have been performing since I was 15 years old.
magic  playingcards  english  2017  video  youtube 
july 2018 by ezequiel
Ruggeri imita al Pollo y estallan todos de risa, ni Vignolo puede parar.. - YouTube
El cabezón arrancó durísimo con el Pollo por un acontecimiento que acusaba en el vestuario, y entre broma y broma el chiste se calentó a niveles nuevos, el Pollo en joda o en serio, se ofende al ser ninguneada y desafía al ex jugador a conducir él el programa!!!
youtube  video  spanish  funny  tv  2017 
july 2018 by ezequiel
How to Fan Cards like a magician - YouTube
Fanning cards is something that comes second nature to magicians. It is easily one of the most used and practiced flourishes. It creates a wonderfully circular pattern with cards and makes you look like a certifiable badass.
playingcards  tutorial  howto  tips  video  youtube  english  2017 
july 2018 by ezequiel
Ecuador vs Argentina - PARTIDO COMPLETO (Relato Argentino - De Paoli) - Eliminatorias Rusia 2018 - YouTube
(me: goles de Argentina: Messi * 3 (PT: 11:55' (video: desde 1:08:22), 19:41 (video: desde 01:16:10), ST: ?'); partido comienza: 56:38)
1-0 > 00:57:06
1-1 > 01:08:25
1-2 > 01:16:15
1-3 > 02:16:58
worldcup  worldcup.2018  football  sports  spanish  argentina  messi  2017 
may 2018 by ezequiel
Ubuntu 16.04: keyring doesn't unlock on login anymore : linuxquestions
Q: A weird issue has come up in the last few days. When I log in, the gnome-keyring is not unlocked automatically anymore. Instead, the first time I use ssh, chromium, etc, it will prompt for my password to unlock the keyring. [...]
forumthread  security  gnome  linux  ubuntu  debian  mint  workaround  2017  configuration  sysadmin  ubuntu.xenial 
april 2018 by ezequiel
Node.js Performance Monitoring - Part 3: Diagnosing the Event Loop
In Part 1 and Part 2 of this series on Node.js Performance Monitoring, we covered the basic metrics to monitor and how to do this with N|Solid.
In this article, we’re going to dig a bit deeper into how to diagnose and resolve common Node.js bottlenecks in the event loop by understanding some of the key metrics around the event loop.
(me: includes links to parts 1 & 2)
node.js  performance  blogpost  2017  multitasking  internals  links 
march 2018 by ezequiel
Server-side I/O: Node vs. PHP vs. Java vs. Go | Toptal
Understanding the Input/Output (I/O) model of your application can mean the difference between an application that deals with the load it is subjected to, and one that crumples in the face of real-world use cases. Perhaps while your application is small and does not serve high loads, it may matter far less. But as your application’s traffic load increases, working with the wrong I/O model can get you into a world of hurt.
(me: interesting comments left by readers)
performance  comparison  golang  php  java  node.js  serverapp  benchmark  2017  blogpost 
march 2018 by ezequiel
« earlier      
per page:    204080120160

Copy this bookmark:





to read