recentpopularlog in

ezequiel : forumthread   1199

« earlier  
FUTURE: Remove printer driver and raw queue support. · Issue #5271 · apple/cups
Note: The goal of this issue is to have a place to discuss the eventual removal of printer driver support and support for raw queues. This bug has not been scheduled for a specific milestone and this is not something we will implement immediately. Because most printer drivers exist outside of CUPS this change needs to be discussed publicly.
Why do we want to do this? [...]
2018  apple  github  forumthread  compatibility  ppd  printing  drivers  hardwaresupport  protocol  unix  linux  macosx  cups 
2 days ago by ezequiel
shell - How can I find the path to a script being sourced in dash? - Stack Overflow
Q: I am trying to have a sourced shell script determine its own location, and I have found that this is a difficult task for dash.

In bash, sh, and csh, I can use: $_.

In fish, I can use (status -f).

In dash, I have had no luck... [...]
2015  forumthread  stackexchange  scripting  shell  dash  bash  posix  unix  tips  example  issue  workaround 
10 days ago by ezequiel
xubuntu - Why does light-locker keep the screen black after unlock? - Ask Ubuntu
Q: A Xubuntu 16.04 fully patched machine with a freshly created user wont let me unlock after using light-locker to lock my screen (regardless if lock was activated manually or via timeout). The screen remains black (but powered) on correct password entry

Killing light-locker from tty1 will reveal the desktop then (and consequently prevents further locking). [...]

A: TL;DR: light-locker keeps the screen black if systemd cannot read /proc

* light-locker depends on dbus providing IPC.
* dbus depends on systemd-logind providing session information.
* systemd-logind depends on /proc providing process information. [...]
2017  forumthread  stackexchange  internals  desktop  xfce  xubuntu  issue  workaround  tips  example  cli  sysadmin  security  hardwaresupport  systemd  dbus  ui 
11 days ago by ezequiel
xfce - Xubuntu: black screen after lock screen (light-locker, lightdm, logind, xfce4-power-manager) - Ask Ubuntu
Q: [...] The problem is that when my laptop goes into lock screen (or maybe suspend but I always disable that in power management options so it shouldn't), then it is quite common that I am not able to login back to it. Screen stays black after opening lid and pressing a button. [...]

A: The issue is due to lightlocker and XFCE no longer playing well.

I was able to fix this issue by upgrading to XFCE 4.14 from the Xubuntu staging PPA, removing light-locker and installing xfce4-screensaver. Please note I did this from a clean install of 18.04.3, so you might need to restore any changed settings.

sudo add-apt-repository ppa:xubuntu-dev/staging
sudo apt update
sudo apt upgrade
sudo apt remove light-locker
sudo apt install xfce4-screensaver
xfce  desktop  issue  workaround  packages  cli  sysadmin  debian  ubuntu  mint  security  forumthread  stackexchange  2019  ui  tips  example 
11 days ago by ezequiel
lock goes to black screen · Issue #114 · the-cavalry/light-locker
Q: [...] Since last update, unlocking with light-locker-command --lock displays a black screen with a cursor, then cursor disappear. Before it worked like a charm.
From black screen get lightm lock screen I have to switch to tty1 using Ctrl+Alt+F1 and then Ctrl + Alt + F7 [...]
desktop  software  issue  workaround  packages  arch  linux  debian  ubuntu  mint  links  forumthread  2018  github  security  ui  gui  xfce 
11 days ago by ezequiel
Can't compile dahdi anymore Kernel 5.0.3-200.fc29.x86_64 - Asterisk Hardware - Asterisk Community
Q: I can’t compile dahdi anymore after today upgrade to fedora Kernel 5.0.3-200.fc29.x86_64.
CC [M] /usr/src/phones/dahdi-linux-master/drivers/dahdi/oct612x/oct612x-user.o
/usr/src/phones/dahdi-linux-master/drivers/dahdi/oct612x/oct612x-user.c: In function ‘Oct6100UserGetTime’:
/usr/src/phones/dahdi-linux-master/drivers/dahdi/oct612x/oct612x-user.c:38:2: error: implicit declaration of function ‘do_gettimeofday’; did you mean ‘do_settimeofday64’? [-Werror=implicit-function-declaration]
do_gettimeofday(&tv);
^~~~~~~~~~~~~~~
do_settimeofday64
[...]
linux  kernel  compatibility  patches  releaserelated  ndiswrapper  2019  forumthread  example 
11 days ago by ezequiel
Clients in same WLAN can't reach each other - Installing and Using OpenWrt / Network and Wireless Configuration - OpenWrt Forum
Q: Ethernet switch + 2.4G Wifi + 5G Wifi is bridged into one interface and firewall zone (lan).
I updated to LEDE 17.01.0 (stable) and got following problem:
Clients connected to the same Wifi SSID can not communicate with each other (same interface/firewall zone)
PING OPO.lan (192.168.0.17) 56(84) bytes of data. From MJ.lan (192.168.0.58) icmp_seq=1 Destination Host Unreachable ...
I can still reach it from Ethernet or from the other WLAN (5G -> 2.4G and vice versa) but not when both are connected to the same... It works fine if i create 2 different SSIDs on an adapter and put a client in each one.
Multiple clients connected through ethernet can also reach all others.
forumthread  openwrt  wifi  networking  firewall  configuration  issue  workaround  links  router  sysadmin  tips 
11 days ago by ezequiel
xorg - How is my Intel gpu running without its driver installed? - Ask Ubuntu
Q: When I boot my Xubuntu 17.04 PC with the integrated Intel gpu, it runs fine (with screen tearing) at full native resolution without the xserver-xorg-video-intel package installed. But, lshw -c video lists the driver in use as driver=i915. How is this possible?
xubuntu  ubuntu  intel  driver  xorg  kernelmodule  hardwaresupport  forumthread  stackexchange  2017  info  links  opengl  memory 
17 days ago by ezequiel
ssh - How to prevent ecryptfs from umounting home if tmux is still running? - Ask Ubuntu
Q: [...] So is there a way to prevent ecryptfs from umounting my home if there is still a (detached) tmux session running?
I know that i could just disable the encryption, but i would rather like to keep it and solve the problem someway else.
2013  forumthread  stackexchange  linux  ecryptfs  issue  workaround  tips  cli  scripting  sysadmin  filesystem  security  example 
17 days ago by ezequiel
Is there any support with a NetGear WNA3100 USB Adapter in Ubuntu 12.10? - Ask Ubuntu
Q: Has there been any changes or updates or additions to Ubuntu 12.10's to pick up a NetGear WNA3100 USB Adapter? Or software updates? Or what can I do to get it to work in the latest Ubuntu 12.10? [...]
ubuntu.precise  forumthread  2012  hardwaresupport  drivers  ndiswrapper  issue  links  usb  wifi 
17 days ago by ezequiel
linux - How to blacklist a correct bad RAM sector according to MemTest86+ error indication? - Unix & Linux Stack Exchange
Q: MemTest86+ (the version included with Ubuntu 13.04) says

Failing address: 002f796c48 - 759.5 MB

What should I specify in the memmap kernel parameter to bypass this area? [...]
memory  issue  workaround  booting  grub  kernel  kernelpatches  forumthread  stackexchange  2013  hardwaresupport  configuration  sysadmin  tips  links  x86  amd64 
18 days ago by ezequiel
Solved: Optiplex GX620 memory limitation - Dell Community
The GX620 can support 2 gig modules. With 4 memory slots and a 64 bit CPU and OS it will see 8 Gigs of Ram in bios but you cant use 8. You can only use 3GB or 3.5GB. You CANNOT utilize more memory than 3.5 Gigs even when you install a 64-bit version of your OS This is a GX620 Limitation. Models with Pentium D also support NX and the other requirements for Windows 8.
hardware  hardwaresupport  memory  motherboard  forumthread  2012  intel  cpu  bios  links  spec  oldversion  info 
19 days ago by ezequiel
How to use wget with ssl certificate - Stack Overflow
Q: I am using wget in my program to get some file using HTTP protocol. Here i need to set security so we moved HTTP protocol to HTTPS.

After changing to HTTPS how to perform wget. I mean how to make trusted connection between two machines then perform wget.

I want to make sure that wget can be performed from certain system only.
2014  tool  cli  example  security  tls  ssl  tips  forumthread  stackexchange  unix  linux  macosx 
20 days ago by ezequiel
#870126 - ecryptfs-mount-private: mount: No such file or directory - Debian Bug report logs
Q: I have setup the standard home ~/Private directory. It looks like it is confused about which key to use.

For the last few months or so, I get this (key IDs changed but consistent in report):

$ ecryptfs-mount-private

[...]

A: [...]

1. The problem is the user keyring not being linked
to the session keyring. keyctl link @u @s is a much easier workaround. [...]
2017  issue  workaround  ecryptfs  encryption  forumthread  cli  example  configuration  pam  filesystem  debian  ubuntu  security  tips 
22 days ago by ezequiel
encryption - SSH remote user need to be logged in? - Ask Ubuntu
Q: I'm trying to set up an SSH server. I put my public key in the authorized_keys file, made sure the permissions were correct, etc.

When I restart the server (really just Ubuntu 12.04 desktop) and I ssh to it without first logging in on the server, I am asked for a password. If, however, I log into the server, I can ssh without being asked for a password. [...]

A: The problem usually arises if your home directory is encrypted. The usual solution is to put your keys in a directory other than your home directory, and point your sshd_config file to it.

For example:

1. Move your authorized_keys file on the server from /home/buck/.ssh/authorized_keys to something like /etc/ssh/keys/buck/authorized_keys [...]
2012  forumthread  stackexchange  ecryptfs  encryption  ubuntu  debian  security  sysadmin  filesystem  issue  workaround  tips  example  configuration  ssh  remote 
22 days ago by ezequiel
encryption - Will changing password re-encrypt my home directory? - Ask Ubuntu
Q: I need to change my user password. Do I need to take any extra steps for my encrypted home directory to become inaccessible with my old password and only accessible with my new password?

A: There is no need to re-encrypt your home directory, and no further steps need to be taken.

Your home directory is not directly encrypted with your password. Instead, the passphrase used to encrypt the home directory is itself encrypted with your password.

When you change your password, the home directory passphrase is re-encrypted with your new password, so you should have continued access to your files with the new password. [...]
2011  forumthread  stackexchange  ecryptfs  encryption  ubuntu  debian  ubuntu.lucid  security  cli  sysadmin  filesystem  issue  workaround  tips  example 
22 days ago by ezequiel
linux mint - mount: No such file or directory with encrypted recovery - Unix & Linux Stack Exchange
Q: [...] Nothing I’ve tried seems to work and I don’t have the original mounting seed. I’ve also tried sudo ecryptfs-recover-private but my system then just says No such file or directory:

frankenmint@honeybadger /home $ sudo ecryptfs-recover-private
INFO: Searching for encrypted private directories (this might take a while)...
INFO: Found [/home/.ecryptfs/frankenmint/.Private].
Try to recover this directory? [Y/n]: y
INFO: Found your wrapped-passphrase
Do you know your LOGIN passphrase? [Y/n] y
INFO: Enter your LOGIN passphrase...
Passphrase:
Inserted auth tok with sig [979c6cdf80d2e44d] into the user session keyring
mount: No such file or directory
ERROR: Failed to mount private data at [/tmp/ecryptfs.Hy3BV96c].

[...]

A: I found that running sudo bash and then running ecryptfs-recover-private as root (rather than via sudo) worked. Not sure why it should be any different.

Edit:
TL;DR:

# ecryptfs-unwrap-passphrase /mnt/crypt/.ecryptfs/user/.ecryptfs/wrapped- passphrase - | ecryptfs-add-passphrase --fnek -
< Type your login password here >
Inserted auth tok with sig [aaaaaaaaaaaaaaaa] into the user session keyring
Inserted auth tok with sig [bbbbbbbbbbbbbbbb] into the user session keyring

You will not see a prompt and must type your login password, blind, into the above command. [...]
2016  forumthread  stackexchange  cli  sysadmin  encryption  filesystem  ubuntu  debian  mint  tips  issue  workaround  example  guide  linux  security  mount  ubuntu.xenial  ubuntu.trusty  ubuntu.bionic  ecryptfs 
23 days ago by ezequiel
windows - How to make "git branch" respect the "core.ignorecase" flag on Linux? - Stack Overflow
Q: [...] How to make “git branch” respect the “core.ignorecase” flag on Linux? [...]

A: [...] You can't, because the flag doesn't do what you think it does. [...]
2011  forumthread  stackexchange  git  cli  configuration  tips  example  issue  filesystem  windows  linux  unix  workaround 
25 days ago by ezequiel
[SOLVED] Hibernate, 15.10, 16.04, Unity, systemd, tlp, wifi module reload, tuxonice
I thought I should share this in case anyone else has the similar problem and wants to know how to solve it. With the new systemd configuration, the Unity menu's "hibernate" option does not call on pm-hibernate. It instead uses the hibernate and sleep service of logind / systemd. I'm using a tuxonice kernel, and the tlp power management setup on a thinkpad w520, running Ubuntu 16.04 (devel). I think this article is still relevant even if you don't have tlp or tuxonice, since it's systemd that changes how suspend and hibernate work.

When this laptop suspends or hibernates, sometimes the wifi stops working when it wakes back up. The solution is to unload the wifi device driver module prior to sleep, and then reload it upon resume, the way the "hibernate" script does, and "pm-hibernate" also did.
2016  forumthread  sysadmin  linux  powermanagement  script  scripts  example  kernelmodule  systemd  tips  cli  configuration  ubuntu  ubuntu.xenial  wifi 
28 days ago by ezequiel
internet - Netgear N-300/ WNA3100 USB Adapter for Ubuntu 16.04 - Ask Ubuntu
Q: I am new to Linux and Ubuntu and I am having trouble connecting to the Internet.

I have a netgear WNA3100 USB Adapter and I don't have anything in my additional drivers.

A: You can add Support for the Netgear N-300/ WNA3100 USB Adapter by installing the ndiswrapper and loading the Windows network driver. [...]

(me: ndiswrapper fails to build when using kernel-headers >= 5.0 (on i686), then (even if patched) the 32-bit WinXP driver from NetGear does not work: ndiswrapper causes an "oops" because of the "nx" cpu protection bit; then, after disabling this (see another link saved today), ndiswrapper gives yet another error. Result (so far): failed).
ndiswrapper  issue  howto  guide  tips  example  cli  sysadmin  networking  wifi  2016  ubuntu  configuration  usb  driver  drivers  windows  links  linux  kernelmodule  forumthread  stackexchange 
4 weeks ago by ezequiel
linux - How to turn off Wireless power management permanently - Unix & Linux Stack Exchange
Q: In Linux Mint 17.3 / 18 iwconfig says the power management of my wireless card is turned on. I want to turn it off permanently or some workaround on this issue.

sudo iwconfig wlan0 power off works, until I reboot the laptop.

Also, if I randomly check iwconfig, sometimes it's on, despite I did run this command. [...]

A #1: Open this file with your favorite text editor, I use nano here:

sudo nano /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

By default there is:

[connection]
wifi.powersave = 3

Change the value to 2. Reboot for the change to take effect. [...]
2016  forumthread  stackexchange  linux  ubuntu  mint  debian  networking  software  configuration  sysadmin  powermanagement  usb  issue  workaround  cli  links  documentation  tips  example  wifi 
4 weeks ago by ezequiel
exploit - How to disable NX on Linux - Super User
Q: I'm learning stack buffer overflow exploitation, and I later posted question Shellcode segmentation fault. about that executing shellcode from test program, or when injected to vulnerable program, causes segmentation violation. Now I found out that it might be caused by NX. When I search for this in dmesg I found this line:

[ 0.000000] NX (Execute Disable) protection: active
2018  forumthread  stackexchange  kernel  booting  security  grub  configuration  sysadmin  howto  x86  amd64  example  tips  links  linux  exploit  cpu  bios 
4 weeks ago by ezequiel
Serious HDMI Problems. What's that smell? Burning Raspberry! - Raspberry Pi Forums
Q: [...] I have just received my Neewer Black HDMI Input To VGA Adapter Converter For PC Laptop.

There was a post here: [...]

That reported it working and I have no reason to doubt that. However when I plugged mine in to my raspberry pi and VGA monitor the screen was black but lit i.e. the screen recognised a connection was present but wasn't receiving any data. A thin wisp of grey smoke appeared from the HDMI and the component labelled "D1" is looking like it has burn out. Suffice to say I very quickly removed it and all power! [...]
2012  forumthread  raspberrypi  hardware  hardwaresupport  electronics  issue  workaround  tips 
4 weeks ago by ezequiel
FS#1960 : hostapd/netifd: multicast_to_unicast/hairpin not set for dynamic vlan, ap not in isolate mode
I noticed that multicast_to_unicast and hairpin_mode are not set on the dynamically created wlan interfaces, and the wireless ap is not running in isolate mode. This is because these interfaces are created by hostapd, unlike other wlan interfaces which are created from netifd/system-linux.

The attached patch fixes this:
- it sets ap_isolate for the hostapd interface, if the interface is using dynamic vlan
- it sets multicast_to_unicast and hairpin_mode after the dynamic interface is created

I haven’t handled the case where the isolate option is not set for the wifi interface, or where multicast_to_unicast is not set on the bridge, since this requires passing additional information to hostapd, and I wasn’t sure what the preferred way to do this would be. I’d probably overload the ap_isolate option to have value 2 mean that multicast_to_unicast and hairpin_mode should be set.
wifi  networking  openwrt  issue  workaround  forumthread  configuration  2018  patches 
4 weeks ago by ezequiel
FS#714 : ARP/Broadcast does not reach other clients in the same WLAN
I have the default bridge with ethernet and WLAN in it. When i try to send data from a client to another, both connected to the same WLAN SSID, it doesn’t work (Destination unreachable).
Wireshark shows that it sends endless ARP requests to Broadcast, but the other clients in that WLAN never get it (and therefore can’t answer). The broadcast gets still delivery to every client connected through Ethernet. If i create a second WLAN SSID (even on the same adapter) and and add it to the bridge, it gets also all broadcast packets from the other WLAN...
So if i put the 2 clients in different WLAN SSIDs or ethernet they get the broadcast from each other, but not when both are connected to the same.
wifi  networking  openwrt  issue  workaround  forumthread  configuration  2017 
4 weeks ago by ezequiel
15.04 - Unable to install tp_smapi 0.41 on Thinkpad T500 - Ask Ubuntu
I have downloaded tp_smapi module for my Thinkpad T500 using the steps in ThinkWiki and ran make. it encountered no errors.

[...]

But when i tried to view the status of the battery using tlp, it shows as not loaded/installed:

root@Forge:/storage/Repository/git/tp_smapi# tlp-stat -b
--- TLP 0.7 --------------------------------------------

+++ ThinkPad Extended Battery Functions
tp-smapi = inactive (kernel module 'tp_smapi' load error)
tpacpi-bat = inactive (unsupported hardware)
[...]
2015  hardwaresupport  laptop  battery  kernelmodule  tool  linux  forumthread  stackexchange  ubuntu  issue  workaround  links  sysadmin 
5 weeks ago by ezequiel
Support for HDMI 1 port (i.e. both ports)
Q: My understanding is that Kodi on Raspbian only supports one HDMI port, yet the Raspberry Pi 4 has two HDMI ports. [...]

[...]

Is it possible to get both HDMI ports working on the RPi 4? Apparently, this would need a code change in Kodi itself (PISink code block in Kodi).

Just to clarify, I only care about audio on the second port, but maybe somebody else has a need to video on that port too.
2019  forumthread  xbmc  raspberrypi  hardwaresupport  linux  configuration 
5 weeks ago by ezequiel
Bought used x230 last week and new 9-cell battery and looking for TPL and tpacpi-bat and recommended thresholds. : thinkpad
Q: [...] I'm quite new here but a good suggestion would be highly appreciated. I want to get the maximum benefit of power comsumption for my x230 and best use of the new 9 cell battery. Can anyone give me some TLP configuration tips that you found works best and tpacpi-bat thresholds (since x230 onwards tp_smapi don't support) that will make the battery age longer? [...]
2018  reddit  forumthread  sysadmin  howto  tips  configuration  laptop  battery  hardwaresupport  hardware  bios 
5 weeks ago by ezequiel
How-to: Stitch together your own battery power manager - Linux Mint Forums
[...] To recap. What I wanted was to preserve my battery's lifespan as long as possible. Note that I don't mean battery life between charges which can be achieved by dimming the screen, turning off Bluetooth, spinning down the HD, etc., but long term battery lifespan.

I had heard of "Intelligent" power managers, but had not paid much attention since it was always in a Windows context. Lenovo have a Power Manager as part of their Windows pre-installed software package ThinkVantage Technologies [[url=http://en.wikipedia.org/wiki/ThinkVantage_Technologies]1[/url]]. Not very useful when you have a strong preference for Linux. [...]
2013  forumthread  laptop  battery  hardwaresupport  mint  linux  sysadmin  configuration  powermanagement  tools  links  howto  guide  kernelmodule 
5 weeks ago by ezequiel
Get the best out of you battery on linux : linux
[...] I noticed that battery life in Linux (Linux Mint 19.1 Cinnamon in my case) is WAY worse than in windows 10, I use my laptop more often to watch TV shows and movies and to browse the internet.

I have a small battery in my laptop, The battery when I'm using mint can't make it over 2 hours of light usage, while in windows 10 with same light usage the battery can make it over 4-4.5 hours. [...]
forumthread  reddit  powermanagement  optimisation  linux  ubuntu  software  tips  sysadmin  configuration  links  howto  guide  tool  tools  cli  wifi  networking  usb  laptop  battery  cpu  memory  2018  hardwaresupport  mint  desktop 
5 weeks ago by ezequiel
"The Battery installed is not supported by this system..." T470 : thinkpad
[...] No problems whatsoever until today. Now suddenly when I booted the system I got a black screen with the error message:

The battery installed is not supported by this system and will not charge. Please replace the battery with the correct Lenovo battery for this system.
2018  forumthread  reddit  laptop  battery  issue  workaround  windows  ubuntu  linux  links  tips  hardwaresupport  tool  debian  mint 
5 weeks ago by ezequiel
How to configure KODI to run in windowed mode from command line? - Ask Ubuntu
Q: I am running Kodi via XServer from 2-monitor remote conputer. When Kodi starts, it occupies entire 2 monitor are and absolutely useless.

It has a config to run in windowed mode, but how to activate it from command line? [...]
2016  forumthread  stackexchange  issue  configuration  cli  example  tips  gui  hardwaresupport  windows  linux  xorg  x11  xbmc 
5 weeks ago by ezequiel
Ubuntu-Lenovo Community
I have just finished creating a script that configures Ubuntu 12.04LTS to work with the thinkpad T530.

I will be documenting all of the configuration changes in this thread soon but in the mean time you can grab it and examine what the script does at https://github.com/wschaub/T530-settings
forumthread  laptop  hardwaresupport  linux  ubuntu  ubuntu.precise  links  info  resources  2013  configuration  sysadmin  powermanagement  battery  kernelmodule 
5 weeks ago by ezequiel
Battery gauge reset features implemented for Linux : thinkpad
So I wrote two crucial patches for Linux that enable the battery gauge to be reset, thus completely eliminating the need for Lenovo Power Manager. The patches are currently awaiting review, but for anyone curious here they are:

0: https://patchwork.kernel.org/patch/10396259/
1: https://patchwork.kernel.org/patch/10396265/
2: https://patchwork.kernel.org/patch/10396271/

I hope that the review process will pass without major issues. If anyone wants more details feel free to ask.
forumthread  reddit  linux  kernel  hardwaresupport  laptop  battery  kernelpatches  links  2018  acpi 
5 weeks ago by ezequiel
Project 294899064488 has been scheduled for deletion and cannot be used for API calls · Issue #736 · jdf76/plugin.video.youtube · GitHub
Q: Since today I'm unable to playing any video on Corelec 9.2.1.

It seems that this youtube extension project is on the way to be deleted in Google's API access. [...]

A: Using your own API keys is the only way to resolve this at this moment. For information on how to do this, see https://github.com/jdf76/plugin.video.youtube/wiki/Personal-API-Keys

Edit: For users that only require playback and don't use the add-on to browse content, https://github.com/enen92/script.tubecast may be an alternative solution for you.

Edit: Additional information [...]
xbmc  extension  issue  workaround  links  google  security  api  2020  forumthread  tips  github  youtube 
5 weeks ago by ezequiel
RPI falls back to 1280x720 from x1024. - Raspberry Pi Forums
Q: I have an HDMI->VGA converter module connected to my 'pi, as I have a bunch of TFT VGA monitors lying around, but no HDMI ones.

When I boot the 'pi with the cable attached, it comes up nicely in 1280x1024 as I told it to:

hdmi_drive=1
hdmi_group=2
hdmi_mode=35
hdmi_force_hotplug=1
config_hdmi_boost=4
disable_overscan=1

(hdmi_mode=35 is 1280x1024@60Hz in group 2)
However, somehow, the mode drops to a 60Hz 1280x720 mode when the monitor is not connected during boot. I was hoping to prevent these problems by specifying hdmi_force_hotplug=1, and directly specifying a mode that I want.
Why does it drop to a lower resolution if the monitor is not connected?
Just to be sure: the /proc/cmdline file shows "fbheight=720", so it is not my VGA converter that isn't booted correctly and somehow converting the 1280x1024 mode into 1280x720 (as if such a cheap piece of electronics would be capable of such a feat).
2012  forumthread  booting  configuration  sysadmin  linux  raspbian  raspberrypi  hardwaresupport  issue  workaround 
5 weeks ago by ezequiel
13.04 - Touchpad stopped working out of the blue - Ask Ubuntu
Q: So, I'm watching "The Walking Dead" and all of the sudden I lose control of my mouse through the touchpad. At first it was just for my user. I could reboot my system and switch to another user and use it just fine. [...]

$ sudo modprobe -r psmouse && sudo modprobe psmouse proto=imps

After this command, I regained control of my mouse but the computer didn't recognize it as a touchpad. I thought if I rebooted again, it may do the trick. So after I rebooted, the mouse went completely kaput. I cannot get the mouse to work at all now even though I've tried the command several times. I've tried different users and it's still the same.

A: 1. [...] synclient Touchpadoff=0 [...]
A: 2. [...] sudo apt-get install --reinstall xserver-xorg-input-synaptics [...]
A: [...]
synaptics  hardwaresupport  ubuntu  2013  forumthread  stackexchange  cli  tool  linux  debian  mint  issue  workaround  xorg 
5 weeks ago by ezequiel
[Tutorial] Show RPI's Temperature with a command. - Raspberry Pi Forums
A #1: [...] So i decided to make a quick Tutorial on how to show the Raspberry PI's Temperature.
Note: this is using the on-board sensor.

The command to do this is:

$ /opt/vc/bin/vcgencmd measure_temp

[...]

A #2: An alternative is to read /sys/class/thermal/thermal_zone0/temp on a recent Raspdian. Divide it by 1000 for degrees C.

$ cat /sys/class/thermal/thermal_zone0/temp
[...]
2013  raspberrypi  cli  tool  tips  example  forumthread  hardwaresupport  linux  links 
5 weeks ago by ezequiel
Kodi playback is choppy and laggy 400% kodi.bin usage - Raspberry Pi Forums
Q: Hello i think that after my last rpi-update suddenly i cannnot watch any video in kodi....either through my usb devices or iptv, netflix,etc.. i have rpi3b+ and kodi 18.3 (multimedia repo) with raspbian buster. The cpu usage is 100% with extreme temps. i set fake gl or full with no result..If i set legacy i have not X(in raspi-config).

A: Kodi Leia 18.3 for RPi4 with Raspbian Buster plays well , videos not choppy, audio (although HDMI and Analog only, DAC HATs not supported) also in sync with video.
gpu memory set at 264 [...]
xbmc  memory  forumthread  2019  issue  workaround  tips  releaserelated  raspberrypi  hardwaresupport  sysadmin  configuration  booting  linux  gpu 
5 weeks ago by ezequiel
Pi4 with 4Gb Ram. Setting max mem for GPU ? - Raspberry Pi Forums
Q: If possible, I'd like to set aside 1024Mb of the 4Gb memory available for GPU memory use.

I've tried adding the 'gpu_mem_1024' command in config.txt which then sees me with 64Mb on reboot.
I've tried setting the maximum setting in Raspberry Pi Configuration for GPU memory, which is "896"
which doesn't work either. On a couple of occassions I have had the system lock on reboot which required me to take the SD card out and edit config.txt externally. [...]
raspberrypi  memory  forumthread  2019  configuration  sysadmin  links  booting  gpu  performance 
5 weeks ago by ezequiel
[UPDATE] Kodi 18.4 Leia for Raspberry Pi 4 - Raspberry Pi Forums
Kodi 18.4 Leia built specifically for RPi 4 [...] with support for hardware decoding of HEVC (h.265) files.
2019  xbmc  releaserelated  raspberrypi  download  links  debianpkg  arm  hardwaresupport  codecs  forumthread 
5 weeks ago by ezequiel
apt - How do I find the reverse dependency of a package? - Ask Ubuntu
Q: I was wondering if it was possible to check what package another package is a dependency of. [...]

A: You can use apt-cache rdepends --installed jetty to see what depends on jetty. [...]
2010  2019  apt  packagemanager  cli  tool  example  sysadmin  forumthread  stackexchange  links  linux  debian  ubuntu  mint 
5 weeks ago by ezequiel
Can't resize or move windows on Raspberry Pi - Stack Overflow
Q: I am using the Raspberry Pi Model 3 B+ and there was recently an update( I did not record what it was doing or what it was called) and upon reboot it mentioned that there was a previous version saved somewhere(did not take note of where this was at). Not thinking much of the update I tried to move windows around and they would not move. I found to try the Alt button and dragging and that is not working.
2018  2019  forumthread  raspberrypi  lxde  windowmanager  issue  workaround  stackexchange  raspbian  x11 
5 weeks ago by ezequiel
less - Colors in Man Pages - Unix & Linux Stack Exchange
Q: When I look at a man page in my 'console' (not an xterm) I see some coloration, but I don't get this in my xterm's (e.g. konsole) is there any way I can enable this? hopefully a fairly simple solution? [...]

A: I do the following so that less and man (which uses less) will have color: [...]
xterm  terminal  colour  configuration  howto  tips  example  forumthread  stackexchange  2010  linux  unix  manpage 
6 weeks ago by ezequiel
How to do local port forwarding with iptables - Stack Overflow
Q: I have an application (server) listening on port 8080. I want to be able to forward port 80 to it, such that hitting http://localhost resolves my application (on localhost:8080).

This should be generalized for any port mapping (e.g. 80:8080 => P_src:P_target), and use best practices for modern *nix machines (e.g. Ubuntu).

N.B. This is all done locally, so there is no need to accept connections from anyone but localhost.
2015  forumthread  iptables  linux  firewall  cli  howto  tips  stackexchange  sysadmin  example  configuration  networking 
6 weeks ago by ezequiel
port forwarding - iptables redirect outside requests to 127.0.0.1 - Unix & Linux Stack Exchange
The iptables rule you are using will work, but there is one additional change you need to make:

sysctl -w net.ipv4.conf.eth0.route_localnet=1
2014  2018  forumthread  iptables  linux  firewall  networking  configuration  sysadmin  cli  howto  tips  example  stackexchange 
6 weeks ago by ezequiel
Execute a command after run · Issue #1809 · docker/compose · GitHub
Q: It will be very helpful to have something like "onrun" in the YAML to be able to run commands after the run. Similar to moby/moby#8860 [...]
2015  github  issue  workaround  scripting  example  cli  configuration  docker  tips  sysadmin  automation  forumthread  tool 
6 weeks ago by ezequiel
(Solved) Flaky wifi with WRT1900ACS v2 and Android phones - Installing and Using OpenWrt - OpenWrt Forum
Q: I have a wrt1900acs v2 running the latest wifi drivers packaged by @eduperez and it is giving me nothing but problems.

Specifically my Android phones simply refuse to stay connected. Recently it's gotten to the point where it hardly will even connect at all and I've turned it off so that my older tp-link devices are the only APs. We've had hot weather, and I wonder if that's relevant because it was never this bad before.

Rebooting the WRT device seems to fix the problem for a few hours. [...]
2018  forumthread  wifi  android  issue  router  openwrt  workaround  tips  configuration  sysadmin  networking  hardwaresupport 
6 weeks ago by ezequiel
I've Bricked My Netgear DG834G v3 - Please Help - OpenWrt Forum Archive
Q: I am hoping someone here more wise then me can help me unbrick my Netgear DG834G v3 Router.

Here are some details I have pulled from the router before I bricked it. [...]
forumthread  2009  router  hacking  firmware  links  issue  workaround  jtag  cli  example  linux  hardware  electronics 
6 weeks ago by ezequiel
Successful unbricking of DG834 DG834G (v4) modems - Netgear
Q: Hi.. thought I'd share my experiences with successfully unbricking these Netgear modems

The usual symptoms are the flashing red/green power light and sometimes the default landing page of the Upgrade Firmware page. [...]
forumthread  2010  2014  router  hacking  firmware  links  issue  workaround 
6 weeks ago by ezequiel
How to access docker container from another machine on local network - Open Source Projects / Docker Toolbox - Docker Forums
If I read the docs right all you need to do is this:

$ docker run --network=host …

host network should piggy back on the host computers connection rather than just machine that the container is running on.
docker  sysadmin  configuration  networking  cli  howto  tips  example  forumthread  2016  linux  links 
6 weeks ago by ezequiel
apt - Find (and reinstall) packages with corrupted files (without breaking anything) - Ask Ubuntu
Q: [...] Such a such situation may occur if you have to work-around dependency problems with dpkg --force-*. One could also reproduce such a situation by deleting a file from /usr as root.

Is there a simple way to verify whether all files belonging to an installed package are present?

If a such a problem package is found, aptitude reinstall fixes the problem.
2011  2014  forumthread  stackexchange  ubuntu  debian  tools  packagemanager  cli  example  tips  linux  configuration  apt 
6 weeks ago by ezequiel
unix - Bash script to receive and repass quoted parameters - Stack Overflow
Q: I'm trying to get quoted parameters of a bash script to safely be received by a nested script. Any ideas? [...]
2009  2015  shell  bash  posix  links  tips  example  forumthread  stackexchange  unix  scripting 
7 weeks ago by ezequiel
debian - Cannot update APT list: "repository no longer has a Release file" - Unix & Linux Stack Exchange
Q: I cannot run apt-get update as I encounter the following error:

# apt-get update
Hit:1 http://ftp.br.debian.org/debian testing InRelease
Ign:2 http://security.debian.org/debian-security testing/updates InRelease
Err:3 http://security.debian.org/debian-security testing/updates Release
404 Not Found [IP: 151.101.92.204 80]
Reading package lists... Done
E: The repository 'http://security.debian.org/debian-security testing/updates Release' no longer has a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Repository 'http://ftp.br.debian.org/debian testing InRelease' changed its 'Codename' value from 'buster' to 'bullseye'
N: This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.
[...]
2019  forumthread  stackexchange  apt  packagemanager  security  sysadmin  cli  example  tips  debian  ubuntu  mint  repository 
7 weeks ago by ezequiel
[Solved] Wireguard - Help with Firewall Rules - Installing and Using OpenWrt - OpenWrt Forum
Q: I have managed to get a split tunnel wireguard vpn working on my road warrior android devices, but I am not sure if I did it properly.

In my current setup, I created a wireguard zone, and added the following rules: [...]
2019  forumthread  iptables  openwrt  configuration  sysadmin  networking  firewall  example  images  tips  wireguard  vpn 
7 weeks ago by ezequiel
Finally got 802.11r roaming working : openwrt
[edit] Since people still find this post for advice, I'll quickly add a few notes.

Configuration has been vastly simplified with a recent OpenWRT release. Basically all you need is the following:

option mobility_domain 'e612' #same for all APs
option ieee80211r '1'
option ft_psk_generate_local '1'
option nasid 'xxxxxxxx' # different for all APs, AFAIK it will automatically derived from the MAC Address if omitted.

All this is availably via LuCI, go to "Wireless Security", enable "802.11r Fast Transition", enable "Generate PMK locally", that should be it. Unfortunately I lack the time and hardware to really test this. [...]
openwrt  wifi  configuration  article  forumthread  reddit  security  example  tips  linux  router  networking  sysadmin  cli  links  2016 
7 weeks ago by ezequiel
Can a Wireguard interface be bridged with a physical one? - Installing and Using OpenWrt / Network and Wireless Configuration - OpenWrt Forum
Q: Can a Wireguard interface be bridged with a physical one? Luci doesn't have an option for this, and the online documentation doesn't discuss this possibility.
2019  forumthread  configuration  networking  wireguard  sysadmin  tips  openwrt  vpn 
7 weeks ago by ezequiel
Add an addition persistent route on eth0 - Raspberry Pi Forums
Q: [...] I have tried adding a route command to dhcpcd.conf in a section called interface eth0 but as that interface is assigned dynamically I don't think it is read.

I would be happy to find a simple command line solution as I can script it to run when I want.
2018  raspberrypi  raspbian  dhcp  configuration  networking  sysadmin  howto  tips  links  forumthread  cli  example 
7 weeks ago by ezequiel
dnsmasq: How to provide route info to clients? | Ubiquiti Community
Q: [...] Does dnsmasq have a way to provide clients on ERX/eth0 with additional IPv4 routing info, beside the default route? I could not immediately spot that info in dnsmasq(8).

A: There is dhcp option 121, which does exactly what is needed:

dhcp-option=option:classless-static-route,1.2.3.0/24,4.3.2.1
dnsmasq  dhcp  serverapp  configuration  sysadmin  linux  unix  networking  example  tips  forumthread  2018 
7 weeks ago by ezequiel
OpenWRT VPN server suggestion : openwrt
Q: [...] What is a good choice for a OpenWRT VPN server?
reddit  2019  forumthread  openwrt  vpn  wireguard  openvpn  links  comparison 
7 weeks ago by ezequiel
Rikomagic MK802 Forums • View topic - Debian on MK80
Hi Everyone. I am looking at strategies to put Debian (jessie, most likely) onto my shiny new MK80. The other Allwinner based devices I have are development boards, and generally have a TTL serial console that provides access to the U-boot shell, and generally kernel boot messages and a tty thereafter
rokumagic.mk80  forumthread  2015  howto  tips  guide  hacking  hardware  hardwaresupport  booting  serialport  allwinner  allwinner.a80 
8 weeks ago by ezequiel
Support of Rikomagic Devices - General chit chat - Armbian forum
Q: [...] what do you (Igor) think about supporting e.g. the following devices from Rikomagic with your nicely developped DEBIAN image:

* http://www.rikomagic.com/en/product/showpro_id_59_pid_19.html CPU: RK3288 Quad Core

* http://www.rikomagic.com/en/product/showpro_id_70_pid_22.html CPU: Allwinner A80 Octa Core
rokumagic.mk80  armbian  hardwaresupport  forumthread  links  howto  guide  2015  hacking  allwinner  allwinner.a80 
8 weeks ago by ezequiel
linux - How to disable AAAA lookups? - Server Fault
Q: ... to compensate for broken DNS servers that are outside our control.

Our problem: We deploy embedded devices that collect sensor data at various, mostly IPv4-only sites. Some sites have poorly maintained networks, e.g. misconfigured or otherwise broken DNS caches and/or firewalls that either ignore AAAA queries altogether, or respond to them with broken replies (e.g. wrong source IP!). As an external supplier to the facilities department, we have next to no influence on the (sometimes reluctant) IT departments. The chances of them fixing their DNS servers/firewalls any time soon are minuscule.

The effect on our device is that with each gethostbyname(), the processes have to wait until the AAAA queries time out, at which point some processes have already timed out their connection attempts altogether.
2014  forumthread  stackexchange  networking  dns  ipv6  configuration  tips  sysadmin  issue  workaround  linux  debian  api  c 
8 weeks ago by ezequiel
domain name system - How to prevent delays associated with IPv6 AAAA records? - Server Fault
Q: Our Windows servers are registering IPv6 AAAA records with our Windows DNS servers. However, we don't have IPv6 routing enabled on our network, so this frequently causes stall behaviours.

Microsoft RDP is the worst offender. When connecting to a server that has a AAAA record in DNS, the remote desktop client will try IPv6 first, and won't fall back to IPv4 until the connection times out. Power users can work around this by connecting to the IP address directly. Resolving the IPv4 address with ping -4 hostname.foo always works instantly. [...]
2013  ipv6  forumthread  issue  workaround  links  stackexchange  windows  rdp  firewall  networking  compatibility  tips  sysadmin  configuration  dns 
8 weeks ago by ezequiel
[SOLVED] disable AAAA response for a given domain - General - Pi-hole Userspace
Q: Is it possible to configure Pi-hole to return only A and not AAAA for a given domain?
The use case is pretty simple - IPv6 is provided via tunnel (HE broker) and accessing local (== in-country) resources via IPv6 is not desirable.
(me: returning '[::]' for every host in a domain does avoid a client attempting to contact a host outside of the local network, but the DNS server (dnsmasq) still produces a valid AAAA record/response, therefore some clients might attempt to still contact a host, and they'll be reaching a local(/ly forwarded?) server)
forumthread  issue  workaround  dnsmasq  dns  configuration  sysadmin  networking  linux  unix  example  2018 
8 weeks ago by ezequiel
download files from luci ( use LuCI as file share ) · Issue #846 · openwrt/luci
Q: I've uploaded some files in my OpenWrt root , /etc , /tmp directories.
I want user to be able to download uploaded files from from the above directories.
How can i give a download URL to user, to download that files?
github  openwrt  issue  workaround  tips  example  configuration  webserver  downloads  links  howto  guide  screenshots  router  serverapp  sysadmin  networking  forumthread  2016 
8 weeks ago by ezequiel
OpenWrt Project: OpenWrt on 4/32 devices
* You have a device with 4MB flash and/or 32MB RAM.
* You have read and understood the 4/32 warning.
* You have adjusted your expectations according to this warning.
* You still want to install OpenWrt on your 4/32 device for [...]
embedded  router  memory  firmware  openwrt  wikientry  tips  howto  links  forumthread  hardwaresupport  oldversion  linux 
8 weeks ago by ezequiel
Limiting access to ssh - Google Groups
Q: I'd like to limit access to ssh to GCE console (so the browser based SSH works) and to our own networks. Is there a specific network mask I can use to allow connections from GCE console?
2015  forumthread  issue  workaround  example  cli  tips  sysadmin  networking  firewall  google.cloud  cloudcomputing  ssh  links  software 
9 weeks ago by ezequiel
1661973 – Sudo cannot authenticate user through PAM
Q: [...]
sudo: backuppc : PAM account management error: Authentication service
cannot retrieve authentication info ; TTY=pts/0 ; PWD=/root ;
USER=root ; COMMAND=/bin/rsync -d /home /tmp/
[...]

A: Adding backuppc via "pwck" fixed the issue. I am now running sudo version 1.8.3-23-3.
[...]
running 'pwck -r' after distro version changes will become part of my routine.
2018  issue  workaround  security  sudo  cli  example  forumthread  redhat  centos  pam  linux  2019  tool  configuration  sysadmin 
9 weeks ago by ezequiel
systemd-nspawn and sh: can't access tty; job control turned off · Issue #1431 · systemd/systemd
Q: Trying to launch alpine container on CoreOS via toolbox and getting sh: can't access tty; job control turned off warning. I've read about it in BusyBox FAQ, which didn't work for me, and tried this, also without any luck.

This works without any issues nor tweaks with docker. Is there some parameter that should be passed to nspawn like --interactive with docker? Or is this something completely different?

A: [...] toolbox getty -nl /bin/sh 0 /dev/console [...]
2015  2016  forumthread  issue  workaround  cli  example  tips  sysadmin  coreos  tool  github  linux  systemd  links 
10 weeks ago by ezequiel
linux - What would happen if the amount of free memory (vm.min_free_kbytes) was too low? - Unix & Linux Stack Exchange
Q: I came across the following parameter in kernel settings (in sysctl):

vm.min_free_kbytes

This is the amount of free memory (RAM) that's always free no matter what. In my case, I have only 1 GiB of RAM, and this parameter was set to about 64MiB. I thought that's pretty high, so I lowered it to 8MiB so far. I don't know if I can lower it any further, or if lowering it to 8MiB can cause any troubles, so the question is what would happen if the amount of the free memory was too low? Can I safely lower the value to 1MiB?
2014  forumthread  stackexchange  links  linux  kernel  memory  tips  sysadmin  configuration 
10 weeks ago by ezequiel
CoreOS: containers not restarting after reboot · Issue #3241 · docker/compose
A: This was indeed a configuration change within CoreOS. For the benefit of others, the solution was to enable the Docker service in systemd:

# systemctl enable docker.service
# systemctl start docker.service
coreos  docker  booting  issue  workaround  cli  example  tips  2016  forumthread  github 
10 weeks ago by ezequiel
Removed Container Still Attached to Network · Issue #33156 · moby/moby
Q: I've got a removed container tying up an endpoint name in the bridged network, and I can't remove the container from the network since the container no longer exists.

The issue could most likely be resolved by clearing everything out and starting it up again but due to #32613 that would result in data loss so I'm avoiding that. Using a different name for the container allows it to be started but this is not ideal.

A: [...] Have you tried the -f / --force option on docker network disconnect? docker network disconnect <network> <endpoint-id>, so in your case; [...]
issue  docker  networking  configuration  workaround  forumthread  2017  linux  sysadmin  tips  example  github 
10 weeks ago by ezequiel
How to allocate 50% CPU resource to docker container via `docker run`? - Stack Overflow
A: cpu-shares is a 'relative weight', relative to the default setting of 1024, so if you had two containers running on the same core, you could give them the CPU 50-50 or 80-20 or whatever you wanted by adjusting the numbers. It is an integer.

You cannot give an overall limit, as you want to, using this flag, but you can restrict the set of CPUs that the container runs on using --cpuset mentioned here.

The number 1024 is in the Cgroups docs.

This blog post from Marek Goldmann explains resource management in Docker. [...]
2014  2019  forumthread  stackexchange  docker  cpu  performance  configuration  example  tips  sysadmin  links  kernel  linux 
10 weeks ago by ezequiel
memory usage - What do the changes in `free` output from 14.04 to 16.04 mean? - Ask Ubuntu
Q: I noticed that the free command reporting has changed somewhere between Trusty and Xenial. Here is what `free -m' shows on one of my Trusty computers: [...]
2016  2018  ubuntu  ubuntu.trusty  ubuntu.xenial  memory  cli  tool  sysadmin  linux  kernel  tips  links  reference  info  forumthread  stackexchange 
10 weeks ago by ezequiel
How to specify Memory & CPU limit in docker compose version 3 - Stack Overflow
Q: I am unable to specify CPU & memory for services specified in version 3.

With version 2 it works fine with "mem_limit" & "cpu_shares" parameters under the services . But it fails while using version 3 , putting them under deploy section doesn't seem worthy unless i am using swarm mode.

Can somebody help?
docker  fileformats  tool  howto  tips  example  issue  workaround  cpu  memory  virtualisation  security  sysadmin  cli  links  forumthread  stackexchange 
10 weeks ago by ezequiel
cloud - How can size of the root disk in Google Compute Engine be increased? - Stack Overflow
Q: The root disk size in GCE is 10 gigs. How do I increase this? I cant find the option in the console or the gcutil flags. This can be easily done in AWS.
2014  2019  forumthread  stackexchange  google.cloud  cloudcomputing  storage  harddisk  virtualisation  tips  example  amazon.aws  cli  unix  linux  filesystem  tool 
10 weeks ago by ezequiel
ssl certificate - SSL encryption with CNAME redirect - Server Fault
Q: Here is my current architecture: I have a simple site hosted in the cloud that needs to be served from my company. Thus, mysite.com has a CNAME redirect to 1234.cloud.com. I understand that the SSL certificate needs to be created for mysite.com.

Here are my questions:

a) how does the CNAME redirect work when fetching content? does DNS resolve the cloud IP address and allow just one HTTP connection to the cloud or is the HTTP connection sent to my server and then relayed to the cloud? which server presents the SSL cert for mysite.com? I believe that I need to configure a local server to offer the SSL certificate because DNS alone would not suffice, but I am not sure on the architecture. [...]
2016  forumthread  stackexchange  faq  info  links  dns  ssl  tls  security  internet  http  protocol  browser 
11 weeks ago by ezequiel
ddos - iptables rules to counter the most common DoS attacks? - Server Fault
Q: Recently I've got a lot of small scale DoS attacks. I am wondering what iptables rules should I use to counter the most common DoS attacks, and generally secure my web server.
[...]
So appreciate your rules to block the most common attack vectors.
2012  2018  forumthread  stackexchange  iptables  linux  firewall  security  example  tips  sysadmin  networking  cloudcomputing  remote 
11 weeks ago by ezequiel
« earlier      
per page:    204080120160

Copy this bookmark:





to read