recentpopularlog in
« earlier   later »
Night Runner - Nuclear Countdown - YouTube
Harry Washello : So he was calling from a missile silo! He said that they were locked in, 50 minutes and counting, to shoot off their nuclear wad. We would be getting it back in an hour and 10. I mean he meant that we're at war! Nuclear war!


From "Miracle Mile" (1988): https://www.imdb.com/title/tt0097889/characters/nm0000381
synthwave  sample  film  quote 
october 2019
How do I uninstall Java on my Mac?
<code class="language-bash">sudo rm -fr /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin
sudo rm -fr /Library/PreferencePanes/JavaControlPanel.prefPane
sudo rm -fr ~/Library/Application\ Support/Oracle/Java</code>
macos  mac  osx  java  uninstallation  uninstall  solution 
october 2019
Refine web searches - Google Search Help
'site:' is about the only useful one; I thought there would be a 'lang:' but nope.
google  keywords  search  searchengine  reference 
september 2019
How a Whistle-Blower Complaint Undermined Trump - The Atlantic
Trump has long worried that America’s intelligence professionals would try to undermine him from the shadows. All they had to do was play by the rules.
ic  presidenttrump 
september 2019
python - make pip ignore an existing wheel - Stack Overflow
Has this problem with python-levenshtein being built with UCS-4 symbols and my homebrew Python was only UCS-2. This totally did the trick. See also: https://bytes.com/topic/python/answers/34496-undefined-symbol-pyunicodeucs4_fromunicode

<code class="language-bash">pip install <package> --no-binary :all:</code>
pip  wheel  binary  workaround  solution 
september 2019
string - What is the difference between UTF-32 and UCS-4? - Stack Overflow
UTF-32 has started as a subset of UCS-4. Now it is identical except that the UTF-32 standard has additional Unicode semantics. See details on wikipedia: http://en.wikipedia.org/wiki/UTF-32


However:
However, I am not exactly sure, what additional Unicode semantics means. Maybe someone can provide a better answer.
unicode  widecharacters  ucs4  explained 
september 2019
undefined symbol: PyUnicodeUCS4_FromUnicode - Python
I ran into this with a wheel for python-levenshtein that was built for UCS-4, but my homebrew Python was UCS-2. Using 'pip install python-levenshtein --no-binary :all:' to ignore the wheel was the solution for me (source: https://stackoverflow.com/a/38263887/785213)
python  pip  wheel  unicode  sortof  solution 
september 2019
How do I increase console-mode resolution? - Ask Ubuntu
No amount of 'GRUB_GFXMODE' or 'GRUB_GFXPAYLOAD' seemd to do me any good, but this old trick worked
This helped me on Ubuntu 14.04 with ESXi 5.5
<code class="language-bash">sudo vi /etc/default/grub</code>
Change line to:
<code>GRUB_CMDLINE_LINUX_DEFAULT="splash vga=792"</code>
centos  centos7  grub  hiresconsole  console  vga  font  solution 
september 2019
Kernighan's lever
Everyone knows that debugging is twice as hard as writing a program in the first place. So if you're as clever as you can be when you write it, how will you ever debug it?


Pay close attention to what is actually being said: Having written code as cleverly as you can, you will suddenly face a problem that you are not clever enough to solve.

Kernighan's witty remarks provide a clue: In programming, as soon as you work at your current level, you will automatically end up in a situation where you have to work beyond your current level. By means of this very fortunate mechanism, you will leverage several basic human drives (honour, pride, stubbornness, curiosity) into providing the motivation necessary for improvement.

I call this mechanism Kernighan's lever. By putting in a small amount of motivation towards the short-term goal of implementing some functionality, you suddenly end up with a much larger amount of motivation towards a long term investment in your own personal growth as a programmer.
devel  software  debugging  advice  career  growth  kernighan 
september 2019
arch linux - Setting console font in vconsole.conf does not work (systemd) - Unix & Linux Stack Exchange
Also mentioned in that email thread: try the (boring) lat0-{08,10,12,14,16} fonts before giving up entirely. At least on CentOS (7), the Terminus console fonts don't seem to work at all.
centos7  consolefont  hiresconsole  annoyance  maybesolution 
september 2019
HowTos/PXE/InternetInstallation - CentOS Wiki
So *this* is why the netinstall ISO doesn't give you a list of mirrors to pick from. Because it's not Debian, and Anaconda doesn't do across-the-Internet installs very well.
People attempting such installations tend to be 'drive-by' distribution 'samplers' or 'first time newbies' who impose a load of many questions on CentOS support structures, seem to always be insistent on receiving immediate answers, but (from experience) have usually not read the Installation documentation. As such, there is little incentive to support such efforts by the regulars in the #centos IRC channel.
centos  netinstall  questions  answered 
september 2019
sqlite - Compile Python 3.4 with sqlite3 - Stack Overflow
There is also the option of pre-linking your custom Python build with your own-built sqlite3. (I had the same issue: the custom python was using the system-provided sqlite3, completely ignoring the sqlite3 I built).

Prefix your configure and make commands with:
<code class="language-bash">LD_RUN_PATH=$HOME/opt/lib configure LDFLAGS="-L$HOME/opt/lib" CPPFLAGS="-I$HOME/opt/include" …
LD_RUN_PATH=$HOME/opt/lib make</code>

so that the built python3 by default is linked to your sqlite3. This worked for me.
python  fromsource  sqlite  errormessage  linkererrors  solution 
september 2019
charles leifer | Compiling SQLite for use with Python Applications
<code class="language-python">>>> import sqlite3
>>> sqlite3.sqlite_version
'3.25.0'</code>
python  sqlite  fromsource  reference 
september 2019
How to Turn Off macOS Mojave Screenshot Preview Thumbnails - The maciOS
This is a ridiculously wordy post for only really saying:
Hide or Turn Off Mojave Screenshot Previews
STEP 1: Shift + Command + 5
STEP 2: Open “options”
STEP 3: Disable floating option
STEP 4: Screenshot thumbnail preview is disabled
macos  mojave  10.14  annoyance  screenshot  solution 
september 2019
bash - How do create an alias in shell scripts? - Stack Overflow
From the bash man page:
Aliases are not expanded when the shell is not interactive, unless the expand_aliases shell option is set using shopt (see the description of shopt under SHELL BUILTIN COMMANDS below).


So this should work:
<code class="language-bash">
#!/bin/bash
shopt -s expand_aliases
alias I_am_only_ls_alias=ls
I_am_only_ls_alias
</code>
Scripts usually use functions, not aliases.
bash  shellscripting  aliases  newbie  solution 
september 2019
swift - How to force reload preference plist for an app in OS X? - Stack Overflow
The reason is, from Mac OS Mavericks, apple started to cache plist files, which results in replacing a plist file manually has no effect until the cache is reloaded automatically. If you open the application which uses this plist file to early, it overwrites your copied file with the old/cached one.

To reload the preference file manually, use
<code class="language-bash">defaults read <filename>.plist</code>

to read the new plist values.

Source: nethack

Now, I just use a sh script to call the defaults after executing my program.
macos  mojave  10.14  preferences  plist  solution 
september 2019
How do I make Git ignore file mode (chmod) changes? - Stack Overflow
<code class="language-bash">git config core.fileMode false
</code>
git  mode  chmod  annoyance  solution 
september 2019
Vim - General - How to get vim patch version number in vim script?
As far as the patch level, the normal way to do it would be something along the lines of
<code class="language-viml">if v:version > 702 || (v:version == 702 && has('patch31'))</code>
which returns true if the vim binary is from the yet-unreleased 7.3 or higher, or if it's from vim 7.2 and includes patch 31.
viml  vimscript  vimrc  conditional  solution 
september 2019
brammool/libvterm: Mirror of http://bazaar.leonerd.org.uk/c/libvterm/
<code>To merge in changes from Github, do this:
- Commit any pending changes.
- Setup the merge tool:
git config merge.tool vimdiff
git config merge.conflictstyle diff3
git config mergetool.prompt false
- Run the merge tool:
git mergetool
This will open a four-way diff between:
LOCAL - your current version
BASE - version as it was at your last sync
REMOTE - version at head on Github
MERGED - best-effort merge of LOCAL and REMOTE
Now find places where automatic merge didn't work, they are marked with
<<<<<<<<, ======= and >>>>>>>
Fix those places in MERGED, remove the markers, and save the file :wqall.</code>
vim  devel  git  vimdiff  merging  merge  mergetool  tipsandtricks 
september 2019
ciaranm/securemodelines: A secure alternative to Vim modelines
This works fine, and it recognizes 'filetype', which is all I really need.
vim  security  plugin  modeline  solution 
september 2019
Can't install addon because it seems to be corrupt | Firefox Support Forum | Mozilla Support
In my case, I had a JavaScript syntax error (missing parenthesis) that prevented me from using 'about:debugging' to load the extension temporarily.
webdevel  firefox  webextension  extension  debugging  sortof  solution 
september 2019
Your first extension - Mozilla | MDN
On macOS 10.14 (Mojave), I had to
<code class="language-bash">
sudo port install nodejs10
sudo port install python27
sudo port select --set python2 python27


# install NPM modules into $HOME
npm config set prefix $HOME/.local/lib/node_modules
echo "export PATH=$HOME/.local/lib/node_modules/bin:$PATH" >> ~/.bash_profile

# this needed 'python2' in the PATH (for node-gyp, whatever that is)
npm install -g web-ext

# then build the extension
web-ext build
</code>

Also, try to use the linter on the built '.zip' file:

<code class="language-bash">addons-linter web-ext-artifacts/*.zip</code>

Otherwise you might get a "Can't install addon because it seems to be corrupt" error, which probably means that you just have a syntax error in your JavaScript, or else the manifest.json is missing a 'content_scripts' 'matches' key (ref: https://developer.mozilla.org/en-US/docs/Mozilla/Add-ons/WebExtensions/manifest.json/content_scripts)
webdevel  firefox  extension  webextension  macos  errormessage  solution 
september 2019
What is the !! (not not) operator in JavaScript? - Stack Overflow
An easy way to describe it is: Boolean(5) === !!5; Same casting, fewer characters
devel  javascript  boolean  idiom  syntax  newbie  dammitbrain 
september 2019
3 from Hell movie review & film summary (2019) | Roger Ebert
Biggest use of 'Tremendous' you've ever seen, tremendous, tremendous tremendousness. People are saying yuge, yuge use of tremendous, trust me, bigly.

Oh boy! So they kidnapped the warden's wife. does she get raped? If she gets raped, how many times does she get raped? She has to at least get stripped naked. Oh boy, stripped at least! If she doesn't get raped, who does? Someone has to get raped, this IS a Rob Zombie movie! Raped and then like, stabbed 50 times or maybe run over by a truck! Oh boy this is going to be awesome! HARDCOOOOREE!
film  review  horror  schlock  forthecomments 
september 2019
Regarding shell scripts that are only meant to be source (SC2148) · Issue #581 · koalaman/shellcheck
Now (in 0.7.0 from MacPorts) I get POSIX 'sh' warnings, even though I've specified
<code class="language-bash"># shellcheck shell=bash</code>
shellcheck  bug  maybesolution 
september 2019
Directive · koalaman/shellcheck Wiki
For files without a shebang line:
<code class="language-bash"># shellcheck shell=bash</code>
shellcheck  bash  shellscripting  linting  staticanalyzer  directive  solution 
september 2019
« earlier      later »
per page:    204080120160

Copy this bookmark:





to read