recentpopularlog in
« earlier   later »
FAQ - btrfs Wiki
From kernel 5.0+ btrfs have native swap files support, but with some limitations. Swap file - must be fully allocated as NOCOW with no compression on one device.
linux  sysadmin  swap  swapfile  btrfs  solution 
november 2019
It's not you. Bad doors are everywhere. - YouTube
This video is about doors. Joe Posner investigates, with some help from 99% invisible, a wonderful podcast. Check them out here: http://www.99pi.org Subscrib...
design  doors  normandoors 
november 2019
When Facebook Spread Hate, One Cop Tried Something Unusual - The New York Times
Social media allows anyone, anywhere to spread rumors about his corner of the world. A number of white nationalists, taking a special interest in Bavaria’s culture wars, have done just that. And Mr. Guske is powerless to stop them.

“It’s hard to prevent fake news, because once Facebook pushes it —” he trailed off, shaking his head and slapping his palm on the table. “What more can you do?”
socialmedia  facebook  hatecrimes  deutschland  immigration 
november 2019
Solved: Isilon Vs ECS - Dell Community
Furthermore Isilon is more a "Filecentric" solution which offers you access to files through different protocols while ECS is "Objectstorage" which offers you acces to objects through several protocols, this said ECS has WORM by design.

Think of ECS in the same way as you may have thought of Centera in the past, a really big archive. It can do more as sluetze said with regards to geo-load balancing and so-forth, and supports the Centera CAS API, and S3. File protocols were added later to ECS initially NFSv3 only, and I think recently SMB as well. But on the big data side it doesn't speak HDFS like Isilon does, and it's not meant to be best of breed performance for really large HDFS datasets. As I understand it the HDFS access is actually over NFS using a java library. So maybe a good spot for cold buckets of data, not hot.
enterpriseclass  storage  isilon  emc  ecs  sysadmin 
november 2019
How do I find stored passwords in Windows 10? - Microsoft Community | https://answers.microsoft.com/
This is where Edge stores HTTP Basic authentication details, *not* in the browser's own saved logins manager.
window  win10  credentials  savedpasswords  edge  browser  security  passwordmanager 
november 2019
Bill Nye, LeVar Burton, And Other Childhood Favorites As Superheroes
I had this dream in November 2019.... and someone at Buzfeed had the same dream in 2013.
levarburton  batman 
november 2019
Rails Conf 2012 Keynote: Simplicity Matters by Rich Hickey - YouTube
Rich Hickey, the author of Clojure and designer of Datomic, is a software developer with over 20 years of experience in various domains. Rich has worked on s...
simplicity  clojure  conference  conferencetalk  video 
november 2019
Wayne McGregor's Chroma – The Hardest Button to Button (The Royal Ballet) - YouTube
Enjoy this video? Subscribe to our channel to receive notifications about new ballet and opera clips. To book tickets or find out more about the Royal Opera ...
ballet  video 
november 2019
Jack Black Performs His Legendary Sax-A-Boom with The Roots - YouTube
Jack Black gives The Tonight Show audience a taste of the Sax-A-Boom skills he made famous by playing the toy instrument at Tenacious D shows. Subscribe NOW ...
saxaboom  video  awesomesauce 
november 2019
Apache Redirect Root URL to Subfolder – JamesCoyle.net Limited | https://www.jamescoyle.net/
I had this bit of configuration in my /etc/httpd/conf.d/something.conf, but I'm not sure if it ever did anything other than "pass through" (if you look at the logs).

Anyways, for posterity:
<code class="language-apache">
# Make all requests to the root go to /wiki. A 'Redirect' (mod_alias)$
# isn't appropriate here because that *also* passes the "path" part of$
# the request, which would lead to a recursive redirect.$
# Source: http://www.jamescoyle.net/how-to/1424-apache-redirect-root-url-to-subfolder
RewriteEngine on
RewriteCond %{REQUEST_URI} ^/$
RewriteRule (.*) /wiki/ [R=301]
</code>
webmaster  apache  httpd  rewrite  mediawiki  maybesolution 
november 2019
php - Alternatives to apache_get_modules() to get list of loaded apache modules - Stack Overflow | https://stackoverflow.com/

* phpinfo() will tell you how PHP is installed, especially the Server API row.
* You could parse the config files for Apache to find out which modules are configured.
* You could run something like apache2 -t -D DUMP_MODULES to obtain a list of modules.
apache  webmaster  modules  annoyance  solution 
november 2019
httpd24-mod_ldap-2.4.34-7.el6.1.x86_64.rpm CentOS 6 Download | https://centos.pkgs.org/
Install Howto
<code class="language-bash">
# Install CentOS SCLo RH repository:
yum install centos-release-scl-rh

# Install httpd24-mod_ldap rpm package:
yum install httpd24-mod_ldap
</code>
webmaster  apache  apache24  ldap  module  centos  centos7  scl  packagemanagement  annoyance  solution 
november 2019
apache 2.2 - Difference between mod_authn_ldap and mod_authz_ldap - Server Fault | https://serverfault.com/
mod_authz_ldap seems to be a third-party module that *only* does authorization (not authentication)--whatever that means.
apache  apache22  httpd  ldap  modules  webmaster  maybesolution 
november 2019
mod_authnz_ldap - Apache HTTP Server Version 2.2 | https://httpd.apache.org/
<code class="language-apache">
<Directory "/var/www/html/someresource">
Order deny,allow
Deny from All
Require valid-user
Satisfy any

AuthName "Some Resource"
AuthType Basic
AuthBasicProvider ldap
# pass bad users/passwords off onto the "file" provider
AuthzLDAPAuthoritative off
AuthBasicProvider file
AuthUserFile /var/www/htpasswd

Require ldap-group CN=group1,OU=DP,OU=dept,DC=subdomain,DC=domain,DC=org
Require ldap-group CN=group2,OU=DP,OU=dept,DC=subdomain,DC=domain,DC=org
Require ldap-group CN=group3,OU=DP,OU=dept,DC=subdomain,DC=domain,DC=org
AuthLDAPGroupAttribute memberOf

AuthLDAPUrl "ldap://ldap1.subdomain.domain.org/OU=Research,OU=Managed,DC=chmcres,DC=cchmc,DC=org?uid?sub?(objectclass=organizationalPerson)"
# 2.4.x should allow multiple URLs

# not supported until 2.3.x
#AuthLDAPInitialBindAsUser
AuthLDAPBindDN "CN=ldapuser,OU=ServiceAccounts,DC=subdomain,DC=domain,DC=org"
AuthLDAPBindPassword "ThisIsThePasswordForThat"
</Directory>
# vim: ft=apache
</code>
webmaster  apache  httpd  authorization  ldap  configfile  solution 
november 2019
user interface - How do I move the X (close) button on Firefox to the left? - elementary OS Stack Exchange | https://elementaryos.stackexchange.com/
Put these in your 'userChrome.css'

<code class="language-css">@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");

/* h/t: https://support.mozilla.org/en-US/questions/1222872 */

/* first, move the window controls all the way to the left */
.titlebar-buttonbox-container {
-moz-box-ordinal-group: 0 !important;
}

/* then move the "close" (X) button all the way to the left */
.titlebar-close {
-moz-box-ordinal-group: 0 !important;
}

/* fix the spacing issue with the "minimize" button (now in the middle) */
.titlebar-min {
margin-left: 6px !important;
}

/* left spacer is too wide when shown and hidden when maximized;
this looks better */
.titlebar-spacer[type="pre-tabs"], .titlebar-spacer[type="post-tabs"] {
display: block !important;
width: 20px !important;
}</code>
elementary  firefox  windowcontrols  annoyance  solution 
november 2019
Integra Chemical :: Hazardous Materials Identification System (HMIS)
Hazard Index:
4 Severe Hazard
3 Serious Hazard
2 Moderate Hazard
1 Slight Hazard
0 Minimal Hazard

Personal Protection Index:
A Eye protection
B A + Gloves
C B + Protective clothing
D C + Face shield
E B + Respiratory protection/dusts
F C + Respiratory protection/dusts
G B + Respiratory protection/vapors
H C + Respiratory protection/ vapors
I B + Respiratory protection/dusts and vapors
J C + Respiratory protection/dusts and vapors
lab  hmis  safety  reference 
november 2019
Ways to Flatten A Perl Array in Scalar Context - Stack Overflow
I had this weird problem with 'getsnpcoords' that was compressing a list within a double-quoted string /without/ the intermediate spaces, like some other package had unset '$"' and not reset it to the default, and what I ended up doing was an explicit 'join'.
$LIST_SEPARATOR
$"

When an array or an array slice is interpolated into a double-quoted string or a similar context such as /.../ , its elements are separated by this value. Default is a space. For example, this:
<code class="language-bash">print "The array is: @array\n";</code>
is equivalent to this:
<code class="language-perl">print "The array is: " . join($", @array) . "\n";</code>
Mnemonic: works in double-quoted context.
perl  syntax  lists  til 
november 2019
Force your site to load securely with an .htaccess file – DreamHost | https://help.dreamhost.com/
<code class="language-apache">
RewriteEngine On
RewriteCond %{HTTPS} !=on
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301,NE]
</code>
https  apache  redirect  dreamhost  hosting  webmaster  solution 
november 2019
Parcellite indicator in Ubuntu 13.10 - Ask Ubuntu | https://askubuntu.com/
It seems that a fork of Parcellite is available and this fork supports does provide an indicator for Unity:

Parcellite with Ubuntu AppIndicator? ClipIt!


Links to: http://www.webupd8.org/2011/01/parcellite-has-new-developer-and-new.html
linux  clipboardmanager  clipboard  history  utility  essential  alternativeto  diodon  movein 
november 2019
mdh34/elementary-indicators: An unofficial guide to restore indicator functionality on elementary OS | https://github.com/
All that seems to be required for most (exception of gtk2) indicators is

- install 'indicator-application' from the repos
- then the old wingpanel-ayatana-indicator package (https://launchpad.net/~elementary-os/+archive/ubuntu/stable/+files/wingpanel-indicator-ayatana_2.0.3+r27+pkg17~ubuntu0.4.1.1_amd64.deb)
- and follow the instructions from https://pinboard.in/u:kme/b:bc95dba3fa3c to customize its XDG .desktop file so it runs in Pantheon

That is:
Edit /etc/xdg/autostart/indicator-application.desktop:
<code class="language-bash">sudo vim /etc/xdg/autostart/indicator-application.desktop</code>
change:
<code class="language-ini">OnlyShowIn=Unity;GNOME;</code>
to
<code class="language-ini">OnlyShowIn=Unity;GNOME;Pantheon;</code>
and 'killall wingpanel'.

Also of note:
If you copy the file to .config/autostart/indicator-application.desktop then you shouldn't have to worry about it getting overwritten again.
elementaryos  wingpanel  panel  indicator  notification  systray  workaround  appindicator  notificationarea  solution  fuckina 
november 2019
« earlier      later »
per page:    204080120160

Copy this bookmark:





to read