recentpopularlog in

kme : android   89

« earlier  
Paste text on Android Emulator - Stack Overflow [http://stackoverflow.com/]
In a terminal, type adb shell input text 'my string here. With some characters escaped like \$ that'


This one's sketchy. I'm sure something wrong with the quotes there, but theoretically 'pbpaste' should be able to feed into this somehow.
adb shell input text "pbpaste`"`
android  emulator  mac  osx  commandline  clipboard  clipboardsharing  solution 
august 2014 by kme
Issues - android - Android Open Source Project - Issue Tracker - Google Project Hosting
Need to file a bug for the ADT tools not EVEN SHOWING devices that don't meet the minimum version/SDK. They should show up, only greyed out or something. This drove me crazy for most of a day trying to run a 2.2 app on a Droid which hadn't received the 2.2 OTA update.
android  bug  devel  eclipse  adtplugin 
may 2014 by kme
MotoCast - Download
These turned out not to be necessary for debugging the Droid 1 on OS X. The issue I was having was that the AndroidManifest for the project I was trying to run was set at a higher Android version than what was actually on the phone (2.2 > 2.1).
motoroladroid  drivers  mac  osx  android  debugging 
may 2014 by kme
Motorola Device Manager Uninstall? - MacRumors Forums
These instructions worked, roughly. The folder was named "Motorla Mobility" and the app "Uninstall Motorola Device Manager.app."
Uninstall MotoCast from Mac OSX Leopard and Snow Leopard:

1. Open a new window within Finder

2. Go to Macintosh HD

3. Select the Library folder

4. Select the Application Support folder

5. If the MotoCast folder exists, select it and:

Double-click on Uninstall MotoCast.app to remove MotoCast
Double-click on Uninstall MotoHelper_Driver.app to remove MotoCast Drivers (requires your Mac password to complete removal of drivers)
6. Select Uninstall MotoCast
mac  osx  drivers  motoroladroid  android  solution 
may 2014 by kme
Why is Eclipse's Android Device Chooser not showing my Android device? - Stack Overflow
Solution in my case was that the Droid I was using had a 2.1 firmware and apparently hadn't received the 2.2 OTA update (https://en.wikipedia.org/wiki/Motorola_droid#2.2_update)--had it been off the network since September 2010?

Therefore, DDMS showed the device, but the launch window (Run As... Android Application) didn't, because my project was set to minimum 2.2 (Froyo) in AndroidManifest.xml. So this answer was actually correct in my case:

The device was not showing up because of the following line in android manifest file---

<uses-sdk android:minSdkVersion="18"
android:targetSdkVersion="18"/>

I changed it to---

<uses-sdk android:minSdkVersion="8"
android:targetSdkVersion="19"/>

Now it worked.
linux  android  udev  motoroladroid  hardware  debugging  usb  solution 
may 2014 by kme
connected Motorola Droid not recognized by adb - Google Groups
SOLUTION: My Droid had a 2.1 firmware; project required 2.2 minimum, and the launch dialog for Run As... Android Application doesn't bother to show incompatible devices (even greyed out).
windows  android  hardware  debugging  drivers  motoroladroid  maybesolution 
may 2014 by kme
android osx my droid does not show up on my mac - Stack Overflow
It took quite a bit of digging around and a couple calls to motorola but the answer is to install Motorola Media Link on the mac. The URL to find it is as follows:

http://www.motorola.com/Consumers/US-EN/Consumer-Product-and-Services/Software/Motorola-Media-Link-Mac-Version-US-EN

SOLUTION: My problem was that the device was running Android 2.1 (which I believed to be 2.2) and my project's AndroidManifest.xml was specifying 2.2 as the minimum. The launch dialog in Eclipse didn't even bother to show the device, which I find problematic.
motoroladroid  mac  osx  android  hardware  debugging  maybesolution  drivers 
may 2014 by kme
Using Hardware Devices | Android Developers

Set up your system to detect your device.

If you're developing on Windows, you need to install a USB driver for adb. For an installation guide and links to OEM drivers, see the OEM USB Drivers document.
If you're developing on Mac OS X, it just works. Skip this step.
If you're developing on Ubuntu Linux, you need to add a udev rules file that contains a USB configuration for each type of device you want to use for development. In the rules file, each device manufacturer is identified by a unique vendor ID, as specified by the ATTR{idVendor} property. For a list of vendor IDs, see USB Vendor IDs, below. To set up device detection on Ubuntu Linux:
Log in as root and create this file: /etc/udev/rules.d/51-android.rules.

Use this format to add each vendor to the file:
SUBSYSTEM=="usb", ATTR{idVendor}=="0bb4", MODE="0666", GROUP="plugdev"

In this example, the vendor ID is for HTC. The MODE assignment specifies read/write permissions, and GROUP defines which Unix group owns the device node.

Note: The rule syntax may vary slightly depending on your environment. Consult the udev documentation for your system as needed. For an overview of rule syntax, see this guide to writing udev rules.
Now execute:
chmod a+r /etc/udev/rules.d/51-android.rules
android  devel  debugging  motoroladroid  linux  solution 
may 2014 by kme
Eclipse with Android SDK missing menu items - Stack Overflow
I was able to restore the missing items in File | New... quite easily by performing the following steps:

Switch to the Java perspective, either via the perspective switcher toolbar at the top right of the main Eclipse window, or via the Window | Open Perspective menu item.
Reset the perspective by either right-clicking on the Java perspective icon in the perspective switcher toolbar, or by clicking Window | Reset Perspective...
android  adt  eclipse  annoyance  solution 
may 2014 by kme
Enable Developer Options on Android 4.2/4.3 JB and Android 4.4 KitKat
Developer Options on Gingerbread (Android 2.3):

Settings> Applications> Development> USB Debugging
android  development  debugging  usb  solution 
may 2014 by kme
Android Flashlight App Developer Settles FTC Charges It Deceived Consumers | Federal Trade Commission
“When consumers are given a real, informed choice, they can decide for themselves whether the benefit of a service is worth the information they must share to use it,” said Jessica Rich, Director of the FTC’s Bureau of Consumer Protection. “But this flashlight app left them in the dark about how their information was going to be used.”
locationsharing  android  insidious  app  privacy  yukyuk 
december 2013 by kme
« earlier      
per page:    204080120160

Copy this bookmark:





to read