recentpopularlog in

kme : annoyance   689

« earlier  
Windows Vista: Security Through Endless Warning Dialogs
The problem with the Security Through Endless Warning Dialogs school of thought is that it doesn't work. All those earnest warning dialogs eventually blend together into a giant "click here to get work done" button that nobody bothers to read any more. The operating system cries wolf so much that when a real wolf-- in the form of a virus or malware-- rolls around, you'll mindlessly allow it access to whatever it wants, just out of habit.
vista  uac  security  badux  annoyance 
3 days ago by kme
Cygwin no available download site - Stack Overflow
Solution for me (modern.ie Win7 VM on corporate network) was to go to https://cygwin.com/mirrors.html and pick one of the mirrors from there.
cygwin  windows  corporatenetwork  mirrors  networksettings  annoyance  workaround  solution 
8 days ago by kme
arch linux - Setting console font in vconsole.conf does not work (systemd) - Unix & Linux Stack Exchange
Also mentioned in that email thread: try the (boring) lat0-{08,10,12,14,16} fonts before giving up entirely. At least on CentOS (7), the Terminus console fonts don't seem to work at all.
centos7  consolefont  hiresconsole  annoyance  maybesolution 
19 days ago by kme
How to Turn Off macOS Mojave Screenshot Preview Thumbnails - The maciOS
This is a ridiculously wordy post for only really saying:
Hide or Turn Off Mojave Screenshot Previews
STEP 1: Shift + Command + 5
STEP 2: Open “options”
STEP 3: Disable floating option
STEP 4: Screenshot thumbnail preview is disabled
macos  mojave  10.14  annoyance  screenshot  solution 
22 days ago by kme
How do I make Git ignore file mode (chmod) changes? - Stack Overflow
<code class="language-bash">git config core.fileMode false
</code>
git  mode  chmod  annoyance  solution 
23 days ago by kme
windows - Getting WGET to display a less verbose output - Super User
You can use -nv to make wget less verbose, but it won't show download progress in that case.


Or:
<code class="language-bash">wget -q --show-progress http://example.com</code>

--show-progress will override the "quiet" flag.


Also interesting:
<code class="language-bash">curl -#:</code>
wget  curl  progressbar  annoyance  downloading  spidering  webcrawling  maybesolution 
29 days ago by kme
Switch Out The Awful Default Notification Center Sound For Something Better [OS X Tips] | Cult of Mac
Doesn't seem to work anymore in Mojave. It's not playing Basso, but some other sound I can't find in /System/Library/Sounds.
macos  notificationcenter  customization  alertsounds  annoyance  maybesolution 
5 weeks ago by kme
How to Show the Expanded Print Details Dialog in Mac OS by Default
<code class="language-bash">defaults write -g PMPrintingExpandedStateForPrint -bool TRUE</code>
macos  mojave  10.14  defaults  essential  movein  annoyance  printing 
5 weeks ago by kme
Disable Notification Center & Remove the Menu Bar Icon in Mac OS X
<code class="language-bash">launchctl unload -w /System/Library/LaunchAgents/com.apple.notificationcenterui.plist

killall NotificationCenter</code>
mac  osx  defaults  notificationcenter  annoyance  maybesolution 
5 weeks ago by kme
Add a quiet option to docker pull · Issue #13588 · moby/moby
And I can't get it on macOS 10.11, of course, but simply redirecting stderr or closing it works:
<code class="language-bash">docker run --rm bash:$tag bash -c "shopt | grep -q $option" 2>&-</code>
docker  cli  annoyance  workaround  solution 
7 weeks ago by kme
Autoconf, Libtool, and an undefined AC_PROG_LIBTOOL - Super User
This fixed this for me—modifying the supplied 'autogen.sh', so that it ran this command instead:
<code class="language-bash">autoreconf -v -f -i -I /usr/share/aclocal</code>
To fix this if you already have a /usr/local/share/aclocal directory, type the following as root:
<code class="language-bash">for file in argz libtool ltdl ltoptions ltsugar ltversion lt~obsolete
do
ln -s /usr/share/aclocal/$file.m4 /usr/local/share/aclocal/$file.m4
done
</code>

To fix this if you don't have a /usr/local/share/aclocal directory, type the following as root:
<code class="language-bash">ln -s /usr/share/aclocal /usr/local/share/aclocal</code>

Voilà -- problem solved.
autoconf  errormessage  build  toolchain  centos7  annoyance  solution 
9 weeks ago by kme
Debug Tool Window. Console - Help | PyCharm
The "Show Python prompt" button is not available if you set "Emulate terminal in output console" in the configuration for the current debug profile (ref: https://www.jetbrains.com/help/pycharm/2018.1/run-debug-configuration-python.html)
pycharm  debugging  annoyance  solution 
10 weeks ago by kme
macos - Add a locale in Mac OSX - Stack Overflow
Looking into this found that, as of Mac OS X 10.10.3, collation is still broken for Spanish and most European languages. Collation definitions for these locales are linked to an ASCII definition. This ends up breaking things such as ORDER BY clauses on PostgreSQL.


Also, WTF is does 'la_LN' mean anyway?
macos  elcapitan  annoyance  sorting  brokenness  collation  lc_all  dateandtime  unix  maybesolution 
12 weeks ago by kme
Re: Lua and pkg-config .pc file | http://lua-users.org/
I was trying to build 'highlight' (https://gitlab.com/saalen/highlight) and got a 'lua.pc' not found error. This was the solution

<code class="language-bash">
make pc INSTALL_TOP=/wherever/you/stow/lua-5.3.5 > lua.pc
</code>

This was just an off-the-cuff answer from someone who probably doesn't know 'pkg-config' very well, though, because it *still* doesn't work unless you add 'Name:', 'Version:', and 'Description:' fields to the .pc file.

THEN, you can move that 'lua.pc' into '/wherever/you/stow/lua-5.3.5/lib/pkgconfig' and update the PKG_CONFIG_PATH environment variable.
lua  build  toolchain  errormessage  library  pkg-config  annoyance  workaround  solution 
july 2019 by kme
Move through wrapped lines | Vim Tips Wiki | FANDOM powered by Wikia
I ended up using a combination of this tip and the one from https://vim.fandom.com/wiki/Move_cursor_by_display_lines_when_wrapping
My current settings are:
<code class="language-vim">map <silent> <Up> gk
imap <silent> <Up> <C-o>gk
map <silent> <Down> gj
imap <silent> <Down> <C-o>gj
map <silent> <home> g<home>
imap <silent> <home> <C-o>g<home>
map <silent> <End> g<End>
imap <silent> <End> <C-o>g<End>

setlocal linebreak
setlocal nolist
setlocal display+=lastline</code>
vim  configfile  wrapping  scrolling  cursormotion  annoyance  sortof  solution 
july 2019 by kme
Move cursor by display lines when wrapping | Vim Tips Wiki | FANDOM powered by Wikia
I ended up using a combination of this tip and the one from https://vim.fandom.com/wiki/Move_through_wrapped_lines.
You can add the following to get the `standard keys' to work:
<code class="language-viml">
noremap <silent> k gk
noremap <silent> j gj
noremap <silent> 0 g0
noremap <silent> $ g$</code>

If you copy the code from the tip into your vimrc file, make sure that you delete trailing spaces from each line, AND that you put the new code near the bottom of the vimrc file. If the code is near the top of vimrc, something coming after it might redefine those keys.

Unfortunately, this tip breaks the movement commands in conjunction with other commands. For example, d<Down> will no longer delete two lines but delete from the cursor to the position in the next line.

But you can still use j to move down by a physical line, and dj will do what you want.
You can avoid this by mapping the keys in the operator-pending mode as well:
<code class="language-viml">
onoremap <silent> j gj
onoremap <silent> k gk</code>
vim  keybinding  configfile  scrolling  cursormotion  annoyance  sortof  solution 
july 2019 by kme
macos - How to remove the scrollbar in Terminal.app on Mac OS X 10.6? - Super User
Go to System Preferences -> General and change Show scroll bars to When scrolling.
macos  mac  osx  terminal.app  scrollbars  annoyance  preference  solution 
july 2019 by kme
savehistory function | R Documentation
The "Example" section is jacked up, and I can't tell what that's supposed to look like; try https://stackoverflow.com/a/16738440 (answer from Hadley Wickham) instead.

Maybe the version of R that we have on the cluster didn't build against the readline library or something, and *that's* why up/down arrows don't recall the history.
r  history  repl  annoyance  maybesolution 
june 2019 by kme
r - Saving and loading history automatically - Stack Overflow
In my ~/.profile I have:
<code class="language-bash">export R_HISTFILE=~/.Rhistory</code>

In my ~/.Rprofile I have:
<code class="language-R">if (interactive()) {
.Last <- function() try(savehistory("~/.Rhistory"))
}</code>

and that works for me (although it doesn't work very well if you have multiple R sessions open). I also have
<code class="language-bash">alias R='R --no-save --no-restore-data --quiet'</code>

in my profile which eliminates the questions on close.
r  repl  history  configfile  annoyance  solution  fuckina 
june 2019 by kme
Docker and Locales
Like, in my case, Vim wasn't displaying UTF-8 encoded symbols (like "»") correctly.

Here's his working Dockerfile recipe:
<code>FROM ubuntu:13.10

# Set the locale
RUN locale-gen en_US.UTF-8
ENV LANG en_US.UTF-8
ENV LANGUAGE en_US:en
ENV LC_ALL en_US.UTF-8
</code>
docker  locale  characterencoding  errormessage  annoyance  solution 
june 2019 by kme
systemctl failed to get Dbus connection: No connection to service manager
It seems like a hot ticket, but this doesn't work if 'systemctl' depends on D-Bus being running. It's a total chicken-and-egg problem then. This is the case in the official Docker image for CentOS 7.

<code class="language-bash">sudo systemctl start dbus.service</code>
centos7  centos  docker  systemctl  systemd  dbus  annoyance 
june 2019 by kme
Force flushing of output to a file while bash script is still running - Stack Overflow
I found a solution to this here. Using the OP's example you basically run
<code class="language-bash">stdbuf -oL /homedir/MyScript &> some_log.log</code>

and then the buffer gets flushed after each line of output. I often combine this with nohup to run long jobs on a remote machine.
<code class="language-bash">stdbuf -oL nohup /homedir/MyScript &> some_log.log</code>

This way your process doesn't get cancelled when you log out.
bash  shellscripting  buffering  annoyance  workaround  solution 
june 2019 by kme
debugging - How can I debug git/git-shell related problems? - Stack Overflow
<code class="language-bash">GIT_CURL_VERBOSE=1 GIT_TRACE=1 git pull origin master</code>
git  curl  debugging  https  troubleshooting  annoyance 
june 2019 by kme
Big gap between icons · Issue #1 · mdh34/elementary-indicators | https://github.com/
Still works in 5.0 Juno.
Try setting the padding to '0 2px' in your theme -> apps.css

In my case I use https://github.com/surajmandalcell/elementary-x :
/usr/share/themes/elementary-x/gtk-3.22/apps.css
<code class="language-css">.composited-indicator {
padding: 0 2px;
}</code>

Then set your theme to something else and then back again to make sure the changes are refreshed(or restart/log out)
elementaryos  juno  panelindicator  appindicators  annoyance  solution 
may 2019 by kme
Question #216282 : Questions : elementary OS | https://answers.launchpad.net/
All the gtk apps had their icons in the panel. Turns out the sni-qt package was missing. They are back now.
elementaryos  qt  panel  indicators  appindicators  annoyance  maybesolution 
may 2019 by kme
Unwanted context menu behaviour after update to Firefox 61.0 - Right clicks are automatically double clicking : firefox | https://www.reddit.com/
After some trial-and-error I was able to fix the issue in about:config by toggling ui.context_menus.after_mouseup to true. The default is false. I believe this may have something to do with the fact that I'd previously toggled dom.event.contextmenu.enabled to false to always allow for the context menu, even if a site disables it.
firefox  nightly  contextmenu  annoyance  solution 
may 2019 by kme
Firefox context menu on right click release. : firefox | https://www.reddit.com/
See also: https://www.reddit.com/r/firefox/comments/8uyoic/unwanted_context_menu_behaviour_after_update_to/
After some trial-and-error I was able to fix the issue in about:config by toggling ui.context_menus.after_mouseup to true. The default is false. I believe this may have something to do with the fact that I'd previously toggled dom.event.contextmenu.enabled to false to always allow for the context menu, even if a site disables it.
firefox  nightly  contextmenu  annoyance 
may 2019 by kme
How to display system tray icons in elementary OS Juno? - elementary OS Stack Exchange | https://elementaryos.stackexchange.com/
The necessary 'indicator-application' package seems to be in the repositories for Juno; all that was probably actually required is
$ sudo nano /etc/xdg/autostart/indicator-application.desktop

find the line

OnlyShowIn=Unity;GNOME;

and add Pantheon

OnlyShowIn=Unity;GNOME;Pantheon;
elementaryos  juno  indicator  icons  appindicator  panelindicators  annoyance  movein  sortof  solution 
may 2019 by kme
How do I change login background in elementary OS Freya or Loki? - elementary OS Stack Exchange | https://elementaryos.stackexchange.com/
Just copy your wallpaper to /usr/share/backgrounds (you're going to need root privileges to do so) and then select your wallpaper from System Settings -Desktop - Wallpaper.
elementaryos  greeter  lockscreen  background  wallpaper  annoyance  solution 
may 2019 by kme
How can I disable searching and domain guessing from the Firefox Address Bar, while keeping other features? - Super User | https://superuser.com/
The settings mentioned in the accepted answer will prevent, for example, 'localhost' from redirecting to 'localhost.com', but this still doesn't stop Firefox from trying to visit a non-existent web site if your search term has a period in it. So a search like "vcruntime140.dll" will still assume that ".dll" is a TLD.

However, I blindly discovered that putting a "?" at the beginning of the query is enough to turn of hostname detection, and pressing Ctrl+K will do that, and focus the Awesome Bar for you.

See also: https://support.mozilla.org/en-US/kb/keyboard-shortcuts-perform-firefox-tasks-quickly#w_search and https://support.mozilla.org/en-US/kb/awesome-bar-search-firefox-bookmarks-history-tabs#w_how-can-i-control-what-results-the-address-bar-shows-me (section called "Changing results on the fly").
Go to about:config and set the following preferences to false:

browser.fixup.alternate.enabled

True (default): Try to fix up http://foo to http://(prefix)foo(suffix)
False: Do not second-guess the user
firefox  search  awesomebar  configsetting  annoyance  url  toosmart  solution  configuration  customization  movein  sortof  workaround 
april 2019 by kme
How can I set up an editor to work with Git on Windows? - Stack Overflow | https://stackoverflow.com/
Git for Windows uses 'nano.exe' for this setting, forcing you to override it if you want to use, say, Vim. It does not seem to respect the EDITOR environment variable.
By configuring git config core.editor notepad, users can now use notepad.exe as their default editor.

Configuring git config format.commitMessageColumns 72 will be picked up by the notepad wrapper and line-wrap the commit
message after the user edits it.
git  gitconfig  commitmessage  windows  newbie  annoyance  solution 
march 2019 by kme
mysql - Can't connect to localhost using Python's MySQLdb - Stack Overflow | https://stackoverflow.com/
I've managed to solve this by setting my host to "127.0.0.1" rather than "localhost".

Turns out if the socket isn't in the default location (/tmp/mysql.sock), the MySQLdb client doesn't take any special measures (lazy!) to discover where it's ACTUALLY at, according to the /etc/my.cnf.

For example, on CentOS (6?), using the SCL version of MySQL, it's at /var/lib/mysql/mysql.sock.
if your mysql socket is not placed in /tmp/mysql.sock, you can specify it with
<code class="language-python">conn = MySQLdb.connect (unix_socket = 'path_to_your_socket', host = 'localhost', user = 'erin', passwd = 'erin', db = 'sec')</code>

edit: for mamp on macosx the mysql socket path should be something like /Applications/MAMP/tmp/mysql/mysql.sock

To figure out where the heck the socket actually *is*, this might work:
using <code class="language-bash">mysql_config --socket</code> in your shell should do, or /path/to/mysql/bin/mysql_config if you installed it in /opt or something – roman Jan 11 '11 at 20:56
python  sqlalchemy  mysql  client  errormessage  webdevel  solution  annoyance 
march 2019 by kme
Sed command returning "invalid command code" - Stack Overflow
I had this error on macOS and the problem was that '-i' expects a (zero-length) string argument. But this is a weird-ass way of telling you that.
macos  bsd  sed  shellscripting  annoyance  erromessage  solution 
march 2019 by kme
readline - python tab completion Mac OSX 10.7 (Lion) - Stack Overflow | https://stackoverflow.com/
Putting this in a ~/.pythonrc works for Python >= 3. Python 2.7.x seems to require that you set PYTHONSTARTUP=~/.pythonrc in your login scripts.

<code class="language-python">import readline
import rlcompleter
if 'libedit' in readline.__doc__:
readline.parse_and_bind("bind ^I rl_complete")
else:
readline.parse_and_bind("tab: complete")</code>
python  macos  osx  repl  tabcompletion  autocompletion  annoyance  configfile  essential  movein 
march 2019 by kme
ruby on rails - How can I remove a default gem? ! want to uninstall a gem 1.7.7 version of json - Stack Overflow | https://stackoverflow.com/
I had to remove the (duplicate) '<ruby_install_dir>/lib/ruby/gems/<ruby_major_ver>/specifications/default/json-x.y.z.gemspec' file from my specifications/default directory.

The top-rated answer was confusingly verbose, but it did contain the solution in there, somewhere.
ruby  rubygems  errormessage  annoyance  solution 
march 2019 by kme
Error installing json 1.8.3 with ruby 2.4 - Stack Overflow | https://stackoverflow.com/
I did <code class="language-bash">gem install -v 1.8.6 json</code> and it worked.
I ran into the same issue recently as well, try and see if there's a newer version of whatever gem you're using that depends on json 1.8.3. This is happening because Ruby 2.4 unified Fixnum and Bignum into Integer. If you're able to upgrade to json 1.8.5 or higher, it should help fix your problems.
ruby  annoyance  errormessage  rubygems  gem  solution 
march 2019 by kme
CalendarAgent process is out of control -… - Apple Community | https://discussions.apple.com/
Yeah, no, this didn't work. I did that, and the CalendarAgent still hogs a CPU and spins the fan up to max. Disabling the Google Calendar accounts might be the only solution.
I was able to get this to stop. Go to:

* System Preferences
* Notifications

Click the "Calendar" entry on the left. Un-Check everything on the right. The entry moves to the bottom (or below the line). After that, my CPU went straight down to a normal percentage, system temp dropped, etc.
mac  osx  calendaragent  troubleshooting  annoyance  maybesolution 
march 2019 by kme
Manual:Image administration - MediaWiki | https://www.mediawiki.org/
Animated GIFs don't scale with the built in PHP routines. And yet the cached (broken) thumbnails aren't refreshed without expiring the cache.

This combination of stuff was required after I discovered that I had to enable ImageMagick in order to get thumbnails of GIFs:

<code class="language-php"># source: https://www.mediawiki.org/wiki/Manual:Image_administration#Image_thumbnailing
# this should enable scaling of GIF images; built-in PHP routines won't
$wgUseImageMagick = true;
$wgImageMagickConvertCommand = '/usr/bin/convert';

# if rendered thumbnails are older than this timestamp, they are regenerated
# copy-pasted from https://www.mediawiki.org/wiki/Manual:$wgCacheEpoch
$wgThumbnailEpoch = 20190314215957;
$wgCacheEpoch = 20190314215957;

# temporarily remove shell time and memory limits (if necessary)
# source: https://www.mediawiki.org/wiki/Manual:$wgMaxShellMemory
#$wgMaxShellTime = 0;
#$wgMaxShellMemory = 0;
</code>
mediawiki  images  uploads  multimedia  animatedgifs  imagemagick  configfile  annoyance  solution 
march 2019 by kme
Animated images - MozillaZine Knowledge Base | http://kb.mozillazine.org/
Pressing the "Esc" key on Windows (other OS may be different) will pause animated images on the current website. Note: Starting in Firefox 20, this is no longer the case due to the fix for bug 614304 unless resolved in an upcoming patch (see comment 45). The SuperStop add-on by Gavin Sharp (https://addons.mozilla.org/en-US/firefox/addon/superstop/) is an alternate solution.
firefox  gif  animation  annoyance  solution 
march 2019 by kme
Blank lines are not preserved. · Issue #48 · janl/mustache.js | https://github.com/
Try the following JS code: var a = Mustache.to_html('{{tag1}}\n\n\n{{tag2}}.\n', {tag1:'Hello', tag2:'World'}, {}); a should contain the string Hello\n\n\nWorld.\n whereas currently it contains the string Hello\nWorld. The problem stems ...
mustache  templates  webdevel  maybesolution  annoyance  bug 
march 2019 by kme
macos - Why CURL return and error (23) Failed writing body? - Stack Overflow | https://stackoverflow.com/

(For completeness and future searches) It 'a matter of how CURL manages the buffer, the buffer disables the output stream with the -N option.
<code class="language-bash">
curl -s -N "URL" | grep -q Welcome
</code>
unix  shellscripting  curl  pipes  errormessage  annoyance  solution 
march 2019 by kme
git - .gitignore exclude folder but include specific subfolder - Stack Overflow | https://stackoverflow.com/
To do what you want, you have to “unignore” every parent directory of anything that you want to “unignore”. Usually you end up writing rules for this situation in pairs: ignore everything in a directory, but not some certain subdirectory.
<code class="language-gitignore"># you can skip this first one if it is not already excluded by prior patterns
!application/

application/*
!application/language/

application/language/*
!application/language/gr/</code>
git  gitignore  devel  annoyance  dammitbrain  solution 
march 2019 by kme
Issues · ether/etherpad-lite · GitHub | https://github.com/
There really needs to be away to resize the chat pane. :-(
Etherpad: Really real-time collaborative document editing - ether/etherpad-lite
etherpad  realtime  colloboration  chat  webapp  bug  annoyance  needshelp 
march 2019 by kme
Floating windows not docking in main window · Issue #984 · sqlitebrowser/sqlitebrowser · GitHub | https://github.com/
Details for the issue I can't get a floating window to dock at the main window's borders. Hovering the dock above the main window has no effect. Useful extra information Double clicking on the title bar of a floating window correctly doc...
sqlitebrowser  qt  gui  sqllite  dba  database  bug  annoyance  needshelp 
march 2019 by kme
man command not found on git bash · Issue #249 · swcarpentry/shell-novice | https://github.com/
man doesn't seem to be installed on git bash - learners get a "man: command not found" error when they try to use it.
softwarecarpentry  git  gitforwindows  bash  annoyance  packagemanagement  workaround  solution 
february 2019 by kme
Wonky display on this one Win10 startup screen in VirtualBox - Linux Mint Forums | https://forums.linuxmint.com/
I asked a question a few days ago about a video snow display when booting LM19 Live DVD in Virtual Box. Turns out that you need to use R-CTRL / F2 followed by R-CTRL / F7 [Host-F2, Host-F7] to go in and out of a terminal to clear the snow. Have you tried this to fix your Wonk? Maybe the Linux Graphics Drive is not really up to snuff with the Virtual Machine Host graphics. After installing the LM 19 system in the VM I have not seen snow again. Or any Wonk. Or at least now your kind of Wonk.
linuxmint  virtualization  virtualbox  graphics  linux  annoyance  solution 
february 2019 by kme
vim - How to fix duplicate cscope ? is it a better way? - Stack Overflow | https://stackoverflow.com/
Solution: put 'set cscopenoverbose' right before the 'if filereadable("cscope.out")' statement.
vim  cscope  errormessage  annoyance  solution 
february 2019 by kme
linux - bash: variable name not being expanded with Tab completion - Super User | https://superuser.com/
shopt -s direxpand will make echo $HOME/<tab> expand to echo /home/matt/ in bash 4.2. In bash 4.1 it should be the default.
bash  tabcompletion  bashcompletion  commandline  shell  configfile  essential  movein  annoyance  solution  fuckina 
february 2019 by kme
python - No module named pkg_resources - Stack Overflow | https://stackoverflow.com/
None of these worked.

What I ended up doing was:

<code class="language-bash">
curl -O https://bootstrap.pypa.io/get-pip.py
python3 get-pip.py --user
rm ~/.local/bin/pip # so the distro pip for Python 2.7 takes precedence
</code>
python  errormessage  annoyance  packaging  pip  ubuntu  16.04  workaround  solution 
february 2019 by kme
Tips and tricks: How to change default Google calendar | https://tips-a-tricks.blogspot.com/
The only real solution is to deselect all the other calendars when you're creating events. The top calendar (of the enabled ones) is the default when adding new events.

Via: https://productforums.google.com/forum/#!topic/calendar/Ehvki1-FOi4
googlecalendar  calendar  tipsandtricks  annoyance  sortof  solution 
january 2019 by kme
« earlier      
per page:    204080120160

Copy this bookmark:





to read