recentpopularlog in

kme : centos   210

« earlier  
How do I increase console-mode resolution? - Ask Ubuntu
No amount of 'GRUB_GFXMODE' or 'GRUB_GFXPAYLOAD' seemd to do me any good, but this old trick worked
This helped me on Ubuntu 14.04 with ESXi 5.5
<code class="language-bash">sudo vi /etc/default/grub</code>
Change line to:
<code>GRUB_CMDLINE_LINUX_DEFAULT="splash vga=792"</code>
centos  centos7  grub  hiresconsole  console  vga  font  solution 
16 days ago by kme
HowTos/PXE/InternetInstallation - CentOS Wiki
So *this* is why the netinstall ISO doesn't give you a list of mirrors to pick from. Because it's not Debian, and Anaconda doesn't do across-the-Internet installs very well.
People attempting such installations tend to be 'drive-by' distribution 'samplers' or 'first time newbies' who impose a load of many questions on CentOS support structures, seem to always be insistent on receiving immediate answers, but (from experience) have usually not read the Installation documentation. As such, there is little incentive to support such efforts by the regulars in the #centos IRC channel.
centos  netinstall  questions  answered 
16 days ago by kme
Issue 31652: make install fails: no module _ctypes - Python tracker
Had to build and install libffi into the PREFIX for Python-3.7.4 when building it from source on CentOS 7.

See also: https://bugs.python.org/issue34036
centos  centos7  fromsource  build  toolchain  compiler  errormessage  python  workaround  solution 
8 weeks ago by kme
How to Check CentOS Version Number
<code class="language-bash">cat /etc/centos-release</code>
sysadmin  centos  release  solution 
11 weeks ago by kme
docker - Setting the hostname for a container running in Kubernetes - Stack Overflow
Yeah, no, with a CentOS 7 docker image, after it's already running, it doesn't look like you can change the hostname, because you get the "hostname: you must be root to change the host name" even when you're (obviously) running as root.
centos  centos7  docker  sysadmin  hostname  almostsolution 
june 2019 by kme
systemctl failed to get Dbus connection: No connection to service manager
It seems like a hot ticket, but this doesn't work if 'systemctl' depends on D-Bus being running. It's a total chicken-and-egg problem then. This is the case in the official Docker image for CentOS 7.

<code class="language-bash">sudo systemctl start dbus.service</code>
centos7  centos  docker  systemctl  systemd  dbus  annoyance 
june 2019 by kme
yum - How to add language support on CentOS 7 (on Docker)? - Server Fault
If they'd just stop saying 'localectl' is the solution, when it doesn't work in Docker. There's no DBus daemon running or something. The 'systemctl' command doesn't work, even. These things are stripped out in container environments, I guess.

What *actually* works is
<code class="language-bash">yum reinstall -y glibc-common</code>
and then setting 'LC_ALL` or 'LANG` in the environment.
centos  centos7  locale  docker  language  characterencoding  maybesolution 
june 2019 by kme
How to Set Up System Locale on CentOS 7 | RoseHosting
I think 'localectl' is not built into the base CentOS 7 OS or something? Or at least not the Docker image? Because, sure enough, it wasn't there before, and after a 'yum update' it is.

For a CentOS 7 Docker image, however, you still need to 'yum reinstall -y glibc-common' and just set 'LC_ALL' or 'LANG' in your environment; the 'localectl' command won't work because there's no D-Bus daemon running on the Docker image.
centos  locale  language  sysadmin  sortof  solution  docker 
june 2019 by kme
windows - How to fix PuTTY showing garbled characters? - Server Fault
The analogous fix on CentOS (7) is to use 'localectl', maybe, except that requires DBus to be running, which it isn't for a fresh-out-of-the-box Docker container. ¯\_(ツ)_/¯
If the locale returns something like POSIX, issue
<code class="language-bash">update-locale LANG=en_US.utf8</code>
at the command line - see thomas-krenn.com/de/wiki/Locales_unter_Ubuntu_konfigurieren – koppor Dec 19 '15 at 11:05
docker  utf8  characterencoding  locale  mojibake  terminal  unix  shell  ubuntu  solution  centos  sortof 
june 2019 by kme
macos - Using the pkg-config macro PKG_CHECK_MODULES failing - Stack Overflow | https://stackoverflow.com/
The solution in my case was to build and install automake-1.16 and pkg-config-0.29.something, which were newer than the OS-supplied versions.
devel  centos  centos6  pkg-config  build  toolchain  errormessage  sortof  solution 
february 2019 by kme
add a docker configuration file · Issue #937 · moby/moby | https://github.com/
Answer: there apparently is no '/etc/docker/docker.conf'; on Debian-derived distros, there's an /etc/default/docker, where you can set the DOCKER_OPTS environment variable for the daemon, though.
docker  ubuntu  debian  centos  configfile  configuration  reference 
january 2019 by kme
Best way to move docker directory · Issue #3127 · moby/moby | https://github.com/
Good evening, I'm looking for the best way to move docker directory (default /var/lib/docker) to another directory. (Technically other disk partition) I'm using devicemapper, and I think a lot of things are mounted, so it's not as easy a...
docker  configfile  centos  ubuntu  migration  reference 
january 2019 by kme
How To Install Node.js on a CentOS 7 server | DigitalOcean | https://www.digitalocean.com/
To gain access to the EPEL repo, you must modify the repo-list of your installation. Fortunately, we can reconfigure access to this repository by installing a package available in our current repos called epel-release.
<code class="language-bash">
sudo yum install epel-release
</code>
nodejs  centos  node  packagemangement  sysadmin  solution 
january 2019 by kme
Bug 1589668 – error: Ignoring osad because of bad file mode - must be 0644 or 0444. | https://bugzilla.redhat.com/
change filemode from /etc/logrotate.d/osad to 0644 or 0444

Followed by:
<code class="language-bash">logrotate -f /etc/logrotate.conf</code>
sysadmin  errormessage  logrotated  centos  centos7  solution 
august 2018 by kme
Rcpp installation error - '::Rf_pythag' - General - RStudio Community | https://community.rstudio.com/
Got the error message
/usr/lib64/R/library/Rcpp/include/Rcpp/Rmath.h:222: error: ‘::Rf_pythag’ has not been declared

when attempting to install/upgrade the 'htmltools' package from CRAN.

This seems to be an effective workaround:
<code class="language-r">install.packages("https://mran.microsoft.com/snapshot/2018-06-01/src/contrib/Rcpp_0.12.17.tar.gz",repos = NULL, type = "source")</code>

Try also:
<code class="language-r">update.packages(ask = FALSE, checkBuilt = TRUE)</code>
r  packagemanagement  annoyance  centos  sysadmin  maybesolution  errormessage  workaround 
august 2018 by kme
Download Shiny Server - RStudio | https://www.rstudio.com/
<code class="language-bash">
# Size: 46.2 MB
# MD5: 3f8f53d87767cc5949d3b83206c628d0
# Version: 1.5.7.907
# Released: 2018-04-06
$ wget https://download3.rstudio.org/centos6.3/x86_64/shiny-server-1.5.7.907-rh6-x86_64.rpm
$ sudo yum install --nogpgcheck shiny-server-1.5.7.907-rh6-x86_64.rpm</code>
shiny  r  centos  installation  sysadmin  solution 
august 2018 by kme
centos5 - How do I change my locale to UTF-8 in CentOS? - Server Fault | https://serverfault.com/
In CentOS try with system-config-language command. That's the CentOS way :) Also you can try with:
<code class="language-bash">
localedef -c -f UTF-8 -i de_DE de_DE.UTF-8
export LC_ALL=de_DE.UTF-8</code>
locale  centos  aufdeutsch  language  i18n  solution 
may 2018 by kme
set locale on commandline without system-config-language - CentOS | https://www.centos.org/
So... there is basically no good solution for this out of the box? A CentOS 7 Docker container has the same problem.

<code class="language-bash">yum whatprovides \*/setlocale</code>
centos  language  locale  i18n  interesting  sysadmin 
may 2018 by kme
how do I allow mysql connections through selinux - Server Fault | https://serverfault.com/

To check SELinux
<code class="language-bash">sestatus</code>

To see what flags are set on httpd processes
<code class="language-bash">getsebool -a | grep httpd</code>

To allow Apache to connect to remote database through SELinux
<code class="language-bash">setsebool httpd_can_network_connect_db 1</code>

Use -P option makes the change permanent. Without this option, the boolean would be reset to 0 at reboot.
<code class="language-bash">
setsebool -P httpd_can_network_connect_db 1
</code>

See also https://codedump.io/share/HBJCXpCN1VLr/1/permission-denied-when-trying-to-connect-to-mysql-installing-mediawiki, because I got that exact error message:

<code>
/var/www/html/Wiki/includes/limit.sh: line 61: ulimit: cpu time: cannot modify limit: Permission denied

/var/www/html/Wiki/includes/limit.sh: line 90: ulimit: file size: cannot modify limit: Permission denied</code>

If you want to create a policy file that allows whatever was failing to not fail, try this:

<code class="language-bash">grep httpd /var/log/audit/audit.log | audit2allow -M mypol
semodule -i mypol.pp</code>
selinux  centos  apache  httpd  mysql  security  sysadmin  webmaster  solution  errormessage 
may 2018 by kme
Warning: preg_match(): Compilation failed: this version of PCRE is compiled without UTF support - DirectAdmin - Peter Sangkhamanon | https://mzpeter.co.uk/
On CentOS, you'll also need 'pcre-tools' to get the 'pcretest' utility.
same as Warning: preg_replace() [function.preg-replace]: Compilation failed: this version of PCRE is not compiled with PCRE_UTF8 support at offset 0 in.
errormessage  php  annoyance  centos  centos7  php56  maybesolution 
may 2018 by kme
MySQL :: MySQL 5.5 Reference Manual :: 2.11.1 Upgrading MySQL | https://dev.mysql.com/
<code class="language-bash">
mysqldump -u root -p \
--add-drop-table --routines --events \
--all-databases --force > data-for-upgrade.sql

# then
# (possibly /usr/libexec/mysqld, if there's no mysqld_safe script)
mysqld_safe --user=mysql --datadir=/path/to/5.5-datadir

# then
mysql -u root -p --force < data-for-upgrade.sql

# finally
mysql_upgrade -u root -p
</code>
mysql  migration  centos  sysadmin  dba  reference  solution 
may 2018 by kme
How to check CentOS version - LinuxConfig.org | https://linuxconfig.org/
First, example uses hostnamectl command:

<code class="language-none"># hostnamectl
Static hostname: localhost.localdomain
Icon name: computer-laptop
Chassis: laptop
Machine ID: 6892999b8d8c43fab29fca961dbff24b
Boot ID: b0a95bf56f61417ca8073b3847a73ab1
Operating System: CentOS Linux 7 (Core)
CPE OS Name: cpe:/o:centos:centos:7
Kernel: Linux 3.10.0-229.7.2.el7.x86_64
Architecture: x86_64</code>
sysadmin  centos  commandline  versioninformation  solution 
april 2018 by kme
How to resolve yum errors during update - CentOS - Server Fault | https://serverfault.com/
What worked for me

<code class="language-bash">
yum clean all # maybe didn't do anything, I dunno
yum distro-sync full # didn't work without the 'full'
yum update # no updates found after 'distro-sync'
</code>


See also: https://www.centos.org/forums/viewtopic.php?t=52898
<code class="language-bash">
package-cleanup --dupes
</code>
sysadmin  rpm  packagemanagement  yum  errormessage  dllhell  centos  centos7  solution 
january 2018 by kme
How to Install MariaDB on CentOS 7 | https://linode.com/
If you try to install 'mysql-server' you'll get this error:
Transaction check error:
file /usr/lib64/mysql/plugin/dialog.so from install of mariadb-galera-server-1:5.5.37-2.el7.x86_64 conflicts with file from package mariadb-libs
-1:5.5.56-2.el7.x86_64
file /usr/lib64/mysql/plugin/mysql_clear_password.so from install of mariadb-galera-server-1:5.5.37-2.el7.x86_64 conflicts with file from packag
e mariadb-libs-1:5.5.56-2.el7.x86_64

The solution is to just install 'mariadb-server' right off the bat.
mysql  mariadb  dba  installation  howto  centos  centos7  sysadmin  errormessage  solution 
january 2018 by kme
How To Disable IPv6 In CentOS 7 | Unixmen
<code class="language-bash">
sysctl -w net.ipv6.conf.all.disable_ipv6=1
sysctl -w net.ipv6.conf.default.disable_ipv6=1
</code>
centos  sysctl  ipv6  networking  sysadmin  linux  troubleshooting  solution 
december 2017 by kme
linux - How do I set the default kernel parameters in CentOS for all existing and future kernels? - Server Fault - https://serverfault.com/
You can have it apply to all current and any future kernels by using ALL. grubby --update-kernel=ALL --remove-args="rhgb quiet" – benjarrell Jul 2 '13 at 18:04

You can also add '--args="vga=792"' to get a decent console resolution.
centos  centos6  grub  console  consolefont  framebufferconsole  configfile  solution 
october 2017 by kme
linux - You don't have permission error in Apache in CentOS - Stack Overflow - https://stackoverflow.com/
This is a common problem, and this is a good tip:
ps axo user,group,comm | grep apache


Also, check "getenforce" to see if SELinux is the problem.
centos  apache  httpd  annoyance  webmaster  syadmin  permissions  solution 
october 2017 by kme
mod_wsgi 4.5.17 : Python Package Index [https://pypi.python.org/]
LoadModule wsgi_module /usr/local/lib/python2.7/site-packages/mod_wsgi/server/mod_wsgi-py27.so
WSGIPythonHome /usr/local/lib
centos  python  wsgi  mod_wsgi  apache  webmaster  solution 
august 2017 by kme
node.js - npm can't find package.json - Stack Overflow
The error message I got was "npm WARN enoent ENOENT: no such file or directory, open '/usr/bin/package.json'" using the SCL 'rh-nodejs4' package. Using the '-g' (global) option worked.
I'll be brief but deadly. :) install -d will not work for you. It's simple. Try

$ npm install -g express
nodejs  npm  errormessage  centos  centos6  solution 
august 2017 by kme
how to set LD_LIBRARY_PATH on VPS red-hat linux to be visible by apache - Server Fault
Turns out you can just 'source /opt/rh/python27/enable' in /etc/sysconfig/httpd. That works fine on CentOS 6.
apache  webmaster  centos  solution 
august 2017 by kme
How do I manage applications on startup in GNOME 3? - Ask Ubuntu
From terminal or AltF2 dialog run: gnome-session-properties.

For newer ( 3.14 ) versions of Gnome just use the Tweak Tool from the applications menu.
centos  gnome  annoyance  solution 
august 2017 by kme
VirtualBox Guest Additions on Fedora 26/25, CentOS/RHEL 7.3/6.9/5.11 - If Not True Then False
<code class="language-bash">yum update kernel*
rpm -Uvh https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
yum install gcc kernel-devel kernel-headers dkms make bzip2 perl
export KERN_DIR=/usr/src/kernels/`uname -r`</code>
virtualbox  centos  centos7  fedora  fedora30  guestadditions  dammitbrain  annoyance  solution 
august 2017 by kme
gdb - Missing separate debuginfos, use: debuginfo-install glibc-2.12-1.47.el6_2.9.i686 libgcc-4.4.6-3.el6.i686 libstdc++-4.4.6-3.el6.i686 - Stack Overflow
debuginfo-install is a command of yum-utils, so

<code class="language-bash">yum install yum-utils
debuginfo-install glibc</code>

if the warning's still there, edit /etc/yum.repos.d/CentOS-Debuginfo.repo, set enabled=1
centos  centos6  debugging  errormessage  maybesolution 
august 2017 by kme
gdb - Missing separate debuginfos - Unix & Linux Stack Exchange
You still have to enable some repo. Good luck finding out how to do that.
centos  debugging  gdb  annoyance  maybesolution 
august 2017 by kme
python - error: command 'gcc' failed with exit status 1 on CentOS - Stack Overflow
I bet you have to install libxml2-devel or libxml++-devel or even python-devel.


So this would've worked:
$ sudo yum -y install gcc gcc-c++ kernel-devel
$ sudo yum -y install python-devel libxslt-devel libffi-devel openssl-devel
$ pip install "your python packet"
python  xml  library  errormessage  missinglibraries  centos6  centos  solution 
may 2017 by kme
PHP :: Bug #48614 :: Loading "pdo_sqlite.so" fails: undefined symbol: sqlite3_libversion
I get this error message with the SCL version of PHP 5.4 on CentOS 6:
$ boris
PHP Warning: PHP Startup: Unable to load dynamic library '/opt/rh/php54/root/usr/lib64/php/modules/pdo_sqlite.so' - /opt/rh/php54/root/usr/lib64/php/modules/pdo_sqlite.so: undefined symbol: sqlite3_column_table_name in Unknown on line 0


Just commenting out the "extension=pdo_sqlite.so" in /opt/rh/php54/root/etc/php.d/pdo_sqlite.ini at least gets rid of the error message.
php  php54  centos  centos6  bug  errormessage  sortof  solution 
may 2017 by kme
Doctrine PEAR channel
This channel is to be used with the PEAR installer.
Registering the channel:

pear channel-discover pear.doctrine-project.org

Listing available packages:

pear remote-list -c doctrine

Installing a package:

pear install doctrine/package_name
centos  centos6  php54  pear  php  packagemanagement  solution 
may 2017 by kme
Cannot download Docker images behind a proxy - Stack Overflow
As mentioned in one of the other posts, the 'export' is required in /etc/sysconfig/docker.

On centos the configuration file for docker is at:

/etc/sysconfig/docker

Adding below line helped me to get docker daemon working behind proxy server:

HTTP_PROXY="http://<proxy_host>:<proxy_port>"
HTTPS_PROXY="http://<proxy_host>:<proxy_port>"
centos  centos6  docker  sysadmin  solution 
may 2017 by kme
Shiny Server on CentOS | R-bloggers
<code class="language-bash">sudo su – -c “R -e \”install.packages(‘ggplot2′, repos=’http://cran.rstudio.com/’)\””</code>
r  packagemanagement  rshiny  centos6  centos  solution 
may 2017 by kme
rpm - yum error "Cannot retrieve metalink for repository: epel. Please verify its path and try again" updating ContextBroker - Stack Overflow
In my case, the only problem was that the 'http_proxy' variable was set in root's .bashrc; doing a 'sudo -s' before installing the packages worked fine.
yum  packagemanagement  centos  errormessage  sortof  solution 
may 2017 by kme
« earlier      
per page:    204080120160

Copy this bookmark:





to read