recentpopularlog in

kme : centos6   59

#28376 (URIs not supported error) – Django
You got this problem because your python was compiled with sqlite < 3.5.0. Checking the versions won't help.

If you are using CentOS 6, don't use python34 from EPEL or rh-python36 from SCL. You can use python from miniconda3 as your base python interpreter. Here is my detailed analysis: ​https://github.com/WqyJh/django_sqlite3_checker/blob/master/python-sqlite3-django-versions.md


<code class="language-python">>>> import sqlite3
>>> sqlite3.version_info
(2, 6, 0)
>>> sqlite3.sqlite_version_info
(3, 11, 0)</code>
python  sqlite  versions  oldversion  annoyance  centos6  scl 
9 days ago by kme
networking - Why the default eth0 interface is down by default on CentOS? - Unix & Linux Stack Exchange
Edit /etc/sysconfig/network-scripts/ifcfg-$IFNAME. Change the ONBOOT line's value to yes.
centos  centos6  networking  sysadmin  solution 
8 weeks ago by kme
[SOLVED] Set console font in minimal install - CentOS
Was:
With CentOS 6 I could specify the console font in /etc/sysconfig/i18n with SYSFONT="foo"


Now:
It is now /etc/vconsole.conf
centos  centos6  centos7  consolefont  console  font  solution 
8 weeks ago by kme
How To Reset Root Password On CentOS 7 | Unixmen
I dunno what the '.autorelabel' SELinux thing is all about, but it DEFinitely seems to be required.

<code>
1. boot into single user mode
- ∆ kernel command line from 'ro' to 'rw init=/sysroot/bin/sh'
2. chroot /sysroot
3. chroot /sysroot
4. touch /.autorelabel # totally 100% required!
5. exit # probably not necessary, just reboot</code>
centos  centos6  rhel  password  sysadmin  howto  solution 
8 weeks ago by kme
Upstart start-up script (Centos 6.x)
I couldn't figure out how to get 'initctl' to disable an init script in /etc/init (like the old 'chkconfig' did), so I just edited it by hand (as root) to comment out the 'start on runlevel' part.
initscripts  upstart  centos  centos6  reference 
december 2019 by kme
Install Elasticsearch on CentOS 6.7 - Sysadmins of the North
<code class="language-bash"><code>sudo chkconfig --add elasticsearch</code>

I also had to:
<code class="language-bash">chmod g+ws /etc/elasticsearch/</code>
elasticsearch  installation  centos  centos6  solution 
december 2019 by kme
Install Elasticsearch with RPM | Elasticsearch Reference [7.5] | Elastic
An alternative package which contains only features that are available under the Apache 2.0 license is also available. To install it, use the following baseurl in your elasticsearch.repo file:
<code>baseurl=https://artifacts.elastic.co/packages/oss-7.x/yum</code>

Not positive how fussy GitLab is about the *exact* version (it says 5.6 - 6.x here - https://docs.gitlab.com/12.5/ee/integration/elasticsearch.html#version-requirements), but unsurprisingly you can get Elasticsearch 6.x OSS packages with this 'baseurl' instead:
<code>baseurl=https://artifacts.elastic.co/packages/oss-6.x/yum</code>
sysadmin  devops  centos  centos6  centos7  elasticsearch  rpm  installation  howto  reference  solution 
december 2019 by kme
HowTos/NewerApps - CentOS Wiki
You might need to do something like

<code class="language-bash">
yum-config-manager --enable centos-sclo-sclo
yum-config-manager --enable centos-sclo-sclo-rh
</code>

…even *after* installing the 'centos-release-scl' package.
centos  epel  scl  sysadmin  packagemanagement  centos6  solution 
october 2019 by kme
MySQL Bugs: #59891: Cmake-gui's error | https://bugs.mysql.com/
Couldn't even get the SRPM package to build, because of this same error, which led me to believe it was a CMake problem, but it also failed with an update CMake.

So maybe you need an *old* CMake? Or an *older* version of MySQL (5.1.72?).
mysql  mysql5.1  centos6  bug  build  compiler  errormessage 
july 2019 by kme
lubridate 1.7 does not compile under RHEL 6.6 · Issue #608 · tidyverse/lubridate · GitHub | https://github.com/
I can install 1.6 from source without a problem, but 1.7 throws errors and won't compile. In file included from ./cctz/include/civil_time.h:18, from update.cpp:2: ./cctz/include/civil_time_detail.h:37: error: expected nested-name-specifi...
r  library  lubridate  tidyverse  centos6  compiler  errormessage  solution 
march 2019 by kme
macos - Using the pkg-config macro PKG_CHECK_MODULES failing - Stack Overflow | https://stackoverflow.com/
The solution in my case was to build and install automake-1.16 and pkg-config-0.29.something, which were newer than the OS-supplied versions.
devel  centos  centos6  pkg-config  build  toolchain  errormessage  sortof  solution 
february 2019 by kme
installation - ImportError: module 'setuptools.dist' has no 'check_specifier' attribute - Stack Overflow | https://stackoverflow.com/
It was due to older setuptools version. I updated setuptools as follows:
<code class="language-bash">sudo pip install setuptools --upgrade</code>

It installed setuptools-31.0.0 and that worked.
pip  python  centos6  errormessage  packaging  installation  solution 
november 2018 by kme
[CentOS-announce] Announcing release for MySQL 5.5 and 5.6 on CentOS Linux 6 x86_64 SCL | https://lists.centos.org/
Both the collections include no client library libmysqlclient.so and client applications are advised to use the client library available in mysql-libs package from base system.
mysql  mysql55  centos6  libmysqlclient  library  build  errormessage  annoyance  solution 
february 2018 by kme
linux - How do I set the default kernel parameters in CentOS for all existing and future kernels? - Server Fault - https://serverfault.com/
You can have it apply to all current and any future kernels by using ALL. grubby --update-kernel=ALL --remove-args="rhgb quiet" – benjarrell Jul 2 '13 at 18:04

You can also add '--args="vga=792"' to get a decent console resolution.
centos  centos6  grub  console  consolefont  framebufferconsole  configfile  solution 
october 2017 by kme
autocompletion - set completeopt=noinsert fails - Vi and Vim Stack Exchange | https://vi.stackexchange.com/
The noinsert option became available with Vim version 7.4.775. Your Vim on the raspberry pi is (probably) older. You can check with :version.
vim  autocomplete  errormessage  centos6  solution 
october 2017 by kme
node.js - npm can't find package.json - Stack Overflow
The error message I got was "npm WARN enoent ENOENT: no such file or directory, open '/usr/bin/package.json'" using the SCL 'rh-nodejs4' package. Using the '-g' (global) option worked.
I'll be brief but deadly. :) install -d will not work for you. It's simple. Try

$ npm install -g express
nodejs  npm  errormessage  centos  centos6  solution 
august 2017 by kme
gdb - Missing separate debuginfos, use: debuginfo-install glibc-2.12-1.47.el6_2.9.i686 libgcc-4.4.6-3.el6.i686 libstdc++-4.4.6-3.el6.i686 - Stack Overflow
debuginfo-install is a command of yum-utils, so

<code class="language-bash">yum install yum-utils
debuginfo-install glibc</code>

if the warning's still there, edit /etc/yum.repos.d/CentOS-Debuginfo.repo, set enabled=1
centos  centos6  debugging  errormessage  maybesolution 
august 2017 by kme
python - error: command 'gcc' failed with exit status 1 on CentOS - Stack Overflow
I bet you have to install libxml2-devel or libxml++-devel or even python-devel.


So this would've worked:
$ sudo yum -y install gcc gcc-c++ kernel-devel
$ sudo yum -y install python-devel libxslt-devel libffi-devel openssl-devel
$ pip install "your python packet"
python  xml  library  errormessage  missinglibraries  centos6  centos  solution 
may 2017 by kme
PHP :: Bug #48614 :: Loading "pdo_sqlite.so" fails: undefined symbol: sqlite3_libversion
I get this error message with the SCL version of PHP 5.4 on CentOS 6:
$ boris
PHP Warning: PHP Startup: Unable to load dynamic library '/opt/rh/php54/root/usr/lib64/php/modules/pdo_sqlite.so' - /opt/rh/php54/root/usr/lib64/php/modules/pdo_sqlite.so: undefined symbol: sqlite3_column_table_name in Unknown on line 0


Just commenting out the "extension=pdo_sqlite.so" in /opt/rh/php54/root/etc/php.d/pdo_sqlite.ini at least gets rid of the error message.
php  php54  centos  centos6  bug  errormessage  sortof  solution 
may 2017 by kme
Doctrine PEAR channel
This channel is to be used with the PEAR installer.
Registering the channel:

pear channel-discover pear.doctrine-project.org

Listing available packages:

pear remote-list -c doctrine

Installing a package:

pear install doctrine/package_name
centos  centos6  php54  pear  php  packagemanagement  solution 
may 2017 by kme
apache 2.2 - Nginx doesn't start after installation - Server Fault
my vps is ipv4 not ipv6 so i changed [::]:80 to 80 in ngnix config file and its working fine :)
nginx  centos6  ipv6  webmaster  errormessage  solution 
may 2017 by kme
Cannot download Docker images behind a proxy - Stack Overflow
As mentioned in one of the other posts, the 'export' is required in /etc/sysconfig/docker.

On centos the configuration file for docker is at:

/etc/sysconfig/docker

Adding below line helped me to get docker daemon working behind proxy server:

HTTP_PROXY="http://<proxy_host>:<proxy_port>"
HTTPS_PROXY="http://<proxy_host>:<proxy_port>"
centos  centos6  docker  sysadmin  solution 
may 2017 by kme
Shiny Server on CentOS | R-bloggers
<code class="language-bash">sudo su – -c “R -e \”install.packages(‘ggplot2′, repos=’http://cran.rstudio.com/’)\””</code>
r  packagemanagement  rshiny  centos6  centos  solution 
may 2017 by kme
Unable to use yum getting: 14: PYCURL ERROR 7 - "Failed to connect to 2a02:2498:1:3d:5054:ff:fed3:e9 - Page 2 - CentOS
In my case, it was because I was using 'sudo' to run 'yum update' instead of running it in a root shell, with HTTP_PROXY and friends set in the environment (presumably by .bashrc).
I had the exactly same problem. I was too much focus on disabling ipv6. But it turned out the message itself has nothing to do with ipv6. In my case, it was
missing proxy setting in the /etc/yum.conf. As soon as I added "proxy=http://<ipv4addr>:3128" to yum.conf, everything started working.
yum  proxy  ipv6  errormessage  centos  centos6  solution 
march 2017 by kme
linux - How to install g++ 4.9.2 in Cent OS 6.5? - Super User
CentOS 6/7 official support this. You don't need third party repository. And gcc version is 4.9.2 in CentOS's repo.

yum install centos-release-scl-rh
yum install devtoolset-3-gcc devtoolset-3-gcc-c++

To use the updated tools, start a new shell using the scl command:

scl enable devtoolset-3 bash

More information on the SCL from CentOS and from Red Hat
gcc  cplusplus  compiler  toolchain  c++14  centos  centos6  solution 
february 2017 by kme
How to install the latest version of Python on CentOS - Daniel Eriksson
This was kind of important:
yum install -y zlib-devel bzip2-devel openssl-devel ncurses-devel sqlite-devel readline-devel tk-devel gdbm-devel db4-devel libpcap-devel xz-devel expat-devel


And then:
./configure --prefix=/usr/local --enable-unicode=ucs4 --enable-shared LDFLAGS="-Wl,-rpath /usr/local/lib"
make && make altinstall
python  centos  centos6  fromsource  installation  solution  python27 
february 2017 by kme
Compiling on CentOS 6 (old compiler warning) · Issue #3678 · nodejs/node · GitHub
Installing the newer GCC (from SL's devtoolkit-2) didn't help; still old include paths in the output / error messages.
mpi  hpc  centos6  centos  errormessage  maybesolution 
december 2016 by kme
devtoolset @ CERN
You need to 'source /opt/rh/devtoolset-2/enable' and then you'll have GCC 4.8.something in your PATH.

GPG key can be found here: http://ftp.scientificlinux.org/linux/scientific/51/i386/RPM-GPG-KEYs/RPM-GPG-KEY-cern
gcc  compiler  c++11  centos6  centos  solution 
december 2016 by kme
yum - How to Install gcc 4.7.x/4.8.x on CentOS - Super User

There is new version of devtoolset 2.0. Nice people from Cern working on Scientific Linux created an open version:

https://linux.web.cern.ch/linux/devtoolset/

Get the GPG key with 'rpm --import http://ftp.scientificlinux.org/linux/scientific/51/i386/RPM-GPG-KEYs/RPM-GPG-KEY-cern'
gcc  compiler  toolchain  centos  centos6  solution 
december 2016 by kme
How To Set Up Python 2.7.6 and 3.3.3 on CentOS 6.4 | DigitalOcean [https://www.digitalocean.com/]
yum groupinstall -y development
yum install -y zlib-dev openssl-devel sqlite-devel bzip2-devel
centos  centos6  python  build  compilation  fromsource  howto  sysadmin  solution 
november 2016 by kme
Uploading big files > 512MB (as set by default) — ownCloud Administrators Manual 7.0 documentation
This worked, but I had to put these lines *outside* any <Directory> stanza in /etc/httpd/conf.d/owncloud.conf
php_value upload_max_filesize 16G
php_value post_max_size 16G
owncloud  webmaster  centos  centos6  solution 
may 2015 by kme
Chapter 10. Network Interfaces
The /etc/sysconfig/networking/ directory is used by the now deprecated Network Administration Tool (system-config-network). Its contents should not be edited manually. Using only one method for network configuration is strongly encouraged, due to the risk of configuration deletion. For more information about configuring network interfaces using graphical configuration tools, refer to Chapter 9, NetworkManager.
networking  centos  centos6  deprecation  configfile  sysadmin 
may 2015 by kme
linux - Attempting to install tmux on CentOS 6.4 or CentOS 6.5 fails with error: ‘EVBUFFER_EOL_LF’ undeclared - Super User
Solution: install a newer libevent.

You may also run into the problem of
tty.o: In function `tty_cmd_setselection':
tty.c:(.text+0x537): undefined reference to `__b64_ntop'
, which is solved by adding "-lresolve" to the LIBS in the Makefile (courtesy: http://permalink.gmane.org/gmane.comp.terminal-emulators.tmux.user/1696)
errormessage  tmux  centos  centos6  build  devel  solution 
october 2014 by kme

Copy this bookmark:





to read