recentpopularlog in

kme : centos7   36

[SOLVED] Set console font in minimal install - CentOS
Was:
With CentOS 6 I could specify the console font in /etc/sysconfig/i18n with SYSFONT="foo"


Now:
It is now /etc/vconsole.conf
centos  centos6  centos7  consolefont  console  font  solution 
17 days ago by kme
Activating a volume group
CentOS 7 seems to make an LVM group by default, and that's fine. When mounting it in a recovery environment, you need to do this in order to access the data on disk:

<code class="language-bash"># vgchange -a y my_volume_group</code>
centos  centos7  linux  sysadmin  storage  lvm  solution 
22 days ago by kme
Install Elasticsearch with RPM | Elasticsearch Reference [7.5] | Elastic
An alternative package which contains only features that are available under the Apache 2.0 license is also available. To install it, use the following baseurl in your elasticsearch.repo file:
<code>baseurl=https://artifacts.elastic.co/packages/oss-7.x/yum</code>

Not positive how fussy GitLab is about the *exact* version (it says 5.6 - 6.x here - https://docs.gitlab.com/12.5/ee/integration/elasticsearch.html#version-requirements), but unsurprisingly you can get Elasticsearch 6.x OSS packages with this 'baseurl' instead:
<code>baseurl=https://artifacts.elastic.co/packages/oss-6.x/yum</code>
sysadmin  devops  centos  centos6  centos7  elasticsearch  rpm  installation  howto  reference  solution 
9 weeks ago by kme
Compiling error · Issue #599 · eclipse/mosquitto
You have to install following packages: xsltproc docbook-xsl
Then it will work.

Just 'docbook-xsl' is enough on CentOS, I think. There is no 'xsltproc' package. Also, moreutils' Makefile points to the wrong place for the DocBook stylesheets, so you need to
<code class="language-bash">DOCBOOKXSL='/usr/share/sgml/docbook/xsl-stylesheets' make</code>
errormessage  docbook  xsl  xml  xsltproc  centos  centos7  solution 
12 weeks ago by kme
httpd24-mod_ldap-2.4.34-7.el6.1.x86_64.rpm CentOS 6 Download | https://centos.pkgs.org/
Install Howto
<code class="language-bash">
# Install CentOS SCLo RH repository:
yum install centos-release-scl-rh

# Install httpd24-mod_ldap rpm package:
yum install httpd24-mod_ldap
</code>
webmaster  apache  apache24  ldap  module  centos  centos7  scl  packagemanagement  annoyance  solution 
november 2019 by kme
How do I increase console-mode resolution? - Ask Ubuntu
No amount of 'GRUB_GFXMODE' or 'GRUB_GFXPAYLOAD' seemd to do me any good, but this old trick worked
This helped me on Ubuntu 14.04 with ESXi 5.5
<code class="language-bash">sudo vi /etc/default/grub</code>
Change line to:
<code>GRUB_CMDLINE_LINUX_DEFAULT="splash vga=792"</code>
centos  centos7  grub  hiresconsole  console  vga  font  solution 
september 2019 by kme
arch linux - Setting console font in vconsole.conf does not work (systemd) - Unix & Linux Stack Exchange
Also mentioned in that email thread: try the (boring) lat0-{08,10,12,14,16} fonts before giving up entirely. At least on CentOS (7), the Terminus console fonts don't seem to work at all.
centos7  consolefont  hiresconsole  annoyance  maybesolution 
september 2019 by kme
Issue 31652: make install fails: no module _ctypes - Python tracker
Had to build and install libffi into the PREFIX for Python-3.7.4 when building it from source on CentOS 7.

See also: https://bugs.python.org/issue34036
centos  centos7  fromsource  build  toolchain  compiler  errormessage  python  workaround  solution 
august 2019 by kme
Autoconf, Libtool, and an undefined AC_PROG_LIBTOOL - Super User
This fixed this for me—modifying the supplied 'autogen.sh', so that it ran this command instead:
<code class="language-bash">autoreconf -v -f -i -I /usr/share/aclocal</code>
To fix this if you already have a /usr/local/share/aclocal directory, type the following as root:
<code class="language-bash">for file in argz libtool ltdl ltoptions ltsugar ltversion lt~obsolete
do
ln -s /usr/share/aclocal/$file.m4 /usr/local/share/aclocal/$file.m4
done
</code>

To fix this if you don't have a /usr/local/share/aclocal directory, type the following as root:
<code class="language-bash">ln -s /usr/share/aclocal /usr/local/share/aclocal</code>

Voilà -- problem solved.
autoconf  errormessage  build  toolchain  centos7  annoyance  solution 
august 2019 by kme
docker - Setting the hostname for a container running in Kubernetes - Stack Overflow
Yeah, no, with a CentOS 7 docker image, after it's already running, it doesn't look like you can change the hostname, because you get the "hostname: you must be root to change the host name" even when you're (obviously) running as root.
centos  centos7  docker  sysadmin  hostname  almostsolution 
june 2019 by kme
systemctl failed to get Dbus connection: No connection to service manager
It seems like a hot ticket, but this doesn't work if 'systemctl' depends on D-Bus being running. It's a total chicken-and-egg problem then. This is the case in the official Docker image for CentOS 7.

<code class="language-bash">sudo systemctl start dbus.service</code>
centos7  centos  docker  systemctl  systemd  dbus  annoyance 
june 2019 by kme
yum - How to add language support on CentOS 7 (on Docker)? - Server Fault
If they'd just stop saying 'localectl' is the solution, when it doesn't work in Docker. There's no DBus daemon running or something. The 'systemctl' command doesn't work, even. These things are stripped out in container environments, I guess.

What *actually* works is
<code class="language-bash">yum reinstall -y glibc-common</code>
and then setting 'LC_ALL` or 'LANG` in the environment.
centos  centos7  locale  docker  language  characterencoding  maybesolution 
june 2019 by kme
Bug 1589668 – error: Ignoring osad because of bad file mode - must be 0644 or 0444. | https://bugzilla.redhat.com/
change filemode from /etc/logrotate.d/osad to 0644 or 0444

Followed by:
<code class="language-bash">logrotate -f /etc/logrotate.conf</code>
sysadmin  errormessage  logrotated  centos  centos7  solution 
august 2018 by kme
Warning: preg_match(): Compilation failed: this version of PCRE is compiled without UTF support - DirectAdmin - Peter Sangkhamanon | https://mzpeter.co.uk/
On CentOS, you'll also need 'pcre-tools' to get the 'pcretest' utility.
same as Warning: preg_replace() [function.preg-replace]: Compilation failed: this version of PCRE is not compiled with PCRE_UTF8 support at offset 0 in.
errormessage  php  annoyance  centos  centos7  php56  maybesolution 
may 2018 by kme
How to resolve yum errors during update - CentOS - Server Fault | https://serverfault.com/
What worked for me

<code class="language-bash">
yum clean all # maybe didn't do anything, I dunno
yum distro-sync full # didn't work without the 'full'
yum update # no updates found after 'distro-sync'
</code>


See also: https://www.centos.org/forums/viewtopic.php?t=52898
<code class="language-bash">
package-cleanup --dupes
</code>
sysadmin  rpm  packagemanagement  yum  errormessage  dllhell  centos  centos7  solution 
january 2018 by kme
How to Install MariaDB on CentOS 7 | https://linode.com/
If you try to install 'mysql-server' you'll get this error:
Transaction check error:
file /usr/lib64/mysql/plugin/dialog.so from install of mariadb-galera-server-1:5.5.37-2.el7.x86_64 conflicts with file from package mariadb-libs
-1:5.5.56-2.el7.x86_64
file /usr/lib64/mysql/plugin/mysql_clear_password.so from install of mariadb-galera-server-1:5.5.37-2.el7.x86_64 conflicts with file from packag
e mariadb-libs-1:5.5.56-2.el7.x86_64

The solution is to just install 'mariadb-server' right off the bat.
mysql  mariadb  dba  installation  howto  centos  centos7  sysadmin  errormessage  solution 
january 2018 by kme
VirtualBox Guest Additions on Fedora 26/25, CentOS/RHEL 7.3/6.9/5.11 - If Not True Then False
<code class="language-bash">yum update kernel*
rpm -Uvh https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
yum install gcc kernel-devel kernel-headers dkms make bzip2 perl
export KERN_DIR=/usr/src/kernels/`uname -r`</code>
virtualbox  centos  centos7  fedora  fedora30  guestadditions  dammitbrain  annoyance  solution 
august 2017 by kme

Copy this bookmark:





to read