recentpopularlog in

kme : debian   118

« earlier  
#927669 - nvpy: could not connect to simplenote server - Debian Bug report logs | https://bugs.debian.org/
This is the standard 'nvpy' package in Ubuntu 18.04. The reason is because 1.0.0 uses the retired Simplenote API. RIP.

Solution is to install it with pip3.
nvpy  debian  ubuntu  simplenote  bug  workaround 
4 weeks ago by kme
Wine - Debian Wiki | https://wiki.debian.org/
wine 1.6.2-20 packages in Debian Jessie - To use the wine-wrapper scripts such as winecfg, wineboot or regedit you have to set them as an option to the command "wine". See Debian bug #784280. wine-development and later wine versions are are not affected. E.g. typing only "winecfg" will cause an error if no wineprefix exists yet, while "wine winecfg" works as expected.
wine  debian  winecfg  configuration  controlpanel  solution 
july 2019 by kme
package management - Restoring all data and dependencies from dpkg --set-selections '*' - Ask Ubuntu
Preferred to 'dpkg --get-selections', apparently, which WTF does 'dpkg --get-selections' even do then, anyway?
<code class="language-bash">
# Backup:
apt-mark showauto > pkgs_auto.lst
apt-mark showmanual > pkgs_manual.lst

# Restore:
sudo apt-mark auto $(cat pkgs_auto.lst)
sudo apt-mark manual $(cat pkgs_manual.lst)
</code>
dpkg  apt  debian  ubuntu  packagemanagement  backupandrecovery  solution 
may 2019 by kme
add a docker configuration file · Issue #937 · moby/moby | https://github.com/
Answer: there apparently is no '/etc/docker/docker.conf'; on Debian-derived distros, there's an /etc/default/docker, where you can set the DOCKER_OPTS environment variable for the daemon, though.
docker  ubuntu  debian  centos  configfile  configuration  reference 
january 2019 by kme
Comment #33 : Bug #959037 : Bugs : network-manager package : Ubuntu | https://bugs.launchpad.net/
I think that there is a clash of civilizations here: the Debian way (modular components that just work together in any combination allowed by package dependencies) versus the RedHat way (big daemons with limited options that own subsystems).
networkmanager  dnsmasq  networking  debian  ubuntu 
january 2019 by kme
[SOLVED] apt-get upgrade keeps some packages back | https://www.linuxquestions.org/
Instead of running: sudo apt-get upgrade you should run: sudo apt-get dist-upgrade. This will install any new packages that are in the updates.
From a lot of testing that I have done, using the GUI update-manager in Ubuntu is the same as doing:
<code class="language-bash">
sudo apt-get update
sudo apt-get dist-upgrade
</code>

Both update-manager and dist-upgrade will remove old packages and install new ones that are in the updates. Just running sudo apt-get upgrade will only install new versions of packages that you already have on your system.
Write back if you need more help.
apt  apt-get  errormessage  packagemanagement  debian  ubuntu  sysadmin  annoyance  solution 
january 2019 by kme
python - pip: no module named _internal - Stack Overflow | https://stackoverflow.com/
What worked for me was:
<code class="language-bash">
sudo apt-get remove python-pip
</code>
python  pip  python27  debian  ubuntu  elementaryos  errormessage  solution 
december 2018 by kme
debian - How to use the command update-alternatives --config java - Stack Overflow | https://stackoverflow.com/
For this specific purpose, the package java-common contains a tool called update-java-alternatives.

In my case, 'sudo apt-get install --reinstall java-common' still didn't fix this after (sort of accidentally) installing then de-installing 'openjdk-9-jre' or 'jdk' left /etc/alternatives/java all fubar.

Then 'update-alternatives' was complaining about the symlink being dangling; so I did an 'ln -sf' to fix it, then I got this:
<code class=""># sudo update-alternatives --config java
There is only one alternative in link group java (providing
/usr/bin/java): /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java Nothing
to configure. update-alternatives: warning: forcing reinstallation of
alternative /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java because link
group java is broken</code>
after which it was pretty much working.
java  jre  jdk  debian  alternatives  sysadmin  errormessage  solution 
january 2018 by kme
Java Installation on Debian using Apt-Get | DigitalOcean | https://www.digitalocean.com/
There can be multiple Java installations on one server. You can configure which version is the default for use in the command line by using update-alternatives, which manages which symbolic links are used for different commands.
There can be multiple Java installations on one server. You can configure which version is the default for use in the command line by using update-alternatives, which manages which symbolic links are used for different commands.
<code class="language-bash">
sudo update-alternatives --config java
</code>
debian  java  jdk  alternatives  solution 
january 2018 by kme
6.12. pam_issue - add issue file to user prompt
Yeah, but in elementaryOS Luna, the pam.d/login thing mentioned in the README.Debian doesn't work. You have to edit /etc/init/ttyX.conf, and add '-f /etc/issue.linuxlogo' to each "getty" invocation.
debian  ubuntu  elementaryos  elementary  console  eyecandy  configfile  workaround  maybe  solution 
december 2017 by kme
installation - How to install libraries? - Ask Ubuntu
Ran into this problem:

checking for DBUS... no
configure: error: Package requirements (dbus-1 >= 1.6) were not met:

No package 'dbus-1' found


trying to install autokey-py3 from pip.

Solution was install 'libdbus-1-dev' Debian package.

Presumably this is an error from a configure script?

The error is referring to pkg-config package files. These do not correspond one-to-one with Ubuntu/Debian package names (since they are not Debian or Ubuntu specific).

In this particular case, the dbus-1.pc file is found in the libdbus-1-dev Ubuntu package, and dbus-glib-1.pc is found in the libdbus-glib-1-dev Ubuntu package. Installing those two should satisfy the dependencies of that configure script check.
dbus  dependencyhell  debian  package  autokey  solution 
november 2017 by kme
unp installation and configuration in debian | http://www.debianhelp.co.uk/
You can download the script itself from https://packages.debian.org/stretch/unp; with slight modifications (about two minutes of work), you can adapt the "install" target in 'debian/rules' into a usable Makefile.

See also https://martin.ankerl.com/2006/08/11/program-e-extract-any-archive/, written in Ruby. Does not have built-in help, though.
unp  unpacker  debian  archive  commandline  utility  essential  movein  solution  reference 
october 2017 by kme
Debian Policy Manual v4.1.1.1 - https://www.debian.org/
5.6.12 Version

The version number of a package. The format is: [epoch:]upstream_version[-debian_revision].

The three components here are:

epoch
This is a single (generally small) unsigned integer. It may be omitted, in which case zero is assumed. If it is omitted then the upstream_version may not contain any colons.

It is provided to allow mistakes in the version numbers of older versions of a package, and also a package’s previous version numbering schemes, to be left behind.
debian  dpkg  packaging  packagemanagement  versioning  version  specification  reference  solution 
october 2017 by kme
Re: dpkg - the letter prefixes.. what do they mean - https://lists.debian.org/
I've wondered for years about this.
On Fri, 2002-03-01 at 08:40, Harry Putnam wrote:
> dpkg -l '*desk*' shows a series of hits, all are preceded by
> `un'
>
> dpkg -l 'gnome*' shows a number of things some are proceeded by
> ii and some by un.
>
> Where does on look to find out what these letters mean. I went thru
> man dpkg several times looking for some referrence. A grep with `ii'
> gets no hits. dpkg --help doesn't appear to make any mention.

dpkg -l | head

The first 3 lines of the dpkg output list what the letters mean.
debian  dpkg  packagemanagement  sysadmin  newbie  solution 
october 2017 by kme
networking - How do I use /etc/network/interfaces instead of network-manager - Ask Ubuntu
This seems to also be the case with elementaryOS if you add a bridged adapter that uses the default (eth0 or eno1 or whatever) adapter.

23
down vote
accepted


If you manually manage your network card in /etc/network/interfaces , network manger will not manage it , it will state "Not Managed"
elementaryos  linux  debian  networking  networkmanager  bridgedethernet  bridge  solution 
october 2017 by kme
Apache: Enable PHP in UserDir - Code Diary
The next step is enable the execution of PHP scripts inside public_html. To do that, as root, open the file /etc/apache2/mods-enabled/php5.conf and find the following lines:

<IfModule mod_userdir.c>
<Directory /home/*/public_html>
php_admin_value engine Off
</Directory>
</IfModule>

On CentOS 6, doing this but specifying 'php_admin_value engine on' actually made the problem worse. Whatever problem I thought I had wasn't this.
apache  configfile  webmaster  debian  sortof  solution 
july 2017 by kme
apt - node: command not found - Ask Ubuntu
Like @minerz029 already said there is a conflict with the node package. But if you still need the node command (because a script uses only nodefor example), the correct way is to install the nodejs-legacy package:

apt-get install nodejs-legacy

and not create a symlink on your own (especially not in /usr/bin/). This will provide a node command for nodejs.
nodejs  node  debian  bower  errormessage  solution 
february 2017 by kme
debian - automate dpkg-reconfigure tzdata - Server Fault
On newer Debian (Ubuntu >= Xenial), you must 'ln -fs /usr/share/zoneinfo/Europe/Berlin /etc/localtime' before running 'dpkg-reconfigure'.

e.g. for me to change to "Europe/Dublin" where I am:

# echo "Europe/Dublin" > /etc/timezone
# dpkg-reconfigure -f noninteractive tzdata

Obviously this allows you to use puppet/cfengine as you like to distribute /etc/timezone also.
debian  timezone  ansible  provisioning  solution 
january 2017 by kme
How to disable secure-file-priv MySQL Ubuntu - Super User
The mysql documentation on secure_file_priv states that the variable is set to a default, platform-specific filesystem location, to make it secure by default.

That said, you need to explicitly set the variable to an empty string in your configuration to disable this security feature.

For Ubuntu, edit the file /etc/mysql/mysql.conf.d/mysqld.cnf and add the following line at the end:
<code>secure_file_priv=""</code>
mysql  dba  database  ubuntu  debian  linux  errormessage  annoyance  configfile  solution 
january 2017 by kme
debian - Disable a service from starting at all runlevels? - Server Fault
The `update-rc.d` utility is only available if you're logged in as root (it's not in normal users' PATH).
debian  sysadmin  rc  runlevels  services  annoyance  dammitbrain  solution 
december 2016 by kme
httpd.conf - Apache Proxy: No protocol handler was valid - Stack Overflow
In my case, it was 'proxy_balancer' that needed to be enabled with 'a2enmod'.
This can happen if you don't have mod_proxy_http enabled

sudo a2enmod proxy_http

For me to get my https based load balancer working, i had to enable the following:

sudo a2enmod ssl
sudo a2enmod proxy
sudo a2enmod proxy_balancer
sudo a2enmod proxy_http
apache  webmaster  debian  errormessage  solution 
november 2016 by kme
upstart - Why the services do not start at installation? - Ask Ubuntu
invoke-rc.d: policy-rc.d denied execution of start.

I actually did this to myself, by following the directions here:

https://serverfault.com/questions/681588/prevent-apache-from-starting-after-apt-get-install

In the provisioning scripts I made for the VM at MLU, I had to prevent 'slurmdbd' from starting automatically because it would fail to run after initial install (probably could've solved this by creating the config files *first*, then installing the packages).

Also, it seems like the Debian packagers may have made a mistake, because it looks like 'munged' doesn't get started automatically after installation. So one of these two issues—or a combination—led to some head-scratching when I used the same provisioning scripts for another project (see bioreactor-vm#5).
debian  policy  errormessage  services  sysadmin  maybesolution  upstart  init  systemd 
october 2016 by kme
Install MySQL with ansible on ubuntu - Stack Overflow
See also: https://stackoverflow.com/questions/28568911/mysql-db-creation-in-ansible
- name: update mysql root password for all root accounts
sudo: yes
mysql_user:
name: root
host: "{{ item }}"
password: "{{ mysql_root_password }}"
login_user: root
login_password: "{{ mysql_root_password }}"
check_implicit_admin: yes
priv: "*.*:ALL,GRANT"
with_items:
- "{{ ansible_hostname }}"
- 127.0.0.1
- ::1
- localhost
mysql  automation  ansible  debian  solution 
july 2016 by kme
ubuntu 12.04 - Prevent Apache from starting after apt-get install - Server Fault
Try this:

Create a file /usr/sbin/policy-rc.d with following content:

#!/bin/sh
exit 101

Make it executable:

chmod +x /usr/sbin/policy-rc.d

After this, all packages will be installed but the services will not start.

Once you are done, you can remove the file:

rm -f /usr/sbin/policy-rc.d


See also: https://people.debian.org/~hmh/invokerc.d-policyrc.d-specification.txt
debian  services  automation  sysadmin  apt-get  provisioning  ansible  solution 
july 2016 by kme
linux - How do I enable non-free packages on Debian? - Server Fault


Open up /etc/apt/sources.list, and you should see lines like the following (URLs will likely vary):

deb http://http.us.debian.org/debian stable main contrib

Simply add non-free to the respective URLs you wish to use, i.e.:

deb http://http.us.debian.org/debian stable main contrib non-free

Running apt-get update will update your local repo with the package listing.



You can also restrict this a little bit if you only want some very specific packages from non-free (firmwares for your hardware for example).

To do so, keep your /etc/apt/sources.list as described by @Andrew M. Then, use Apt Pinning to disable by default all non-free packages for your current release:

Create a file named /etc/apt/preferences.d/non-free_policy containing the following directives:

Explanation: Disable packages from non-free tree by default
Package: *
Pin: release o=Debian,a=stable,l=Debian,c=non-free
Pin-Priority: -1

Now, create another file for the specific package you want to get from non-free.
Let's assume you want to add the Intel drivers for wireless cards for instance (package firmware-iwlwifi).
Create a file name /etc/apt/preferences.d/firmware-iwlwifi_nonfree with these lines:

Explanation: Enable package firmware-iwlwifi from non-free tree
Package: firmware-iwlwifi
Pin: release o=Debian,a=stable,l=Debian,c=non-free
Pin-Priority: 600

This configuration avoids bloating your package with these annoying non-free packages ;)
apt  apt-get  packagemanagement  debian  non-free  apt-pinning  solution 
july 2016 by kme
Re: a2ps margins
This problem has been plaguing me for, like, 20 years.
debian  libpaper  a2ps  papersize  i11n  maybesolution  annoyance 
july 2016 by kme
grub2 - How to preseed installing grub to a device during installation without prompt? - Ask Ubuntu [http://askubuntu.com/]
Higher up in your preseed file, this line should appear:

d-i debconf/priority string critical
This should ensure that only 'critical' questions are asked

This line alone seems sufficient to provide enough info for the bootloader to be put on /dev/sda;

alter to suit your needs

d-i grub-installer/bootdev string /dev/sda
As for your other question, the line <-- 0 ok is merely a return value (success); you can ignore it.

Hope this helps.
debian  automation  preseed  debian-installer  maybesolution 
july 2016 by kme
Debian -- Debian Releases
Debian 8 ("jessie") — current stable release
Debian 7 ("wheezy") — obsolete stable release
Debian 6.0 ("squeeze") — obsolete stable release
debian  linux  distro  versioning  releases  dammitbrain 
july 2016 by kme
zsh - tmux exits abruptly right after loading - Unix & Linux Stack Exchange
My group wasn't being resolved by LDAP (showed as 'nogroup')--maybe that had something to do with it?
tmux  debugging  debian  maybesolution 
july 2016 by kme
tmux exits immediately after starting - Unix & Linux Stack Exchange
This little tidbit

If screen does not work as well, make sure you have read-write access to /dev/ptmx. If not, no new pty can be spawned and especially tmux terminates without an error message.


that eventually turned up http://lxr.free-electrons.com/source/Documentation/filesystems/devpts.txt, which recommends:
As an option instead of placing a /dev/ptmx device node at /dev/ptmx it is possible to place a symlink to /dev/pts/ptmx at /dev/ptmx or to bind mount /dev/ptx/ptmx to /dev/ptmx. If you opt for using the devpts filesystem in this manner devpts should be mounted with the ptmxmode=0666, or chmod 0666 /dev/pts/ptmx should be called.


and it seems that was the eventual solution.

This bug report could also be related, as the host where I experienced this problem had a bunch of 'lxcfs' entries in the mounts list: https://bugs.launchpad.net/ubuntu/+source/lxc/+bug/1242913
tmux  screen  annoyance  ptmx  devpts  debian  jessie  solution 
july 2016 by kme
How can I install GNU Parallel alongside Moreutils on Ubuntu/Debian? - Super User
Debian 7.11: 'apt-get install parallel' just works
Debian 8.5: doesn't work anymore
debian  gnuparallel  packagemangement  apt  annoyance  maybesolution 
july 2016 by kme
apt - Trouble downloading packages list due to a "Hash sum mismatch" error - Ask Ubuntu

Just remove all the content of /var/lib/apt/lists directory:

sudo rm -rf /var/lib/apt/lists/*

then run:

sudo apt-get update
apt  debian  ubuntu  apt-get  errormessage  troubleshooting  solution 
june 2016 by kme
APT Hash sum mismatch
Users can force apt not to use lzma compressed metadata in two ways.

The first way is by adding an extra command line flag when running apt-get commands:

$ apt-get update -o Acquire::CompressionTypes::Order::=gz

(Note: You can also specify “bz2” if you prefer bzipped archives instead.)

Alternatively, you can specify this option globally in an apt config so you don’t need to type that each time.

In order to do this:

Create a new file called /etc/apt/apt.conf.d/99compression-workaround
Add the text Acquire::CompressionTypes::Order:: "gz";' to the file

Now, apt-get update will attempt to use gzip compressed metadata first.
debian  apt  apt-get  bug  errormessage  maybesolution 
june 2016 by kme
ubuntu - How do you fix apt-get update "Hash Sum mismatch" - Unix & Linux Stack Exchange
See also: http://blog.packagecloud.io/eng/2016/03/21/apt-hash-sum-mismatch/

Possible solution in some cases (didn't work for me):

Things I've tried to work around this error.

Used 3 different ubuntu 12.04 boxes from 'http://www.vagrantbox.es'

solution suggested here:

sudo rm -rf /var/lib/apt/lists/*
sudo apt-get update
sudo apt-get clean

Removed and readded the puppet labs packages
Some apt repositories use LZMA (.xz) compressed metadata. apt before version 1.0 fails to decompressed LZMA archives correctly (sometimes) giving the hash sum mismatch error.

There's two work arounds for this:

Tell your apt client not to use XZ compressed metadata
Upgrade apt on your system to a version newer than 1.0

Check out this blog post I wrote about this issue which explains both work arounds in greater detail.
debian  apt  apt-get  errormessage  maybesolution 
june 2016 by kme
Debian Policy Manual - Control files and their fields
5.6.12 Version

The version number of a package. The format is: [epoch:]upstream_version[-debian_revision]


The "Revision:" in the controlfile seems to be ignored now; even Vim didn't syntax highlight it.

I tried putting it a version number like '1.2.3-mine1' in 'debian/changelog' and that worked. You get this warning[1], but it seems harmless. You can't use something like '+mine1' because that's considered part of the "upstream" release number, and so the tarball needs to have the same name.

[1] https://lintian.debian.org/tags/source-nmu-has-incorrect-version-number.html
debian  apt  packaging  packagemanagement  spec  guide  solution 
june 2016 by kme
Lintian Tag: source-nmu-has-incorrect-version-number
It's just a warning. It's what happens when you use something '2.2-mine1' in 'debian/changelog'.
debian  packaging  errormessage  solution 
june 2016 by kme
HowToPackageForDebian - Debian Wiki
For a Debian packaging tutorial:

- https://wiki.debian.org/BuildingAPackage

- also https://wiki.debian.org/Packaging/Intro

Prereqs:

sudo apt-get install build-essential dpatch fakeroot devscripts equivs lintian quilt
debian  packaging  packagemanagement  overview  reference 
june 2016 by kme
Packaging/Intro - Debian Wiki
See also: https://wiki.debian.org/BuildingAPackage

* Prerequisite packages:

$ sudo apt-get install build-essential dpatch fakeroot devscripts equivs lintian quilt

* Rename source package: mv hithere-1.0.tar.gz hithere_1.0.orig.tar.gz

* possibly just copy the 'debian' directory from the latest version available in the repositories; if not:

$ dch --create -v 1.0-1 --package hithere

* update 'debian/docs' if anything has changed in the source tarball (for example, tmux-2.2 removed the 'NOTES' file)

* within the unpacked source:

$ debuild -us -uc
debian  packaging  howto  packagemanagement  build  fromsource  toolchain  solution 
june 2016 by kme
BuildingAPackage - Debian Wiki
See also: https://wiki.debian.org/Packaging/Intro
sudo apt-get install build-essential dpatch fakeroot devscripts equivs lintian quilt
debian  packaging  gettingstarted  build  toolchain  packagemanagement  newbie  howto  solution 
june 2016 by kme
How to install new tmux 1.8 on Ubuntu 12.10 or 12.04? - Ask Ubuntu

12.04 AND UP:

sudo add-apt-repository ppa:pi-rho/dev
sudo apt-get update
sudo apt-get install tmux

OLD ANSWER:

As you possibly already realized, tmux version 1.8 is too new. As of writing this answer, version 1.8 is only 19 hours old.

There is indeed an official PPA for tmux, but don't expect new version to appear there instantly. It might take hours, days, and even weeks, and it's totally up to PPA maintainer.

If you for some reason need a newest version, then you might download the code and build/install tmux by yourself. Should not be a big deal, since tmux has dependencies only on libevent and ncurses packages, and both of these packages are present on most if not all of Linux distros. Just download the latest code, and type following via terminal:

$ sudo apt-get install libevent-dev libncurses-dev pkg-config
$ autoreconf -fis
$ ./configure
$ make
$ sudo make install
tmux  debian  ubuntu  build  fromsource  packaging  packagemanagement 
june 2016 by kme
Index of /cdimage
Damn, this is hard to find.
debian  linux  distro  iso  download  annoyance 
june 2016 by kme
python - PIP install unable to find ffi.h even though it recognizes libffi - Stack Overflow
While trying to install 'ansible' with 'pip', the python-dev and 'libffi-dev' packages were also required.
You need to install the development package as well.

libffi-dev on Debian/Ubuntu, libffi-devel on Redhat/Centos/Fedora.
python  pip  debian  ansible  solution  errormessage 
june 2016 by kme
14.04 - When will PHP 5.6 be in the official Canonical repos? - Ask Ubuntu

As an option I would strongly recommend to use ppa:ondrej/php that includes co-installable PHP 5.6 and PHP 7.0 versions:

sudo add-apt-repository ppa:ondrej/php
sudo apt-get update
# pull a default PHP FPM (currently PHP 7.0)
sudo apt-get install php php-fpm
# pull PHP 7.0 Apache2 mod_php7 explicitly
sudo apt-get install php7.0 libapache2-mod-php7.0
# pull PHP 5.6 - just CGI SAPI
sudo apt-get install php5.6-cgi
php  php56  debian  ubuntu  14.04  webdevel  solution 
june 2016 by kme
Locales unter Ubuntu konfigurieren – Thomas-Krenn-Wiki
This fixes the problem (with PuTTY, anyway) of Unicode linedraw characters just *refusing* to draw, regardless of font, TERM, or NCURSES_NO_UTF8_ACS=1 being set in the environment.
# update-locale LANG=de_DE.UTF-8
putty  ubuntu  debian  locale  linedrawcharacters  unicode  solution 
february 2016 by kme
php - install php5 with readline support on debian wheezy - Unix & Linux Stack Exchange
Couldn't find php5-readline on this system, and didn't want to mess with adding "unofficial" software sources. Facebook's 'phpsh' seems to work okay without any extra dependencies; just remeber to set PYTHONPATH to wherever the libraries ended up, otherwise you'll get:
Traceback (most recent call last):
File "./phpsh", line 4, in <module>
from phpsh import PhpshState, PhpMultiliner, do_sugar, line_encode, __version__
ImportError: No module named phpsh

However an alternative equivalent solution is facebook's phpsh. this is an interactive php shell and it has some nice features such as tabtab completion for function names and syntax highlighting for notices.
php  debian  readline  repl  webdevel  solution 
february 2016 by kme
Delete/Remove WebSVN Repos 1 « Knowledge Stack

nano /etc/websvn/svn_deb_conf.inc
and comment out the line

//$config->addRepository("repos 1", "file:///var/svn-repos");
websvn  svn  debian  versioncontrol  webapp  solution 
february 2016 by kme
cleanup php session files - Stack Overflow
On Debian, it's /var/lib/php5. PHP's session_save_path() will probably tell you on another distro.
php  debian  sessions  webdevel  solution 
february 2016 by kme
LDAP/LDAPUtils - Debian Wiki
You need to install the package 'ldap-utils'
debian  solution  ldap  reference  sysadmin 
february 2016 by kme
TimeZoneChanges - Debian Wiki
Solution: `dpkg-reconfigure tzdata` then restart programs or log out/back in.

Tricky thing is: /etc/timezone seems to just be the human-readable representation. What the system libraries *actually* use is /etc/localtime, and that's a binary file (so it's usually symlinked to /usr/share/zoneinfo/Whatever/Zone).
debian  timeanddate  timezone  dammitbrain  annoyance  movein 
january 2016 by kme
« earlier      
per page:    204080120160

Copy this bookmark:





to read