recentpopularlog in

kme : eclipse   123

« earlier  
Create python project in eclipse with Pydev fails, why? - Stack Overflow | https://stackoverflow.com/
Plug-in org.python.pydev was unable to load class org.python.pydev.ui.wizards.project.PythonProjectWizard.
An error occurred while automatically activating bundle org.python.pydev (547).
devel  eclipse  luna  plugin  pydev  errormessage  annoyance  solution 
october 2018 by kme
Eclipse Mars freezes after splash screen - elementary OS Stack Exchange
1. Modifying eclipse.ini by hand

You need to open eclipse.ini in your Eclipse folder:

sudo -i scratch-text-editor /opt/eclipse/eclipse.ini

and add the following lines:

--launcher.GTK_version
2

It's important to add these lines before --launcher.appendVmargs, otherwise Eclipse will crash.
eclipse  oxygen  elementaryos  elementary  crash  annoyance  solution 
november 2017 by kme
Eclipse Community Forums: C / C++ IDE (CDT) » cdt debug can't find source files
In my case, I had to map '/' -> 'c:\cygwin64'
My Projects ara all under J:\Projects, so my mapping needs to be present in Eclipse as:

/cygdrive/j j:/

Open Eclipse and then click

- Windows => Preferences... => C/C => Debug =>Common Source Lookup Path

- Add a new Path Mapping: click [Add] => Path Mapping => [OK]

- Select the new Mapping => [Edith] => change Name of Mapping "Project Source" => [Add]

- set "Compilation path" to the Source (Sample cygwin "/cygdrive/j" (without the quotes

- set"Local file system path" tho "J:\" (without the quotes

Now you are ready ti give it another try.... good luck
cygwin  windows  eclipse  cdt  build  toolchain  errormessage  solution 
august 2017 by kme
c++ - How to deal with Eclipse CDT+Cygwin? - Stack Overflow
Not super helpful. Some of the package names mentioned in one of the answers have already changed.
eclipse  cygwin  cdt  windows  toolchain  compiler  maybesolution 
august 2017 by kme
What to do about Eclipse's "No repository found containing: ..." error messages? - Stack Overflow
As Mauro said: "you have to remove and re-add the Eclipse Project Update site, so that its metadata are re-calculated." - works as workaround
eclipse  softwareupdate  annoyance  errormessage  solution 
june 2017 by kme
Java+Eclipse: how do you debug a java program that is receiving piped/redirected stdin? - Stack Overflow
I'm not sure why just adding '< inputfile' to the list of arguments in the debugging configuration doesn't work, but this is at least a workaround.
Run your app, with the pipe, on the command line but add JVM args for remote debugging, like this:

-Xdebug -Xrunjdwp:transport=dt_socket,server=y,suspend=y,address=1044

suspend=y will tell the JVM to not actually run the program until the debugger is attached.

Next, go into the Eclipse debug launch configurations (Run -> Debug Configurations...) and create a "Remote Java Application" to connect to your app. Run the launch in Eclipse (after setting some breakpoints) and you should be able to debug. Not terribly convenient, but if you can't reproduce your issues without the pipe, this is an option.
java  eclipse  debugging  maybesolution 
april 2017 by kme
install Apache common lang 2.5 in Eclipse - Stack Overflow


Detailed steps -

0) Download commons-lang-2.5-bin.zip from Apache Commons - Lang Downloads http://commons.apache.org/lang/download_lang.cgi Expand the archive in a directory (eg. \projects\commons-lang-2.5)

In Eclipse -

1). Put the library in the Java build path

Eclipse -> Preferences: Java - Build path - User Libraries push the "New..." button, and in the "User library name:" enter 'appache-commons-lang'.

Click to select "appache-commons-lang" in the "Defined user libraries" list and then click on the "Add JARs..." button and browse for commons-lang-2.5.jar (in the folder saved earlier) and select it.

In the "Defined user libraries", under commons-lang-2.5.jar need to have "Source attachment" and "Javadoc location" specified. For each of them, select it, then push "Edit..." , then "External file" and browse for the corresponding jar (commons-lang-2.5-sources.jar and commons-lang-2.5-javadoc.jar)

2) In the project add this user library In the Package Explorer right-click on the project name, go to Properties, and select the Libraries tab; click the "Add Library..." button, from the list select "User library" , "Next", mark [x] appache-commons-lang, and click "Finish"
java  thirdparty  library  eclipse  classpath  javadoc  solution 
january 2017 by kme
java - What is the use of Interactive Console in Eclipse (Debug view) - Stack Overflow
Answer: it only works for dynamic languages like maybe Perl or with PyDev. In a Java debugging session, just use the "Expressions" tab, because "Interactive Console" is useless.
eclipse  java  debugging  solution 
september 2016 by kme
About running 32 bit programs on 64 bit Ubuntu and shared libraries » markusbe.com
This has some interesting background, but in Ubuntu 15.04, simply installing 'ia32-libs' isn't an option. The (almost) actual solution is mentioned here: https://stackoverflow.com/questions/8752727/executing-32-bit-code-under-ubundu-64-bit-installation-error-no-such-file-or-di
Due to the march of time the answer marked as correct no longer works. As of release 13 there no longer exists an ia32-libs package. Instead you must install the following:

lib32z1 lib32ncurses5 lib32bz2-1.0

This resolved the issue for me with release 14.

This at least got Eclipse running again, even if it wasn't happy about something else to do with my setup (maybe missing plugins).

See also: https://askubuntu.com/questions/147400/problems-with-eclipse-and-android-sdk
eclipse  ubuntu  32bit  64bit  annoyance  sharelibraries  almost  solution 
may 2016 by kme
Bug 436175 – [Themes] [ui][CSS][Dark] The "Help > Install New Software" dialog's table widget turns white while search is in progress
I sort of had this problem. Sort of. Actually *nothing* would show up in the "Available Software" dialog. The problem was something inside the 'workspace/.metadata' folder, because when I opened a new workspace, it was fixed.
eclipse  bug  annoyance  ubuntu  14.04  sortof  solution 
may 2016 by kme
Backup Eclipse settings - Stack Overflow
We use the concept of a baseline for new dev's but I think you can apply the same technique. Basically, what you need to do is this:

Get a new copy of Ecipse and set it up how you like with no projects.
Take a copy both the Eclipse install directory and the workspace - zip them up and store them somewhere
Remove the workspace link in Window -> Preferences -> Workspaces
When you need a new version, copy the template version down and voila!

Hope this helps.
eclipse  backup  collaboration  backupandrecovery  migration  settings  conffiles  maybesolution 
may 2016 by kme
Config to make Eclipse Juno icons and tabs look small and nice in Linux
# Create a new file in your home directory called .gtkrc-eclipse

# call eclipse with this command:
# Gtk2 forced:
# export SWT_GTK3=0
# env GTK2_RC_FILES=/usr/share/themes/<YourTheme>/gtk-2.0/gtkrc:/home/<YourUser>/.gtkrc-eclipse '/path_to_eclipse/eclipse'

# In your Eclipse directory find the file 'e4_default_gtk.css'
# In this file there's a CSS class:

# .MPartStack {
# font-size: 11;
# swt-simple: false;
# swt-mru-visible: false;
# }

# And you have two possible solutions:

# 1. Change font-size to something smaller
# 2. Just comment out or remove font-size from this class (works well for me)

# http://stackoverflow.com/questions/11805784/very-large-tabs-in-eclipse-panes-on-ubuntu

# .gtkrc-eclipse

style "gtkcompact" {
GtkButton::default_border={0,0,0,0}
GtkButton::default_outside_border={0,0,0,0}
GtkButtonBox::child_min_width=0
GtkButtonBox::child_min_heigth=0
GtkButtonBox::child_internal_pad_x=0
GtkButtonBox::child_internal_pad_y=0
GtkMenu::vertical-padding=1
GtkMenuBar::internal_padding=0
GtkMenuItem::horizontal_padding=4
GtkToolbar::internal-padding=0
GtkToolbar::space-size=0
GtkOptionMenu::indicator_size=0
GtkOptionMenu::indicator_spacing=0
GtkPaned::handle_size=4
GtkRange::trough_border=0
GtkRange::stepper_spacing=0
GtkScale::value_spacing=0
GtkScrolledWindow::scrollbar_spacing=0
GtkTreeView::vertical-separator=0
GtkTreeView::horizontal-separator=0
GtkTreeView::fixed-height-mode=TRUE
GtkWidget::focus_padding=0
}
class "GtkWidget" style "gtkcompact"

# Make tabs smaller

style "compact-toolbar" {
GtkToolbar::internal-padding = 0
xthickness = 1
ythickness = 1
}

style "compact-button" {
xthickness = 0
ythickness = 0
}

class "GtkToolbar" style "compact-toolbar"
widget_class "*<GtkToolbar>*<GtkButton>" style "compact-button"
ubuntu  eclipse  mars  annoyance  theme  gtk3  solution 
may 2016 by kme
XDebug ignores Breakpoints in Eclipse – FIXED | Roland Fiala | Software Development | Software and System Architecture - http://www.webgrafiker.net/
It helps a lot, actually, when you have xdebug.remote_enable=1 in your 'php.ini' That was actually all my problem was when I came looking here.
php  debugging  xdebug  eclipse  maybesolution 
february 2016 by kme
php - Xdebug ignores breakpoints - Stack Overflow - http://stackoverflow.com/
Solution: see http://stackoverflow.com/a/4071916 (I hadn't set 'xdebug.remote_autostart' in php.ini, because I was using MacPorts and it was... complicated. And I forgot to.
netbeans  eclipse  php  xdebug  debugging  annoyance 
february 2016 by kme
php - Remote debugging won't stop at breakpoints - Stack Overflow - http://stackoverflow.com/
I thought I had the same problem. The first problem was, I found that my php.ini was missing these two important settings:

xdebug.remote_autostart = "On"
xdebug.remote_enable = "On"
Then it worked perfectly.

The whole "Path Mapping" section under "Debug Configurations" in Eclipse doesn't seem to ever help me fix anything. I did notice that Eclipse/Xdebug sometime seem to completely ignore breakpoints in any file *other* than the one you specified in the "File' field of the "Server" tab. With "File" set to your "index.php" or whatever, and "Break at first line" also set, the first F8 after that usually seems to take you where you'd expect.

You can, of course, set it to break on the first line and then step through; that seems to work pretty consistently, as long as you didn't eff up the php.ini like I had.
php  xdebug  debugging  eclipse  annoyance  mac  osx  macports  webdevel  fuckina  solution 
february 2016 by kme
Eclipse Mars freezes after splash screen - elementary OS Stack Exchange
1. Modifying eclipse.ini by hand
You need to open eclipse.ini in your Eclipse folder:

sudo -i scratch-text-editor /opt/eclipse/eclipse.ini
and add the following lines:

--launcher.GTK_version
2
It's important to add these lines before --launcher.appendVmargs, otherwise Eclipse will crash.
eclipse  elementaryos  freya  crash  solution 
february 2016 by kme
colors - The selected entry in Eclipse content assist is unreadable because of colours - Stack Overflow
This seems to actually work, but it seemed like maybe the Greybird theme was ignoring it (XFCE 4.10).

Create a file ~/.gtkrc-2.0 and add this content to the file:

style "eclipse_fix"
{
base[ACTIVE] = shade(0.7, "#4283d3")
}

class "GtkTreeView" style "eclipse_fix"
eclipse  ubuntu  colorscheme  annoyance  solution 
february 2016 by kme
Eclipse for PHP Code Assistant not working - Stack Overflow
NB: Ctrl+Space seems never to actually bind, or register, or something else has grabbed that key combination. Try a different binding before giving up entirely.

One time, the solution for me was to right click on the project, then "Configure" -> "Add PHP support".

Sometimes that's greyed out, and you'll have to go into the project properties, then "Project Facets," then click "Convert to faceted form." Why the effin' effity eff this is required, perhaps I'll never understand.
php  eclipse  annoyance  intellisense  autocomplete  codecompletion  solution 
february 2016 by kme
java - Error: Could not find or load main class - Stack Overflow
My solution was to edit the project properties, then "Run/Debug Settings," then modify the launch configuration to add the 'src' folder to the Classpath tab.
eclipse  java  ide  classpath  sortof  solution 
february 2015 by kme
Change default general Eclipse project to Eclipse Java project | enarion.net
Open your project file (which is located in your root directory of the appropriate project) called .project with your default editor. Search for
<natures>
</natures>
and change it to
<natures>
<nature>org.eclipse.jdt.core.javanature</nature>
</natures>
Save the changed file.
eclipse  annoyance  solution 
january 2015 by kme
Eclipse Community Forums: Newcomers » Unable to install Scala IDE plug-in for Eclipse Juno
I think my problem was I had *parts* of Kepler (4.3) installed with update sites for Juno (3.8/4.2).
eclipse  kepler  software  update  errormessage  maybesolution 
december 2014 by kme
Help - Eclipse Platform
In computing, 56-bit encryption refers to a key size of fifty-six bits, or seven bytes, for symmetric encryption. While stronger than 40-bit encryption, this still represents a relatively low level of security in the context of a brute force attack.
eclipse  java  security  likeosx  keyring  keychain  password  manager  insecure 
october 2014 by kme
Adding an existing project to Aptana RadRails - Ruby Forum - https://www.ruby-forum.com/
From Aptana you can just create a 'new' project, uncheck the "Use
Default Location" box, point it at the folder containing your Rails
project files and tell it not to generate the rails application
skeleton. This makes it just configure the project to point at the
directory you specify.


So, basically, delete the project from the workspace, then create a new project where you specify the existing working folder as the starting point. You can also re-import a Git repo as an Aptana (rather than EGit) Git project using a similar method--although I still don't understand how or why Eclipse chooses one type of Git project over the other.
aptana  eclipse  rails  solution 
july 2014 by kme
GeekoZoid...: Eclipse on Linux Missing Icons [http://geekozoid.blogspot.com/]
Here is the solution: 

gsettings set org.gnome.desktop.interface menus-have-icons true

Reference:
http://gnomeshell.wordpress.com/2011/09/11/show-and-hide-the-menu-icons/


Turns out Eclipse honors the old GTK2 menu icons setting.
gtk  gnome  eclipse  icons  solution 
june 2014 by kme
administrator - Change environment variables as standard user (Windows 7) - Super User
Looking for a solution to set environment variables without having access to the System control panel in order to do this (http://stackoverflow.com/a/11763013) with Eclipse and EGit.
Just type “environment” into the start menu (or press Win+W in Windows 8 and search there). One option you are presented will be “Edit environment variables for your account”.

Similarly, searching for “environment” in the control panel yields that option, too.

Generally, I have noticed that simply searching for something in the start menu or control panel is much faster than trying to remember a series of icons, dialogs, etc. one has to access to find something. At least for the vast majority of tasks1.

A little digging yields that

rundll32 sysdm.cpl,EditEnvironmentVariables
is the command used to present that dialog. You can put a shortcut to that somewhere if you like.
windows  labcomputer  environmentvariable  eclipse  egit  solution 
may 2014 by kme
Is there any command line tool that can be used to edit environment variables in Windows? - Super User
Looking for a solution to set environment variables without having access to the System control panel in order to do this (http://stackoverflow.com/a/11763013) with Eclipse and EGit.
I don't know any tool that does this, but maybe you can use the regcommand:

reg query "HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment" /v Path
to read the current path, and

reg add "HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment" /v Path /d "newPath" /f
to write your new value.

You need admin rights for hsving right acccess in HKLM. If that is a problem, consider modifying the user specific path setting in HKCU\Environment instead.

Also interesting:
If you need a generic way to set any environment variable and have the changes persist, then setx.exe would be the tool to use. It cannot do the "smart" things you are asking for, though...

setx.exe is included with Windows Vista or later; if you use an earlier version of Windows, you can use the above download link to get it.
windows  registry  environmentvariable  labcomputer  nonadmin  cli  maybesolution  eclipse 
may 2014 by kme
Using putty's pagent with egit in Eclipse - Stack Overflow
After reading morellet.d's answer, I was able to set this up for myself very simply.

I added the user environment variable GIT_SSH and set it to "C:\Program Files (x86)\PuTTY\plink.exe" So, you just need to set it to wherever your plink file is and it will work.

Instructions worked with PuTTY 0.62, the latest EGit and Eclipse Juno x64.

Also, I think this script is needed due to some discrepancies between OpenSSH and PLINK's command line arguments:
@ECHO OFF
SET c="plink.exe" -ssh -agent -l [username]

:loop
if NOT _%1_ == __ (
IF _%1_ == _-p_ (
SET c=%C% -P
) else (
SET c=%C% %1
)
shift
goto loop
)
%c%

NB: You may also need to run PLINK once manually to cache the host key in the registry. EGit fails silently (although the error message output ends up in the Eclipse error log, and it *does* remind you of that). And for some odd reason, PLINK may not remember this (not *actually* cache it) between invocations.
eclipse  ssh  git  github  putty  pageant  solution  windows 
may 2014 by kme
Aptana Studio should install plugins per user even when installed system-wide / Problems / Discussion Area - Aptana Studio Support
On Windows, it seems the following directories are ignored by Aptana Studio 3:

%USERPROFILE%\.eclipse\.eclipse\org.eclipse.platform_3.whatever
%USERPROFILE%\AppData\Local\Aptana Studio 3\dropins[\plugins]
%USERPROFILE%\AppData\Local\Aptana Studio 3\plugins

This works fine on a Mac (with vanilla Eclipse). What gives? Well, it seems like the release version is really important. And copying .jar files alone doesn't seem to install plugins into Eclipse (or Aptana); there might be stuff in the 'features' folder that's also needed.

Looks like the best solution is just to find the appropriate update site here (http://wiki.eclipse.org/Eclipse_Project_Update_Sites), add that back into software sources, then install the Marketplace client (older versions here: http://www.eclipse.org/mpc/archive.php) and reinstall all the desired plugins. After that, you can zip up .eclipse and be relatively assured that *that* bundle of plugins will work on another lab computer with the same version of Eclipse, ADT, or Aptana Studio.
eclipse  aptana  plugin  annoyance  windows  maybesolution  labcomputers 
may 2014 by kme
Modifying Your Configuration - Titanium 3.X - Appcelerator Docs
The actual solution was to put the plugin (Vrapper) .jars in C:\Users\<username>\.eclipse\org.eclipse.platform_3.whatever\dropins, creating that folder if it doesn't exist.

Check the timestamp on the folder if there are multiple org.eclipse.platform_* folders.
aptanastudio  eclipse  plugin  solution 
may 2014 by kme
Issues - android - Android Open Source Project - Issue Tracker - Google Project Hosting
Need to file a bug for the ADT tools not EVEN SHOWING devices that don't meet the minimum version/SDK. They should show up, only greyed out or something. This drove me crazy for most of a day trying to run a 2.2 app on a Droid which hadn't received the 2.2 OTA update.
android  bug  devel  eclipse  adtplugin 
may 2014 by kme
php - How to manually specify syntax highlighting for a specific extension in Eclipse? - Stack Overflow
In Preferences, go to General -> Content Types. Unfold Text, then go to PHP Content Type. Click Add and input *.ctp. Then apply your changes.

You may need to restart eclipse to take effect.


This fixed my problem with Aptana Studio 3 not syntax-highlighting .handlebars files as HTML.
aptanastudio  eclipse  syntaxhighlighting  solution  handlebars 
may 2014 by kme
Eclipse with Android SDK missing menu items - Stack Overflow
I was able to restore the missing items in File | New... quite easily by performing the following steps:

Switch to the Java perspective, either via the perspective switcher toolbar at the top right of the main Eclipse window, or via the Window | Open Perspective menu item.
Reset the perspective by either right-clicking on the Java perspective icon in the perspective switcher toolbar, or by clicking Window | Reset Perspective...
android  adt  eclipse  annoyance  solution 
may 2014 by kme
Bug 330060 – Can't easily issue GDB commands in Mac
https://git.eclipse.org/r/#/c/7290/

Abandoned?
I don't think it's worth looking into this and adding more complexity to the code now that Apple's GDB is pretty much gone.
eclipse  bug  cdt  gdb  debugging  commandline  wishlist  needshelp  mac  osx  annoyance 
april 2014 by kme
Bug 303808 – Debug console lacks many important features
On OS X, I can enter commands into the gdb console, but to *see* them, I have to switch to "gdb traces." Platform-specific bug?
eclipse  bug  cdt  gdb  debugging  commandline  wishlist  needshelp 
april 2014 by kme
keyboard shortcuts - How Do I Switch Between Multiple Eclipse Windows (in "Split Screen" Mode) - Stack Overflow
By default, its Ctrl+F6. However, its useful if you map you keys to Ctrl+Tab to switch between open editors like Windows.

You can change your preferred keys in Window>Preferences>General>Keys and change "Next Editor" to any key of your choice(Ex: Ctrl+Tab). Hope this is what you needed.
eclipse  editor  hotkey  shortcut  solution  movein 
april 2014 by kme
c++ - Eclipse CDT Kepler does not allow "Display as array..." - Stack Overflow

Dive a bit deeper into the structure of the std::vector variable, and look for s.th. named _M_start or alike (may be implementation dependent).
Cast this one to the final type array you know and want to see.

The reason is, that std::vector<T> just wraps and manages an array of T internally and thus can't be displayed as an array itself.
gdb  eclipse  debugging  prettyprinting  stl  vectors  solution 
february 2014 by kme
Code for Concinnity: » Useful tips

“Pretty-printing” STL vector in Eclipse CDT

It’s surprising to see why the C++ debugging scene in Mac/Linux is so behind Visual Studio. One definite strengths of MSVS is the ability to display STL vectors as arrays in the debug view.

If you’re using Eclipse CDT on Mac, you’re probably stuck with GDB 6.8 which doesn’t come with pretty printing. I tried self building GDB 7.2 but Eclipse CDT 8.0 doesn’t seem to be able to interact well with it (please someone come and correct me if I’m wrong).

So here’s how to display std::vector nicely even if you’re using GDB 6.8:
gdb  debugging  eclipse  stl  vectors  maybesolution  prettyprinting 
february 2014 by kme
Eclipse: Fixing the “Program is not a Recognized Executable” Error | Thoughts on Programming and Software
In the Eclipse main menu

select “Project” -> “Properties”
navigate to “C/C++ Build” -> “Settings” -> (on the right) “Binary Parsers”

In the “Binary parser:” list, check the “PE Windows Parser” and click “OK” (lower right)
eclipse  errormessage  solution  toolchain  compiler 
february 2014 by kme
Split View in Eclipse

Select the file editor you want to split and choose “Window > New Editor”. Eclipse will open a new editor tab on the same file as you are currently editing. You can now drag and drop the new editor tab to the side of the editor pane where you want it. The two editor tabs will automatically stay synchronized.
eclipse  ide  programming  editor  solution 
february 2014 by kme
« earlier      
per page:    204080120160

Copy this bookmark:





to read