recentpopularlog in

kme : elcapitan   21

maint: skip a check when en_US.UTF-8 collation rules are broken
On OS X, *.UTF-8 locales use ASCII collating rules(!?):
<code class="language-bash">readlink /usr/share/locale/*.UTF-8/LC_COLLATE|sort -u
# result: ../la_LN.US-ASCII/LC_COLLATE</code>

This means that sort, and any other program that relies on strcoll,
cannot be expected to work consistently on OS X in any UTF-8 locale.
sorting  collation  i18n  locale  lc_all  macos  elcapitan  brokenness 
12 weeks ago by kme
Issue 23195: Sorting with locale (strxfrm) does not work properly with Python3 on BSD or OS X - Python tracker
What is 'ln_LA' anyway?
The initial difference appears to be a long-standing BSD (including OS X) versus GNU/Linux platform difference. See, for example:
http://www.postgresql.org/message-id/18C8A481-33A6-4483-8C24-B8CE70DB7F27@eggerapps.at

Why there is no difference between en and fr UTF-8 is obvious when you look under the covers at the system locale definitions. This is on FreeBSD 10, OS X 10.10 is the same:

$ cd /usr/share/locale/fr_FR.UTF-8/
$ ls -l
total 8
lrwxr-xr-x 1 root wheel 28 Jan 16 2014 LC_COLLATE -> ../la_LN.US-ASCII/LC_COLLATE
lrwxr-xr-x 1 root wheel 17 Jan 16 2014 LC_CTYPE -> ../UTF-8/LC_CTYPE
lrwxr-xr-x 1 root wheel 30 Jan 16 2014 LC_MESSAGES -> ../fr_FR.ISO8859-1/LC_MESSAGES
-r--r--r-- 1 root wheel 36 Jan 16 2014 LC_MONETARY
lrwxr-xr-x 1 root wheel 29 Jan 16 2014 LC_NUMERIC -> ../fr_FR.ISO8859-1/LC_NUMERIC
-r--r--r-- 1 root wheel 364 Jan 16 2014 LC_TIME

For some reason US-ASCII is used for UTF-8 collation; this is also true for en_US.UTF-8 and de_DE.UTF-8, the only other ones I checked.

The postresq discussion and some earlier Python issues suggest using ICU to properly implement Unicode functions like collation across all platforms. But that has never been implemented in Python. Nosing Marc-Andre.
python  sorting  locale  collation  strings  macos  elcapitan  brokenness 
12 weeks ago by kme
Unicode collation table for swedish do no… - Apple Community
The problem is clearly in Mac OS X since other systems (Linux) do get the correct output. I've been told that the problem seems to be that sv_SE.UTF-8 locale's collation table is a symlink to "la
LN.US-ASCII/LCCOLLATE".
macos  elcapitan  sorting  colation  brokenness  sigh 
12 weeks ago by kme
Sorting strings properly is stupidly hard – Daniel Lemire's blog
However, I tried to test out the sorting on fr_ca locale and got the incorrect answer, which I found out was due to incorrect locale settings on Max OS X/BSD. On my machine, fr_FR.UTF-8 collation is linked to la_LN.US-ASCII
sorting  ishard  collation  strings  devel  javascript  python  pitfalls  macos  elcapitan  brokenness 
12 weeks ago by kme
macos - Add a locale in Mac OSX - Stack Overflow
Looking into this found that, as of Mac OS X 10.10.3, collation is still broken for Spanish and most European languages. Collation definitions for these locales are linked to an ASCII definition. This ends up breaking things such as ORDER BY clauses on PostgreSQL.


Also, WTF is does 'la_LN' mean anyway?
macos  elcapitan  annoyance  sorting  brokenness  collation  lc_all  dateandtime  unix  maybesolution 
12 weeks ago by kme
Rcpp, RcppArmadillo and OS X Mavericks "-lgfortran" and "-lquadmath" error - The Coatless Professor | http://thecoatlessprofessor.com/
I didn't actually need any of this to install ade4 after uninstalling R 3.4.1 from MacPorts and using the official installer from https://cran.rstudio.com/bin/macosx/, which seems to have all the right pieces in place.
r  fortran  compiler  error  mac  osx  elcapitan  maybesolution 
september 2017 by kme
xcode - Unable to use xcodebuild on Mavericks with Command Line Tools installed - Stack Overflow

I know that this is a late answer, but in my case this command solved the issue:
<code style="language-bash">sudo xcode-select --switch /Applications/Xcode.app/Contents/Developer</code>
mac  osx  devel  build  toolchain  cli  commandline  xcode  annoyance  solution  elcapitan 
december 2016 by kme
What to do when El Capitan sidebar's favorites disappear | Macworld
Did you suddenly notice that the items you added to the Finder sidebar are suddenly missing either in the Finder or Open/Save dialogs or both? It’s not you: It’s a bug.

It’s a subtle thing, because nothing fails; rather, it dawns on you that when you’re clicking to navigate to a folder via your sidebar’s Favorites list, there’s nothing there. This happened to me recently, and I discovered it’s a routine problem people are experiencing.

While several solutions have been proposed, including deleting cache files and the like, what appears to work best—and worked for me—is to restart your Mac. When I had my sidebar faves disappear, I also had some other seemingly inexplicable slowdowns and system oddities. These went away with the restart as well.
elcapitan  yosemite  finder  favorites  fileopensaveas  dialog  bug  annoyance  solution 
april 2016 by kme
Noodlesoft Forums • View topic - Applescripts are altered after Yosemite upgrade
Really weird, but putting it back to the way it was before El Capitan *does* fix the problem:

Applescripts are altered after Yosemite upgrade

Postby leebj7 » Sat May 16, 2015 7:42 am
Hi,

So before my Yosemite upgrade my applescript to add screenshots to evernote looked like this:

Code: Select all
tell application "Evernote"
activate
create note from file theFile notebook {"098 BKamp Images"} tags {"screenshot”}
end tell

but then it switched to this and it won't accept my above applescript:

Code: Select all
tell application "Evernote"
activate
«event EVRNcrnt» given «class kfil»:theFile, «class Ennb»:{"098 BKamp Images"}, «class Engg»:{"screenshot"}
end tell

What am I doing wrong?
solution  mac  osx  automation  applescript  evernote  weirdness  yosemite  elcapitan 
april 2016 by kme
Resolved - Finder: drag item to other folder, and... | MacRumors Forums
The behavior *has* changed, however, since Mavericks (relative to 10.11.4). It seems you can no longer press spacebar in "Miller Columns" view to expand one level of hierarchy while dragging. The only way to get this behavior seems to be to enable "Spring-loaded folders," which is in this goofy place in the "Acessibility" prefpane now.
ha! just found 'spring-loaded delay', it's been moved to: System Preferences>Accessibility>Mouse & Trackpad
(if i'd known it was there, i would have tried changing those settings first...)
mac  osx  accessibility  filemanagement  finder  annoyance  elcapitan 
march 2016 by kme

Copy this bookmark:





to read