recentpopularlog in

kme : elementary   41

user interface - How do I move the X (close) button on Firefox to the left? - elementary OS Stack Exchange | https://elementaryos.stackexchange.com/
Put these in your 'userChrome.css'

<code class="language-css">@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");

/* h/t: https://support.mozilla.org/en-US/questions/1222872 */

/* first, move the window controls all the way to the left */
.titlebar-buttonbox-container {
-moz-box-ordinal-group: 0 !important;
}

/* then move the "close" (X) button all the way to the left */
.titlebar-close {
-moz-box-ordinal-group: 0 !important;
}

/* fix the spacing issue with the "minimize" button (now in the middle) */
.titlebar-min {
margin-left: 6px !important;
}

/* left spacer is too wide when shown and hidden when maximized;
this looks better */
.titlebar-spacer[type="pre-tabs"], .titlebar-spacer[type="post-tabs"] {
display: block !important;
width: 20px !important;
}</code>
elementary  firefox  windowcontrols  annoyance  solution 
november 2019 by kme
how do I move close,max,min buttons location | Firefox Support Forum | Mozilla Support
<code class="language-css">
@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");

#titlebar-max {
-moz-box-ordinal-group: 0;
}

#titlebar-content {
direction: rtl;
}

#TabsToolbar {
direction: rtl;
}

#tabbrowser-tabs {
direction: ltr;
}
</code>
firefox  elementary  windowcontrols  userchrome  customization  csd  solution 
october 2019 by kme
16.04 - /usr/sbin/fanctl: No such file or directory in /etc/network/if-up.d/ubuntu-fan" - Ask Ubuntu | https://askubuntu.com/
Not sure if this fixed anything (or broke Docker), but at least `ifup` works now without bombing with error code 127.
I had this happen after I installed and later removed Docker. The Docker daemon depends on FAN so it gets installed, but if you don't purge it upon removal the startup script in /etc/network/if-up.d/ sticks around. Remove it with apt remove --purge ubuntu-fan.
docker  networking  ubuntu  elementary  errormessage  maybesolution 
december 2018 by kme
6.12. pam_issue - add issue file to user prompt
Yeah, but in elementaryOS Luna, the pam.d/login thing mentioned in the README.Debian doesn't work. You have to edit /etc/init/ttyX.conf, and add '-f /etc/issue.linuxlogo' to each "getty" invocation.
debian  ubuntu  elementaryos  elementary  console  eyecandy  configfile  workaround  maybe  solution 
december 2017 by kme
Eclipse Mars freezes after splash screen - elementary OS Stack Exchange
1. Modifying eclipse.ini by hand

You need to open eclipse.ini in your Eclipse folder:

sudo -i scratch-text-editor /opt/eclipse/eclipse.ini

and add the following lines:

--launcher.GTK_version
2

It's important to add these lines before --launcher.appendVmargs, otherwise Eclipse will crash.
eclipse  oxygen  elementaryos  elementary  crash  annoyance  solution 
november 2017 by kme
maintenance - How do I clean up my dconf database? - Ask Ubuntu


This is possible using the dconf reset command, though it's not clear if that's a side-effect of a bug.

For a single key:

dconf reset "/path/to/the/key"

Must not end with a /.

For a whole path:

dconf reset -f "/path/to/the/path/"

Must end with a /.

If you do this while having dconf-editor opened, it will likely crash.
dconf  gsettings  elementary  configsettings  solution 
june 2017 by kme
KeePassX – Requirements
On elementaryOS Loki (Ubuntu 16.04) I had to install

libqt4-dev libxtst-dev qt4-qmake

and maybe not required, but for good measure, qt4-default.

I also had to add "#include <unistd.h>" to src/lib/random.cpp as described at https://stackoverflow.com/a/17837158.
build  toolchain  fromsource  keepass  ubuntu  elementary  solution  keepassx 
may 2017 by kme
How can I install Skype on Freya? - elementary OS Stack Exchange
This was necessary, in addition to enabling the "Canonical partner" software source:
sudo dpkg --add-architecture i386
skype  ubuntu  linux  solution  elementary 
may 2017 by kme
[SOLVED] You're using an old version of dropbox. No dropbox for you! - Page 2 - https://ubuntuforums.org/
I have it working now. It turns out that installing/updating the dropbox software package did not update the deamon installed in the user home directory (~/.dropbox-dist).

Here is what I did:

1. Quit dropbox
2. mv .dropbox-dist dropbox-dist-old
3. Start dropbox

Dropbox will guide you with the deamon download and installation in your home directory. Log on to your account and after reindexing, it works as usual.
dropbox  ubuntu  elementary  upgradehell  solution 
september 2016 by kme
NVIDIA CUDA Getting Started Guide for Linux - CUDA_Getting_Started_Linux.pdf
Installing Mesa may overwrite the /usr/lib/libGL.so that was previously installed by the NVIDIA driver, so a reinstallation of the NVIDIA driver might be required after installing these libraries.


Indeed. Other steps were necessary to build CUDA sample applications on elementary OS Luna (Ubuntu 12.04 Precise Pangolin). See: https://pinboard.in/u:kme/b:901551f9a7b7
solution  cuda  devel  documentation  reference  linux  ubuntu  elementary 
september 2015 by kme
Gloobus Preview Update Brings GTK3 And Ubuntu 12.04 Support, More ~ Web Upd8: Ubuntu / Linux blog [http://www.webupd8.org/]
Marlin, the file manager that will be used by default in elementary OS, can also use Gloobus Preview. To set Marlin to use Gloobus Preview, install Dconf-Editor:
sudo apt-get install dconf-tools
Then launch Dconf-Editor, navigate to apps > marlin > preferences and set "/usr/bin/gloobus-preview" for the previewer-path. Then, just like in Nautilus, use the SPACE key to quickly preview files.


This works, but the config path is under org/pantheon/files now.
gloobuspreview  elementary  nautilus  marlin  solution  likeamac  alternativeto  quicklook 
june 2014 by kme
Meet 'Files,' the Latest elementary App | elementary
Gloobus was considered and we ended up dropping it because it's just a workaround for application statup time which we intend to fix directly, and its feature of supporting a lot of formats in one UI so one can quickly preview files of different types in one folder is brough to naught by the fact that previous/next actions do not sync with sort mode set in file manager.
elementary  pantheon  needshelp  filemanager  ux  todo  programming  gloobus  quicklook 
july 2012 by kme

Copy this bookmark:





to read