recentpopularlog in

kme : elementaryos   132

« earlier  
power management - How do I disable my system from going to sleep? - Ask Ubuntu | https://askubuntu.com/
Why the fuck doesn't the System Settings "Sleep after inactive for" setting do this this?
On Ubuntu 16.04 LTS, I successfully used the following to disable suspend:
<code class="language-bash">
sudo systemctl mask sleep.target suspend.target hibernate.target hybrid-sleep.target
</code>
And this to re-enable it:
<code class="language-bash">
sudo systemctl unmask sleep.target suspend.target hibernate.target hybrid-sleep.target
</code>
ubuntu  elementaryos  annoyance  sleep  suspend  powersave  powermanagement  systemd  maybesolution 
5 weeks ago by kme
lightdm - Personalize monitor position before login - Ask Ubuntu | https://askubuntu.com/
<code class="language-bash">sudo cp ~/.config/monitors.xml /var/lib/lightdm/.config/</code>
linux  elementaryos  lightdm  multimonitor  annoyance  solution 
10 weeks ago by kme
mdh34/elementary-indicators: An unofficial guide to restore indicator functionality on elementary OS | https://github.com/
All that seems to be required for most (exception of gtk2) indicators is

- install 'indicator-application' from the repos
- then the old wingpanel-ayatana-indicator package (https://launchpad.net/~elementary-os/+archive/ubuntu/stable/+files/wingpanel-indicator-ayatana_2.0.3+r27+pkg17~ubuntu0.4.1.1_amd64.deb)
- and follow the instructions from https://pinboard.in/u:kme/b:bc95dba3fa3c to customize its XDG .desktop file so it runs in Pantheon

That is:
Edit /etc/xdg/autostart/indicator-application.desktop:
<code class="language-bash">sudo vim /etc/xdg/autostart/indicator-application.desktop</code>
change:
<code class="language-ini">OnlyShowIn=Unity;GNOME;</code>
to
<code class="language-ini">OnlyShowIn=Unity;GNOME;Pantheon;</code>
and 'killall wingpanel'.

Also of note:
If you copy the file to .config/autostart/indicator-application.desktop then you shouldn't have to worry about it getting overwritten again.
elementaryos  wingpanel  panel  indicator  notification  systray  workaround  appindicator  notificationarea  solution  fuckina 
november 2019 by kme
Ayatana indicator has dissapeared (again) from Juno : elementaryos | https://www.reddit.com/
Ok, I found the solution: it was enough to re-edit /etc/xdg/autostart/indicator-application.desktop:
<code class="language-bash">sudo nano /etc/xdg/autostart/indicator-application.desktop</code>

change again:

<code>OnlyShowIn=Unity;GNOME;</code>

to

<code>OnlyShowIn=Unity;GNOME;Pantheon;</code>

and reboot.


Also:
If you copy the file to .config/autostart/indicator-application.desktop then you shouldn't have to worry about it getting overwritten again.
elementaryos  juno  appindicator  panelindicators  systemtray  systray  fuckina  solution 
may 2019 by kme
Big gap between icons · Issue #1 · mdh34/elementary-indicators | https://github.com/
Still works in 5.0 Juno. And you can put that CSS snippet in ~/.config/gtk-3.0/gtk.css to make the change permanent, even if updates to the upstream package clobbers your local modifications.
Try setting the padding to '0 2px' in your theme -> apps.css

In my case I use https://github.com/surajmandalcell/elementary-x :
/usr/share/themes/elementary-x/gtk-3.22/apps.css
<code class="language-css">.composited-indicator {
padding: 0 2px;
}</code>

Then set your theme to something else and then back again to make sure the changes are refreshed(or restart/log out)
elementaryos  juno  panelindicator  appindicators  annoyance  solution 
may 2019 by kme
elementary/wingpanel-indicator-ayatana: Wingpanel Ayatana-Compatibility Indicator | https://github.com/
Wingpanel Ayatana-Compatibility Indicator. Contribute to elementary/wingpanel-indicator-ayatana development by creating an account on GitHub.
elementaryos  panelindicator  appindicators  maybesolution  deadproject 
may 2019 by kme
Question #216282 : Questions : elementary OS | https://answers.launchpad.net/
All the gtk apps had their icons in the panel. Turns out the sni-qt package was missing. They are back now.
elementaryos  qt  panel  indicators  appindicators  annoyance  maybesolution 
may 2019 by kme
How to display system tray icons in elementary OS Juno? - elementary OS Stack Exchange | https://elementaryos.stackexchange.com/
The necessary 'indicator-application' package seems to be in the repositories for Juno; all that was probably actually required is
$ sudo nano /etc/xdg/autostart/indicator-application.desktop

find the line

OnlyShowIn=Unity;GNOME;

and add Pantheon

OnlyShowIn=Unity;GNOME;Pantheon;
elementaryos  juno  indicator  icons  appindicator  panelindicators  annoyance  movein  sortof  solution 
may 2019 by kme
How do I change login background in elementary OS Freya or Loki? - elementary OS Stack Exchange | https://elementaryos.stackexchange.com/
Just copy your wallpaper to /usr/share/backgrounds (you're going to need root privileges to do so) and then select your wallpaper from System Settings -Desktop - Wallpaper.
elementaryos  greeter  lockscreen  background  wallpaper  annoyance  solution 
may 2019 by kme
guake hangs when you put exit on the CLI and then choose No. · Issue #1014 · Guake/guake | https://github.com/
To whom hangs on Ubuntu 18.04

#1198 (comment) mentioned a solution:

sudo apt install --reinstall libutempter0

This works for me
guake  hang  elementaryos  ubuntu  18.04  solution 
may 2019 by kme
python - pip: no module named _internal - Stack Overflow | https://stackoverflow.com/
What worked for me was:
<code class="language-bash">
sudo apt-get remove python-pip
</code>
python  pip  python27  debian  ubuntu  elementaryos  errormessage  solution 
december 2018 by kme
c - GLib-GIO-ERROR**: No GSettings schemas are installed on the system - Stack Overflow | https://stackoverflow.com/
I ran into this problem when trying to using GNU Stow with two different GLib (elementaryOS) applications, which both provided their own 'gschemas.compiled'. My solution was to remove the existing one and run 'glib-compile-schemas /usr/local/share/glib-2.0/schemas'.
The problem is with the Glib schemas that apparently are not compiled on your system.

You need the glib-compile-schemas and find the glib-2.0/schemas directory which is located in /usr/share/glib-2.0/schemas, I don't know if it will be found in the same path within MinGW, but I don't see why it wouldn't, so you must execute the following command1

<code class="language-bash">
glib-compile-schemas /usr/share/glib-2.0/schemas/
</code>

and that will create a file gschemas.compiled so you need write permission, then the error will go away.
gnustow  stow  errormessage  gsettings  glib  gnome  elementaryos  workaround  solution 
january 2018 by kme
keyring - Private SSH key with password no longer stays unlocked for session - elementary OS Stack Exchange | https://elementaryos.stackexchange.com/
Script 90x11-common_ssh-agent should somehow start your ssh-agent. But not add the keys. If you want to add a key with the first usage, you can configure ssh to do so in ~/.ssh/config:

AddKeysToAgent yes
ssh  ssh-agent  keyring  elementaryos  ubuntu  annoyance  solution 
january 2018 by kme
Bug #1596377 “Desktop takes a long time to initialize” : Bugs : elementary OS
Yup, seems like renaming (disabling) the file to at-spi-dbus-bus.desktop.disabled in /etc/xdg/autostart and the login delay no longer occurs
x  x11  elementaryos  annoyance  login  wm  desktopsession  workaround  solution 
january 2018 by kme
Ubuntu: Only works in debug mode · Issue #19 · wavexx/screenkey | https://github.com/
<code class="language-bash">
# it's set to "!@im=ibus" by default, but ibus-daemon isn't running
unset XMODIFIERS

# don't need this if you run the previous one
ibus-daemon -d -x

screenkey -d
</code>

See also: https://github.com/wavexx/screenkey/issues/56 and https://bugs.launchpad.net/elementaryos/+bug/1701010
ibus  inputmethod  screencasting  elementaryos  errormessage  solution  needshelp  bug  workaround 
january 2018 by kme
MySQL Bugs: #72663: MySQL Workbench 6.1.4 error when open MySQL Utilities. | https://bugs.mysql.com/
How to fix.

In file: /usr/lib/mysql-workbench/modules/wb_utils_grt.py
should replace line:
for term in ["gnome-terminal", "konsole", "xterm", "rxvt"]:
to line:
for term in ["gnome-terminal", "konsole", "xterm", "rxvt", "xfce4-terminal"]:
mysql  workbench  bug  ubuntu  16.04  elementaryos  loki  solution 
december 2017 by kme
release freya - Where can I download older versions of elementary OS? - elementary OS Stack Exchange
Softpedia didn't work either. Ended up finding Freya here http://www.virtualpanic.com/isos/Linux/Elementary%20OS/2015/0.3.2/ and here http://osarchive.sda1.eu/elementary-os, and verified the latter with the SHA256 checksum given below.
Freya 0.3.2 (64-bit) (32-bit)

Softpedia also has a mirror of the latest Freya ISOs

sha256sum elementaryos-0.3.2-stable-amd64.20151209.iso ee737ffa6bf33b742c5a7cee17aa26dec5ee3b573cbbc4b53cbe2a2513c9197a

sha256sum elementaryos-0.3.2-stable-i386.20151209.iso 97e143e762a1d1e3abac9eba33a59a7a6b9f319a7063cd47e406678c379fc683
elementaryos  freya  iso  solution 
december 2017 by kme
artemanufrij/webpin: An elementary OS app
Wish list:

- cookie clearing
- search keywords (search box in headerbar)
elementaryos  ssb  browser  alternativeto  prism  chromeapp  fogapp  needshelp 
december 2017 by kme
Hourglass in Launchpad
No, the app does not need to be running for the alarms to work. And 'at' doesn't seem to have been installed as a dependency, so Hourglass has its own persistent daemon apparently, or else the notification system allows you to create timed notifications.
elementaryos  utility  app  essential  movein 
december 2017 by kme
6.12. pam_issue - add issue file to user prompt
Yeah, but in elementaryOS Luna, the pam.d/login thing mentioned in the README.Debian doesn't work. You have to edit /etc/init/ttyX.conf, and add '-f /etc/issue.linuxlogo' to each "getty" invocation.
debian  ubuntu  elementaryos  elementary  console  eyecandy  configfile  workaround  maybe  solution 
december 2017 by kme
Eclipse Mars freezes after splash screen - elementary OS Stack Exchange
1. Modifying eclipse.ini by hand

You need to open eclipse.ini in your Eclipse folder:

sudo -i scratch-text-editor /opt/eclipse/eclipse.ini

and add the following lines:

--launcher.GTK_version
2

It's important to add these lines before --launcher.appendVmargs, otherwise Eclipse will crash.
eclipse  oxygen  elementaryos  elementary  crash  annoyance  solution 
november 2017 by kme
networking - How do I use /etc/network/interfaces instead of network-manager - Ask Ubuntu
This seems to also be the case with elementaryOS if you add a bridged adapter that uses the default (eth0 or eno1 or whatever) adapter.

23
down vote
accepted


If you manually manage your network card in /etc/network/interfaces , network manger will not manage it , it will state "Not Managed"
elementaryos  linux  debian  networking  networkmanager  bridgedethernet  bridge  solution 
october 2017 by kme
power - How to enable hibernate option in menu? [Loki] - elementary OS Stack Exchange
Is this "S3" or "S4" sleep? Anyway, this worked:
On my Dell XPS 9350, hibernate works just fine with elementary OS (via 'sudo systemctl hibernate').


whereas setting the power button to "Hibernate" didn't (on an HP EliteDesk 800 G1 SFF)
elementaryos  loki  hibernate  powermanagement  annoyance  sortof  solution 
september 2017 by kme
Clipboard manager with Pantheon integration - elementary OS Stack Exchange
You can use "Clippy" docklet in the dock (Plank).

Open Plank preferences by pressing Ctrl and right/secondary clicking on Plank (or just run plank --preferences in the Terminal) and go to Docklets tab.
elementaryos  tipsandtricks  dock  clipboardmanager 
september 2017 by kme
LinuxQuestions.org - How to disable HP Device Manager Autostart
PITA huh, the presumption that everyone needs or wants that service running? Kind of like Windows....

* Create $HOME/.config/autostart/hplip-systray.desktop

* In that text file add this:

[Desktop Entry]
Hidden=true

In addition to that, because I don't want the service running at all, I delete /etc/xdg/autostart/hplip-systray.desktop. I delete the file because the file gets updated every time hplip gets updated.
hplip  printer  driver  annoyance  notification  systray  elementaryos  solution 
may 2017 by kme
Ubuntu - WineHQ Wiki
Don't forget to download and install the key.
ubuntu  wine  installation  packagemanagement  ppa  elementaryos  solution 
may 2017 by kme
pm-utils - ArchWiki
This worked on the VAIO VGC-JS110J
"Sleep" and "power" buttons are handled by acpid in /etc/acpi/handler.sh (see "button/power" and "power/sleep" entries). You may want to substitute the default actions with calls to pm-suspend and pm-hibernate.

Please note that systemd handles power events on its own and does not use pm-utils or any scripts from /etc/pm/*.
elementaryos  solution  powerbutton  powermanagement  linux  reference 
may 2017 by kme
release freya - elementary tweaks will not Install - elementary OS Stack Exchange
I had this problem, but the problem was that I was trying to use a Loki (v0.4) version of elementary-tweaks on Freya (v0.3).
elementaryos  ubuntu  packagemanagement  errormessage  ppa  solution 
may 2017 by kme
« earlier      
per page:    204080120160

Copy this bookmark:





to read