recentpopularlog in

kme : errormessage   517

« earlier  
redis-cli just can not understand my input · Issue #6146 · antirez/redis
I get the error message "(error) ERR unknown command 'KEYS'" using the 3.2.someting version of 'redis-cli' that comes with GitLab Omnibus 11.something. Using '--scan --pattern "*"' is an acceptable workaround.

Possibly related mailing list thread: https://groups.google.com/forum/#!topic/redis-db/W68TQMkiNUw
errormessage  redis  redis-cli  gitlab 
29 days ago by kme
Error 422 The change you requested was rejected on login (#40898) · Issues · GitLab.org / GitLab FOSS · GitLab
For those running into this issue, have you tried flushing the session store in Redis? Delete all keys that start with session:gitlab from Redis.


A good reference for that is https://docs.gitlab.com/ee/administration/operations/cleaning_up_redis_sessions.html, if you just update the instructions to use '/var/opt/gitlab/redis/redis.socket' and 'redis-cli --scan --pattern "session:gitlab:*"' instead.

Useful comments:
- (Apache) https://gitlab.com/gitlab-org/gitlab-foss/issues/40898#note_265993372
- (Redis) https://gitlab.com/gitlab-org/gitlab-foss/issues/40898#note_265995771
gitlab  sysadmin  error422  errormessage  solution 
29 days ago by kme
Compiling error · Issue #599 · eclipse/mosquitto
You have to install following packages: xsltproc docbook-xsl
Then it will work.

Just 'docbook-xsl' is enough on CentOS, I think. There is no 'xsltproc' package. Also, moreutils' Makefile points to the wrong place for the DocBook stylesheets, so you need to
<code class="language-bash">DOCBOOKXSL='/usr/share/sgml/docbook/xsl-stylesheets' make</code>
errormessage  docbook  xsl  xml  xsltproc  centos  centos7  solution 
8 weeks ago by kme
finally remove declaration of Rf_pythag · wch/r-source@4384716
If you have a project with a 'packrat.lock' from the 3.3.x days, and you get an error message about Rf_pythag while building Rcpp, this is why. You're using R 3.5.x or 3.6.x, and you either need to update Rcpp from CRAN, or use an older version of R.
r  rcpp  errormessage 
9 weeks ago by kme
Install Rcpp 0.12.12 from Source R 3.5.1 · Issue #915 · RcppCore/Rcpp · GitHub
Solution for me was

<code class="language-R">install.packages("https://mran.microsoft.com/snapshot/2018-06-01/src/contrib/Rcpp_0.12.17.tar.gz",repos = NULL, type = "source")</code>

under the same conditions he describes (project with an old Packrat lockfile).
r  rcpp  packagemanagement  packrat  errormessage  maybesolution 
9 weeks ago by kme
PHP large file uploads - Hacker's ramblings
As found in the net max_input_time and max_execution_time have nothing to do with the network transfer. Both of those limits affect only server's processing after the bytes are transferred.
webmaster  errormessage  fileupload  bigfiles  php  php.ini  tipsandtricks  maybesolution 
9 weeks ago by kme
Print to STDERR in AWK - Google Groups
I forgot the quotes around "/dev/stderr" is all:
<code class="language-awk">print "foo" > "/dev/stderr"</code>
unix  linux  shellscripting  awk  errormessage  stderr  solution 
11 weeks ago by kme
[SOLVED] XCode 7 and Qt error | Qt Forum
In my case the error
<code>clang: warning: no such sysroot directory</code>
was caused by Xcode.app being in an Applications/Developer subdirectory, and some part of the build process not expecting that.

The fix was to move it back to /Applications and run 'sudo xcode-select -s /Applications/Xcode.app'.
xcode  errormessage  anoyance  build  toolchain  clang  maybesolution 
october 2019 by kme
joe is broken · Issue #99 · karan/joe
is solved the update issue by going into the .joe-data directory and manually checking out the master branch. After checking out the branch, joe recognizes the .gitignore files.
joe  python  gitignore  bug  errormessage  needshelp 
october 2019 by kme
sqlite - Compile Python 3.4 with sqlite3 - Stack Overflow
There is also the option of pre-linking your custom Python build with your own-built sqlite3. (I had the same issue: the custom python was using the system-provided sqlite3, completely ignoring the sqlite3 I built).

Prefix your configure and make commands with:
<code class="language-bash">LD_RUN_PATH=$HOME/opt/lib configure LDFLAGS="-L$HOME/opt/lib" CPPFLAGS="-I$HOME/opt/include" …
LD_RUN_PATH=$HOME/opt/lib make</code>

so that the built python3 by default is linked to your sqlite3. This worked for me.
python  fromsource  sqlite  errormessage  linkererrors  solution 
september 2019 by kme
Your first extension - Mozilla | MDN
On macOS 10.14 (Mojave), I had to
<code class="language-bash">
sudo port install nodejs10
sudo port install python27
sudo port select --set python2 python27


# install NPM modules into $HOME
npm config set prefix $HOME/.local/lib/node_modules
echo "export PATH=$HOME/.local/lib/node_modules/bin:$PATH" >> ~/.bash_profile

# this needed 'python2' in the PATH (for node-gyp, whatever that is)
npm install -g web-ext

# then build the extension
web-ext build
</code>

Also, try to use the linter on the built '.zip' file:

<code class="language-bash">addons-linter web-ext-artifacts/*.zip</code>

Otherwise you might get a "Can't install addon because it seems to be corrupt" error, which probably means that you just have a syntax error in your JavaScript, or else the manifest.json is missing a 'content_scripts' 'matches' key (ref: https://developer.mozilla.org/en-US/docs/Mozilla/Add-ons/WebExtensions/manifest.json/content_scripts)
webdevel  firefox  extension  webextension  macos  errormessage  solution 
september 2019 by kme
macOS build fails by linker · Issue #82 · shundhammer/qdirstat
<code>/Applications/Developer/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang++ -stdlib=libc++ -headerpad_max_install_names -arch x86_64 -Wl,-syslibroot,/Applications/Developer/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.14.sdk -mmacosx-version-min=10.12 -Wl,-rpath,@executable_path/../Frameworks -o .app/Contents/MacOS/ -F/opt/local/libexec/qt5/lib -framework QtGui -framework QtCore -framework DiskArbitration -framework IOKit -framework OpenGL -framework AGL
Undefined symbols for architecture x86_64:
"_main", referenced from:
implicit entry/start for main executable
ld: symbol(s) not found for architecture x86_64
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make[1]: *** [.app/Contents/MacOS] Error 1
make: *** [sub-doc-make_first-ordered] Error 2</code>
build  compiler  errormessage  maybesolution  macos 
september 2019 by kme
linux - Getting warning ignoring option '--databases' due to invalid value 'testdatabase' in mysql while importing data - Stack Overflow
tl;dr: the 'database=' option from the '[client]' section is getting mistaken for the '--databases' (boolean) option to 'mysqldump'. It's harmless.

See also: https://bugs.mysql.com/bug.php?id=41209
mysql  errormessage  dba  bug  solution 
august 2019 by kme
UTF8, MySQL, Perl and PHP (Phil Gyford: Writing)
Only these two together seemed to work for me (CentOS 7, using vendor-supplied perl-DBD-MySQL-4.023-6.el7.x86_64):

<code class="language-perl">$dbh->{'mysql_enable_utf8'} = 1;
$dbh->do('SET NAMES utf8');</code>

The error message I would get otherwise was
SQL execution failed: COLLATION 'utf8_bin' is not valid for CHARACTER SET 'latin1' (1253)


Even if the table, server, column, collation were all 'utf8'. The *client* was the missing part, and 'SET NAMES utf8' fixes that, seemingly.
perl  dbd  dbi  database  errormessage  devel  solution 
august 2019 by kme
DBD::mysql - MySQL driver for the Perl5 Database Interface (DBI) - metacpan.org
Additionally, turning on this flag tells MySQL that incoming data should be treated as UTF-8. This will only take effect if used as part of the call to connect(). If you turn the flag on after connecting, you will need to issue the command SET NAMES utf8 to get the same effect.


This did *not* work as advertised, and I ended up setting it *after* the connect, along with 'SET NAMES', which actually *did* seem to fix the error messages I was getting about "COLLATION 'utf8_bin' is not valid for CHARACTER SET 'latin1'":

<code class="language-perl"># source https://www.gyford.com/phil/writing/2008/04/25/utf8-mysql-perl/
# see also: https://stackoverflow.com/a/6423280/785213
$dbh->{mysql_enable_utf8} = 1;
# $dbh->do('SET NAMES utf8');</code>
perl  dbi  dbd  mysql  dba  devel  reference  errormessage  workaround  solution 
august 2019 by kme
perl - Why CONCAT() does not default to default charset in MySQL? - Stack Overflow
This did NOT work (for me):
It probably is DBD::mysql issue/peculiarity. Try enabling utf8 in database handle as described in POD for DBD::mysql (mysql_enable_utf8 part).
perl  dbi  mysql  dba  database  query  collation  errormessage  maybesolution 
august 2019 by kme
undefined reference to symbol 'XFlush' · Issue #1 · archetipo/leapmouse · GitHub | https://github.com/
I ran into this issue trying to compile gSTM on elementaryOS Loki 5.0, based on Ubuntu 18.04, and I had to add `-lX11 -lxml2` in about three different places in 'src/Makefile'. Still didn't run.
build  compiler  toolchain  linker  errormessage  maybesolution 
august 2019 by kme
Issue 31652: make install fails: no module _ctypes - Python tracker
Had to build and install libffi into the PREFIX for Python-3.7.4 when building it from source on CentOS 7.

See also: https://bugs.python.org/issue34036
centos  centos7  fromsource  build  toolchain  compiler  errormessage  python  workaround  solution 
august 2019 by kme
Autoconf, Libtool, and an undefined AC_PROG_LIBTOOL - Super User
This fixed this for me—modifying the supplied 'autogen.sh', so that it ran this command instead:
<code class="language-bash">autoreconf -v -f -i -I /usr/share/aclocal</code>
To fix this if you already have a /usr/local/share/aclocal directory, type the following as root:
<code class="language-bash">for file in argz libtool ltdl ltoptions ltsugar ltversion lt~obsolete
do
ln -s /usr/share/aclocal/$file.m4 /usr/local/share/aclocal/$file.m4
done
</code>

To fix this if you don't have a /usr/local/share/aclocal directory, type the following as root:
<code class="language-bash">ln -s /usr/share/aclocal /usr/local/share/aclocal</code>

Voilà -- problem solved.
autoconf  errormessage  build  toolchain  centos7  annoyance  solution 
august 2019 by kme
Issue 34036: ModuleNotFoundError: No module named '_ctypes' when install Python 3.7 on Linux - Python tracker
Ran into this problem building Python 3.7.4 on the HPC cluster.
Ctypes is meant to be (at least it used to be) an optional module. If you don’t actually care about building ctypes, this might be the same as Issue 31652. Using “configure --without-ensurepip” was suggested as a workaround.
python  build  fromsource  compiler  errormessage  maybesolution 
august 2019 by kme
MySQL Bugs: #59891: Cmake-gui's error | https://bugs.mysql.com/
Couldn't even get the SRPM package to build, because of this same error, which led me to believe it was a CMake problem, but it also failed with an update CMake.

So maybe you need an *old* CMake? Or an *older* version of MySQL (5.1.72?).
mysql  mysql5.1  centos6  bug  build  compiler  errormessage 
july 2019 by kme
Re: Lua and pkg-config .pc file | http://lua-users.org/
I was trying to build 'highlight' (https://gitlab.com/saalen/highlight) and got a 'lua.pc' not found error. This was the solution

<code class="language-bash">
make pc INSTALL_TOP=/wherever/you/stow/lua-5.3.5 > lua.pc
</code>

This was just an off-the-cuff answer from someone who probably doesn't know 'pkg-config' very well, though, because it *still* doesn't work unless you add 'Name:', 'Version:', and 'Description:' fields to the .pc file.

THEN, you can move that 'lua.pc' into '/wherever/you/stow/lua-5.3.5/lib/pkgconfig' and update the PKG_CONFIG_PATH environment variable.
lua  build  toolchain  errormessage  library  pkg-config  annoyance  workaround  solution 
july 2019 by kme
Failure while executing git config, exit code 129 · Issue #921 · Linuxbrew/brew
<code class="language-bash">export HOMEBREW_GIT_PATH=$HOME/bin/git
export HOMEBREW_NO_ENV_FILTERING=1</code>
homebrew  hpc  cluster  errormessage  solution 
june 2019 by kme
ExifTool FAQ
By default, ExifTool applies a print conversion (PrintConv) to extracted information to make the output more human-readable. Some conversions involve lookup tables which are documented in the Values column of the tag name documentation. For example, the GPSAltitudeRef tag defines the following conversions:
0 = Above Sea Level
1 = Below Sea Level


For this tag, a value of '0' is printed as 'Above Sea Level', and '1' is printed as 'Below Sea Level'. Reading and writing with ExifTool is symmetrical [with the possible exception of list-type tags -- see FAQ number 17 below], so a value that is printed as 'Above Sea Level' must also be written in that form. (In other words, the inverse print conversion is applied when writing values.) For example, to write GPSAltitudeRef you can type:
<code class="language-bash">exiftool -gpsaltituderef="Above Sea Level" image.jpg</code>

or any unambiguous short form may be used and ExifTool will know what you mean, eg)
<code class="language-bash">exiftool -gpsaltituderef=above image.jpg</code>

Alternatively, the print conversion can be disabled for all tags with the -n option, or for individual tags by suffixing the tag name with a '#' character. In either case the printed value of GPSAltitudeRef will be '0' or '1' when extracting information, and the value is written in the same way. So following two commands have exactly the same effect as above:
<code class="language-bash">exiftool -gpsaltituderef=0 -n image.jpg
exiftool -gpsaltituderef#=0 image.jpg</code>
exiftool  errormessage  gps  geo  exif  jpeg  jpg  solution 
june 2019 by kme
python - Is it possible to open a locked sqlite database in read only mode? - Stack Overflow
SQLITE_OPEN_READONLY flag - look into this. Probably only part of the C API, which Python's sqlite3 won't necessarily support.

This is the solution I ended up using:
You could try just copying the database file (e.g., with the system utility cp) and using that snapshot for reading purposes
python  sqlite  concurrency  database  locking  errormessage  maybesolution 
june 2019 by kme
Python SQLite: database is locked - Stack Overflow
Got this message when trying to use my 'ffhist' Python script while Firefox was open.
python  sqlite  dba  database  locking  errormessage 
june 2019 by kme
linux - bashdb startup error: bashdb/lib/setshow.sh: line 91: /dev/pts/2: Permission denied - Stack Overflow - https://stackoverflow.com/
Got this error message in a CentOS 7 Docker image, added user to the 'tty' group with 'vigr', then also had to 'chmod g+r' /dev/pts/0.
bash  shellscripting  bashdb  errormessage  maybesolution 
june 2019 by kme
Don't write "ignore-file" unless the content actually changes by mdshw5 · Pull Request #303 · rstudio/packrat
This clued me in to the fact that yes, the Shiny application *did* need to write to the '.gitignore' because of something to do with Packrat.
shinyserver  shiny  errormessage  packrat  gitignore  solution 
june 2019 by kme
Docker and Locales
Like, in my case, Vim wasn't displaying UTF-8 encoded symbols (like "»") correctly.

Here's his working Dockerfile recipe:
<code>FROM ubuntu:13.10

# Set the locale
RUN locale-gen en_US.UTF-8
ENV LANG en_US.UTF-8
ENV LANGUAGE en_US:en
ENV LC_ALL en_US.UTF-8
</code>
docker  locale  characterencoding  errormessage  annoyance  solution 
june 2019 by kme
mysql - Can't connect to localhost using Python's MySQLdb - Stack Overflow | https://stackoverflow.com/
I've managed to solve this by setting my host to "127.0.0.1" rather than "localhost".

Turns out if the socket isn't in the default location (/tmp/mysql.sock), the MySQLdb client doesn't take any special measures (lazy!) to discover where it's ACTUALLY at, according to the /etc/my.cnf.

For example, on CentOS (6?), using the SCL version of MySQL, it's at /var/lib/mysql/mysql.sock.
if your mysql socket is not placed in /tmp/mysql.sock, you can specify it with
<code class="language-python">conn = MySQLdb.connect (unix_socket = 'path_to_your_socket', host = 'localhost', user = 'erin', passwd = 'erin', db = 'sec')</code>

edit: for mamp on macosx the mysql socket path should be something like /Applications/MAMP/tmp/mysql/mysql.sock

To figure out where the heck the socket actually *is*, this might work:
using <code class="language-bash">mysql_config --socket</code> in your shell should do, or /path/to/mysql/bin/mysql_config if you installed it in /opt or something – roman Jan 11 '11 at 20:56
python  sqlalchemy  mysql  client  errormessage  webdevel  solution  annoyance 
march 2019 by kme
ERROR : Base home directory does not exist within the container - Google Groups | https://groups.google.com/
This worked for me, but the kernel on our cluster is too old:

<code class="language-bash">
singularity shell --no-home docker://centos:7
</code>
singularity  errormessage  workaround  solution 
march 2019 by kme
ruby on rails - How can I remove a default gem? ! want to uninstall a gem 1.7.7 version of json - Stack Overflow | https://stackoverflow.com/
I had to remove the (duplicate) '<ruby_install_dir>/lib/ruby/gems/<ruby_major_ver>/specifications/default/json-x.y.z.gemspec' file from my specifications/default directory.

The top-rated answer was confusingly verbose, but it did contain the solution in there, somewhere.
ruby  rubygems  errormessage  annoyance  solution 
march 2019 by kme
Error installing json 1.8.3 with ruby 2.4 - Stack Overflow | https://stackoverflow.com/
I did <code class="language-bash">gem install -v 1.8.6 json</code> and it worked.
I ran into the same issue recently as well, try and see if there's a newer version of whatever gem you're using that depends on json 1.8.3. This is happening because Ruby 2.4 unified Fixnum and Bignum into Integer. If you're able to upgrade to json 1.8.5 or higher, it should help fix your problems.
ruby  annoyance  errormessage  rubygems  gem  solution 
march 2019 by kme
lubridate 1.7 does not compile under RHEL 6.6 · Issue #608 · tidyverse/lubridate · GitHub | https://github.com/
I can install 1.6 from source without a problem, but 1.7 throws errors and won't compile. In file included from ./cctz/include/civil_time.h:18, from update.cpp:2: ./cctz/include/civil_time_detail.h:37: error: expected nested-name-specifi...
r  library  lubridate  tidyverse  centos6  compiler  errormessage  solution 
march 2019 by kme
macos - Why CURL return and error (23) Failed writing body? - Stack Overflow | https://stackoverflow.com/

(For completeness and future searches) It 'a matter of how CURL manages the buffer, the buffer disables the output stream with the -N option.
<code class="language-bash">
curl -s -N "URL" | grep -q Welcome
</code>
unix  shellscripting  curl  pipes  errormessage  annoyance  solution 
march 2019 by kme
Installation Problems · Issue #716 · klaussilveira/gitlist | https://github.com/
Hi,
I think that this problem is related to apache virtual host configuration.
Try to find in your apache virtual host configuration something like:
<code style="lang-apache"><Directory ...> AllowOverride None </Directory></code>
Change it to
<code style="lang-apache"><Directory ...> AllowOverride All </Directory></code>
gitlist  php  apache  errormessage  solution 
february 2019 by kme
vim - How to fix duplicate cscope ? is it a better way? - Stack Overflow | https://stackoverflow.com/
Solution: put 'set cscopenoverbose' right before the 'if filereadable("cscope.out")' statement.
vim  cscope  errormessage  annoyance  solution 
february 2019 by kme
macos - Using the pkg-config macro PKG_CHECK_MODULES failing - Stack Overflow | https://stackoverflow.com/
The solution in my case was to build and install automake-1.16 and pkg-config-0.29.something, which were newer than the OS-supplied versions.
devel  centos  centos6  pkg-config  build  toolchain  errormessage  sortof  solution 
february 2019 by kme
"help2man: can't get `--help' info from automake-1.16" · Issue #6275 · Linuxbrew/homebrew-core | https://github.com/
Ran into this problem trying to build 'automake-1.16' from source; 'module load'ing a new-ish Perl and then re-doing './configure' fixed the problem, I guess.
automake  build  toolchain  errormessage  solution 
february 2019 by kme
python - No module named pkg_resources - Stack Overflow | https://stackoverflow.com/
None of these worked.

What I ended up doing was:

<code class="language-bash">
curl -O https://bootstrap.pypa.io/get-pip.py
python3 get-pip.py --user
rm ~/.local/bin/pip # so the distro pip for Python 2.7 takes precedence
</code>
python  errormessage  annoyance  packaging  pip  ubuntu  16.04  workaround  solution 
february 2019 by kme
curl - ERROR: The certificate of `raw.githubusercontent.com' is not trusted - Stack Overflow | https://stackoverflow.com/
In my case, 'wget' gave a better error message than 'curl', and it told me that my organization was using a fake root CA, and 'wget' didn't recognize *its* issuer.

Solution for a Debian system at https://pinboard.in/u:kme/b:c57651a965b4 (convert issuer CA to PEM-encoded .crt, put in /usr/local/share/ca-certificates, and run 'sudo update-ca-certificates)
github  errormessage  ssl  cacert  certificates  crypto  headache 
january 2019 by kme
c++ - undefined reference to boost::system::system_category() when compiling - Stack Overflow | https://stackoverflow.com/
The '-lboost_filesystem' didn't work for me with the MacPorts version of Boost (either 1.59 or 1.65, I dunno), but setting '-DBOOST_SYSTEM_NO_DEPRECATED' did. Oh, and you also need '-lboost_filesystem-mt' (multithreaded?).
Linking with a library that defines the missing symbol (-lboost_system) is the obvious solution, but in the particular case of Boost.System, a misfeature in the original design makes it use boost::system::generic_category() and boost::system::system_category() needlessly. Compiling with the flag -DBOOST_SYSTEM_NO_DEPRECATED disables that code and lets a number of programs compile without requiring -lboost_system (that link is of course still needed if you explicitly use some of the library's features).
mac  osx  boost  compiler  linker  errormessage  solution 
january 2019 by kme
[SOLVED] apt-get upgrade keeps some packages back | https://www.linuxquestions.org/
Instead of running: sudo apt-get upgrade you should run: sudo apt-get dist-upgrade. This will install any new packages that are in the updates.
From a lot of testing that I have done, using the GUI update-manager in Ubuntu is the same as doing:
<code class="language-bash">
sudo apt-get update
sudo apt-get dist-upgrade
</code>

Both update-manager and dist-upgrade will remove old packages and install new ones that are in the updates. Just running sudo apt-get upgrade will only install new versions of packages that you already have on your system.
Write back if you need more help.
apt  apt-get  errormessage  packagemanagement  debian  ubuntu  sysadmin  annoyance  solution 
january 2019 by kme
python - pip: no module named _internal - Stack Overflow | https://stackoverflow.com/
What worked for me was:
<code class="language-bash">
sudo apt-get remove python-pip
</code>
python  pip  python27  debian  ubuntu  elementaryos  errormessage  solution 
december 2018 by kme
16.04 - /usr/sbin/fanctl: No such file or directory in /etc/network/if-up.d/ubuntu-fan" - Ask Ubuntu | https://askubuntu.com/
Not sure if this fixed anything (or broke Docker), but at least `ifup` works now without bombing with error code 127.
I had this happen after I installed and later removed Docker. The Docker daemon depends on FAN so it gets installed, but if you don't purge it upon removal the startup script in /etc/network/if-up.d/ sticks around. Remove it with apt remove --purge ubuntu-fan.
docker  networking  ubuntu  elementary  errormessage  maybesolution 
december 2018 by kme
Resolving EACCES permissions errors when installing packages globally
<code class="language-bash"># create a directory for global installations:
mkdir ~/.npm-global

# Configure npm to use the new directory path:
npm config set prefix '~/.npm-global'

# open or create a ~/.profile file and add this line:
export PATH=~/.npm-global/bin:$PATH

# update your system variables:
source ~/.profile

# install a package globally without using sudo:
npm install -g jshint</code>
javascript  nodejs  node  packagemanagement  errormessage  solution  annoyance  dammitbrain 
november 2018 by kme
install - Error in R: (Package which is only available in source form, and may need compilation of C/C++/Fortran) - Stack Overflow
There were two good ideas here: 1) using Rtools (https://cran.r-project.org/bin/windows/Rtools/); and 2) using binaries from https://cran.r-project.org/bin/windows/contrib/3.3.

What I ended up doing to solve this problem (shiny-1.2.0 w/ R 3.3.3 on Windows required httpuv-1.4.5, but only 1.4.1 was available as a binary for R 3.3.x on CRAN), was to download the Windows binary shiny_1.0.5zip from the URL in #2 above.

install.packages("https://cran.r-project.org/bin/windows/contrib/3.3/stringi_1.1.1.zip", repos =NULL)
r  rstudio  shiny  packagemanagement  errormessage  sortof  workaround  solution 
november 2018 by kme
Re: Compilation options for ncurses static library | https://lists.gnu.org/
I had this problem when compiling libedit-3.1 against a homebrew ncurses. The error you get looks like:

<code>/usr/bin/ld: path/to/lib/libncurses.a(lib_termcap.o): relocation R_X86_64_32S against `_nc_globals' can not be used when making a shared object; recompile with -fPIC
path/to/lib/libncurses.a: could not read symbols: Bad value
collect2: ld returned 1 exit status
</code>

Setting CFLAGS to include '-fPIC' and recompiling solved the problem.
build  toolchain  linker  compiler  errormessage  solution 
november 2018 by kme
Editline Library (libedit) - Port of NetBSD Command Line Editor Library | http://thrysoee.dk/
ncurses is required for libedit (which is required when you can't get Ruby 2.5.something to build with readline).

In order to build libedit successfully, you either need to have your ncurses headers in the $PREFIX/include directory, or explicitly give CFLAGS *and* CPPFLAGS a '-I/path/to/your/include/ncurses', because ncurses itself puts its headers in a 'ncurses' subdirectory.

The 'CPPFLAGS' one was surprise to me, but if you don't you get this error message while './configure' runs:
<code>checking ncurses.h presence... no
configure: WARNING: ncurses.h: accepted by the compiler, rejected by the preprocessor!
configure: WARNING: ncurses.h: proceeding with the compiler's result</code>
build  toolchain  headache  annoyance  workaround  solution  errormessage  lib 
november 2018 by kme
« earlier      
per page:    204080120160

Copy this bookmark:





to read