recentpopularlog in

kme : gitlab   96

« earlier  
Same steps for multiple named environments with GitLab CI - Stack Overflow
Yes, you can use anchors (https://docs.gitlab.com/ee/ci/yaml/#anchors). If I follow the documentation properly, you would rewrite it using a hidden key .XX and then apply it with <<: *X.

For example this to define the key:
<code class="language-yaml">.job_template: &deploy_definition
environment:
url: ${CI_ENVIRONMENT_SLUG}.mydomain.com
scripts:
- deploy ${CI_ENVIRONMENT_SLUG}</code>

And then all blocks can be writen using <<: *job_template. I assume environment will merge the name with the predefined URL.
<code class="language-yaml">
deploy_to_test:
<<: *deploy_definition
environment:
name: test

deploy_to_stage:
<<: *deploy_definition
environment:
name: stage

deploy_to_prod:
<<: *deploy_definition
environment:
name: prod</code>
testing  gitlab  gitlab-ci  yaml  anchors  syntax  reference 
8 weeks ago by kme
Multiline YAML string for GitLab CI (.gitlab-ci.yml) - Stack Overflow
Multi-line scalars (just break over multiple lines and indent at least up to the value in the previous line) will probably work fine in most cases, unless there's a ':' somewhere in the command line.

I used a "folded scalar":
A folded scalar is similar to a plain scalar in that all (single) newlines are substituted by a space during loading:
<code class="language-yaml">script:
- >
echo -e
"echo 'hi';
echo 'bye';"</code>
You need to indent the actual command information at least as much as the folded scalar indicator (>).

Contrary to plain scalars things like : have no special meaning. So if plain scalars fail by throwing a YAML error, similar folded scalars most likely won't.
yaml  gitlab  gitlab-ci  configuration  multilinestrings  solution 
8 weeks ago by kme
redis-cli just can not understand my input · Issue #6146 · antirez/redis
I get the error message "(error) ERR unknown command 'KEYS'" using the 3.2.someting version of 'redis-cli' that comes with GitLab Omnibus 11.something. Using '--scan --pattern "*"' is an acceptable workaround.

Possibly related mailing list thread: https://groups.google.com/forum/#!topic/redis-db/W68TQMkiNUw
errormessage  redis  redis-cli  gitlab 
december 2019 by kme
Redis command to get all available keys? - Stack Overflow
For some odd reason, the 3.2.something version of 'redis-cli' that comes with GitLab Omnibus just says "(error) ERR unknown command 'KEYS'", but using '--scan --pattern "session:gitlab:*"' works fine.

<code class="language-bash">redis-cli --scan --pattern '*'</code>
gitlab  redis  redis-cli  solution 
december 2019 by kme
Error 422 The change you requested was rejected on login (#40898) · Issues · GitLab.org / GitLab FOSS · GitLab
For those running into this issue, have you tried flushing the session store in Redis? Delete all keys that start with session:gitlab from Redis.


A good reference for that is https://docs.gitlab.com/ee/administration/operations/cleaning_up_redis_sessions.html, if you just update the instructions to use '/var/opt/gitlab/redis/redis.socket' and 'redis-cli --scan --pattern "session:gitlab:*"' instead.

Useful comments:
- (Apache) https://gitlab.com/gitlab-org/gitlab-foss/issues/40898#note_265993372
- (Redis) https://gitlab.com/gitlab-org/gitlab-foss/issues/40898#note_265995771
gitlab  sysadmin  error422  errormessage  solution 
december 2019 by kme
Cleaning up stale Redis sessions | GitLab
GitLab Omnibus puts the socket at /var/opt/gitlab/redis/redis.socket, and Redis 3.2.something doesn't accept the 'KEY' command anymore (use 'redis-cli --scan --pattern "session:gitlab:*"' instead), so update accordingly.

<code class="language-bash">rcli() {
# This example works for Omnibus installations of GitLab 7.3 or newer. For an
# installation from source you will have to change the socket path and the
# path to redis-cli.
sudo /opt/gitlab/embedded/bin/redis-cli -s /var/opt/gitlab/redis/redis.shared_state.socket "$@"
}

# test the new shell function; the response should be PONG
rcli ping</code>
sysadmin  gitlab  sessionmanagement  sessionstore  sessions  solution 
december 2019 by kme
README.md · master · GitLab.org / gitlab-workhorse · GitLab
FIXME: sit down and document how I *actually* did this. I don't think it was necessary to specify the auth backend in /etc/gitlab/gitlab.rb.
Relative URL support If you are mounting GitLab at a relative URL, e.g. example.com/gitlab, then you should also use this relative URL in the authBackend setting:
<code class="language-bash">gitlab-workhorse -authBackend http://localhost:8080/gitlab</code>
gitlab  workhorse  config  sysadmin  webmaster 
december 2019 by kme
Auto DevOps - YouTube | https://www.youtube.com/
This was actually a better explanation than the video that the marketing people gave me
gitlab  autodevops  cicd  automation  devel  video 
december 2019 by kme
Backups | GitLab
Note: Running
<code class="language-bash">sudo gitlab-ctl backup-etc <DIRECTORY></code> will place the backup in the specified directory. The directory will be created if it does not exist. Absolute paths are recommended.

Note: backup-etc introduced in GitLab 12.3.
gitlab  configuration  backup  disasterpreparedness  sysadmin  solution 
december 2019 by kme
apache - Apache2 ProxyPass for Rails App Gitlab - Stack Overflow
The problem I was having was a route that matched "/icons," and it was trying to serve GitLab's 'icons-[HASH].svg' from the filesystem, which resulted in a 404.
webmaster  gitlab  apache  rails  proxy  config  reference 
december 2019 by kme
Elasticsearch integration | GitLab
Note that you have to have a paid (at least "Starter") license for the Elasticsearch options to even show up in the Admin Area. It doesn't work to just stick some config options in /etc/gitlab/gitlab.rb and 'gitlab-ctl reconfigure'. :-(

<code class="language-bash"># Create empty indexes
sudo gitlab-rake gitlab:elastic:create_empty_index

# index personal snippets
sudo gitlab-rake gitlab:elastic:index_snippets
</code>
gitlab  gitlab-ee  elasticsearch  searchandindex  webmaster  sysadmin  solution 
december 2019 by kme
Elasticsearch settings in /etc/gitlab/gitlab.rb not used/mentioned/synced (#1581) · Issues · GitLab.org / GitLab · GitLab
You can't enable Elasticsearch just by putting these in /etc/gitlab/gitlab.rb. You actually have to have a ("Starter" or above) license.

<code class="language-ruby">## ElasticSearch (EE only)
# gitlab_rails['elasticsearch_enabled'] = false
# gitlab_rails['elasticsearch_host'] = "localhost"
# gitlab_rails['elasticsearch_port'] = 9200</code>
gitlab  elasticsearch  searchandindex  solution 
december 2019 by kme
ElasticSearch configuration via `gitlab.rb` (#3457) · Issues · GitLab.org / omnibus-gitlab · GitLab
Not a problem I have, just interesting. As of GitLab 12.5.something, you have to enable and configure Elasticsearch through the "Admin Area," and you have to have an active (paid) license.
gitlab  configuration  searchandindex  elasticsearch  interesting 
december 2019 by kme
GitLab Release and Maintenance Policy | GitLab
Under "Upgrade recommendations" they say upgrade to the latest point release, then do one minor release, *before* jumping major versions.

For example:
11.3.4 -> 11.11.8 -> 12.0.9 -> 12.5.8
gitlab  upgrade  migration  centos  solution 
december 2019 by kme
Gitlab update to version from 10.* - Questions & Answers / Upgrade - GitLab Forum
This is exactly what https://docs.gitlab.com/ee/policy/maintenance.html#upgrade-recommendations says anyway.

However, there's this tidbit:
Upgrading to 12.0 is absolutely safe. We run extensive tests internally before releases are made available. 12.0 should bring some improvements and additional features/functionality.

For the smoothest possible experience, I would suggest following this sequential upgrade path: 10.8.7 -> 11.3.4 -> 11.11.4 -> 12.0.2

You can check that the upgrade was successful between versions with:

sudo gitlab-rake gitlab:check

If you have any problems, reply to this with any error messages and relevant info.
gitlab  upgrade  bestpractices 
december 2019 by kme
GitLab Release and Maintenance Policy | GitLab
They say upgrade to the latest point release before jumping major versions.
gitlab  upgrade 
december 2019 by kme
github - Relative Link to Repo's Root from Markdown file - Stack Overflow
On GitLab, it seems to be '/../tree/whatever'.
after some research I've found such solution:

[the real relative root of any fork](/../../)
github  gitlab  gfm  markdown  relativelinks  maybesolution 
october 2019 by kme
offer to help with Python 3 support - Google Groups
Looking at Jun's work, it seems he is more or less reimplementing a subset of the functionality that six provides in `trac.util.compat`. I think adding six as a dependency or vendoring it (Django's solution) would save some work. Either approach is fine with me, just let me know what you think.
trac  wiki  issuetracker  python  2to3  needshelp  alterantiveto  github  gitlab  mediawiki 
june 2019 by kme
Rack Attack | GitLab
Documentation for GitLab Community Edition, GitLab Enterprise Edition, Omnibus GitLab, and GitLab Runner.
gitlab  sysadmin  rackattack  throttling  configsetting  maybesolution 
june 2019 by kme
Merge requests | GitLab
Interesting tip on how to make an alias accept arguments:
<code class="language-bash">[alias]
mr = !sh -c 'git fetch $1 merge-requests/$2/head:mr-$1-$2 && git checkout mr-$1-$2' -
</code>
git  gitlab  versioncontrol  scm  vcs  mergerequest  merging  devel  reference 
april 2019 by kme
Fail to clone over https without username in URL - Questions & Answers - GitLab Forum | https://forum.gitlab.com/
What does this do again?
<code class="language-bash">
git config --global credential.helper store
</code>
gitlab  git  cloneurl  needshelp  watchthisspace 
march 2019 by kme
Feature Highlight: Set Due Dates for Issues and Create Milestones | GitLab | https://about.gitlab.com/
GitLab has a powerful issue tracker that completely integrates into the GitLab workflow. Our team uses our issue tracker for almost everything, including projects that contain no code. We believe that if anything is significant enough to work on then it deserves an issue. Before GitLab 8.7, there was no way to communicate that you needed a specific issue to be completed by a specified time. While we had the ability to add milestones to issues and merge requests, there was no way to s...
gitlab  issues  collaboration  workflow  bestpractices 
march 2019 by kme
GitLab.com settings | GitLab | https://docs.gitlab.com/
<code>
DSA 7a:47:81:3a:ee:89:89:64:33:ca:44:52:3d:30:d4:87 p8vZBUOR0XQz6sYiaWSMLmh0t9i8srqYKool/Xfdfqw
ECDSA f1:d0:fb:46:73:7a:70:92:5a:ab:5d:ef:43:e2:1c:35 HbW3g8zUjNSksFbqTiUWPWg2Bq1x8xdGUrliXFzSnUw
ED25519 2e:65:6a:c8:cf:bf:b2:8b:9a:bd:6d:9f:11:5c:12:16 eUXGGm1YGsMAS7vkcx6JOJdOGHPem5gQp4taiCfCLB8
RSA b6:03:0e:39:97:9e:d0:e7:24:ce:a3:77:3e:01:42:09 ROQFvPThGrW4RuWLoL9tq9I9zJ42fK4XywyRtbOz/EQ
</code>
gitlab  ssh  fingerprint  hostkeyfingerprints  reference  fuckina  solution 
may 2018 by kme
Unlisted snippets (#13235) · Issues · GitLab.org / GitLab Community Edition · GitLab | https://gitlab.com/
I would like to have snippets that are viewable by everyone, but not listed everywhere (IE you have to know the URL). Just like secret gists on GitHub Gist.
gitlab  featurerequest  snippets  watchthisspace 
may 2018 by kme
How to debug Gitlab LDAP authentication? - Stack Overflow
Run GitLab's LDAP rake check to localize the problem. https://docs.gitlab.com/ce/administration/raketasks/ldap.html#check. There's also a more comprehensive one that's listed in the GitLab install document you're using.
gitlab  troubleshooting  ldap  authentication  sysadmin  webmaster  maybesolution 
december 2017 by kme
Could not authenticate you from ldapmain because "undefined method provider for nil:nilclass" - Troubleshooting - GitLab Community Forum
I got the error message

<code class="language-ruby">NoMethodError: undefined method `provider' for nil:NilClass</code>

inside OmniauthCallbacksController#failure when a user without an email from a whitelisted domain tried to log in. Not sure if the signup whitelist is checked for LDAP logins, but the solution may, in the end, be to just create the guy an email on the internal domain, because I'm pretty sure that will work fine.

This may, however, be the solution:
Solved myself: Log in as admin, goto Admin Area >> Settings >> Restricted domains for sign-ups.

Here is a list of domains which reflects the dns suffixes from the server.
gitlab  sysadmin  errormessage  maybesolution 
december 2017 by kme
Markdown - GitLab Documentation | https://docs.gitlab.com/
GFM also recognizes certain cross-project references:
input references
namespace/project#123 issue
namespace/project!123 merge request
namespace/project%123 project milestone
namespace/project$123 snippet
namespace/project@9ba12248 specific commit
gitlab  gfm  markdown  devel  reference  dammitbrain 
november 2017 by kme
Pagure: DIY git project hosting - Fedora Magazine | https://fedoramagazine.org/
Pagure is a new, full featured git repository service for the web, written in Python. It is similar to other popular git forges like Github and Gitlab, allowing open source contributors to share and collaborate on code and content. By the way, pagure is French for “hermit crab,” as reflected in the logo on the project documentation.
git  scm  fedorahosted  hosting  fedora  alternativeto  gitlab  github 
october 2017 by kme
git - How do I make GitLab delete old backups? - Server Fault | https://serverfault.com/
In /etc/gitlab/gitlab.rb I added the following line:

gitlab_rails['backup_keep_time'] = 60


Don't forget 'gitlab-ctl reconfigure' after that.
gitlab  backupandrecovery  backup  sysadmin  configfile  solution 
october 2017 by kme
gitlab-recipes/import/bitbucket at master · gitlabhq/gitlab-recipes | https://github.com/
The whole '@project="group%2Fproject_name"' thing (around line 26 of 'bitbucket2gitlab.rb') didn't work for me, so I looked up the actual project ID with the API and used that instead. Worked OK then.

In other words, https://server/api/v3/projects/group/project_name/issues is a 404, but https://server/api/v3/projects/<group_id>/issues works fine.

Maybe a "group" is not a "namespace"?
gitlab  bitbucket  importexport  sourcecodehosting  ruby  solution 
october 2017 by kme
Authentication log · User Settings · GitLab | https://tfwebdev.research.cchmc.org/
GitLab defaults its time zone to UTC. It has a global timezone configuration parameter in /etc/gitlab/gitlab.rb.

To update, add the time zone that best applies to your location. Here are two examples:

gitlab_rails['time_zone'] = 'America/New_York'

or

gitlab_rails['time_zone'] = 'Europe/Brussels'

After you added this field, reconfigure and restart:

gitlab-ctl reconfigure
gitlab-ctl restart
timezone  gitlab  configfile  solution 
october 2017 by kme
Missing webpack js after update to 8.17 (#28910) · Issues · GitLab.org / GitLab Community Edition · GitLab
Thanks the comment of @mgpawlik in #28759, my bug is finally fixed / is disappeared. He pointed me into the correct direction! It wasn't the apache config itself but I had to change config.serve_static_files = true to true in the file <gitlab_root>/config/environments/production.rb to serve static files. Now all JS works on my GitLab UI...
gitlab  errormessage  maybesolution 
may 2017 by kme
Error "Failed to load related branches" [possible regression] (#20141) · Issues · GitLab.org / GitLab Community Edition · GitLab
In my case, I had the 'external_url' parameter in gitlab.rb set incorrectly (missing the 's' in "https://").

The browser then "Blocked loading mixed active content".

I just randomly tried putting 'RequestHeader set X-Forwarded-Proto https' in a <LocationMatch> section within the GitLab Apache config, and that seems to work.

See also:

* https://en.wikipedia.org/wiki/List_of_HTTP_header_fields
* https://gitlab.com/gitlab-org/gitlab-ce/issues/20131
gitlab  errormessage  sortof  solution 
may 2017 by kme
Gitblit
Gitblit is an open-source, pure Java stack for managing, viewing, and serving Git repositories.

It's designed primarily as a tool for small workgroups who want to host centralized repositories.
git  hosting  server  java  devops  versioncontrol  alternativeto  gitlab  bitbucket  github  gog 
may 2017 by kme
Ability to configure sidekiq concurrency · Issue #2780 · gitlabhq/gitlabhq · GitHub
See also: https://gitlab.com/gitlab-org/gitlab-ce/issues/27640

P.S.: This doesn't really help with memory usage, so there's not much point.
at gitlab 8.16 installed with the omnibus package you can also control the number of concurrent sidekiq processes by editing the /etc/gitlab/gitlab.rb file. Just uncomment sidekiq['concurrency'] = 25 and alter.

As always, be sure to run gitlab-ctl reconfigure afterwards
(note: i've just installed the 8.16 package, i'm sure that it's also available in less current versions)
gitlab  sidekiq  configfile  memoryusage  sysadmin  solution 
may 2017 by kme
« earlier      
per page:    204080120160

Copy this bookmark:





to read