recentpopularlog in

kme : importexport   86

« earlier  
Downsampling a video with avconv / ffmpeg - Unix & Linux Stack Exchange
<code class="language-bash">ffmpeg -i in.avi -c:a copy -c:v libx264 -crf 23 -s:v 640x360 output.mp4</code>
video  downsampling  transcoding  importexport  commandline  solution 
28 days ago by kme
Firefox Bookmark Backup Reader/Decompressor — Fx File Utilities
Firefox creates frequent backups of your bookmarks. Automatic backups are compressed using Mozilla's flavor of LZ4 compression (.jsonlz4 file extension), while backups you create yourself (in the Library window) are not compressed (.json file extension by default). This tool can convert a backup file to the HTML export format.
firefox  bookmarks  json  jsonlz4  backupandrecovery  importexport  solution 
10 weeks ago by kme
shell - Unable to locate and replace an element with its classname using bash script? - Stack Overflow
The actual solution is
Clean it up into valid XHTML with tidy

I used
<code class="language-bash">tidy -f /dev/null -w 0 -n -q -asxhtml</code>
in a pipe to suppress all the extraneous warnings, and get XML that something like XMLStarlet could handle.
html  xhtml  xml  tidy  importexport  datamunging  solution  dammitbrain  fuckina 
september 2019 by kme
A stupid proposal: fill stackexchange with Miller · Issue #212 · johnkerl/miller | https://github.com/
Miller is like awk, sed, cut, join, and sort for name-indexed data such as CSV, TSV, and tabular JSON - johnkerl/miller
textprocessing  importexport  conversion  delimitedtext  tabdelimited  csv  miller  sampleusage  needshelp 
january 2019 by kme
DER vs. CRT vs. CER vs. PEM Certificates and How To Convert Them | https://support.ssl.com/
Microsofty things use the '.cer' extension (which is interchangeable with '.crt'), and are often DER-encoded. PEM-encoded certs are "ASCII (Base64) armored data" prefixed with a "-----BEGIN CERTIFICATE-----" line.

Here's how to "cat" a DER-encoded certificate:
<code class="language-bash">
openssl x509 -in certificate.der -inform der -text -noout
</code>

And here's how to convert one in that format to the format expected on a Debian GNU/Linux system:
<code class="language-bash">
openssl x509 -in cert.crt -inform der -outform pem -out cert.crt
</code>

NB: the '.crt' extension seems to be important, otherwise 'sudo update-ca-certificates' doesn't pick up on new ones that you've added to /usr/local/share/ca-certificates.
ssl  certs  cacert  certificates  openssl  sysadmin  webmaster  crypto  fuckina  solution  importexport  conversion 
january 2019 by kme
curl - Download/Export Public Google Spreadsheet as TSV from Command Line? - Stack Overflow - https://stackoverflow.com/
There's no really good answer in this thread, but here's the gist:

<code class="language-bash">
# the ID from the sharing URL
SHAREID=T2uGFNEuumY9WV21F1kEFItTWFehkI2nkntnHN-gh29E

# 0 for first sheet; for others, find this ID by switching to
# sheet and looking for '#gid=NUMBER' in browser's address bar
SHEETID=0

# 'csv' and 'tsv' both work; 'docx' and others may work, too
FORMAT=csv

# same as 'wget -O -'; outputs to stdout
curl "https://docs.google.com/spreadsheets/d/$SHAREID/export?gid=$SHEETID&format=$FORMAT"

# save some other sheet (gid=8675309) as a tab-delimited local file,
# using filename from the remote end (-OJ)
SHEETID=8675309
curl -LOJ "https://docs.google.com/spreadsheets/d/$SHAREID/export?gid=$SHEETID&format=$FORMAT"
</code>
google  googlesheets  gsheets  cli  curl  commandline  api  csv  importexport  solution  googledocs  tabdelimited 
january 2019 by kme
How to Open WebP Images in GIMP – Better Tech Tips | https://www.bettertechtips.com/
Or you can install 'webp' and 'imagemagick' packages and use 'convert' to convert to a format that GIMP or whatever can actually open natively.
webdevel  webdesign  webp  gimp  conversion  importexport  plugin  sortof  solution 
january 2019 by kme
converter - ffmpeg - Converting MOV files to MP4 - Stack Overflow | https://stackoverflow.com/
This worked:
<code class="language-bash">ffmpeg -i movie.mov -vcodec copy -acodec copy out.mp4</code>
mov  mp4  video  codec  conversion  transcoding  importexport  solution 
november 2018 by kme
Manual:Importing Wikipedia infoboxes tutorial - MediaWiki | https://www.mediawiki.org/
w:Module:Citation
w:Module:Hatnote
w:Module:Unsubst
w:Module:Sidebar
w:Module:Message_box
w:Module:Navbox
w:Module:Arguments
w:Module:Yesno
w:Module:Authority_control
w:Module:Infobox
w:Module:Navbar
w:Module:InfoboxImage
mediawiki  infoboxes  templates  importexport  howto  reference 
may 2018 by kme
mysql - Is it not possible to show warnings when using mysqlimport? - Stack Overflow | https://stackoverflow.com/
I used the mysql CLI tool, passing an equivalent "LOAD DATA ..." command followed by a semicolon, followed by "SHOW WARNINGS". The resulting display is helpful in finding detail on each warning.

For example:
<code class="language-bash">mysql <options> -e "LOAD DATA LOCAL INFILE 'foo' INTO TABLE bar; SHOW WARNINGS"</code>

P.S.: You will probably also need to add the '--local-infile=1' option or you'll get an error message about something not being supported in this version of MySQL.

What worked (finally) for me was:
<code class="language-sql">
mysql --login-path=dbserver --local-infile=1 --protocol=TCP \
-e 'load data local infile "zz_ensembl_genes.tsv" into table zz_ensembl_genes; show warnings;' \
the_database
</code>
dba  mysql  importexport  solution  debugging  logging  errormessage 
february 2018 by kme
Can error 1231 after importing a MySQL database be a compatibility issue? - Database Administrators Stack Exchange | https://dba.stackexchange.com/
This really did seem to have something to do with max_allowed_packet, because it worked between two VMs where they were both set to 64M, and failed on the MySQL server where it was only set to 16M.

Maybe try:
<code class="language-sql">/*!40101 SET @OLD_CHARACTER_SET_CLIENT=@@CHAR */;
/*!40101 SET @OLD_COLLATION_CONNECTION=@@COLL */;</code>
mysql  importexport  errormessage  dba  maybesolution 
february 2018 by kme
How to import CSV file to MySQL table - Stack Overflow | https://stackoverflow.com/

phpMyAdmin can handle CSV import. Here are the steps:

1. Prepare the CSV file to have the fields in the same order as the MySQL table fields.
2. Remove the header row from the CSV (if any), so that only the data is in the file. (not necessary --Ed.)
3. Go to the phpMyAdmin interface.
4. Select the table in the left menu.
5. Click the import button at the top.
6. Browse to the CSV file.
7. Select the option "CSV using LOAD DATA".
8. Enter "," in the "fields terminated by".
9. Enter the column names in the same order as they are in the database table.
10. Click the go button and you are done.

This is a note that I prepared for my future use, and sharing here if someone else can benefit.
database  dba  mysql  import  automation  csv  tabdelimited  solution  importexport 
january 2018 by kme
load data infile - Importing a very large tab delimited file into MySQL WITHOUT first creating a table - Stack Overflow | https://stackoverflow.com/
I don't want to create a table, I want some computer thing to figure out how long my fields need to be (and of what types) and then make the table automatically.
mysql  importexport  tabdelimited  needshelp 
january 2018 by kme
MAN2HTML
This is the one bundled with jimeh/manservant, that doesn't seem to work on Linux manual pages.
man2html  conversion  importexport  manual  manpages  documentation 
december 2017 by kme
excel - Convert xlsx to csv in linux command line - Stack Overflow
Mentioned in this thread:

- csvkit's 'in2csv'
- Gnumeric's 'ssconvert'
- libreoffice --headless --convert-to csv $filename --outdir $outdir
- xls2csv
- an R snippet
linux  excel  xlsx  textprocessing  importexport  conversion  reference 
december 2017 by kme
ASCII Tables (astropy.io.ascii) — Astropy v2.0.2
The entire 'astropy' distribution seems to be less than 10 MB, so it's kinda worth it to have it around.

<code class="language-python">
>>> data = ascii.read('/etc/passwd', format='no_header', delimiter=':')
>>> print(data[0:4])
col1 col2 col3 col4 col5 col6 col7
------ ---- ---- ---- -------------------------- --------------- ----------------
nobody * -2 -2 Unprivileged User /var/empty /usr/bin/false
root * 0 0 System Administrator /var/root /bin/sh
daemon * 1 1 System Services /var/root /usr/bin/false
_uucp * 4 4 Unix to Unix Copy Protocol /var/spool/uucp /usr/sbin/uucico
</code>
python  tables  ascii  textprocessing  importexport  solution 
october 2017 by kme
gitlab-recipes/import/bitbucket at master · gitlabhq/gitlab-recipes | https://github.com/
The whole '@project="group%2Fproject_name"' thing (around line 26 of 'bitbucket2gitlab.rb') didn't work for me, so I looked up the actual project ID with the API and used that instead. Worked OK then.

In other words, https://server/api/v3/projects/group/project_name/issues is a 404, but https://server/api/v3/projects/<group_id>/issues works fine.

Maybe a "group" is not a "namespace"?
gitlab  bitbucket  importexport  sourcecodehosting  ruby  solution 
october 2017 by kme
perl - How can I convert my JSON to CSV using jq? - Stack Overflow | https://stackoverflow.com/
Building upon Joe Harris' answer, you can use the @csv filter so that strings are properly quoted and escaped when necessary :

jq -r '[.case, .custom."speech invoked", .custom."input method"] | @csv'
jq  json  csv  importexport  textprocessing  webdevel  solution 
october 2017 by kme
sqlite - How to import a tsv file with SQLite3 - Stack Overflow
There is actually a dedicated mode for importing tab separated files:

sqlite> .mode tabs
sqlite> .import data.tsv people

Also if you include a header row in your tsv file, you can let sqlite automatically create the table. Just use an unused table-name during import and change the tsv file to:

name param1 param2
Bob 30 1000
Wendy 20 900
sqlite  importexport  tabdelimited  csv  solution 
june 2017 by kme
dumblob/mysql2sqlite: Converts MySQL dump to SQLite3 compatible dump
Using 'mysqldump' is no joke. SequelPro didn't work (at least with default options).
mysqldump --skip-extended-insert --compact [options]... DB_name
sqlite  conversion  dba  script  importexport  mysql  solution 
february 2017 by kme
openpyxl / openpyxl / issues / #537 - UserWarning: Unknown extension is not supported — Bitbucket
Solution was:

with warnings.catch_warnings() as w:
warnings.filterwarnings('ignore', 'Unknown extension')
wb = load_workbook(excelfile)
python  warnings  errormessage  excel  importexport  solution 
february 2017 by kme
MySQL: Enable LOAD DATA LOCAL INFILE - Stack Overflow
Yep, it actually *does* need to be in ~/.my.cnf.

From the MySQL 5.5 manual page:

LOCAL works only if your server and your client both have been configured to permit it. For example, if mysqld was started with --local-infile=0, LOCAL does not work. See Section 6.1.6, “Security Issues with LOAD DATA LOCAL”.

You should set the option:

local-infile=1

into your [mysql] entry of my.cnf file or call mysql client with the --local-infile option:

mysql --local-infile -uroot -pyourpwd yourdbname
mysql  importexport  dba  configfile  solution 
january 2017 by kme
Text Import Wizard - Excel
This has moved from File -> Import to the "Data" tab recently:
To start the Text Import Wizard, on the Data tab, in the Get External Data group, click From Text. Then, in the Import Text File dialog box, double-click the text file that you want to import.
excel  autoformat  autocorrect  annoyance  importexport  tsv  csv  solution 
december 2016 by kme
Decoding UTF-8 charset in an .EML file [http://www.perlmonks.org/]
I ran into this problem saving an email to the .eml format with Thunderbird. Mail.app on the Mac is an okay viewer for this kind of file, but what I really wanted was the UTF-8 source text to paste into LibreOffice.
email  encoding  utf8  importexport  conversion  maybesolution  sarcasm 
september 2016 by kme
Import CSV File Into MySQL Table
The following statement imports data from the c:\tmp\discounts.csv file into the discounts table.
LOAD DATA INFILE 'c:/tmp/discounts.csv'
INTO TABLE discounts
FIELDS TERMINATED BY ','
ENCLOSED BY '"'
LINES TERMINATED BY '\n'
IGNORE 1 ROWS;
1
2
3
4
5
6

LOAD DATA INFILE 'c:/tmp/discounts.csv'
INTO TABLE discounts
FIELDS TERMINATED BY ','
ENCLOSED BY '"'
LINES TERMINATED BY '\n'
IGNORE 1 ROWS;
mysql  importexport  csv  dba  database  solution 
july 2016 by kme
Xidel - HTML/XML/JSON data extraction tool
Easier to use than some of its counterparts:

<code class="language-bash">xidel https://lithub.com/the-ultimate-best-books-of-2018-list/ -e //title</code>
Pronounciation: To say the name "Xidel" in English, you say "excited" with a silent "C" and "D", followed by an "L". In German, you just say it as it is written.

Mirrored (?) at: http://videlibri.sourceforge.net/xidel.html
Source code at: https://github.com/benibela/xidel
FAQ at: https://github.com/benibela/xidel/wiki/Frequently-asked-questions
macOS build instructions: http://bit.ly/34VzheD (evernote.com)
textprocessing  html  xml  json  datamunging  extraction  importexport  cli  commandline  utility  software  xpath  xslt  alternativeto  xmlstarlet 
march 2016 by kme
linux - How do I clone an OpenLDAP database - Stack Overflow - http://stackoverflow.com/
http://stackoverflow.com/questions/792563/how-do-i-clone-an-openldap-database#2902158
For example, dump database from a master server under dc=master,dc=com and load it in a backup server

$ ldapsearch -Wx -D "cn=admin_master,dc=master,dc=com" -b "dc=master,dc=com" -H ldap://my.master.host -LLL > ldap_dump-20100525-1.ldif
$ ldapadd -Wx -D "cn=admin_backup,dc=backup,dc=com" -H ldap://my.backup.host -f ldap_dump-20100525-1.ldif

The -W flag above prompts for ldap admin_master password however since we are redirecting output to a file you wont see the prompt - just an empty line. Go ahead and type your ldap admin_master password and and it will work. First line of your output file will need to be removed (Enter LDAP Password:) before running ldapadd.

Last hint, ldapadd(1) is a hard link to ldapmodify(1) with the -a (add) flag turned on.
openldap  ldap  sysadmin  backupandrecovery  importexport  solution 
february 2016 by kme
import .eps file problem OSX - Gimptalk - Premier Gimp Community [http://www.gimptalk.com/]
I found my success by editing the default.env file, found at "Gimp.app/lib/gimp/2.0/environ" and just adding the line "GS_PROG=/usr/local/bin/gs" after which I was able to open/import .eps files AND .pdf files as well, which I was not able to do before.
gimp  mac  osx  solution  eps  importexport  environmentvariable 
august 2014 by kme
How to export PDF with EPS image in writer - Ask LibreOffice
In my case, here is what I did:

p=$(launchctl getenv PATH)
launchctl setenv PATH /opt/local/bin:/opt/local/sbin:$p

And it now finally works for me!!!


Didn't work for me, but using SVG instead did.
libreoffice  openoffice  eps  importexport  pdf  annoyance  bug  solution 
february 2014 by kme
Save an Access 2010 database in an earlier file format - Access - Office.com
Save a copy of an .accdb file in the .mdb file format

On the File tab, click Save & Publish.
Under Save Database As, do one of the following:
To save a copy of the database in a format that can be opened by using Access 2002 or later, click Access 2002 - 2003 Database (*.mdb).
To save a copy of the database in a format that can be opened by using Access 2000 or later, click Access 2000 Database (*.mdb).
Click Save As.
access  dba  mdb  accdb  importexport  windows  solution 
january 2014 by kme
« earlier      
per page:    204080120160

Copy this bookmark:





to read