recentpopularlog in

kme : issuetracker   15

#12130 (Add Python 3 compatibility using six) – The Trac Project
I doubt the branch discussed in comment:6 is suitable for use in production by even a very proficient Python developer. What's your motivation for running with Python 3?
python  2to3  trac  wiki  issuetracker  porting  needshelp 
june 2019 by kme
offer to help with Python 3 support - Google Groups
Looking at Jun's work, it seems he is more or less reimplementing a subset of the functionality that six provides in `trac.util.compat`. I think adding six as a dependency or vendoring it (Django's solution) would save some work. Either approach is fine with me, just let me know what you think.
trac  wiki  issuetracker  python  2to3  needshelp  alterantiveto  github  gitlab  mediawiki 
june 2019 by kme

Copy this bookmark:





to read