recentpopularlog in

kme : proxy   72

Configure Docker to use a proxy server | Docker Documentation
This didn't work, but this did: https://www.thegeekdiary.com/how-to-configure-docker-to-use-proxy/ (Method 2).

<code class="language-json">{
"proxies":
{
"default":
{
"httpProxy": "http://127.0.0.1:3001",
"httpsProxy": "http://127.0.0.1:3001",
"noProxy": "*.test.example.com,.example2.com"
}
}
}</code>
docker  proxy  http  maybesolution 
8 weeks ago by kme
How to configure docker to use proxy – The Geek Diary
See also: https://stackoverflow.com/questions/26166550/set-docker-opts-in-centos
1. Create a drop-in
<code class="language-bash">sudo mkdir /etc/systemd/system/docker.service.d</code>

2. Create a file with name /etc/systemd/system/docker.service.d/http-proxy.conf that adds the HTTP_PROXY environment variable:
<code class="language-ini">[Service]
Environment="HTTP_PROXY=http://user01:password@10.10.10.10:8080/"
Environment="HTTPS_PROXY=https://user01:password@10.10.10.10:8080/"
Environment="NO_PROXY= hostname.example.com,172.10.10.10"</code>

3. reload the systemd daemon
<code class="language-bash">sudo systemctl daemon-reload</code>

4. restart docker
<code class="language-bash">sudo systemctl restart docker</code>

5. Verify that the configuration has been loaded:
<code class="language-bash">sudo systemctl show docker --property Environment
# result:
# Environment=GOTRACEBACK=crash HTTP_PROXY=http://10.10.10.10:8080/ HTTPS_PROXY=http://10.10.10.10:8080/ NO_PROXY= hostname.example.com,172.10.10.10
</code>
docker  sysadmin  systemd  proxy  configfile  configuration  solution 
8 weeks ago by kme
apache - Apache2 ProxyPass for Rails App Gitlab - Stack Overflow
The problem I was having was a route that matched "/icons," and it was trying to serve GitLab's 'icons-[HASH].svg' from the filesystem, which resulted in a 404.
webmaster  gitlab  apache  rails  proxy  config  reference 
8 weeks ago by kme
Fixers — Werkzeug Documentation (0.12) | http://werkzeug.pocoo.org/
This wasn't the solution to any of the stupid mixed-content problems I ran into at work--yet.
flask  proxy  loadbalancer  maybesolution 
june 2018 by kme
openssl s_client using a proxy - Stack Overflow | https://stackoverflow.com/


You can use proxytunnel:

proxytunnel -p yourproxy:8080 -d www.google.com:443 -a 7000

and then you can do this:

openssl s_client -connect localhost:7000 -showcerts

Hope this can help you!
proxy  debugging  http  https  webdevel  sysadmin  webmaster  ssl  cert  cacert  solution 
december 2017 by kme
perl - CPAN first launch (Proxy Configuration) - Stack Overflow | https://stackoverflow.com/
See also:

which has this actual solution:
Try these:

Before running cpan: export -n http_proxy
In the cpan shell: o conf http_proxy ''
To save your modified cpan config: o conf commit

That will disable any http proxy CPAN is configured to use.
cpan  http  proxy  annoyance  errormessage 
october 2017 by kme
perl - Force CPAN to download via HTTP - Server Fault | https://serverfault.com/
Try these:

Before running cpan: export -n http_proxy
In the cpan shell: o conf http_proxy ''
To save your modified cpan config: o conf commit

That will disable any http proxy CPAN is configured to use.
perl  cpan  http  proxy  annoyance  fuckina  solution 
october 2017 by kme
perl - Using CPAN with a proxy failing after o conf init /proxy/ - Stack Overflow
Solution for me (from https://serverfault.com/a/130736) was to 'cpan o conf http_proxy ""' and remove the username and password entirely.

Then just having HTTP_PROXY and friends set in the environment seemed to work.
perl  packagemanagement  errormessage  cpan  proxy  annoyance  maybesolution 
august 2017 by kme
Can a BlueCoat SSL Proxy steal your password? : networking
If there's a certificate in the chain that doesn't match, it's most likely an internal certificate from your organisation. If it is, then they're performing TLS inspection and they can see your details.
ssl  tls  proxy  ca  snooping  surveillance  security  privacy 
june 2017 by kme
Git 1.9 — Software Collections
Just remember to 'sudo -s' if root's .bashrc is where the 'http_proxy' variables are getting set, otherwise you get weird errors like:
$ sudo yum install git19
Loaded plugins: fastestmirror, refresh-packagekit, rhnplugin, security
This system is receiving updates from RHN Classic or Red Hat Satellite.
Setting up Install Process
Loading mirror speeds from cached hostfile
http://mirror.centos.org/centos/6/sclo/x86_64/rh/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "Failed to connect to 2606:d280:3::2: Network is unreachable"
Trying other mirror.
http://mirror.centos.org/centos/6/sclo/x86_64/sclo/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "Failed to connect to 2606:d280:3::2: Network is unreachable"
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: centos-sclo-sclo. Please verify its path and try again
git  centos  errormessage  proxy  yum  packagemanagement  solution 
may 2017 by kme
Unable to use yum getting: 14: PYCURL ERROR 7 - "Failed to connect to 2a02:2498:1:3d:5054:ff:fed3:e9 - Page 2 - CentOS
In my case, it was because I was using 'sudo' to run 'yum update' instead of running it in a root shell, with HTTP_PROXY and friends set in the environment (presumably by .bashrc).
I had the exactly same problem. I was too much focus on disabling ipv6. But it turned out the message itself has nothing to do with ipv6. In my case, it was
missing proxy setting in the /etc/yum.conf. As soon as I added "proxy=http://<ipv4addr>:3128" to yum.conf, everything started working.
yum  proxy  ipv6  errormessage  centos  centos6  solution 
march 2017 by kme
php 5.3 - PHP Composer behind http proxy - Stack Overflow
Fiddling with HTTP(S)_PROXY_REQUEST_FULLURI environment variables didn't seem to make a difference but this did;

iconoclast's answer did not work for me.

I upgraded my php from 5.3.* (xampp 1.7.4) to 5.5.* (xampp 1.8.3) and the problem was solved.

Try iconoclast's answer first, if it doesn't work then upgrading might solve the problem.
php  compooser  webdevel  errormessage  proxy  solution 
december 2016 by kme
Apache redirect to another port - Stack Overflow [http://stackoverflow.com/]
You should leave out the domain http://example.com in ProxyPass and ProxyPassReverse and leave it as /. Additionally, you need to leave the / at the end of example/ to where it is redirecting. Also, I had some trouble with http://example.com vs. http://www.example.com - only the www worked until I made the ServerName www.example.com, and the ServerAlias example.com. Give the following a go.

<VirtualHost *:80>
ProxyPreserveHost On
ProxyRequests Off
ServerName www.example.com
ServerAlias example.com
ProxyPass / http://localhost:8080/example/
ProxyPassReverse / http://localhost:8080/example/
</VirtualHost>
apache  proxy  webmaster  hosting  webserver  solution 
november 2016 by kme
webserver - Difference between proxy server and reverse proxy server - Stack Overflow

A pair of simple definitions would be

Forward Proxy: Acting on behalf of a requestor (or service consumer)

Reverse Proxy: Acting on behalf of service/content producer.


See also: http://httpd.apache.org/docs/2.4/mod/mod_proxy.html#forwardreverse
networking  proxy  apache  http  terminology  web  reference  solution  explained 
january 2015 by kme
Roland Schulz: SSH ProxyCommand without netcat

The ProxyCommand is very useful when hosts are only indirectly accessible. With netcat it is relative strait forward:
ProxyCommand ssh {gw} netcat -w 1 {host} 22

Here {gw }and {host} are placeholders for the gateway and the host.

But it is also possible when netcat is not installed on the gateway:
ProxyCommand ssh {gw} 'exec 3<>/dev/tcp/{host}/22; cat <&3 & cat >&3;kill $!'

The /dev/tcp is a built-in feature of standard bash. The files don't exist. To check whether bash has this feature built-in use run cat < /dev/tcp/google.com/80 on the gateway. To make sure that bash is used, use:
ProxyCommand ssh {gw} "/bin/bash -c 'exec 3<>/dev/tcp/{host}/22; cat <&3 & cat >&3;kill $!'"
ssh  proxy  openssh  networking  remoteaccess  maybesolution 
december 2014 by kme
Fixing "authentication is required to set the network proxy ..." on Redhat/REL/OEL | Oracle Corner
From a terminal window run "gnome-session-properties" and un-check "PackageKit Update Applet"
centos  packagemanagement  errormessage  proxy  solution 
september 2014 by kme
Error 0x80072efd - PatchAholic...The WSUS Blog!
Not a solution at all, just for future reference. Solved my problem by removing a registry key associated with an intranet WU server at HKLM\Software\Policies\Microsoft\Windows\WindowsUpdate\AU (source: http://www.pctools.com/guides/registry/detail/1241/)
windows  winxp  update  errormessage  proxy  windowsupdate 
may 2014 by kme
Polipo — a caching web proxy
Polipo has some features that are, as far as I know, unique among currently
browser  cache  utility  linux  sysadmin  webmaster  proxy 
september 2013 by kme

Copy this bookmark:





to read