recentpopularlog in

kme : rubygems   13

ruby on rails - How can I remove a default gem? ! want to uninstall a gem 1.7.7 version of json - Stack Overflow | https://stackoverflow.com/
I had to remove the (duplicate) '<ruby_install_dir>/lib/ruby/gems/<ruby_major_ver>/specifications/default/json-x.y.z.gemspec' file from my specifications/default directory.

The top-rated answer was confusingly verbose, but it did contain the solution in there, somewhere.
ruby  rubygems  errormessage  annoyance  solution 
march 2019 by kme
Error installing json 1.8.3 with ruby 2.4 - Stack Overflow | https://stackoverflow.com/
I did <code class="language-bash">gem install -v 1.8.6 json</code> and it worked.
I ran into the same issue recently as well, try and see if there's a newer version of whatever gem you're using that depends on json 1.8.3. This is happening because Ruby 2.4 unified Fixnum and Bignum into Integer. If you're able to upgrade to json 1.8.5 or higher, it should help fix your problems.
ruby  annoyance  errormessage  rubygems  gem  solution 
march 2019 by kme
osx - Why can't Ruby find my Net::SCP? - Stack Overflow
The error message I get from 'veewee' after installing it in the usual way is "LoadError: cannot load such file -- net/scp." Apparently, it did not pull in the 'net-scp' package properly as a dependency.
I chose to install my gem home in my home directory to avoid permissions issue with OXS El Capitan. gem list shows net-scp (1.2.1) – Pierre-Loup Jan 20 at 21:47
veewee  macos  mac  osx  ruby  headache  rubygems  errormessage  solution 
june 2016 by kme
Resolving TZInfo::DataSourceNotFound Errors · tzinfo/tzinfo Wiki · GitHub
You may encounter a TZInfo::DataSourceNotFound exception with the message No source of timezone data could be found when you use TZInfo or other libraries that depend on it (for example, Active Support and Ruby on Rails). The error indicates that TZInfo was unable to find a source of time zone data on your system. This will typically occur if you are using Windows.

The simplest way to resolve this error is to install the tzinfo-data gem, either by editing your Gemfile or by running gem install tzinfo-data.

On most Unix-based systems (e.g. Linux), TZInfo is able to use the system zoneinfo directory as a source of data. However, Windows doesn't include such a directory, so the tzinfo-data gem needs to be installed instead. The tzinfo-data gem contains the same zoneinfo data, but is packaged as a set of Ruby modules.
rails  rubygems  windows  errormessage  solution 
july 2014 by kme

Copy this bookmark:





to read