recentpopularlog in

kme : storage   173

« earlier  
Activating a volume group
CentOS 7 seems to make an LVM group by default, and that's fine. When mounting it in a recovery environment, you need to do this in order to access the data on disk:

<code class="language-bash"># vgchange -a y my_volume_group</code>
centos  centos7  linux  sysadmin  storage  lvm  solution 
8 weeks ago by kme
GNU Core Utilities Frequently Asked Questions - https://www.gnu.org/
Useful:
<code class="language-bash"> alias del='mv --verbose --backup=simple --suffix=$(date +".(%F_%T)") --target-directory=$HOME/.Trash/'</code>

See also: http://gentoo-wiki.com/HOWTO_Move_Files_to_a_Trash
linux  storage  extfs  ext2fs  ext3fs  ext4fs  undelete  reference 
12 weeks ago by kme
How to Delete Recovery Partition in Windows 7/8/10 (Solved)
One time I had this Windows (VM) where the recovery partition was *after* the C: partition, preventing me from resizing it. Disk Management snap-in prevents you from deleting this partition. Bullshit.

You can 'delete partition override' in DISKPART, though.
windows  win10  storage  diskmanagement  diskadministrator  sysadmin  solution 
12 weeks ago by kme
Solved: Isilon Vs ECS - Dell Community
Furthermore Isilon is more a "Filecentric" solution which offers you access to files through different protocols while ECS is "Objectstorage" which offers you acces to objects through several protocols, this said ECS has WORM by design.

Think of ECS in the same way as you may have thought of Centera in the past, a really big archive. It can do more as sluetze said with regards to geo-load balancing and so-forth, and supports the Centera CAS API, and S3. File protocols were added later to ECS initially NFSv3 only, and I think recently SMB as well. But on the big data side it doesn't speak HDFS like Isilon does, and it's not meant to be best of breed performance for really large HDFS datasets. As I understand it the HDFS access is actually over NFS using a java library. So maybe a good spot for cold buckets of data, not hot.
enterpriseclass  storage  isilon  emc  ecs  sysadmin 
november 2019 by kme
find disk usage per user on a filesystem
<code class="language-bash">find / -printf "%u %s\n" \
| awk '{user[$1]+=$2}; END{ for( i in user) print i " " user[i]}'</code>
bash  unix  sysadmin  diskusage  quota  storage  solution 
september 2019 by kme
macos - How to check whether there is bad sector on an external USB hard disk on OS X? - Super User

The OS X built in command fsck_hfs has an option -S that apparently will check whether there is bad block on a USB hard disk on OS X.

From the official man page:
<code>-S Cause fsck_hfs to scan the entire device looking for I/O
errors. It will attempt to map the blocks with errors to names,
similar to the -B option.</code>

Example:
<code class="language-bash">fsck_hfs -fy -S /dev/disk3s11</code>

It seems to be doing that when run on partitions without bad blocks but I've yet to check/document what it does when there are bad blocks.
storage  disasterrecovery  hardwaremonitoring  repair  commandline  mac  osx  fsck 
may 2019 by kme
encryption - LUKS and loop device - Ask Ubuntu | https://askubuntu.com/
For me, what worked was:

<code class="language-bash">
head -c 100M /dev/zero > crypt
sudo cryptsetup luksFormat crypt
sudo cryptsetup luksOpen crypt
sudo mke2fs /dev/mapper/c1

# then mount with the file manager
</code>

Finally:
<code class="language-bash">
sudo cryptsetup luksClose filecontainer
</code>
crypto  blockdevice  storage  linux  howto  sortof  solution  alternativeto  truecrypt 
march 2019 by kme
Where are checkdisk/scandisk logs ? - Windows 7 Help Forums
if I remember try..

Go to Start > Run and type: eventvwr.msc /s , and hit enter.
When Event Viewer opens, click on "Application", then scroll
down to "Winlogon" and double-click on it. This is the log
created after running Checkdisk.

In Event viewer, under Application logs, you need to double click on "wininit".

"Winlogon" is applicable for XP.
windows  scandisk  logging  systemmonitoring  sysadmin  storage  troubleshooting  solution 
december 2016 by kme
Data corruption on USB flash drive | FreeNAS Community
That I think is open for debate and interpretation. ZFS on solaris was designed so that on a loss of power the worst that would happen is any transactions that were in progress would roll back. ZFS on FreeBSD is based on the solaris code, but is not a copy/paste. So there might be small differences.

From what I've seen in the forums since I read every post is that some people have problems recovering from a loss of power. Often those people also did other things wrong like used a RAID array for ZFS, shorted their system on RAM by a large margin, didn't use ECC RAM, etc. So it's hard to put a finger and say that the loss of power was solely responsible for the problem. Many users also don't know what they are talking about and deny that some things are the way they are despite them providing logs that disagree with them.

I've had to do some hard power cycling and never had a problem. In fact, most users have had no problems with a loss of power with FreeNAS. But.. a few users do.

Also worth considering is that many users are not running server grade parts. They aren't buying high quality server-grade components like what Solaris hardware ran on and instead looking for the absolute cheapest motherboard, CPU, RAM, SATA controller, and other components for as cheap as they can find. That's just plain stupid to do if you actually value your data. Often those cheap components aren't reliable and shouldn't ever be used in a server. But they do it anyway and often the symptom is performance and reliability issues but there's no smoking gun for the exact component that didn't perform as expected.

For one, comparing building desktops to servers is comparing apples to oranges. Additionally, if a desktop breaks its not a big deal, you just replace it. But if a server goes down the consequences are far more serious. I've had plenty of people message me in IRC asking me to help them recover their data because their business will be ruined otherwise and 10 people's lifes and jobs depend on this server to work.

I'd say if you aren't using server grade stuff you shouldn't expect server level reliability. For years computer geeks have enjoyed bending that rule. But FreeNAS isn't for those amateurs that don't want to go to the big leagues and are willing to buy the proper hardware. You can certainly use desktop hardware. Just don't be shocked when it doesn't go well for you.

Aside from that, you've really provided little evidence to point to any one thing as the culprit. You didn't use server grade, but that's not necessarily a deal breaker. It often is, but there's now guarantee for that. It's also possible you purchased some USB sticks from somewhere that ended up with fake Corsair USB sticks. I'm not saying that is your problem or that I have any evidence that is the case. But that is possible. There's lots of possibilities that you can consider if you really want to think about it. Unfortunately, only you can effectively determine where the fault is.

You really have provided no evidence of anything being wrong. So its hard to help you. Can you post the actual error message you are getting? It could be you are interpreting something as being wrong when that error is normal. Some errors on bootup are completely normal. And what version of FreeNAS are you using?
nas  zfs  freenass  discussion  storage  sysadmin  datacorruption  bestpractices 
july 2016 by kme
osx - How do I prevent a disk from mounting? - Super User [http://superuser.com/]
sudo touch /etc/fstab
sudo sh -c 'echo "UUID=3B5315C1-96AE-3471-B43C-2C41CDB12A64 none hfs rw,noauto" >> /etc/fstab'


Also super-useful:

https://github.com/aburgh/Disk-Arbitrator
mac  osx  storage  diskimage  partitioning  fstab  sysadmin  annoyance  solution 
july 2016 by kme
[vbox-dev] Attaching .vdi image as a removable disk [https://www.virtualbox.org/]
Actually, if you give 'usb-creator-gtk' the '--allow-system-internal' flag, you can just directly install onto another attached .vdi.
ubuntu  liveusb  virtualbox  storage  installation  virtualization  solution 
july 2016 by kme
VirtualBox – Cannot Register the Hard Drive Because a Hard Drive with UUID Already Exists – Bradley Schacht
I looked all over the place to find what was causing it and finally found a fix. Of course it requires the command prompt, so open that junk up and let’s get started!

**Note that I am on VirtualBox version 4.1.6 and from what I’ve read this command used to be something different a few versions ago. I think instead of setdhuuid it was setvdiuuid, but don’t hold me to that.**

Open the Command Prompt
Change the directory to where VirtualBox is installed (Default: C:Program FilesOracleVirtualBox)
Type the following VBOXMANAGE.EXE internalcommands sethduuid <PathOfNewVHD>

Note that internalcommands and sethduuid need to be lowercase. I spent more than a couple minutes trying to figure out why things weren’t working.
virtualbox  storage  errormessage  virtualdisks  diskimage  solution 
april 2016 by kme
How to use Diskpart commands line to convert/resize/delete partitions?
Content mill? All the same, DISKPART.EXE worked for the simple case of having just resized a VDI with VBoxManage modifyhd --resize <MB>; just SELECT DISK, then SELECT PARTITION, then do your thing.
Extends the volume or partition (increase size) in DiskPartTo extend the volume or partition with focus and its file system into free (unallocated) space which can be used to store data on a disk, use following command syntax:

extend [size=<n>] [disk=<n>] [noerr]

The above command works on when both volume or partition is selected.

Example:

extend size=500

(Increase the size of current partition or volume selected by 500MB.)
windows  sysadmin  hdd  storage  commandline  reference  partitioning  resize  solution 
february 2016 by kme
How to Change the UUID of a Linux Partition | Sudo JuiceSudo Juice
You'll want to do this if you, e.g., use GParted to copy a partition from one drive to another.
linux  storage  grub  disk  blkid  uuid  howto  installation  solution 
december 2015 by kme
« earlier      
per page:    204080120160

Copy this bookmark:





to read