recentpopularlog in

kme : toolchain   202

« earlier  
How do I identify and eliminate unused CSS styles from my bloated stylesheet? - Stack Overflow
<code class="language-bash">npm install uncss -g</code>
Then
<code class="language-bash">uncss http://example.com/ > out.css</code>
webdevel  css  minifier  cleaner  commandline  build  toolchain  maybesolution 
8 weeks ago by kme
Goals (GNU make)
You use the *variable* '.DEFAULT_GOAL' *not* the special target '.DEFAULT' (which I don't even know what that does).
<code class="language-makefile">.DEFAULT_GOAL = targetname</code>
make  makefile  build  toolchain  dammitbrain  weirauchlab 
10 weeks ago by kme
How to Get CMake to Use Default Compiler on System PATH? - Stack Overflow
OK, so it's *not* ignoring $PATH, it's just prefering 'cc' and 'c++', which just happen to point to the OS-default compilers in /usr/bin, rather than the ones loaded by, say, 'module load gcc/8.1.0'.
CMake honors the setting of the PATH environment variable, but gives preference to the generic compiler names cc and c++. To determine which C compiler will be used by default under UNIX by CMake, run:
<code class="language-bash">$ which cc
</code>
To determine the default C++ compiler, run:
<code class="language-bash">$ which c++</code>
If you generate a symbolic link c++ in /opt/gcc-4.8/bin which points to /opt/gcc-4.8/bin/g++, CMake should use GCC 4.8 by default.
cmake  build  toolchain  annoyance  solution 
december 2019 by kme
linux - How to get CMake to use the default compiler on system PATH? - Stack Overflow
As is already written in the answer to the other question, CMake prefers the generic compiler names cc and c++ when searching for the C and C++ compilers. These probably refer to GNU version 4.1 compilers on your system.

Anyway, to force CMake to use the default compilers on the system path, add the following code to the beginning of your outermost CMakeLists.txt.
<code class="language-cmake">find_program(CMAKE_C_COMPILER NAMES $ENV{CC} gcc PATHS ENV PATH NO_DEFAULT_PATH)
find_program(CMAKE_CXX_COMPILER NAMES $ENV{CXX} g++ PATHS ENV PATH NO_DEFAULT_PATH)
...
project (Foo C CXX)</code>
The find_program calls must occur before the call to project or enable_language.
cmake  build  toolchain  annoyance  workaround 
december 2019 by kme
[SOLVED] XCode 7 and Qt error | Qt Forum
In my case the error
<code>clang: warning: no such sysroot directory</code>
was caused by Xcode.app being in an Applications/Developer subdirectory, and some part of the build process not expecting that.

The fix was to move it back to /Applications and run 'sudo xcode-select -s /Applications/Xcode.app'.
xcode  errormessage  anoyance  build  toolchain  clang  maybesolution 
october 2019 by kme
undefined reference to symbol 'XFlush' · Issue #1 · archetipo/leapmouse · GitHub | https://github.com/
I ran into this issue trying to compile gSTM on elementaryOS Loki 5.0, based on Ubuntu 18.04, and I had to add `-lX11 -lxml2` in about three different places in 'src/Makefile'. Still didn't run.
build  compiler  toolchain  linker  errormessage  maybesolution 
august 2019 by kme
Issue 31652: make install fails: no module _ctypes - Python tracker
Had to build and install libffi into the PREFIX for Python-3.7.4 when building it from source on CentOS 7.

See also: https://bugs.python.org/issue34036
centos  centos7  fromsource  build  toolchain  compiler  errormessage  python  workaround  solution 
august 2019 by kme
Autoconf, Libtool, and an undefined AC_PROG_LIBTOOL - Super User
This fixed this for me—modifying the supplied 'autogen.sh', so that it ran this command instead:
<code class="language-bash">autoreconf -v -f -i -I /usr/share/aclocal</code>
To fix this if you already have a /usr/local/share/aclocal directory, type the following as root:
<code class="language-bash">for file in argz libtool ltdl ltoptions ltsugar ltversion lt~obsolete
do
ln -s /usr/share/aclocal/$file.m4 /usr/local/share/aclocal/$file.m4
done
</code>

To fix this if you don't have a /usr/local/share/aclocal directory, type the following as root:
<code class="language-bash">ln -s /usr/share/aclocal /usr/local/share/aclocal</code>

Voilà -- problem solved.
autoconf  errormessage  build  toolchain  centos7  annoyance  solution 
august 2019 by kme
Re: Lua and pkg-config .pc file | http://lua-users.org/
I was trying to build 'highlight' (https://gitlab.com/saalen/highlight) and got a 'lua.pc' not found error. This was the solution

<code class="language-bash">
make pc INSTALL_TOP=/wherever/you/stow/lua-5.3.5 > lua.pc
</code>

This was just an off-the-cuff answer from someone who probably doesn't know 'pkg-config' very well, though, because it *still* doesn't work unless you add 'Name:', 'Version:', and 'Description:' fields to the .pc file.

THEN, you can move that 'lua.pc' into '/wherever/you/stow/lua-5.3.5/lib/pkgconfig' and update the PKG_CONFIG_PATH environment variable.
lua  build  toolchain  errormessage  library  pkg-config  annoyance  workaround  solution 
july 2019 by kme
linux - Why does BASH process substitution not work with some commands? - Unix & Linux Stack Exchange | https://unix.stackexchange.com/
The error message would come about when you tried to do something like
<code class="language-bash">
gcc <(echo "#include <X11/Xatom.h>
> int main() { return 0; }") -lX11
# result:
# /dev/fd/63: file not recognized: Illegal seek
# collect2: error: ld returned 1 exit status
</code>
gcc wants to be able to perform random access on its input files to detect what language they are written in. If you instead give gcc a hint about the input file's language, it's happy to stream the file:
<code class="language-bash">
gcc -x c <(echo 'int main(){return 0;}')
</code>/blockquote>
devel  build  toolchain  makefile  gcc  bash  processsubstitution  solution 
february 2019 by kme
macos - Using the pkg-config macro PKG_CHECK_MODULES failing - Stack Overflow | https://stackoverflow.com/
The solution in my case was to build and install automake-1.16 and pkg-config-0.29.something, which were newer than the OS-supplied versions.
devel  centos  centos6  pkg-config  build  toolchain  errormessage  sortof  solution 
february 2019 by kme
"help2man: can't get `--help' info from automake-1.16" · Issue #6275 · Linuxbrew/homebrew-core | https://github.com/
Ran into this problem trying to build 'automake-1.16' from source; 'module load'ing a new-ish Perl and then re-doing './configure' fixed the problem, I guess.
automake  build  toolchain  errormessage  solution 
february 2019 by kme
linux - C++ error: undefined reference to 'clock_gettime' and 'clock_settime' - Stack Overflow | https://stackoverflow.com/
Got this error building MySQL 5.6 from source (in the 'libmysql' subdirectory) and this seemed to fix i: add '-lrt' to the end of '-DCMAKE_CXX_FLAGS=' command line option when initially running 'cmake'.
Add -lrt to the end of g++ command line. This links in the librt.so "Real Time" shared library.
build  toolchain  compiler  error  mysqlclient  mysql  solution 
february 2019 by kme
sucks | suckless.org software that sucks less | https://suckless.org/
cmake (written in C++) - so huge and bloated, compilation takes longer than compiling GCC (!). It’s not even possible to create freestanding Makefiles, since the generated Makefiles call back into the cmake binary itself. Usage of cmake requires learning a new custom scripting language with very limited expressiveness. Its major selling point is the existence of a clicky-click GUI for windows users.
build  toolchain  annoyance  rant 
january 2019 by kme
Building R for Windows
You can install the Rtools package in order to install packages that are only available as source (like httpuv-1.4.5, which is required by shiny-1.2.0, which is not available in the CRAN repos for R 3.3.3).
build  compiler  toolchain  r  sortof  solution 
november 2018 by kme
How do I compile Readline support into Ruby - Stack Overflow | https://stackoverflow.com/
This is *NOT* work for me. I ended up using 'libedit' instead, after much exasperation, trials, and tribulations.
ruby  readline  compiler  build  toolchain  fromsource  headache  workaround  solution 
november 2018 by kme
Bug #8762: CFLAGS and LDFLAGS are not set properly in Makefile when they are already set as environment variables - Ruby trunk - Ruby Issue Tracking System | https://bugs.ruby-lang.org/
I thought I had this problem, but I think it turned out that the CFLAGS *were* actually being fed to the compiler. They just weren't being reported in the './configure' summary.
ruby  fromsource  compiler  build  toolchain  maybebug  makefile 
november 2018 by kme
Re: Compilation options for ncurses static library | https://lists.gnu.org/
I had this problem when compiling libedit-3.1 against a homebrew ncurses. The error you get looks like:

<code>/usr/bin/ld: path/to/lib/libncurses.a(lib_termcap.o): relocation R_X86_64_32S against `_nc_globals' can not be used when making a shared object; recompile with -fPIC
path/to/lib/libncurses.a: could not read symbols: Bad value
collect2: ld returned 1 exit status
</code>

Setting CFLAGS to include '-fPIC' and recompiling solved the problem.
build  toolchain  linker  compiler  errormessage  solution 
november 2018 by kme
Editline Library (libedit) - Port of NetBSD Command Line Editor Library | http://thrysoee.dk/
ncurses is required for libedit (which is required when you can't get Ruby 2.5.something to build with readline).

In order to build libedit successfully, you either need to have your ncurses headers in the $PREFIX/include directory, or explicitly give CFLAGS *and* CPPFLAGS a '-I/path/to/your/include/ncurses', because ncurses itself puts its headers in a 'ncurses' subdirectory.

The 'CPPFLAGS' one was surprise to me, but if you don't you get this error message while './configure' runs:
<code>checking ncurses.h presence... no
configure: WARNING: ncurses.h: accepted by the compiler, rejected by the preprocessor!
configure: WARNING: ncurses.h: proceeding with the compiler's result</code>
build  toolchain  headache  annoyance  workaround  solution  errormessage  lib 
november 2018 by kme
gnu make - makefile: concatenate text with infix operator - Stack Overflow | https://stackoverflow.com/


Louis is correct: there's no magical way of doing this. But if, instead of trying to remove the last item or treat it specially, you instead treat the first item specially, the work is much simpler to understand (I think); you can create a function combine that takes two arguments: the first is the text to put between the words and the second is a space-separated list of words to combine:
<code class="language-makefile">combine = $(word 1,$2) $(foreach W,$(wordlist 2,$(words $2),$2),$1 $W)</code>

Now you can use it like this:
<code class="language-makefile">$(call combine,-o,$(EXCLUDE_LIST))</code>

to get output like:
<code class="language-">$(BASE_DIR)/aaa* -o $(BASE_DIR)/bbb*</code>
devel  build  toolchain  makefile  stringfunctions  workaround  solution 
november 2018 by kme
linux - How to install `build-essential` in `Cygwin`? - Stack Overflow | https://stackoverflow.com/
Build-essential is a collection of packages. So you'll have to select the packages manually, which I believe are the following:

- make
- automake
- gcc
- gcc-c++
windows  cygwin  devel  build  toolchain  gcc  cplusplus  maybesolution  likedebian 
june 2018 by kme
What is cmake equivalent of 'configure --prefix=DIR && make all install '? - Stack Overflow | https://stackoverflow.com/
You can pass in any CMake variable on the command line, or edit cached variables using ccmake/cmake-gui. On the command line,
<code class="language-bash">cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr . && make all install</code>

Would configure the project, build all targets and install to the /usr prefix. The type (PATH) is not strictly necessary, but would cause the Qt based cmake-gui to present the directory chooser dialog.
cmake  build  toolchain  devel  dammitbrain  solution 
march 2018 by kme
The magic behind configure, make, make install | https://robots.thoughtbot.com/
aclocal # Set up an m4 environment
autoconf # Generate configure from configure.ac
automake --add-missing # Generate Makefile.in from Makefile.am
./configure # Generate Makefile from Makefile.in
make distcheck # Use Makefile to build and test a tarball to distribute
automake  autotools  unix  build  toolchain  newbie  reference  solution 
september 2017 by kme
installation on Mac OS from source with error · Issue #5 · sdray/ade4 | https://github.com/
I was trying to install the motifStack Bioconductor package when I got this error.
ld: library not found for -lgfortran
clang: error: linker command failed with exit code 1 (use -v to see invocation)


Installing gfortran-4.2.3.pkg from CRAN's "R for Mac OS X" page helped, but I got the same error for libquadmath right afterwards, so it's not a total solution, and something else must be wrong.
errormessage  clang  compiler  toolchain  r  mac  osx  almost  solution 
september 2017 by kme
Eclipse Community Forums: C / C++ IDE (CDT) » cdt debug can't find source files
In my case, I had to map '/' -> 'c:\cygwin64'
My Projects ara all under J:\Projects, so my mapping needs to be present in Eclipse as:

/cygdrive/j j:/

Open Eclipse and then click

- Windows => Preferences... => C/C => Debug =>Common Source Lookup Path

- Add a new Path Mapping: click [Add] => Path Mapping => [OK]

- Select the new Mapping => [Edith] => change Name of Mapping "Project Source" => [Add]

- set "Compilation path" to the Source (Sample cygwin "/cygdrive/j" (without the quotes

- set"Local file system path" tho "J:\" (without the quotes

Now you are ready ti give it another try.... good luck
cygwin  windows  eclipse  cdt  build  toolchain  errormessage  solution 
august 2017 by kme
c++ - How to deal with Eclipse CDT+Cygwin? - Stack Overflow
Not super helpful. Some of the package names mentioned in one of the answers have already changed.
eclipse  cygwin  cdt  windows  toolchain  compiler  maybesolution 
august 2017 by kme
Stuck on an older toolset version? Move to Visual Studio 2017 without upgrading your toolset | Visual C++ Team Blog
If you're getting this error message for VB or C## projects try this: https://msdn.microsoft.com/en-us/vstudio/dn425032.aspx (build tools v120, which is I think what VS 2013 shipped with)

No dice for Visual C++ projects, unfortunately.
visualstudio  windows  ide  devel  build  toolchain 
july 2017 by kme
KeePassX – Requirements
On elementaryOS Loki (Ubuntu 16.04) I had to install

libqt4-dev libxtst-dev qt4-qmake

and maybe not required, but for good measure, qt4-default.

I also had to add "#include <unistd.h>" to src/lib/random.cpp as described at https://stackoverflow.com/a/17837158.
build  toolchain  fromsource  keepass  ubuntu  elementary  solution  keepassx 
may 2017 by kme
gnu make - Makefile variable assignment - Stack Overflow
Lazy Set

VARIABLE = value

Normal setting of a variable - values within it are recursively expanded when the variable is used, not when it's declared
Immediate Set

VARIABLE := value

Setting of a variable with simple expansion of the values inside - values within it are expanded at declaration time.
Set If Absent

VARIABLE ?= value

Setting of a variable only if it doesn't have a value
Append

VARIABLE += value

Appending the supplied value to the existing value (or setting to that value if the variable didn't exist)
makefile  toolchain  compiler  devel  reference  newbie  dammitbrain  solution 
march 2017 by kme
Series: Unix as IDE « Arabesque
How is UNIX an IDE?

The primary rationale for using an IDE is that it gathers all your tools in the same place, and you can use them in concert with roughly the same user interface paradigm, and without having to exert too much effort to make separate applications cooperate. The reason this becomes especially desirable with GUI applications is because it’s very difficult to make windowed applications speak a common language or work well with each other; aside from cutting and pasting text, they don’t share a common interface.

The interesting thing about this problem for shell users is that well-designed and enduring Unix tools already share a common user interface in streams of text and files as persistent objects, otherwise expressed in the axiom “everything’s a file”. Pretty much everything in Unix is built around these two concepts, and it’s this common user interface, coupled with a forty-year history of high-powered tools whose users and developers have especially prized interoperability, that goes a long way to making Unix as powerful as a full-blown IDE.

However, it often becomes apparent to me when reading about these efforts that the developers concerned are trying to make these text editors into IDEs in their own right. There are posts about never needing to leave Vim, or never needing to leave Emacs. But I think that trying to shoehorn Vim or Emacs into becoming something that it’s not isn’t quite thinking about the problem in the right way. Bram Moolenaar, the author of Vim, appears to agree to some extent, as you can see by reading :help design-not. The shell is only ever a Ctrl+Z away, and its mature, highly composable toolset will afford you more power than either editor ever could.
unix  devel  toolchain  asanide 
march 2017 by kme
linux - How to install g++ 4.9.2 in Cent OS 6.5? - Super User
CentOS 6/7 official support this. You don't need third party repository. And gcc version is 4.9.2 in CentOS's repo.

yum install centos-release-scl-rh
yum install devtoolset-3-gcc devtoolset-3-gcc-c++

To use the updated tools, start a new shell using the scl command:

scl enable devtoolset-3 bash

More information on the SCL from CentOS and from Red Hat
gcc  cplusplus  compiler  toolchain  c++14  centos  centos6  solution 
february 2017 by kme
HowTos/SetupRpmBuildEnvironment - CentOS Wiki
To create the RPM building environment, run the two commands below:
<code class="language-bash">mkdir -p ~/rpmbuild/{BUILD,RPMS,SOURCES,SPECS,SRPMS}</code>

<!> Beware: this next command will overwrite an existing .rpmmacros file if it exists, so check that you don't already have one before continuing.
<code class="language-bash">echo '%_topdir %(echo $HOME)/rpmbuild' > ~/.rpmmacros</code>
centos  fromsource  srpm  rpm  build  toolchain  howto  reference 
february 2017 by kme
xcode - Unable to use xcodebuild on Mavericks with Command Line Tools installed - Stack Overflow

I know that this is a late answer, but in my case this command solved the issue:
<code style="language-bash">sudo xcode-select --switch /Applications/Xcode.app/Contents/Developer</code>
mac  osx  devel  build  toolchain  cli  commandline  xcode  annoyance  solution  elcapitan 
december 2016 by kme
mpicc command not found with openmpi
mpicc' is in the package 'openmpi-devel'.


You can list the installed files from a package with :
rpm -ql openmpi


'openmpi-devel' will provide /usr/lib/openmpi/1.4-gcc/bin/mpicc
... and 250 other files.
mpi  openmpi  devel  build  toolchain  centos  solution 
december 2016 by kme
centos - OPEN MPI is not working for me - Stack Overflow
They mention using Environment Modules to load the module (on Centos 6 it's called 'openmpi-1.10-x86_64'), but there's still no 'mpic++'.

The solution is to install 'openmpi-devel', which provides the compilers (or wrappers).
mpi  openmpi  centos  build  toolchain  almost  solution 
december 2016 by kme
« earlier      
per page:    204080120160

Copy this bookmark:





to read