recentpopularlog in

kme : ubuntu   327

« earlier  
windows - How to fix PuTTY showing garbled characters? - Server Fault
The analogous fix on CentOS (7) is to use 'localectl', maybe, except that requires DBus to be running, which it isn't for a fresh-out-of-the-box Docker container. ¯\_(ツ)_/¯
If the locale returns something like POSIX, issue
<code class="language-bash">update-locale LANG=en_US.utf8</code>
at the command line - see thomas-krenn.com/de/wiki/Locales_unter_Ubuntu_konfigurieren – koppor Dec 19 '15 at 11:05
docker  utf8  characterencoding  locale  mojibake  terminal  unix  shell  ubuntu  solution  centos  sortof 
june 2019 by kme
guake hangs when you put exit on the CLI and then choose No. · Issue #1014 · Guake/guake | https://github.com/
To whom hangs on Ubuntu 18.04

#1198 (comment) mentioned a solution:

sudo apt install --reinstall libutempter0

This works for me
guake  hang  elementaryos  ubuntu  18.04  solution 
may 2019 by kme
Ubuntu: Rename an Account [ User ID ] - nixCraft
'usermod -l newuserid olduserid', but 'groupmod -n newgroupid oldgroupid'.
ubuntu  linux  sysadmin  usermanagement  usermod  solution 
may 2019 by kme
package management - Restoring all data and dependencies from dpkg --set-selections '*' - Ask Ubuntu
Preferred to 'dpkg --get-selections', apparently, which WTF does 'dpkg --get-selections' even do then, anyway?
<code class="language-bash">
# Backup:
apt-mark showauto > pkgs_auto.lst
apt-mark showmanual > pkgs_manual.lst

# Restore:
sudo apt-mark auto $(cat pkgs_auto.lst)
sudo apt-mark manual $(cat pkgs_manual.lst)
</code>
dpkg  apt  debian  ubuntu  packagemanagement  backupandrecovery  solution 
may 2019 by kme
python - No module named pkg_resources - Stack Overflow | https://stackoverflow.com/
None of these worked.

What I ended up doing was:

<code class="language-bash">
curl -O https://bootstrap.pypa.io/get-pip.py
python3 get-pip.py --user
rm ~/.local/bin/pip # so the distro pip for Python 2.7 takes precedence
</code>
python  errormessage  annoyance  packaging  pip  ubuntu  16.04  workaround  solution 
february 2019 by kme
add a docker configuration file · Issue #937 · moby/moby | https://github.com/
Answer: there apparently is no '/etc/docker/docker.conf'; on Debian-derived distros, there's an /etc/default/docker, where you can set the DOCKER_OPTS environment variable for the daemon, though.
docker  ubuntu  debian  centos  configfile  configuration  reference 
january 2019 by kme
Best way to move docker directory · Issue #3127 · moby/moby | https://github.com/
Good evening, I'm looking for the best way to move docker directory (default /var/lib/docker) to another directory. (Technically other disk partition) I'm using devicemapper, and I think a lot of things are mounted, so it's not as easy a...
docker  configfile  centos  ubuntu  migration  reference 
january 2019 by kme
ubuntu - Using dnsmasq with NetworkManager - Super User | https://superuser.com/
This didn't fix anything for me, but https://stackoverflow.com/a/24189767/785213 did --that is, set DOCKER_OPTS in /etc/default/docker to the corporate DNS servers, instead of the defaults which are, like, Google's DNS servers or something. Then 'sudo systemctl restart docker'.
If this is right I think that, as you say, the only solution to the problem is to disable the NM-drive dnsmasq by commenting out the line
<code class="language-bash">
dns=dnsmasq
</code>

in the file /etc/NetworkManager/NetworkManager.conf and install the "standard" dnsmasq and then configure it via its standard /etc/dnsmasq.conf configuration file.
dns  docker  dnsmasq  networking  ubuntu  annoyance 
january 2019 by kme
Comment #33 : Bug #959037 : Bugs : network-manager package : Ubuntu | https://bugs.launchpad.net/
I think that there is a clash of civilizations here: the Debian way (modular components that just work together in any combination allowed by package dependencies) versus the RedHat way (big daemons with limited options that own subsystems).
networkmanager  dnsmasq  networking  debian  ubuntu 
january 2019 by kme
[SOLVED] apt-get upgrade keeps some packages back | https://www.linuxquestions.org/
Instead of running: sudo apt-get upgrade you should run: sudo apt-get dist-upgrade. This will install any new packages that are in the updates.
From a lot of testing that I have done, using the GUI update-manager in Ubuntu is the same as doing:
<code class="language-bash">
sudo apt-get update
sudo apt-get dist-upgrade
</code>

Both update-manager and dist-upgrade will remove old packages and install new ones that are in the updates. Just running sudo apt-get upgrade will only install new versions of packages that you already have on your system.
Write back if you need more help.
apt  apt-get  errormessage  packagemanagement  debian  ubuntu  sysadmin  annoyance  solution 
january 2019 by kme
python - pip: no module named _internal - Stack Overflow | https://stackoverflow.com/
What worked for me was:
<code class="language-bash">
sudo apt-get remove python-pip
</code>
python  pip  python27  debian  ubuntu  elementaryos  errormessage  solution 
december 2018 by kme
16.04 - /usr/sbin/fanctl: No such file or directory in /etc/network/if-up.d/ubuntu-fan" - Ask Ubuntu | https://askubuntu.com/
Not sure if this fixed anything (or broke Docker), but at least `ifup` works now without bombing with error code 127.
I had this happen after I installed and later removed Docker. The Docker daemon depends on FAN so it gets installed, but if you don't purge it upon removal the startup script in /etc/network/if-up.d/ sticks around. Remove it with apt remove --purge ubuntu-fan.
docker  networking  ubuntu  elementary  errormessage  maybesolution 
december 2018 by kme
Index of /bin/linux/ubuntu | https://cran.r-project.org/
Some people have reported difficulties using this approach. The issue is usually related to a firewall blocking port 11371. If the first gpg command fails, you may want to try (thanks to Mischan Toosarani for the tip):
<code class="language-bash">
gpg --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys E298A3A825C0D65DFD57CBB651716619E084DAB9
</code>

and then feed it to apt-key with
<code class="language-bash">
gpg -a --export E298A3A825C0D65DFD57CBB651716619E084DAB9 | sudo apt-key add -
</code>

Another alternative approach is to search for the key at http://keyserver.ubuntu.com:11371/ and copy the key to a plain text file, say key.txt. Then, feed the key to apt-key with
<code class="language-bash">
sudo apt-key add key.txt
</code>
r  installation  ubuntu  packages  keyserver  errormessage  workaround  solution 
november 2018 by kme
apt - "GPG error:The following signatures were invalid: KEYEXPIRED" - Ask Ubuntu | https://askubuntu.com/
That ppa has been removed and no longer exists. You must find a different source for the packages installed through the samrog131 ppa.

In the meantime, run the following commands to resolve the situation.

First, to delete the expired key:
<code class="language-bash">
sudo apt-key del 1436387333
</code>

Then, to delete the ppa:
<code class="language-bash">
sudo rm /etc/apt/sources.list.d/samrog131*
sudo apt-get clean
sudo apt-get update
</code>

If you need to add a key see here.
<code class="language-bash">
sudo apt-get upgrade
</code>

You may want to run:
<code class="language-bash">
sudo apt-get dist-upgrade
</code>

depending on your situation. If you are not sure, see here.
ubuntu  apt  packagemanagement  crypto  pubkey  errormessage  solution 
november 2018 by kme
keyring - Private SSH key with password no longer stays unlocked for session - elementary OS Stack Exchange | https://elementaryos.stackexchange.com/
Script 90x11-common_ssh-agent should somehow start your ssh-agent. But not add the keys. If you want to add a key with the first usage, you can configure ssh to do so in ~/.ssh/config:

AddKeysToAgent yes
ssh  ssh-agent  keyring  elementaryos  ubuntu  annoyance  solution 
january 2018 by kme
Compose Key - Solus Forums
The terminal command works fine, but you can also install (might be installed by default) gnome-tweak-tool. You can search it in software gui or type

Code: Select all

sudo eopkg it gnome-tweak-tool


This worked for the Ubuntu Budgie remix, too.
composekey  specialcharacters  keyboard  inputmethod  ubuntu  linux  budgie  solution 
january 2018 by kme
SecurityTeam/KnowledgeBase/SpectreAndMeltdown - Ubuntu Wiki
The one for CVE-2017-5753 is listed as "pending" as of 19 January 2018.
ubuntu  spectre  meltdown  vulnerability  kpti  patch  sysadmin  reference 
january 2018 by kme
17.04 - Errors updating zesty packages - apt update/upgrade - Ask Ubuntu
As described in release notes. Zesty will be supported for 9 months until January 2018. Therefore you can use old-releases site, to install zesty packages.


You'll need to change the "partner" repository to use 'archive.canonical.com', though. A global search-and-replace won't work for that one, it'll leave 'apt-get update' in a broken state.
apt  ubuntu  packagemanagement  oldversion  solution 
january 2018 by kme
MySQL Bugs: #72663: MySQL Workbench 6.1.4 error when open MySQL Utilities. | https://bugs.mysql.com/
How to fix.

In file: /usr/lib/mysql-workbench/modules/wb_utils_grt.py
should replace line:
for term in ["gnome-terminal", "konsole", "xterm", "rxvt"]:
to line:
for term in ["gnome-terminal", "konsole", "xterm", "rxvt", "xfce4-terminal"]:
mysql  workbench  bug  ubuntu  16.04  elementaryos  loki  solution 
december 2017 by kme
How do I make my systemd service run via specific user and start on boot? - Ask Ubuntu
tl;dr: Put the unit file in ~/.config/systemd/user, then enable it with 'systemctl --user enable'.
systemd  ubuntu  linux  sysadmin  initscript  sortof  solution 
december 2017 by kme
I have been using Gnome desktop since the announcement and here's what I think : Ubuntu
I did the same thing, and tried it after the announcement came out that Unity was dead. However I am actually still using it, and have come to like it. That said, I had to make a TON of adjustments from stock.

Stock Gnome sucks. But add the right extensions, and GTK theme and shell theme, and you're back in business.

Arc, Arc Dark & Arc Darker are fabulous themes and get rid of that top bar that is stupid large. The new(er) United theme is pretty good too. I flip back and forth. Adwaita is horrid.

Dash to Dock, Frippery Move Clock, Top Icons Plus and Workspace Grid are a must for extensions. Up and down for switching workspaces, what were they thinking? Fortunately this can be changed with the Workspace Grid extension. I also have also have the, Alternate Tab, Openweather and Dynamic Panel Transparency extensions installed/enabled to round out the look, and make the default look go far, far away.

I can't figure out how to modify the notifications either, but I'm getting used to where they are now.

I also had to install the DMZ mouse cursors, again because the default Adwaita stuff is horrible.

To move the buttons, use dconf editor. Navigate to: /org/gnome/desktop/wm/preferences/button-layout - then change the order to: close,minimize,maximize:appmenu

Ahhhhhh! Much better!
ubuntu  gnomedesktop  whither  unity  customization  tipsandtricks  de 
december 2017 by kme
6.12. pam_issue - add issue file to user prompt
Yeah, but in elementaryOS Luna, the pam.d/login thing mentioned in the README.Debian doesn't work. You have to edit /etc/init/ttyX.conf, and add '-f /etc/issue.linuxlogo' to each "getty" invocation.
debian  ubuntu  elementaryos  elementary  console  eyecandy  configfile  workaround  maybe  solution 
december 2017 by kme
How to install certificates for command line - Ask Ubuntu
The ca-certificates package has the instructions in its README.Debian:

If you want to install local certificate authorities to be implicitly trusted, please put the certificate files as single files ending with .crt into /usr/local/share/ca-certificates/ and re-run update-ca-certificates.

Note that it mentions a directory different from the other answers here:

/usr/local/share/ca-certificates/

After copying into /usr/local/share/ca-certificates/ you can then update the cert's permissions and run sudo update-ca-certificates as mentioned in Telegraphers answer. You will see in the output that the cert was added.


Also notable (not strictly true, since .cer files are a Windows thing, binary, in ASN.1/DER format):
Extensions .crt, .pem and .cer are interchangeable, just change the file name extension, they have the same form.
ssl  certificate  ubuntu  linux  sysadmin  howto  solution  ca 
june 2017 by kme
How to install certificates for command line - Ask Ubuntu
For everything to work and not only your browser, you need to add that CA certificate to the system's trusted CA repository.

In ubuntu:

Go to /usr/share/ca-certificates/
Create a new folder, i.e. "sudo mkdir school"
Copy the .crt file into the school folder
Make sure the permissions are OK (755 for the folder, 644 for the file)
Run "sudo update-ca-certificates"
sysadmin  ubuntu  linux  ca  certificates  ssl  github  mitm  solution 
june 2017 by kme
init.d - service vs. initctl - Ask Ubuntu
This is not a duplicate. The other answer doesn't even mention 'initctl'.
initclt  upstart  sysvinit  ubuntu  solution 
may 2017 by kme
Ubuntu - WineHQ Wiki
Don't forget to download and install the key.
ubuntu  wine  installation  packagemanagement  ppa  elementaryos  solution 
may 2017 by kme
KeePassX – Requirements
On elementaryOS Loki (Ubuntu 16.04) I had to install

libqt4-dev libxtst-dev qt4-qmake

and maybe not required, but for good measure, qt4-default.

I also had to add "#include <unistd.h>" to src/lib/random.cpp as described at https://stackoverflow.com/a/17837158.
build  toolchain  fromsource  keepass  ubuntu  elementary  solution  keepassx 
may 2017 by kme
Ubuntu 16.04 doesn't hibernate - Ask Ubuntu
I cloned a partition from one device to another and changed the UUID of the original swap partition, so hibernate didn't work anymore. The culprit is /etc/initramfs-tools/conf.d/resume. Even if you remembered to update /etc/fstab and do a new 'update-grub' this is the last thing you need to update if any of your drive letters' UUIDs were changed (intentionally or unintentionally).

The 'resume=' option isn't required (somehow it's given to the kernel by the initramfs environment). The "pci=nomsi" kernel option looks interesting (but didn't change anything on the VAIO VGC-JS110J).
ubuntu  hibernate  powermanagement  configfile  fuckina  solution  vgcjs110j 
may 2017 by kme
[SOLVED] Can We Have Grub2 simpy ignore a 2nd drive?
OSPROBED="`os-prober | grep /dev/sdb | tr ' ' '^' | paste -s -d ' '`"
linux  ubuntu  grub  configfile  solution 
may 2017 by kme
Grub2/Troubleshooting - Community Help Wiki
This is what you do when you get an 'error: file not found' error and a "grub rescue>" prompt.

set prefix=(hdX,Y)/boot/grub
set root=(hdX,Y)
insmod normal
normal
grub  troubleshooting  solution  bootmanager  errormessage  linux  ubuntu 
may 2017 by kme
AcpiSupportDeprecation - Ubuntu Wiki
I changed stuff in /etc/default/acpi-support on an Ubuntu Xenial (elementaryOS Loki 0.4) and nothing happened. Maybe here's why:
/etc/default/acpi-support

We have the following settings by default:

SUSPEND_METHODS: Defaults to dbus-pm and dbus-hal, which is what gnome-power-manager, KDE, etc. use as well. Also, this value is not used anywhere in acpid, acpi-support, or any other package, thus it is a dead variable which should just be eliminated.
Some variables for the legacy built-in suspend support: this mode is already deprecated

So the entire file can just be dropped as soon as acpi-support internal suspend/resume handling should stop being supported.
ubuntu  linux  acpi  powermanagement  deprecation  reference 
may 2017 by kme
How can I install Skype on Freya? - elementary OS Stack Exchange
This was necessary, in addition to enabling the "Canonical partner" software source:
sudo dpkg --add-architecture i386
skype  ubuntu  linux  solution  elementary 
may 2017 by kme
release freya - elementary tweaks will not Install - elementary OS Stack Exchange
I had this problem, but the problem was that I was trying to use a Loki (v0.4) version of elementary-tweaks on Freya (v0.3).
elementaryos  ubuntu  packagemanagement  errormessage  ppa  solution 
may 2017 by kme
How to disable secure-file-priv MySQL Ubuntu - Super User
The mysql documentation on secure_file_priv states that the variable is set to a default, platform-specific filesystem location, to make it secure by default.

That said, you need to explicitly set the variable to an empty string in your configuration to disable this security feature.

For Ubuntu, edit the file /etc/mysql/mysql.conf.d/mysqld.cnf and add the following line at the end:
<code>secure_file_priv=""</code>
mysql  dba  database  ubuntu  debian  linux  errormessage  annoyance  configfile  solution 
january 2017 by kme
« earlier      
per page:    204080120160

Copy this bookmark:





to read