recentpopularlog in

kme : virtualbox   80

Linux Mint 19.1 Cinnamon Release Notes - Linux Mint | https://www.linuxmint.com/
These release notes are actually *helpful*. Covers the issue I had with garbled display on VirtualBox *and* being able to move around windows that are too large (like Timeshift's setup wizard) to fit on the screen at the default screen resolution.

The problem I had with the system menu not showing up on the first reboot after setup went away after resetting the menus (or a reboot).
If the screen is garbled when launching Linux Mint in Virtualbox, switch to console with HOST+F1 (e.g. the RIGHT Ctrl key, no ALT) and back to tty7 with HOST+F7.

Another workaround is to disable "nested paging" (in the System -> Acceleration settings) and to increase the video memory to 128MB (in the Display settings).

Note: This issue only affects the live session. You don't need these workarounds post-installation.
virtualbox  linuxmint  linux  releasenotes  virtualization  solution 
february 2019 by kme
Wonky display on this one Win10 startup screen in VirtualBox - Linux Mint Forums | https://forums.linuxmint.com/
I asked a question a few days ago about a video snow display when booting LM19 Live DVD in Virtual Box. Turns out that you need to use R-CTRL / F2 followed by R-CTRL / F7 [Host-F2, Host-F7] to go in and out of a terminal to clear the snow. Have you tried this to fix your Wonk? Maybe the Linux Graphics Drive is not really up to snuff with the Virtual Machine Host graphics. After installing the LM 19 system in the VM I have not seen snow again. Or any Wonk. Or at least now your kind of Wonk.
linuxmint  virtualization  virtualbox  graphics  linux  annoyance  solution 
february 2019 by kme
windows 7 - Setting up VirtualBox guest for PXE boot - Super User | https://superuser.com/
Solution: make sure the VM is using bridged networking (to the physical host adapter, 'eno1' or whatever) and install the Oracle secret-sauce Extension Pack.

Older releases here: https://www.virtualbox.org/wiki/Download_Old_Builds_5_1
virtualbox  virtualization  networking  pxe  pxeboot  secretsauce  nonfree  fuckina  solution 
january 2019 by kme
virtualbox.org • View topic - PXE boot from bridged adaptor | https://forums.virtualbox.org/
Lots of good suggestions here, but all that was *really* necessary was to bridge the physical adapter ('eno1' for me) and install the non-free Extension Pack.

The bundled PXE ROM is not sufficient to boot the Windows workstation installation environment.

See also: https://superuser.com/a/448743/73744
pxe  pxeboot  networking  virtualbox  windows  win7  virtualization  sortof  solution 
january 2019 by kme
virtualbox.org • View topic - Paste into Linux Console?
Hrm, yeah, no, I'm not sure whether bidirectional clipboard sharing ever worked in the console
virtualbox  console  clipboardsharing  clipboard  gpm 
december 2017 by kme
networking - PXE boot with Virtualbox - Server Fault
The PXEboot server that VirtualBox's (default) NAT network interface communicates with is built-in, that's why the filename it looks for matches the name of the VM.

I set up a bridged adapter (br0) using the instructions here (https://wiki.ubuntu.com/QemuPxe) and told the VirtualBox VM to use that instead. Then everything worked fine.
After clarification, not using VirtualBox's built-in PXE feature at all seems the way to go. Instead, assign a secondary NIC with "host only" or "internal" networking to server and client, and bind the DHCP server to listen at the second interface. Do not use Intel cards for the second interface: PXE Booting Virtualbox guests in internal networking mode?

Answer to VirtualBox NAT and PXE:

vmname.pxe contains the code your VM runs after downloading it, the so called NBP (Network Bootstrap Program)
virtualbox  networking  pxeboot  tftp  sortof  solution 
october 2017 by kme
VirtualBox Guest Additions on Fedora 26/25, CentOS/RHEL 7.3/6.9/5.11 - If Not True Then False
<code class="language-bash">yum update kernel*
rpm -Uvh https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
yum install gcc kernel-devel kernel-headers dkms make bzip2 perl
export KERN_DIR=/usr/src/kernels/`uname -r`</code>
virtualbox  centos  centos7  fedora  fedora30  guestadditions  dammitbrain  annoyance  solution 
august 2017 by kme
VirtualBox VMs and Windows Vista license keys
Odd thing: booting from a Vista DVD in VirtualBox, I get asked for a license key; then, after entering a presumably valid one, I get an error about some file on the setup drive being missing or corrup...
windows  vista  licensing  licensekey  virtualbox  virtualizationandemulation  solution 
may 2017 by kme
Basic Usage - Synced Folders - Vagrant by HashiCorp
Modifying the Owner/Group

By default, Vagrant mounts the synced folders with the owner/group set to the SSH user. Sometimes it is preferable to mount folders with a different owner and group. It is possible to set these options:

config.vm.synced_folder "src/", "/srv/website",
owner: "root", group: "root"


Mount options for mount.vboxsf:

uid=UID
set the default file owner user id to UID

gid=GID
set the default file owner group id to GID

ttl=TTL
set the "time to live" to TID for the dentry

dmode=MODE
override the mode of all directories to (octal) MODE

fmode=MODE
override the mode of all regular files to (octal) MODE

umask=UMASK
set the umask to (octal) UMASK

dmask=UMASK
set the umask applied to directories only

fmask=UMASK
set the umask applied to regular files only


Source: http://manpages.ubuntu.com/manpages/wily/man8/mount.vboxsf.8.html
vagrant  virtualbox  sharedfolder  permissions  solution 
march 2017 by kme
"Vagrant could not detect VirtualBox!" · Issue #192 · ptwobrussell/Mining-the-Social-Web-2nd-Edition · GitHub
Ran into this once during a workshop; solution was to add the path where the user had installed VirtualBox (it was something odd, like C:\Program Files\Oracle) to the PATH environment variable. Possibly the registry was out of sync with the actually VirtualBox installation path, or maybe Vagrant is hard-coded to look for VBoxManage.exe in only a couple of places on Windows.
windows  vagrant  virtualbox  errormessage  solution 
november 2016 by kme
virtualbox.org • View topic - on El Capitan: NS_ERROR_FAILURE (0x80004005)
Same problem I had, either after OS or VirtualBox upgrade (-> 5.0.something): no idea what the actual problem was, but creating a new Windows VM and then selecting the .vdi from the "broken" one solved the problem.

Most of the troubleshooting "advice" on the VirtualBox forums for this error is *way* off, maybe because people aren't paying attention to which *component* is implicated;
The VM session was aborted.

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: SessionMachine
virtualbox  errormessage  mac  osx  sortof  solution 
october 2016 by kme
[vbox-dev] Attaching .vdi image as a removable disk [https://www.virtualbox.org/]
Actually, if you give 'usb-creator-gtk' the '--allow-system-internal' flag, you can just directly install onto another attached .vdi.
ubuntu  liveusb  virtualbox  storage  installation  virtualization  solution 
july 2016 by kme
#6877 (Broken if cancel creation snapshot => fixed in SVN) – Oracle VM VirtualBox
Referred here by another article: "NS_ERROR_FAILURE (0x80004005)" https://www.virtualbox.org/ticket/8423

Solution was to remove the fixed disk from the storage manager and then re-add it to the VM. No idea.
Summary:

In the GUI, remove the existing guest VM,
Create a new guest VM (click the New button),
Use the wizard to set up the new VM (be careful, you should probably select Use existing image VMDK if VBox was accessing the guest via VMDK / raw partition),
Change the Settings (it can be found under the Machine menu) per your requirements,
Quit VBox,
Restart VBox,
Run the guest VM.
virtualbox  errormessage  solution 
june 2016 by kme
[SOLVED] Virtualbox won't forward port 8000
Indeed, by default the Django webserver only listens on 127.0.0.1. You can configure it to listen on all IP addresses by specifying the IP address 0.0.0.0. That is, you should launch the webserver with this command

Code:

python manage.py runserver 0.0.0.0:8000

To be clear, this is the solution to my problem.
virtualbox  python  django  networking 
may 2016 by kme
VirtualBox – Cannot Register the Hard Drive Because a Hard Drive with UUID Already Exists – Bradley Schacht
I looked all over the place to find what was causing it and finally found a fix. Of course it requires the command prompt, so open that junk up and let’s get started!

**Note that I am on VirtualBox version 4.1.6 and from what I’ve read this command used to be something different a few versions ago. I think instead of setdhuuid it was setvdiuuid, but don’t hold me to that.**

Open the Command Prompt
Change the directory to where VirtualBox is installed (Default: C:Program FilesOracleVirtualBox)
Type the following VBOXMANAGE.EXE internalcommands sethduuid <PathOfNewVHD>

Note that internalcommands and sethduuid need to be lowercase. I spent more than a couple minutes trying to figure out why things weren’t working.
virtualbox  storage  errormessage  virtualdisks  diskimage  solution 
april 2016 by kme
How to install Virtualbox guest additions on Ubuntu 14.04
1. Install kernel headers and build tools

Virtualbox guest additions are compiled for the target system, so it needs the necessary kernel headers and related programs. Install the following 2 packages.

$ sudo apt-get install build-essential module-assistant

Now run

$ sudo m-a prepare
solution  virtualbox  ubuntu  xubuntu  guestadditions  dammitbrain  annoyance 
april 2016 by kme
GitHub - jedi4ever/veewee: Easing the building of vagrant boxes
The first step to build a new virtual machine is to download an existing 'base box'. I believe this scares a lot of people as they don't know how these unverified boxes were built. Therefore a lot of people end up building their own base box which is often time consuming and cumbersome. Veewee aims to automate all the steps for building base boxes and to collect best practices in a transparent way.
virtualbox  vagrant  automation  devops  devel 
april 2016 by kme
linux - Failed to connect to the VirtualBox kernel service - Super User

Make sure you have dkms installed.

apt-cache search dkms | grep '^dkms'
dkms - Dynamic Kernel Module Support Framework

If this is the case try the following:

$ sudo /etc/init.d/vboxdrv setup
again  virtualbox  linux  kernel  errormessage  ubuntu  maybesolution  annoyance 
february 2016 by kme
VirtualBox Host ssh to Guest - Super User
This seems to work for accessing a port running on the HOST from the GUEST OS.
virtualbox  networking  webmaster  webdevel  portforwarding  solution 
january 2016 by kme
virtualbox.org • View topic - Restoring a Win 8/8.1 guest does not work - https://forums.virtualbox.org/
Sort of: for me the solution was to disable a port forward with no host/guest IP address, which seems to have been the only hangup.
virtualbox  errormessage  troubleshooting  mac  osx  maybesolution 
january 2016 by kme
[SOLVED] VirtualBox can't restore saved session / NS_ERROR_CALL_FAILED / Applications & Desktop Environments / Arch Linux Forums - https://bbs.archlinux.org/
Sort of: for me the solution was to disable a port forward with no host/guest IP address, which seems to have been the only hangup.
errormessage  virtualbox  mac  osx  solution 
january 2016 by kme
How to SSH to a VirtualBox guest externally through a host? - Stack Overflow
The GUI forces you to put an IP in there, but the default (if you leave it off below) is

I can't figure out whether you need to *know* the guest IP (10.0.2.15 or whatever) or whether 127.0.0.1 works. It's flaky, even on 4.x versions of VirtualBox.
VBoxManage modifyvm myserver --natpf1 "ssh,tcp,,3022,,22"
virtualbox  portforwarding  annoyance  dammitbrain  maybesolution 
january 2016 by kme
virtualbox - VERR_VMX_MSR_VMXON_DISABLED when starting an image from Oracle virtual box - Stack Overflow - http://stackoverflow.com/
You haven't enabled VT-x in BIOS and it's required.
Check your motherboard manual but you basically want to enter your BIOS just after the machine turns on (usually DEL key, F2, F12 etc) and find something in the CPU area/menu about "Virtualization" and enable it.
virtualbox  virtualizationandemulation  solution 
november 2015 by kme
unity - unknown version of the X Window System installed. Not installing X Window System drivers - Ask Ubuntu
It's possible that installing the 'dkms' actually fixes this issue. But this did the trick for me:
Install guest additions apt-get install virtualbox-guest-x11
ubuntu  virtualbox  guestadditions  errormessage  solution 
october 2015 by kme
apache - Vagrant's port forwarding not working - Stack Overflow
Duh.
I reprint Robert's comment below because it is such a trivial way to check: Run service iptables stop as root to quickly rule out a Guest firewall issue. Reenable it later if needed.
apache  virtualbox  portforwarding  iptables  firewall  centos  vagrant  devops  automation  ansible  solution 
september 2015 by kme
virtualbox.org • View topic - Discard Snapshot /w 2 HDD? For backup?
The "If No" (not used by multiple machines) worked for me. So far. Fingers crossed.
Re: Discard Snapshot /w 2 HDD? For backup?

Postby MarkCranness » 27. Oct 2009, 02:44
The '...has more than one child hard disk (n).' message likely occurs because the VDI is being used by more than one VM (currently, or was/is used by another VM's snasphot).

To see which VMs may or may not have the VDI attached, use File>Virtual Media Manager, select the VDI file and expand the tree below it (use * on the numeric keypad).

Is the VDI currently being used by multiple VMs?

If No, then you should be able to Remove some of the child {hexUUID} VDI files immediately under the main VDI in the tree, until there is only one child {hexUUID} VDI left and then the snapshot can be discarded.
Select each child {hexUUID} file in turn and note what it says below 'Attached to:'.
If it says 'Not Attached', then that file can be Removed.

If Yes, then you will have to decide which VMs will have their Current State (as relates to that base VDI) discarded and which VM will have it's Current State preserved (if any).
(This is because the snapshot you are trying to discard is snapshotting/protecting the base hard disk and it needs to be protected if it is to be shared by multiple VMs.)

For all VMs that will have their Current State discarded (as relates to that base VDI), do the following:
In Virtual Media Manager, find the immediate child {hexUUID} file that is attached to the VM
Does that file have its own '+' sign and a tree under it?
If Yes, then view the VM's snapshots, and Discard the last (current, bolded) snapshot, (preceeded by a Revert if appropriate...) and repeat until the child does not have a tree
Select the (treeless) immediate child and use 'Release' followed by 'Remove' to delete that file (this does a 'Revert' on the Current State, as it relates to this base VDI)
In the VM that will have it's Current State preserved, you should now be able to Discard snapshots as normal.

Backup/whatever you need to do with the base VDI, take a snapshot on the main VM and then reattach to the VMs that were 'Released' above.
virtualbox  modifyhd  snapshots  troubleshooting  errormessage  solution 
june 2015 by kme
Building a Vagrant Box from Start to Finish
Has some handy advice not found in the "official" guide, such as filling up the root block device with /dev/zero before packaging the box.
vagrant  virtualization  devops  virtualbox  setupguide  howto 
may 2015 by kme
virtualbox.org • View topic - Cannot ssh to Ubuntu server guest on a Mac OSX host
Some advice seen on the IntarWebs telling you to enable SSH or disable the firewall simply isn't necessary. By following the advice here (http://stackoverflow.com/a/10532299) and LEAVING HOST AND GUEST IP address BLANK in the NAT "Port Forwarding" settings, you can SSH to the guest with 'ssh -p <the_port> localhost'. Easy peasy.
macosx  virtualbox  networking  ssh  misguided  almostsolution 
may 2015 by kme
How to SSH to a VirtualBox guest externally through a host? - Stack Overflow
The best way to login to a guest Linux VirtualBox VM is port forwarding. By default, you should have one interface already which is using NAT. Then go to the Network settings and click the Port Forwarding button. Add a new Rule:

Host port 3022, guest port 22, name ssh, other left blank.
or from command line

VBoxManage modifyvm myserver --natpf1 "ssh,tcp,,3022,,22"
virtualbox  ssh  virtualization  networking  sysadmin  fuckina  solution 
may 2015 by kme
Howto: SSH into VirtualBox 3 Linux Guests by Stuart Colville
This method works all right (creating a host-only network in the VirtualBox application's preferences, then creating a host-only adapter for the VM), but setting up port forwarding with the primary NAT-only interface works okay, too. You just need to follow the advice here (http://stackoverflow.com/a/10532299) and do NOT specify an IP address for either the host or guest.

Then connecting to localhost -p <whatever> works just fine, whereas specifying 127.0.0.1 for the guest IP (as you'd expect) gives you a "connection refused" or similar error.
ssh  virtualbox  solution 
may 2015 by kme
Creating Application Control Exclusions in Symantec Endpoint Protection 12.1 | Symantec Connect
We have this problem with VirtualBox 4.3.14-95030 too an d we find no solution (add exception...) to run it. Switch back to VirtualBox 4.3.12-93733 and everything is fine...

Tested with: SEP 12.1.4013.4013, up-to-date Win 8.1


SOLVED: Revert to 4.3.12.
windows  sysadmin  symantecendpointprotection  solution  virtualbox  errormessage 
august 2014 by kme
virtualbox.org • View topic - Disable menu bar in fullscreen mode - https://forums.virtualbox.org/
Re: Disable menu bar in fullscreen mode
by iVirtualize » 6. Sep 2009, 23:06

Perryg wrote:
Have you tried to open the VBox program GUI and then in Settings -> General -> Advanced, take the check mark out of the mini toolbar?


I was looking for how to do this. I was blind, and didn't see it. Thanks.
virtualbox  max  osx  annoyance  solution 
june 2014 by kme
Snippet: How to Hide Menu Bar and Status Bar in VirtualBox - Make Tech Easier - http://www.maketecheasier.com/
VBoxManage setextradata global GUI/Customizations noMenuBar,noStatusBar

Still doesn't get rid of the auto-hiding menu bar in full screen.
virtualbox  customization  tipsandtricks 
june 2014 by kme
How do I install Guest Additions in VirtualBox? - Ask Ubuntu
Because the autorun prompt doesn't work on Lucid:
The Guest Additions .iso file needs to be installed on /dev/cdrom from the Virtual Box Manager (see above). We then may install Guest Additions by typing the following commands:

mount /dev/cdrom /mnt # or any other mountpoint
cd /mnt
./VBoxLinuxAdditions.run
reboot
ubuntu  10.04  lucid  solution  virtualbox  guestadditions 
january 2014 by kme
Bug #1061001 “Shutter only shows Wallpaper / black screen in Ubu...” : Bugs : “shutter” package : Ubuntu
None of the proposed solutions seem to work. So I've just used Skitch from within the host environment, then cropped to the window as best I could.

In my case, logging out and using the "Unity 2D" (Metacity) fallback session worked all right.
unity  shutter  bug  virtualbox  watchthisspace  screencapture  screenshot  sortof  solution 
january 2014 by kme
virtualbox.org • View topic - How to ssh into a guest using NAT?
Aha. Maybe there's another way to do this, but in VirtualBox, VM's Network panel, click on advanced, click on Port Forwarding button. In there set up a rule:

Host IP: 127.0.0.1
Host Port: 2222
Guest IP: 10.0.2.15
Guest Port: 22

Then enable ssh in the guest, and I'm able to connect from the host using:

ssh -p 2222 root@127.0.0.1

I haven't tried it because I don't have a 2nd computer, but I think ssh -p 2222 root@192.168.21.121 would also work.


I can't seem to use "127.0.0.1" as the guest IP, which would make the most sense. I guess this works fine as long as VirtualBox assigns the same IP to each guest, no matter how many VMs you have running.

However, following the advice here (http://stackoverflow.com/a/10532299), and LEAVING THE HOST AND GUEST IP addresses BLANK, you can SSH with 'ssh -p <whatever_port> localhost' just fine.

Alternatives using a host-only network and setting up a second, host-only network adapter for the VM also work, but unnecessarily complicate things, and make sharing the VM image with others more of a challenge (because they also have to set up the host-only network, and the network address/subnet mask must match the configuration on the VM).
virtualbox  ssh  portforwarding  remoteadministration  virtualizationandemulation  solution 
january 2014 by kme
virtualbox.org • View topic - Settings for GPM
This integration would need to be programmed into gpm.

https://www.virtualbox.org/ticket/6642#comment:6 mentions setting up the pointing device to be "USBTablet" in the config file, which seems to correspond to the GUI option "Enable absolute pointing device," but you can still make the pointer get out of sync pretty easily, and then you're stuck either killing gpm or disabling host pointer integration (Host + I) anyway.
virtualbox  linux  pointingdevice  gpm  needshelp 
january 2014 by kme
How To Fix User32.dll is Missing or Not Found Errors
After a late-November 2013 Windows Update frenzy, the Win 7 VM had a corrupted disk and was stuck in an update/rollback/reboot/fdisk/reboot cycle. These instructions seemed legit, but probably 'CHKDSK /f' (or /r) and a System Restore rollback will be what ends up fixing it. Or recovering to a VM snapshot
Run the sfc /scannow System File Checker command to replace a missing or corrupt copy of the user32.dll file. If this DLL file is provided my Microsoft, the System File Checker tool should restore it.

But what I actually ended up doing was this: http://www.sevenforums.com/tutorials/3413-repair-install.html (NT-style). But then what I actually ended up doing was actually rolling back to a previous VM snapshot.
virtualbox  win7  updatehell  windowsupdate  disasterrecovery  troubleshooting  dllhell  filesystemcorruption  maybesolution 
january 2014 by kme
LAMP doesn't boot on VMVirtualBox 4.2.16 - loading initial ramdisk... | TurnKey Linux Forum
On Mac OS X with VirtualBox 4.3.something, the solution (so far) seems to be use the i386 image instead of the amd64 one.
Generally enabling CPU virtual extensions (Intel-VT or AMD-V depending on processor) will do the trick although some virtual environments may also require settings adjustment. The 'i386' (i.e. 32 bit version) should run fine regardless... FYI all the appliances in their various builds are available from the TKL SourceForge Files page.
virtualizationandemulation  ovf  linux  solution  mac  osx  virtualbox 
january 2014 by kme
#8825 (Virtual machines hang if PAE enabled) – Oracle VM VirtualBox
Disabling either nested paging or PAE for the guest will workaround this bug.
virtualbox  ubuntu  lucid  10.04  32bit  pae  nestedpaging  annoyance  maybesolution 
may 2013 by kme
virtualbox.org • View topic - usb flash drive problem
Ejecting with Disk Utility doesn't really work. EHCI (USB 2.0) support doesn't really work.
virtualbox  usb  annoyance  mac  osx  hardware  flashdrive  sortofsolution  bug 
january 2013 by kme

Copy this bookmark:





to read