recentpopularlog in

racl101 : fix   335

« earlier  
Failed to download Chromium r515411 · Issue #1597 · GoogleChrome/puppeteer
In short: when installing Puppeteer and you get an error about downloading chromium, you might get an error. It could be an intermittent connection so try a few more times to see if works.
github  forum  puppeteer  google  chrome  chromium  headless  browser  issue  howto  troubleshoot  fix  example  guide  reference 
6 weeks ago by racl101
iptables sometimes works inside container, sometimes not - docker 0.8.1 · Issue #4424 · moby/moby
In short, you need to use --cap-add=NET_ADMIN when you launch a Docker Image to be able to enable tools such as the ufw tool in say a Docker image running the Ubuntu . 16.04 image, for example.
github  forum  howto  run  docker  container  troubleshoot  fix  network  admin  capabilities  universal  firewall  ufw  example  guide  reference 
9 weeks ago by racl101
Docker container will automatically stop after "docker run -d" - Stack Overflow
TLDR: I've tried adding: tail -f /dev/null to my start script and that worked allong with invoking the container with the: docker run -t -d <image-name> command invocation.
stackoverflow  howto  troubleshoot  example  docker  container  automatically  suddenly  stops  running  detached  mode  foreground  workaround  hack  hackfix  fix  toread  tolearn  totry  tounderstand  guide  reference 
9 weeks ago by racl101
Error during install , "python mysqldb module is required" · Issue #42 · geerlingguy/ansible-role-mysql
If using python3 as the Ansible Python Interpreter then you'll need to install both:

- python3-pip
and
- python3-mysqldb

to be able to update mysql user passwords with Ansible.
github  forum  mysql  module  howto  fix  troubleshoot  python  python3  ansible  update  root  password  user  example  guide  reference  pip 
july 2018 by racl101
Troubleshooting Systems Manager Run Command - AWS Systems Manager
If your instances don't show up on SSM service console check the following:

- If using non admin/account owner users (i.e. IAM users) check if they have the right policies attached to them.
- Do the EC2 instances in question have SSM Agent software installed on them
- Do the EC2 instances in question have the Role containing the policy named AmazonEC2RoleforSSM attached to it and, if so, has the instance been restarted after having the role attached to it?
- Is type of command that is being run available for the OS in question
aws  amazon  ssm  howto  troubleshoot  guide  reference  ec2  instance  role  policy  user  iam  fix  toread  tolearn  tounderstand 
july 2018 by racl101
Error: Cannot find module 'internal/util/types' · Issue #1124 · remy/nodemon
I was only able to fix this for myself by installing NodeJS / NPM with nvm and by installing the LTS Boron NodeJS version (v6.14.1) and npm version (v3.10.10) as of April 27, 2018.

I encountered this error when trying to run the DCIDA Web app Grunt task.
github  nodejs  npm  internal  util  types  error  howto  troubleshoot  fix  dependency  grunt  guide  reference 
april 2018 by racl101
"Could not get any response" on all my api calls · Issue #3127 · postmanlabs/postman-app-support
Bug with Postman caused by copying token from Laravel Passport Personal Access Token generating modal output, which includes a newline / return at the end. Remove that newline / return at the end and it should fix this.
github  forum  postman  howto  troubleshoot  fix  bug  token  bearer  authentication  newline  return  character  example  guide  reference 
april 2018 by racl101
MySQLdb User's Guide
I don't get it, but I guess you're supposed to use %s as a placeholder even for integers (so not %d) in a query string that is used in a cursor.execute() statement. I tried it with pymysql. I'm not sure why, but it worked.

This is the explanation: In this example, max_price=5 Why, then, use %s in the string? Because MySQLdb will convert it to a SQL literal value, which is the string '5'. When it's finished, the query will actually say, "...WHERE price < 5".
mysql-python  howto  troubleshoot  cursor  mysql  pymysql  query  python  python2.7  string  format  number  error  fix  guide  reference  examples 
april 2018 by racl101
mysql - MySQLdb Python insert %d and %s - Stack Overflow
I don't get it, but I guess you're supposed to use %s as a placeholder even for integers (so not %d) in a query string that is used in a cursor.execute() statement. I tried it with pymysql. I'm not sure why, but it worked.
stackoverflow  howto  troubleshoot  cursor  mysql  pymysql  query  python  python2.7  string  format  number  error  fix  guide  reference 
april 2018 by racl101
insertion - Python MySQLdb issues (TypeError: %d format: a number is required, not str) - Stack Overflow
I don't get it, but I guess you're supposed to use %s as a placeholder even for integers (so not %d) in a query string that is used in a cursor.execute() statement. I tried it with pymysql. I'm not sure why, but it worked.
stackoverflow  howto  troubleshoot  cursor  mysql  pymysql  query  python  python2.7  string  format  number  error  fix  guide  reference 
april 2018 by racl101
Error: duplicate listen options for [::]:443 · Issue #5550 · certbot/certbot
This happened to me when I tried to create an SSL certificate for two virtual hosted sites that share the same top level domain but have different subdomains and their www versions.

E.g. site1.myawesomesite.com and site2.myawesomesite.com (and their www versions www.site1.myawesomesite.com and www.site2.myawesomesite.com )

TLDR:

change listen [::]:443 ssl ipv6only=on; to listen [::]:443;
github  forum  letsencrypt  ssl  certificate  ubuntu  ubuntu16.04  howto  troubleshoot  fix  duplicate  listen  options  error  virtualhost  example  guide  reference 
march 2018 by racl101
I 'm getting error "Class 'PredisClient' not found" in Laravel 5.2 - Stack Overflow
Had this issue on Laravel 5.5 when I wanted to set Supervisord to do some queue work on a Beanstalkd Queue. Fixed issue by simply installing predis/predis package.
stackoverflow  howto  troubleshoot  laravel  laravel5  laravel5.5  error  message  supervisord  beanstalkd  queue  redis  fix  guide  reference 
january 2018 by racl101
Problem with Doctrine instantiator · Issue #20255 · laravel/framework
Encountered this issue with installing Laravel 5.5 on Homestead (which is running PHP 7.1) and then deploying codebase to an AWS server running Ubuntu 16.04 and PHP 7.0. This fix worked well.
github  laravel  composer  issues  php  php7  version  conflict  howto  fix  troubleshoot  doctrine  instantiator  guide  reference 
january 2018 by racl101
PHP: Description of core php.ini directives - Manual
If you are running Nginx and serving PHP with PHP-FPM, if you are having problems with the variable: $_SERVER['PHP_SELF'] not being set then it could be that cgi.fix_pathinfo is set to 0 . However, I needed to change it to 1 for that variable to work. It doesn't seem to be a problem with Laravel 5.4 installation. But this is a problem with REDCap since it uses $_SERVER['PHP_SELF'] extensibly.
php  manual  guide  reference  documentation  ini  php.ini  $_SERVER  $_SERVER['PHP_SELF']  howto  troubleshoot  fix  php-fpm  nginx  cgi.fix_pathinfo 
january 2018 by racl101
Nginx location "not equal to" regex - Stack Overflow
This is a trick when you want to apply a rewrite to a bunch of URIs matching a certain pattern, with the exception of a fie (the ones with an empty location block.)
stackoverflow  howto  example  nginx  server  config  conf  file  trick  fix  guide  reference  exception  rewrite  expression  empty  block 
december 2017 by racl101
« earlier      
per page:    204080120160

Copy this bookmark:





to read