recentpopularlog in

therobyouknow : fix   27

composer install error under CentOS 6 · Issue #2098 · puphpet/puphpet · GitHub
==> default: Error: curl -sS https://getcomposer.org/installer | php returned 255 instead of one of [0]
==> default: Error: /Stage[main]/Composer/Exec[download_composer]/returns: change from notrun to 0 failed: curl -sS https://getcomposer.org/installer | php returned 255 instead of one of [0]
==> default: Notice: /Stage[main]/Composer/File[/usr/local/bin/composer]: Dependency Exec[download_composer] has failures: true
==> default: Warning: /Stage[main]/Composer/File[/usr/local/bin/composer]: Skipping because of failed dependencies

Only for info. I had this puphpet issue, after vagrant provision, this contained the solution:
https://github.com/puphpet/puphpet/issues/2098#issuecomment-172428654
(2nd solution is what I am using, according to my beyond compare with my current setup vs the original zip I downloaded from puphpet. I used beyond compare to remind me as I had forgotten how I had fixed it)

'wget': {
- $download_command = "wget https://getcomposer.org/composer.phar -O composer.phar"
+ $download_command = "wget -qO- https://getcomposer.org/installer | ${composer::php_bin}"

if defined(File["${target_dir}/${composer_file}"]) == false {
exec { 'download_composer':
command => $download_command,
cwd => $tmp_path,
require => $download_require,
creates => "${tmp_path}/composer.phar",
logoutput => $logoutput,
environment => "COMPOSER_HOME={$composer_home}",

This is in puphpet/puppet/modules/composer/manifests/init.pp
puphpet  error  vm  remedy  fix  issue  github  computing  dev  vagrant  virtualbox  virtualmachine  wget  curl  problem  solution 
january 2016 by therobyouknow
Adding a renderable-array block to a page gives errors in the admin UI [#1925018] | Drupal
Notice: Array to string conversion in filter_xss() (line 1442 of /includes/common.inc).
Unsupported operand types in /var/www/go-on/includes/common.inc on line 4461
Fatal error: Unsupported operand types in /home/www/public_html/includes/common.inc on line 4462
solution  fix  patch  panels  ajax  block  error  drupal  computing  web  dev  cms 
september 2013 by therobyouknow
"The import data is not valid import text." - Google Search
when i enabled the france24 modules for the first time i got this but reloading the admin/modules page it went away
drupal  problem  france24  fix 
march 2010 by therobyouknow
"Cannot redeclare aef_externodes_get_current_revision_id()" - Google Search
no google searches showed up for this "Cannot redeclare aef_externodes_get_current_revision_id()" - I commented out the shorter of the 2 functions by the same name, thinking that the one with the more code was the one to use. I'll find out if im correct when i try out the modules
drupal  france24  aef  newspaper  fix  error  redeclare  workaround  module 
march 2010 by therobyouknow
MYSQL Server has gone away query | drupal.org
Disable Update Status Module advice here worked for me.
drupal  fix  mysql  query  sql  troubleshooting 
march 2010 by therobyouknow
Download details: Update for Windows XP Service Pack 2 (KB884020)
Minor patch that fixes " Programs that connect to IP addresses in the loopback address range may not work as expected and you may receive an error message indicating you cannot establish a connection. After you install this item, you may have to restart your computer."
windows  microsoft  xp  fix  update  networking  network  patch  routing  troubleshooting  sp2  servicepack  servicepack2  computng  software  upgrade  maintenance 
november 2009 by therobyouknow
Taskbar Repair Tool Plus!
tool for fixing windows not showing as minimised on taskbar works on Vista as well as XP
windows  xp  vista  taskbar  task  bar  minimise  minimize  not  disappear  invisible  visible  hidden  solution  fix  problem  script  vbscript  repair  tool  visual  basic  microsoft  safe 
march 2009 by therobyouknow

Copy this bookmark:





to read